New issue
Advanced search Search tips
Starred by 679 users

Issue metadata

Status: Duplicate
Merged: issue 71067
Owner:
Closed: Jul 2011
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 37762: Need a way to enable/disable JavaScript for extensions

Reported by christia...@gmail.com, Mar 9 2010

Issue description

Chrome Version       : 5.0.342.2 (Official Build 40685) dev
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
  Firefox 3.x: OK
IE 7:
IE 8:

Some web developers extensions need an API to disable/enable JavaScript on 
the fly in order to test very quickly if a web site is correctly handled 
without scripting.
 

Comment 1 by felix.na...@gmail.com, Mar 12 2010

This is the only reason i cant use Chrome. If i would change i still need a second one 
cause of my job as a webdeveloper.
Please add asap!!!

Comment 2 by trumbi...@gmail.com, Mar 19 2010

Me too. Chrome is really great. But without such an option I just can't use it for my 
job as a webdeveloper. BTW, firefox has it.

Comment 3 by e.bouger...@gmail.com, Mar 21 2010

we need this.

Comment 4 by Deleted ...@, Mar 23 2010

I need this for testing Mr. Chrome.

Comment 5 by hegga...@gmail.com, Mar 23 2010

Yep, this would be ideal for testing. Until this happens, it's of to Firefox I go...

Comment 6 by leckl...@gmail.com, Mar 23 2010

Final step toward 100% (work & home) Chrome usage.

Comment 7 by john.fra...@gmail.com, Mar 23 2010

I would go even further and say that the API would need to allow finer granularity into 
exactly what Javascript functionality should be enabled/disabled.  For example, a major 
annoyance for some users is some websites that think they have the right to decide what 
size a new browser window should be (window.resizeTo()).  Even worse is when they set a 
minimum size and you can't resize the window below that.

Firefox has a preference menu that allows you to enable or disable certain problematic 
Javascript functionality.  Chromium can take that to a new level through a fine grained 
API and the various extensions that would surely follow.

Comment 8 by john.fra...@gmail.com, Mar 23 2010

I suggest this be designated a feature request and not a bug. Some developers may be 
interested implementing sought after features and others may spend more time on bug 
fixing. The bug fixing types would just get annoyed that this is label "bug" and would 
not give it any attention.

Comment 9 by lister....@gmail.com, Mar 25 2010

would be really useful to me as a web developer, would definitly make chrome my
number one web devel browser!

Comment 10 by s.aarts....@gmail.com, Mar 26 2010

Needed for web development!

Comment 11 by andrewpm...@gmail.com, Mar 29 2010

A must for any serious developer.

Comment 12 by Deleted ...@, Apr 2 2010

Not only for web developers but regular users too!  I hate going to a site as a normal 
surfer and have a ton of JS slow it down to a crawl, or even let the site control how I 
browse their pages or site.

Comment 13 by stephan....@gmail.com, Apr 2 2010

Agreed. It'd be nice to be able to control JS on a per-domain basis via a page action 
for a NoScript-like effect.

Comment 14 by thecybor...@gmail.com, Apr 6 2010

You can already disable javascript per host in Chrome options.

Comment 15 by oelme...@gmail.com, Apr 6 2010

@TheCybor
You should read more carefully before commenting.

Comment 16 by thecybor...@gmail.com, Apr 6 2010

huh?

My comment pretty much solves the problem described in commend #12.

Comment 17 by oelme...@gmail.com, Apr 6 2010

My bad, I thought you answered to the main issue. I should read more carefully before 
commenting. ;)

Comment 18 by jonathan...@gmail.com, Apr 14 2010

it's very needed

Comment 19 by j.w12...@gmail.com, Apr 20 2010

MUST-HAVE for web developers

Comment 20 by ken.mcgl...@gmail.com, Apr 26 2010

Yes, this would be useful for web developers, but I like having the security of NoScript as well. It's one of the 
several reasons I haven't switch to Chrome full-time yet. I'd like to leave Firefox behind — it's really been getting 
memory-hungry and crashes often — but Chrome doesn't seem to have the flexibility I need to actually do so.

Comment 21 by kdms...@gmail.com, Apr 26 2010

{conjecture} Is this feature central to making NoScript-like tools?  If so, then maybe Google is sensitive to it because it can be used to defeat online advertising, which is 
important business for Google? {/conjecture}

Comment 22 by thecybor...@gmail.com, Apr 26 2010

I don't think so.

As i mentioned earlier, Chrome already has built-in options for disabling JavaScript, 
either per host or completely.
I don't see why making an API to access this option from an extension would have 
anything to do with that.

Comment 23 by felix.na...@gmail.com, Apr 26 2010

@TheCybor...
Please ask somebody who develops accessable FE.

Comment 24 by intoxina...@gmail.com, May 4 2010

This is the one missing feature that is stopping me from moving from Firefox to
Chrome. Being a web developer, I find the ability to quickly switch on and off
Javascript via the Firefox web developer plugin invaluable. It provides a very quick
and easy way to test out degradation issues when trying to insure my sites work in
browsers without javascript. Hopefully Google can add this into Chrome so I can
switch from the memory hog that is Firefox over to the lightning fast Chrome.

Comment 25 by Deleted ...@, May 10 2010

This feature is the same as most others the reason for me not switching 100% to chrome, 
I use chrome for everyday use but not when developing. If this feature was added 
alongside with more options to customize plugins, I would change to chrome without a 
blink in the eye.

Comment 26 by adrian.m...@gmail.com, May 10 2010

Would be realy handy to turn java script via extension. All other ways to do that is 
way to long for developing sites.

Comment 27 by mpcomplete@chromium.org, May 18 2010

Labels: -Area-Undefined Area-Internals Feature-Extensions
Status: Assigned
This sounds like a job for a content settings API.

Comment 28 by kieran...@gmail.com, May 28 2010

+1 Extensions could really benefit from this, and soon. One major drawback of swtiching to Chrome full time was 
the lack of ease disabling JS during website creation,

Comment 29 Deleted

Comment 30 Deleted

Comment 31 by micha.wo...@gmail.com, Jun 8 2010

I am not really sure of the purpose of the previous comment. As a web-developer, I develop my own sites, as well as get paid good money to make other people's average ideas a reality. As with any job in any business not your own, "working for the man and slaving for someone else's chores. That is NOT an impressive occupation."

BTW, as a web-developer, I love Chrome, but really miss this function. This and compatibility testing are the only reasons I still use Firefox at times.

Comment 32 Deleted

Comment 33 by manifest...@gmail.com, Jun 8 2010

@craigbarnes85 Some of us are freelancers who do web development
because we love it and find it to be an incredibly "impressive
occupation."  If you are not happy with your choice of work, do
something else.  No one is forcing you to be a "slave" for "the man."
In the mean time, let the rest of us talk to the creators of useful
products, like Google Chrome, to help make it that much better for
people like you.  Personally,I love Google Chrome, but there were a
few things that were keeping me from using it primarily for
development.  Most of those issues have been taken care of because of
the wonderful people who came on here and asked for functionality.
They contributed to making something great... what are you doing to
help?

- Peter

Comment 34 by stratosp...@gmail.com, Jun 8 2010

Quit feeding the troll please; they're just jealous of everyone else with ability.

Comment 35 by institut...@gmail.com, Jun 15 2010

We need this !!

Comment 36 by igel.w...@gmail.com, Jun 15 2010

DO NOT POST COMMENTS LIKE #35.

You cause 319 needless emails to 319 people who starred this bug. Just star the bug, if you like to support it.

Comment 37 by flussence@gmail.com, Jun 20 2010

The root problem here isn't so much a lack of API, it's that the current UI for permissions (especially turning them off) is bad.

On Firefox for comparison, all the site permissions are in one place that takes 0.5 seconds to get to (Ctrl+I Alt+P). I can't imagine a case for letting extensions directly access these settings that couldn't be solved by just making what's already there less painful to use.

Comment 38 by minitech...@gmail.com, Jun 25 2010

For now, I'm just commenting out the Javascript, which works fine - why can't people just click the "Refresh" button and type 6 characters?

BTW, I'm all for it too ;)

Comment 39 by Deleted ...@, Jun 25 2010

Which 6 characters? Please tell me the way how you disable js like this.

Comment 40 by minitech...@gmail.com, Jun 25 2010

Put /* and */ if it's inline, <!-- and --> if it's not. Of course, this works for me because I only ever have one to four scripts on a page, and they're external.

Comment 41 by Deleted ...@, Jun 28 2010

I need this also.

Comment 42 by 2silkw...@gmail.com, Jul 1 2010

We really need this feature.

Comment 43 by fahadsa...@gmail.com, Jul 2 2010

To sgaltier and 2silkworm:

By posting your useless comments, you unnecessarily sent an email to 329 people. Please don't.

Comment 44 by Deleted ...@, Jul 6 2010

Agreed +1.  How are affirmations about the community's demand for new features useless comments?

Comment 45 by jyos...@gmail.com, Jul 6 2010

I think he means, just simply voting for the feature is enough. Leaving a comment that doesn't add anything to what was already previously said borders on useless.

Comment 46 by 2silkw...@gmail.com, Jul 9 2010

Sorry,guys. It's really stupid. I've never posted here before. I'd read the notice on voting just after I clicked send button. Maybe it's my ADHD :) This is the last useless comment from me. 
To fahadsadah, michael.r.mcneil, jyoseph:
Thank you for criticism.

Comment 47 by Deleted ...@, Aug 5 2010

it is a MUST!

Comment 48 by evan@chromium.org, Aug 12 2010

Labels: Restrict-AddIssueComment-Commit
To reduce noise on this bug, I'm restricting future comments to committers only.

Comment 49 by bauerb@chromium.org, Jul 7 2011

Mergedinto: 71067
Status: Duplicate
This should be able with the (experimental) content settings API (see http://code.google.com/chrome/extensions/trunk/samples.html#e1f97e61e28ff33131d66dd28a4ed70a77874a51).

Comment 50 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-Internals -Feature-Extensions Cr-Internals Cr-Platform-Extensions

Sign in to add a comment