New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 374979 link

Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 415953
Owner: ----
Closed: Nov 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment

Menus are too big on Linux when using Classic theme

Reported by loic.yh...@gmail.com, May 19 2014

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.8 Safari/537.36

Steps to reproduce the problem:
Compare menus (Chrome menu, context menus) size between Classic and GTK+ themes.

What is the expected behavior?
They should have the same size.

What went wrong?
Since 36.0.1964.2, menus have bigger horizontal and vertical padding when using Classic theme, unlike previous versions where both themes did look the same.

Did this work before? Yes 36.0.1951.5

Chrome version: 36.0.1985.8  Channel: dev
OS Version: Fedora 20
Flash Version: Shockwave Flash 13.0 r0

 
Screenshots : menus were the same for both themes in 36.0.1951.5, GTK+ hasn't changed, now Classic has too much padding.
36.0.1951.5_classic_aura.png
21.6 KB View Download
36.0.1985.8_classic_aura.png
22.2 KB View Download
36.0.1985.8_gtk+_aura.png
17.5 KB View Download

Comment 2 by e...@chromium.org, May 19 2014

Cc: est...@chromium.org

Comment 3 by est...@chromium.org, May 19 2014

I don't really want to own this bug, but I do think it would be fixed by https://codereview.chromium.org/245863002/

Comment 4 by dvanh...@gmail.com, Jun 21 2014

Has this made it into a release yet?

I can confirm this is still a problem as of 37.0.2054.3 dev (64-bit).
It also affects the context menu, regardless of the theme used.

Comment 5 by ajha@chromium.org, Jul 2 2014

Labels: Needs-Feedback
Could anyone please check on the latest chrome version,if this is still an issue at there end and update here.
Still the same on 37.0.2062.3

Comment 7 by dvanh...@gmail.com, Aug 12 2014

Still there in 38.0.2114.2 dev 64-bit.

Comment 8 by dvanh...@gmail.com, Sep 7 2014

Still an issue in version 39.0.2145.4 dev 64-bit.
Same problem here, even in last dev build.
Still the same on 40.0.2194.2 dev ...
Labels: -Needs-Feedback M-40 Cr-UI-Browser-Themes
Status: Untriaged
Able to reproduce in Linux Ubunti 14.04 with chrome beta 39.0.2171.36. Please find the attachments.
Screenshot from 2014-10-24 15:48:41.png
261 KB View Download
Screenshot from 2014-10-24 15:48:22.png
1.8 MB View Download
Labels: -M-40 M-41 MovedFrom-40
Moving all non essential bugs to the next Milestone.
Labels: -M-41 MovedFrom-41
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.
So, still no progress on this bug, and I can't find the files to try fixing it myself on my own computer. Version 48.0.2552.0 dev (64-bit) still includes this bug, and since the menu for an image with a hyperlink attached takes up almost half the screen's height, this is still a major annoyance for me.
Cc: e...@chromium.org
+erg, do you think this is something we should fix? It seems like a grey area (if your desire is GTK nativeness, use the GTK theme).

Comment 16 by e...@chromium.org, Nov 9 2015

I'd be fine with a policy where gtk style menus only showed up in gtk mode. I'd be fine if gtk menus showed up consistently everywhere. I think it's this weird half-way point (gtk theming / chrome sizing) which is wrong.

I don't really care that much which way it is resolved.
Labels: Hotlist-GoodFirstBug
Status: Available
agreed on all the above points. Perhaps the community should decide. First CL that fixes it either way wins.
How do you define "chrome sizing" ?
Shouldn't the "classic theme" match Windows, which doesn't have the big padding ?

When you say "half-way point", is it about the colors ?
> "chrome sizing"

this sizing is probably coming from/matching ChromeOS

> When you say "half-way point", is it about the colors ?

yes, that is what he meant. The colors are GTK colors regardless of Chrome's theme mode.
Mergedinto: 415953
Status: Duplicate

Sign in to add a comment