Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 41 users
Status: Verified
Owner:
Closed: Mar 2010
Cc:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Google Chrome Crash when trying to open Gmail offline
Reported by jerome.d...@gmail.com, Feb 28 2010 Back to list
Chrome Version       : <5.0.341.0 40245>
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK
  Chrome 5.0.328.0 : OK 
What steps will reproduce the problem?
1. Open Chromium
2. Open gmail
3.

What is the expected result?
Gmail should open

What happens instead?
Chromium chrash during the opéning of gmail

Please provide any additional information below. Attach a screenshot if
possible.

 
Seems to be solved in 5.0342.0 40278
Comment 2 Deleted
not solved in 5.0343.0 40383 

This is a huge regression
Status: WontFix
Tested on 5.0.342.0 r40345. Not able to reproduce.

Please retry on latest available builds with a clean profile. Thanks.
Does not work either with your version 40345 but work well with 40278, even with clean 
profile

seems to work with the simplified version of gmail but not with the standard that I am 
using with gmail parameter connexion off
Comment 6 Deleted
Comment 7 Deleted
I tested again, the problem is when we use the out of connexion gmail to have the 
messages saved on the pc when we don not have connexion

It seems that chromium chrashes when the synchronization of the mail starts

This is a regression of Chromium for this labs functionnality of gmail

I do not understand why the status is to wontfix?
Hi jerome.dono,
Thanks for additional information you had given, can we please let us know in which
platform are you seeing the issue? and also provide the "Gmail-Lab Name" title you
enabled.

Thanks,
I am using a pc platform with windows 7, the gmail is : I use the offline system and 
when you enable the offline mail, then during the update chromium crashes or it crashes 
if ths was enable in a former version where it was working well, now with the versions 
it does not work see the picture of the settings
Capture.JPG
32.7 KB View Download
Labels: OS-Windows
Status: Unconfirmed
Thanks jerome.donon

"pc platform with windows 7"

Pointing to Windows team, can any one help to confirm this. Thanks.

I am not sure that this is a windows problem as this was working well in old version of 
Chromium as 40245 and former, after that version the problem appear and deseappear in 
40278 and reappear in 40283, and now it is here all the time.

On the same pc this is working perfectly in Chrome 5.0.328.0, so this significate that 
certainly it is a last versions problem.
Status: Untriaged
Confirmed, saw this in 342.0, intermittent.
Same thing with Google Docs. Crashes with "Offline" enabled, doesn't without. Gears-
related?

I use Google Gears 0.5.33.0 on Google Chrome 5.0.342.1 (Official Build 40461) dev
Ah yes, on Windows 7, forgot to mention that.
Labels: -Pri-2 Pri-1 Crash
Comment 17 by dhw@chromium.org, Mar 4 2010
Labels: Gears
This is being reported for the just released Dev 5.0.342.1

http://googlechromereleases.blogspot.com/2010/03/dev-channel-update.html
Comment 18 by dhw@chromium.org, Mar 4 2010
 Issue 37281  has been merged into this issue.
Comment 19 by dhw@chromium.org, Mar 4 2010
 Issue 37432  has been merged into this issue.
Comment 20 by dhw@chromium.org, Mar 4 2010
 Issue 37437  has been merged into this issue.
Comment 21 by dhw@chromium.org, Mar 4 2010
Summary: Chromium Crash when trying to open Gmail offline (was: NULL)
Comment 22 by dhw@chromium.org, Mar 4 2010
 Issue 37444  has been merged into this issue.
Labels: Regression ReleaseBlock-Dev
Summary: Google Chrome Crash when trying to open Gmail offline (was: NULL)
Build: 5.0.342.1
Gears: 0.5.33.0

This is bad. It repros for me 100%.
After it crashes for 1st time with offline syncing, then every time Google Chrome
crashes while logging in to my gmail a/c.

The full stack trace can be found @
http://crash/reportdetail?reportid=93b876a6f4904b8b#crashing_thread

Stack trace:
Thread 8 *CRASHED* ( EXCEPTION_BREAKPOINT @ 0x01d141a1 ) 
0x01d141a1  [chrome.dll  - logging.cc:598]  logging::LogMessage::~LogMessage()  
0x01e87c45  [chrome.dll  - safe_browsing_resource_handler.cc:51] 
SafeBrowsingResourceHandler::OnUploadProgress(int,unsigned __int64,unsigned __int64)  
0x01dbb565  [chrome.dll  - resource_dispatcher_host.cc:1672] 
ResourceDispatcherHost::MaybeUpdateUploadProgress(ResourceDispatcherHostRequestInfo
*,URLRequest *)  
0x01dbb1a2  [chrome.dll  - resource_dispatcher_host.cc:1606] 
ResourceDispatcherHost::UpdateLoadStates()  
0x01f4cc55  [chrome.dll  - timer.h:159] 
base::BaseTimer<views::MenuController::MenuScrollTask,1>::TimerTask::Run()  
0x01d0bb3a  [chrome.dll  - message_loop.cc:329]  MessageLoop::RunTask(Task *)  
0x01d0bb74  [chrome.dll  - message_loop.cc:337] 
MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &)  
0x01d0bdef  [chrome.dll  - message_loop.cc:471] 
MessageLoop::DoDelayedWork(base::Time *)  
0x01d1d9b5  [chrome.dll  - message_pump_win.cc:458] 
base::MessagePumpForIO::DoRunLoop()  
0x01d1d4eb  [chrome.dll  - message_pump_win.cc:52] 
base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate
*,base::MessagePumpWin::Dispatcher *)  
0x01d1d330  [chrome.dll  - message_pump_win.h:78] 
base::MessagePumpWin::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 9 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df59  [ntdll.dll  + 0x0000df59]  ZwWaitForSingleObject  
0x7c8025da  [kernel32.dll  + 0x000025da]  WaitForSingleObjectEx  
0x7c802541  [kernel32.dll  + 0x00002541]  WaitForSingleObject  
0x01d159fa  [chrome.dll  - waitable_event_win.cc:50]  base::WaitableEvent::Wait()  
0x01d1d268  [chrome.dll  - message_pump_default.cc:42] 
base::MessagePumpDefault::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 10 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df59  [ntdll.dll  + 0x0000df59]  ZwWaitForSingleObject  
0x7c8025da  [kernel32.dll  + 0x000025da]  WaitForSingleObjectEx  
0x7c802541  [kernel32.dll  + 0x00002541]  WaitForSingleObject  
0x01d159fa  [chrome.dll  - waitable_event_win.cc:50]  base::WaitableEvent::Wait()  
0x01d1d268  [chrome.dll  - message_pump_default.cc:42] 
base::MessagePumpDefault::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 11 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df59  [ntdll.dll  + 0x0000df59]  ZwWaitForSingleObject  
0x7c8025da  [kernel32.dll  + 0x000025da]  WaitForSingleObjectEx  
0x7c802541  [kernel32.dll  + 0x00002541]  WaitForSingleObject  
0x01d159fa  [chrome.dll  - waitable_event_win.cc:50]  base::WaitableEvent::Wait()  
0x01d1d268  [chrome.dll  - message_pump_default.cc:42] 
base::MessagePumpDefault::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 12 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df49  [ntdll.dll  + 0x0000df49]  NtWaitForMultipleObjects  
0x7c80958f  [kernel32.dll  + 0x0000958f]  CreateFileMappingA  
0x7c80a114  [kernel32.dll  + 0x0000a114]  WaitForMultipleObjects  
0x769c87bc  [userenv.dll  + 0x000087bc]  NotificationThread()  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 13 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df59  [ntdll.dll  + 0x0000df59]  ZwWaitForSingleObject  
0x7c8025da  [kernel32.dll  + 0x000025da]  WaitForSingleObjectEx  
0x7c802541  [kernel32.dll  + 0x00002541]  WaitForSingleObject  
0x01d15a26  [chrome.dll  - waitable_event_win.cc:63] 
base::WaitableEvent::TimedWait(base::TimeDelta const &)  
0x01d1d2ab  [chrome.dll  - message_pump_default.cc:46] 
base::MessagePumpDefault::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 14 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df59  [ntdll.dll  + 0x0000df59]  ZwWaitForSingleObject  
0x7c8025da  [kernel32.dll  + 0x000025da]  WaitForSingleObjectEx  
0x7c802541  [kernel32.dll  + 0x00002541]  WaitForSingleObject  
0x01d15a26  [chrome.dll  - waitable_event_win.cc:63] 
base::WaitableEvent::TimedWait(base::TimeDelta const &)  
0x01d1d2ab  [chrome.dll  - message_pump_default.cc:46] 
base::MessagePumpDefault::Run(base::MessagePump::Delegate *)  
0x01d0b9ea  [chrome.dll  - message_loop.cc:205]  MessageLoop::RunInternal()  
0x01d0b96f  [chrome.dll  - message_loop.cc:177]  MessageLoop::RunHandler()  
0x01d0b920  [chrome.dll  - message_loop.cc:155]  MessageLoop::Run()  
0x02471e36  [chrome.dll  - thread.cc:133]  base::Thread::Run(MessageLoop *)  
0x02471ebb  [chrome.dll  - thread.cc:155]  base::Thread::ThreadMain()  
0x01d14ea1  [chrome.dll  - platform_thread_win.cc:26]  `anonymous
namespace'::ThreadFunc(void *)  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

Thread 15 
0x7c90e514  [ntdll.dll  + 0x0000e514]  KiFastSystemCallRet  
0x7c90df49  [ntdll.dll  + 0x0000df49]  NtWaitForMultipleObjects  
0x7c929cb5  [ntdll.dll  + 0x00029cb5]  RtlpWaitThread  
0x7c80b728  [kernel32.dll  + 0x0000b728]  BaseThreadStart  

 Issue 37443  has been merged into this issue.
Comment 26 by mal@google.com, Mar 4 2010
Status: Assigned
Seems to be hitting the second CHECK here:

bool SafeBrowsingResourceHandler::OnResponseStarted(
    int request_id, ResourceResponse* response) {
  CHECK(state_ == STATE_NONE);
  CHECK(defer_state_ == DEFERRED_NONE);
  return next_handler_->OnResponseStarted(request_id, response);
}
is it same as  issue 17544  ??.
Labels: -OS-Windows OS-All
Status: Fixed
Removed the check in r40684.
Labels: -OS-All OS-Windows
can't repro in mac and no offline gmail support in linux.
Comment 31 by pdxr...@gmail.com, Mar 5 2010
Just an fyi... I had to uninstall all google gears before I could get gmail to open.
definitely happening to me, using 5.0.342.1 (Official Build 40461) dev
Same here - windows 7 and 5.0.342.1 crashing each time either offline gmail or offline 
google calendar starts to synchronise. Offline google reader not crashing, though.
Disabling Gears for Gmail (Wrench -> Options -> Under the Hood -> Change Gears 
Settings) provides a workaround.


 Issue 37472  has been merged into this issue.
 Issue 37471  has been merged into this issue.
 Issue 37458  has been merged into this issue.
 Issue 37435  has been merged into this issue.
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=40684 

------------------------------------------------------------------------
r40684 | eroman@chromium.org | 2010-03-04 15:54:44 -0800 (Thu, 04 Mar 2010) | 9 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/renderer_host/safe_browsing_resource_handler.cc?r1=40684&r2=40683

Remove a CHECK() which was firing.

The problem was the load state poller may call OnUploadProgress() while a redirect is in progress.
It should be safe to remove the CHECK(), since it was recently added and execution used to pass through previously in this case.

BUG= 37035 
TBR=wtc

Review URL: http://codereview.chromium.org/669117
------------------------------------------------------------------------

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=40685 

------------------------------------------------------------------------
r40685 | eroman@chromium.org | 2010-03-04 15:58:35 -0800 (Thu, 04 Mar 2010) | 12 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/342/src/chrome/browser/renderer_host/safe_browsing_resource_handler.cc?r1=40685&r2=40684

Merge 40684 - Remove a CHECK() which was firing.

The problem was the load state poller may call OnUploadProgress() while a redirect is in progress.
It should be safe to remove the CHECK(), since it was recently added and execution used to pass through previously in this case.

BUG= 37035 
TBR=wtc

Review URL: http://codereview.chromium.org/669117

TBR=eroman@chromium.org
Review URL: http://codereview.chromium.org/668116
------------------------------------------------------------------------

Comment 41 by dhw@chromium.org, Mar 5 2010
 Issue 37453  has been merged into this issue.
Comment 42 by dhw@chromium.org, Mar 5 2010
Issue 37464 has been merged into this issue.
 Issue 37474  has been merged into this issue.
Status: Verified
Build: 5.0.342.2
I am having similar issues when I just installed offline syncing.  Now cannot open
gmail in chrome.  but ff works fine.
 Issue 37537  has been merged into this issue.
 Issue 37482  has been merged into this issue.
Comment 48 by dhw@chromium.org, Mar 6 2010
 Issue 37517  has been merged into this issue.
Comment 49 by dhw@chromium.org, Mar 6 2010
 Issue 37508  has been merged into this issue.
Comment 50 by dhw@chromium.org, Mar 6 2010
 Issue 37483  has been merged into this issue.
Comment 51 by dhw@chromium.org, Mar 6 2010
 Issue 37569  has been merged into this issue.
This happened to me, too when I used the offline version! (on the latest version)
what version of chrome?
Chrome version: 5.0.349.0 (Developer Build 40971)

Issue seems to be fixed in this release, anyone care to confirm?
Yes this is working
Works for me.
Comment 57 by Deleted ...@, May 5 2010
fixed on 5.0.396! (Daily Updates - PPA)
Have enabled offline gmail in Chrome build 6.0.447.0 using standard gmail settings.  The process generated a desktop icon with the following target information: 

"C:\Documents and Settings\William\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" --app="https://mail.google.com/mail/"

Offline database is in the Gears folder and size changed as synchronization progressed.  Chrome crashes as soon as above command is issued.  Synchronization appears to work fine, but I cannot access the offline mail.  Can start and use Chrome normally without any issues.  Normal gmail is fine as well.  Have attached screen shot of directory containing databases.


Screen - offline mail issue.bmp
2.2 MB Download
@WSklar99: There was a regression in build 6.0.447.0 that caused application shortcuts to crash. ( bug 47484 ). That should be resolved now, are you still experiencing the problem?

If so, then please follow the instructions here (http://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug) to find the "report ID" for your crash.
Comment 60 by Deleted ...@, Aug 25 2010
I am running windows xp professional sp3 and chrome version 5.0.375.127.
Chrome crashes everytime i login to gmail.
The problem appears to happen when the loading var is around 75%.
The same version with comment 60 ( chrome 5.0.375.127) but in windows 7.
Firstly it worked even with gmail.
Then I installed beta 6 and it crashed when I opened gmail.
After that I uninstalled chrome then reinstall stable version (chrome 5), but nothing changed. It still crashed on gmail.

Gmail and Chrome is the "children" of Google. 
Why they can't play along peacefully?
I've just started to love Chrome (today!) but I'm being put off by this issue, seriously.
:(
If you are getting crashes, please open a new bug.
In that bug, follow the instructions here:
  http://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug
and make sure to include either a report id or client id.
Comment 63 by Deleted ...@, Nov 4 2010
still have this
It is solved
@jerome.
how does it solved?
I do not know but in the actual version it is solved
@jerome: see comment #62.
Er, i meant @jeffpeiyt :)
Comment 69 by Deleted ...@, Jan 9 2011
I am using Chrome version 8.0.552.224.

I can only access GMail if I use a browser other than Chrome, or by using Chrome on another PC. (I've tried deleting it and reinstalling. It doesn't help.)

When I bring up GMail I can login. But it flashes the messages and then goes to a blank screen that looks like it's loading. And that it where it stays.
I can switch to the HTML version and get my email that way. But it's much easier to simply switch to IE or Firefox.

I appreciating reading in this thrad that the problem is solved but, for me, it's not.
Could someone let me know how to use GMail with Chrome?
moshe.haven@gmail.com
@moshe.haven: open a new bug for other issues. Also check if you have any chrome extensions (if so then disable them all and see what happens).
Labels: -Regression bulkmove Type-Regression
Chrome Version       : &lt;5.0.341.0 40245&gt;
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK
  Chrome 5.0.328.0 : OK 
What steps will reproduce the problem?
1. Open Chromium
2. Open gmail
3.

What is the expected result?
Gmail should open

What happens instead?
Chromium chrash during the opéning of gmail

Please provide any additional information below. Attach a screenshot if
possible.
Labels: -Crash Stability-Crash
Chrome Version       : &lt;5.0.341.0 40245&gt;
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK
  Chrome 5.0.328.0 : OK 
What steps will reproduce the problem?
1. Open Chromium
2. Open gmail
3.

What is the expected result?
Gmail should open

What happens instead?
Chromium chrash during the opéning of gmail

Please provide any additional information below. Attach a screenshot if
possible.
Project Member Comment 73 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 74 by bugdroid1@chromium.org, Mar 9 2013
Labels: -Type-Regression Type-Bug-Regression
Project Member Comment 75 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-Undefined
Sign in to add a comment