New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 67 users

Issue metadata

Status: Untriaged
Owner: ----
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 370022: switching virtual desktops leaves artifacts from the previous desktop

Reported by stephen....@gmail.com, May 5 2014

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.86 Safari/537.36

Steps to reproduce the problem:
I'm running Chrome 35 in LXDE/Xmonad and just upgraded to Ubuntu Trusty.

Now, when I switch desktops, if Chrome was on, say, Desktop 3, and I switch to Desktop 4 then:

* If desktop 4 is empty, then I still see Chrome. If I open a new application, then the new application renders correctly.

* If desktop 4 has a application already running then, somewhat randomly: 1) sometimes it looks fine, 2) sometimes I see all of Chrome still displayed, 3) sometimes parts of the application are shown and parts are not. If I move the mouse around, then some of the correct output is redrawn over the old Chrome output, but not all of it.

What is the expected behavior?
For virtual desktop switching to not leave artifacts.

What went wrong?
It does leave artifacts.

This makes it hard to read the switched-to desktop and makes Chrome 35 basically unusable for me. 

E.g. I switch to my email client and can't read any email, because the Chrome UI is still being shown.

Did this work before? Yes In Ubuntu Saucy

Chrome version: 35.0.1916.86  Channel: beta
OS Version: Ubuntu Trusty
Flash Version: Shockwave Flash 13.0 r0

I apologize if this is not a Chrome bug--I have another machine running Ubuntu Saucy, with the same LXDE/Xmonad setup, and it works fine there, I don't get artifacts when switching windows.

I know that points to an Ubuntu Trusty bug, but my only hesitation is that these artifacts only happen with Chrome. If I switch desktops that are displaying any other applications, like email or terminal or Firefox or empty, everything works fine.

It's only when I switch from a desktop with Chrome 35 to something else that I get these wonky "still showing Chrome from the previous desktop" artifacts.

Even if you can point me in the right direction, of what component might be causing this, or where else I should file a bug, I'd really appreciate it.

(I've checked the other major players, and both Saucy and Trusty are using the same versions of xmonad/LXDE, so I don't believe they're at fault.)

Also, it seems to be worse is Chrome is actively fetching a page from the network--e.g. I'll be on Desktop 4, but if Chrome on Desktop 3 is loading a page, it will redraw itself on top of the Desktop 4, even if I had briefly seen Desktop 4's content.
 
Showing comments 5 - 104 of 104 Older

Comment 6 by Deleted ...@, May 23 2014

I have a similar problem on ArchLinux with XMonad (two monitors, intel driver) and it started with Chromium 35. Interestingly, if the window does not occupy whole screen (it's floating or tiled along with other windows) it behaves fine but once it's maximized, weird things begin.

Comment 7 by Deleted ...@, May 27 2014

Seeing this same issue with Ubuntu 14.04 and Gnome/Metacity.

Comment 8 by mdempsky@chromium.org, May 27 2014

Cc: piman@chromium.org sadrul@chromium.org
 Issue 375037  has been merged into this issue.

Comment 9 by a...@pdp7.net, May 27 2014

I too can confirm this, xmonad + nvidia drivers (331.67-2) + Google Chrome Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2008.2 Safari/537.36

Comment 10 by timothe@google.com, May 28 2014

Using xcompmgr with xmonad fixed that issue for me.

Comment 11 by ryans...@gmail.com, May 30 2014

Same for me, xcompmgr also fixed it, but it would be better if this was not a problem to begin with.

Comment 12 by bderr@google.com, May 30 2014

I'm running i3 and have started using xcompmgr which has corrected most of the chrome artifact problems. Primarily these came from pop-up notifications from things like calendar or music track changes. My main concern at this point is that the Google calendar notifications will pop-up over the top of my screen locker (i3lock). This is a privacy issue that should make this a higher priority.

Ubuntu 14.04
Chrome 35.0.1916.114
xcompmgr 1.1.6
i3-wm 4.7.2
i3lock 2.5

Comment 13 by Deleted ...@, May 31 2014

I had this problem, have found a few references to disabling hardware acceleration.

Though it would seem it defies the few recommendation to turn it off, I found this page and did what it said (turning ON hardware acceleration).

http://www.webupd8.org/2014/01/enable-hardware-acceleration-in-chrome.html

It work for me, no more artifacts of moved/minimized chromium windows.

Added bonus, you don't have to fear modifying switches on the command line. I was worried about doing so as i could not find a corresponding enable switch to go with the disable command. I was afraid i would not be able to revert the changes.

Anyway... the posted method leads you to the chromium config page, which has an enable/disable button along with a reset to defaults.
So, you can try it out and not be worried about the ability to undo the changes.

I haven't rebooted yet, but my buggy window painting was extremely consistent.
Now it is fixed after restarting chromium.

Comment 14 by johannes...@gmail.com, Jun 5 2014

Using flag `--disable-gpu-compositing` fixed this for me.

Version 34.0.1847.116 Ubuntu 14.04 aura (260972)

Comment 15 by johannes...@gmail.com, Jun 5 2014

Correction: `--disable-gpu-compositing` fixes it only for switching desktops not for swapping windows using xmonad.

Comment 16 by Deleted ...@, Jun 11 2014

I think applies to any accelerated rendering, on the NVidia driver, without xcompmgr or other compositor.

I'm experiencing this, but I can reproduce it with glxgears, not just chromium. So I don't think this is a chromium issue. Ref: https://bbs.archlinux.org/viewtopic.php?id=175658&p=2

Comment 17 by roni.cho...@kitware.com, Jun 11 2014

Wow, smart find (I just reproduced the problem using glxgears on my end).

For those of us who have barely any grasp on how all this works, can you recommend a way to solve this?  For example, how would I use xcompmgr to fix this?  Thanks!

Comment 18 by dstern@google.com, Jun 11 2014

Running "xcompmgr -a &" in a terminal should fix the issue (by enabling basic server-side compositing) - you probably want to add that line to your .Xsession or other initialization script.

Comment 19 by roni.cho...@kitware.com, Jun 11 2014

Fantastic.  Seems to work like a charm.  Thanks!!

Comment 20 by shadowc...@gmail.com, Jun 26 2014

Well, I just got this behavior on Gentoo Linux running LXDE on Openbox for Chromium versions 35.0.1916.153 and 36.0.1985.67.

My experience matches Stephen's above with one addition; if I leave Chromium up for longer than 10 minutes, rendering of all virtual desktops when switching from one to another takes much longer.

For clarification, I am not running xmonad or xcompmgr, but I am running nvidia-drivers-337.25 and chrome-binary-plugins-36.0.1985.84_beta1.

And, I could not reproduce the behavior with glxgears.  glxgears ran just fine for over 10 minutes and didn't artifact between desktops or on the same desktop when minimized.  

Adding '--disable-gpu-compositing' to the chromium command caused all tabs to tile each of the pages it was requesting within each tab's page area, and produced a lot of the following in the terminal:
...
[16828:16855:0626/094135:ERROR:gservices_settings.cc(103)] Setting not found: checkin_interval
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(77)] [.Compositor-0x36c461406e0]GL ERROR :GL_INVALID_ENUM : glBindTexture: target was GL_FALSE
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(1891)] [.Compositor-0x36c461406e0]GL ERROR :GL_INVALID_ENUM : glTexParameteri: target was GL_FALSE
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(1891)]
...<snip>...
[16828:16914:0626/094135:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(77)] [.Compositor-0x36c461406e0]GL ERROR :GL_INVALID_ENUM : glBindTexture: target was GL_FALSE
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(1891)] [.Compositor-0x36c461406e0]GL ERROR :GL_INVALID_ENUM : glTexParameteri: target was GL_FALSE
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(1891)]
...<snip>...
[16870:16870:0626/164135:ERROR:gles2_cmd_decoder_autogen.h(1891)] [.Compositor-0x36c461406e0]GL ERROR :GL_INVALID_ENUM : glTexParameteri: target was GL_FALSE
[16870:16870:0626/164135:ERROR:logger.cc(46)] Too many GL errors, not reporting any more for this context. use --disable-gl-error-limit to see all errors.
[WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
[16828:16855:0626/094157:ERROR:raw_channel_posix.cc(139)] recvmsg: Connection reset by peer
[16828:16855:0626/094157:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
...<snip>...

HTH.

Comment 21 by piman@chromium.org, Jun 26 2014

--disable-gpu-compositing is not a functional flag. Please don't use it :)

You can use --disable-gpu if you want to disable the usage of the GPU.

Comment 22 by sdayala@chromium.org, Jul 7 2014

Labels: Needs-Feedback
folks, are u still getting the same issue?Can you please try as per comment#21?

Comment 23 by johannes...@gmail.com, Jul 7 2014

#21 seems to fix it for me but disabling GPU support doesn't seem like a proper solution.

Comment 24 by vin...@doorstop.net, Jul 7 2014

Running xcompmgr fixes it for me.

Comment 25 by Deleted ...@, Jul 7 2014

#21 fixes it for me.

Comment 26 by martink...@gmail.com, Jul 10 2014

I have the same problem with Chrome "36.0.1985.103 beta" and Linux Mint 17 MATE which is based on Ubuntu Trusty. 

The problem has appeared after upgrading from Mint 16 to Mint 17, i.e. Ubuntu Saucy to Ubuntu Trusty, with the same version of Chrome.

Chrome cannot be iconified if my window manager is not compositing. The problem can be solved by enabling compositing in window manager, or by starting Chrome with --disable-gpu option.

I also confirm that glxgears have the same problem as Chrome. So it looks like a bug in OpenGL in Ubuntu Trusty.

Comment 27 by martink...@gmail.com, Jul 10 2014

It looks like it was a bug in NVIDIA driver that is fixed in 331.89:

"Fixed an interaction problem with xserver 1.15 that occasionally caused OpenGL applications to continue rendering when they are minimized or unmapped."

http://www.sysads.co.uk/2014/07/install-nvidia-driver-331-89-on-ubuntu-14-04/

Comment 28 by Deleted ...@, Jul 26 2014

I'm still having such problem in Lubuntu 14.04.1 (full update today 2014-07-26), I also have NVIDIA graphics (GT 620).

Comment 29 by srom...@gmail.com, Aug 2 2014

I'm having this problem as well under XFCE. I use CTRL+ALT+ARROWS to move between my 6 (3x2) workspaces, and each time I move to the desktop having chromium is only partially refreshed.

I've found that it only happens if I switch on XFCE's "Enable display composition" under Settings --> Window Manager Tweaks --> Compositor.

If I disable that option, then the refresh problem disappears (but I loose as well the fance transparency effects on terminals and windows :( ).

I don't think it's an nvidia problem. My Laptop has an Intel graphic card (Chipset: Mobile Intel GE45 Express, Card: Intel GMA 4500MHD)

PS: It happens as well in Linux Mint 17.

Comment 30 by pawelszc...@gmail.com, Aug 21 2014

The Ubuntu's nvidia-current (and nvidia-331) are still 331.79.

Comment 31 by johannes...@gmail.com, Aug 21 2014

For me the issues are gone on Ubuntu 14.04 since updating to chrome 36 and removing all the options I tried before (though I never had the problems with NVIDIA but with an Intel chip).

Comment 32 Deleted

Comment 33 by Deleted ...@, Aug 26 2014

On 14.04.1 and Nvidia 304-117, Chrome/36.0.1985.143
Tried using the suggestions on the webupd8 site (enabling hardware acceleration)- seemed to fix the multiple windows issue, but it returned in short order.  I also get a flickering cursor and check-boxes in Chrome (but not Firefox).  This is occurring on two or three machines on my network which I've upgraded this week.

Common denominator seems to be the version upgrade to 14.04 on Ubuntu and to 17 on Mint.  I never had this issue on 12.04 LTS.

Comment 34 by Deleted ...@, Aug 27 2014

Addendum:  Upgrading to NVidia's 331.38 (curiously, the latest available @ the main Ubuntu repos) appears to have solved the problem, both with Chrome and with the MythTV application playing a full-screen video on one of the desktops.  I also updated Chrome to 37.0.2062.94.  So far, so good.

Comment 35 by dow4hu...@gmail.com, Oct 8 2014

LinuxMint 17
Nvidia 331.38
window compositing turned on
Google Chrome 37.0.2062.120 (window not maximized)

Still have to switch desktops twice to remove Chrome window from displaying on a desktop it is not supposed to show on. 

With glxgears, I have to switch to a desktop without any windows at all and then back to a desktop I need to use, to get the glxgears window to not show up.

Comment 36 Deleted

Comment 37 by Deleted ...@, Oct 8 2014

I discovered after many tests, that this problem only happens in Ubuntu derivatives of 64 bits. So if you want to avoid this problem, install the "original" Ubuntu 64, or derivatives of 32 bits. I tested with Nvidia 750 Ti SC and Nvidia 620, distributions (all 14.04) Ubuntu 64/32, Lubuntu 64/32, Xubuntu 64/32, LXLE 64. The problem only happened in Google Chrome and Steam "Desktop Client".

Comment 38 by dow4hu...@gmail.com, Oct 8 2014

Adding the x-org-edgers repo to get the nvidia 331.89 driver fixed the problem in Linux Mint 17.  Reference back to comment #35 for my initial versions.  Maximized Google Chrome and glxgears now do not show artifacts or windows on desktops they were not started on when switching desktops.

Comment 39 by Deleted ...@, Oct 9 2014

Have the same problem with Ubuntu 14.04, Nvidia 331.38 and Xmonad. Happens with Chromium, Opera 26 and Spotify. Looks like xcompmgr fixes it.

Comment 40 by Deleted ...@, Oct 15 2014

Looks like xcompmgr is awesome - because fixed the issue for me as well! ;-) Running Ubuntu Release 12.04 (precise) 64-bit
Kernel Linux 3.2.0-32-generic
GNOME 3.4.2
Unity + Multi-Desktop Environment
command in terminal to fix: sudo apt-get install xcompmgr
pw + install (y) 
Issue is gone - and working immediately. Thanks to all contributors.

Comment 41 by mdempsky@chromium.org, Oct 24 2014

Cc: jbau...@chromium.org
 Issue 378420  has been merged into this issue.

Comment 42 by mdempsky@chromium.org, Oct 24 2014

I spent some time trying to repro this.  Here's where I've gotten so far:

Using Ubuntu 14.04.1, Xorg 7.7, Nvidia's 331.79 drivers, and xmonad 0.11 (and xmobar + xscreensaver), I'm able to reproduce very similar repainting problems using just uxterm and glxgears, even in a fresh X server session where I've never run Chrome.  (I haven't yet tried a fresh machine reboot without having run Chrome.)

So at this point, it doesn't seem likely that Chromium specifically is the culprit.  Since people have reported similar issues with non-Ubuntu and non-xmonad window managers, it seems highly suspect the issue is either in Xorg or Nvidia's drivers.

(As one tangential data point, I've heard from several OpenBSD developers that Chromium has lately started mispainting on OpenBSD too; however, Nvidia doesn't provide binary drivers for OpenBSD, so *if* it that had the same root cause, it would seemingly have to be in Xorg.)

Comment 43 by kenlu@google.com, Oct 24 2014

I've experienced this with another app using OpenGL, so it's not specific to Chromium.

compton seems to be a fork of xcompmgr that is more up-to-date, and it works to fix this problem with:

compton --backend glx --paint-on-overlay

And you can add a -b flag when running it on startup.

Comment 44 by skuhne@chromium.org, Oct 28 2014

I just had to reboot my linux system and got a new nvidia driver (and I think chrome updated itself in the process as well).

After that I constantly get white rectangles drawn on top of everything where the last Chrome window is / was (e.g.: minimizing chrome drawed the rectangle sporadically where it had been before). After starting compton as indicated in #43 it worked properly and I got this output:

restack_win(0x01000ac6, 0x010000af): Failed to found new above window.
restack_win(0x01000375, 0x010000af): Failed to found new above window.
restack_win(0x0380004f, 0x010000af): Failed to found new above window.
restack_win(0x01004a00, 0x010000af): Failed to found new above window.
restack_win(0x01e0001f, 0x010000af): Failed to found new above window.
restack_win(0x01e0000b, 0x010000af): Failed to found new above window.
restack_win(0x01a0000a, 0x010000af): Failed to found new above window.
[     0.24 ] error 9 (BadDrawable) request 14 minor 0 serial 1070 ("BadDrawable (invalid Pixmap or Window parameter)")
glx_bind_pixmap(0x04400118): Failed to query Pixmap info.
win_paint_win(0x01008216): Failed to bind texture. Expect troubles.
win_paint_win(0x01008216): Missing painting data. This is a bad sign.
[     0.26 ] error 4 (BadPixmap) request 54 minor 0 serial 1302 ("BadPixmap (invalid Pixmap parameter)")
[    18.37 ] error 9 (BadDrawable) request 14 minor 0 serial 13023 ("BadDrawable (invalid Pixmap or Window parameter)")
glx_bind_pixmap(0x04400606): Failed to query Pixmap info.
win_paint_win(0x01009570): Failed to bind texture. Expect troubles.
win_paint_win(0x01009570): Missing painting data. This is a bad sign.
[    18.37 ] error 4 (BadPixmap) request 54 minor 0 serial 13037 ("BadPixmap (invalid Pixmap parameter)")
[    24.15 ] error 3 (BadWindow) request 138 minor 7 serial 26242 ("BadWindow (invalid Window parameter)")
[    24.15 ] error 140 (BadRegion) request 138 minor 17 serial 26243 ("BadRegion (invalid Region parameter)")
[    24.15 ] error 140 (BadRegion) request 138 minor 14 serial 26244 ("BadRegion (invalid Region parameter)")
[    24.15 ] error 140 (BadRegion) request 138 minor 10 serial 26245 ("BadRegion (invalid Region parameter)")
[    24.16 ] error 9 (BadDrawable) request 14 minor 0 serial 26345 ("BadDrawable (invalid Pixmap or Window parameter)")
glx_bind_pixmap(0x04400a97): Failed to query Pixmap info.
win_paint_win(0x0100962f): Failed to bind texture. Expect troubles.
win_paint_win(0x0100962f): Missing painting data. This is a bad sign.
[    24.16 ] error 4 (BadPixmap) request 54 minor 0 serial 26359 ("BadPixmap (invalid Pixmap parameter)")

Using xwininfo indicates that there is no window. So in my case this might very well be a driver problem.

Comment 45 by vex...@gmail.com, Nov 29 2014

I've been experiencing a similar problem for a couple of months on OpenBSD, but with an Intel card:

ga1 at pci0 dev 2 function 0 "Intel HD Graphics 4000" rev 0x09
intagp at vga1 not configured
inteldrm0 at vga1
drm0 at inteldrm0
drm: Memory usable by graphics device = 2048M
inteldrm0: 1366x768

Currently I am running 39.0.2171.65 and the bug is still with me. It's super annoying.

Behavior is as follows:
 1) Start chrome on a fresh desktop switch to another and back, it will redraw correctly every time.
 2) Start a terminal on the same desktop as chrome, then switch to another desktop and back. Redraw will only occur if the mouse is on-top of chrome after the desktop switch, otherwise the desktop background is in the chrome window.
 3) When chrome fails to redraw (as in 2), moving the mouse over chrome will cause a redraw.
 4) Starting chrome with --disable-gpu works around this. As does --disable-gpu-compositing.
 5) A compositor will make no difference. I have tried xcompmgr, compton and the xfce4 built-in compositors.

I am not using any binary drivers, just the opensource driver in xorg 1.16.2.

Screenshot attached.
openbsd.png
2.6 MB View Download

Comment 46 by martink...@gmail.com, Dec 11 2014

Ubuntu 14.04 released an update to Nvidia drivers to version 311.113 and the problem disappeared. Checked both Chrome and glxgears.

Comment 47 by Deleted ...@, Dec 12 2014

Did you mean Nvidia driver version "331.113" rather than "311.113"?

Comment 48 by martink...@gmail.com, Dec 15 2014

Yes, I meant 331.113, sorry for the typo.

Comment 49 by here...@gmail.com, Jan 11 2015

ubuntu 14.04.01
Linux 3.13.0-43-generic
xfce 4.10
chrome Version 40.0.2214.45 beta (64-bit)

nvidia driver: none? how to check this?

Switching desktops results in chrome on target desktop appearing as previous desktop's background.

Fix #29: Disable all of XFCE's "Enable display composition" under Settings --> Window Manager Tweaks --> Compositor.

Comment 50 by Deleted ...@, Jan 23 2015

Ubuntu 14.04.1
Linux version 3.13.0-44-generic
xfce 4.10
Chrome Version 40.0.2214.91 (64-bit)

Intel HD 4000 integrated graphics card, driver=i915

Changing to a workspace with Chrome open results in parts of the open Chrome window not drawing over top of the image from the previous desktop.  Sometimes it will be part of the the window usually the top half and sometimes it is the entire window so that it appears as if the workspace has not changed at all.  Switching to a different window in the same workspaces causes Chrome to redraw, moving the mouse pointer over certain screen elements results in them being redrawn.  Animated elements such as the loading spinner on tabs are always redrawn.  Scrolling a webpage also results in a redraw.

Can confirm that disabling "Enable display composition" prevents the issue from occurring.

Issue began occurring after a recent update that included an update for Chrome.

Comment 51 by eugene.c...@gmail.com, Jan 24 2015

I'm seeing similar corruption, but here is my use case:
I notice after updating to chromium 40 (on Gentoo) with intel5000

If I open chromium, switch desktops, and come back to the desktop with chromium, it still shows the last desktop until I mouse over the windows, in which case 'parts' of the window reappears, or minimize/maximize which redraws the window

I am using compton on awesome.

Comment 52 by frant.ha...@gmail.com, Jan 27 2015

Ubuntu 14.04.1 LTS (xubuntu)
xfce 4.10
Chrome Version 40.0.2214.91 (64-bit)
Intel HD 4000 (i915)

Same issue as #49 and #50, appeared after recent update of chrome.

Interestingly, using primusrun (or optirun) to run chrome using my discrete nvidia card the issue goes away.

Comment 53 Deleted

Comment 54 by t4exan...@gmail.com, Jan 29 2015

I'm having the same issues as many others here: when I switch away from a desktop with an open Chrome window, and back to that desktop, there are artifacts from the other desktop inside the Chrome window. Once I move the mouse, the artifacts go away. Chrome apps running in window mode seem the most affected, although it happens to the main Chrome window as well. 

It began sometime in the last 6 months, but I've lost track of when it began. It didn't always occur, though. I am running Chrome Dev and Chrome Beta, 64bit (I use Dev daily, Beta is a backup for times when the Dev release gets buggy). I am running Peppermint 5 (64bit), using LXDE/xfwm4. I have an NVidia card, but it should be disabled, so I'm not sure this issue has anything to do with the graphics card. It seems pretty specific to Chrome. I've noticed that the screen artifacts issue seems to occur mainly in the Dev channel releases, Beta seems immune (at least the last time I tested it). 

I tried many of the fixes mentioned here, with no luck. I was hoping the xcompmgr fix would resolve the issue, but since I am already running xfwm4, xcompmgr won't run. I shouldn't have to muck around with my compositer to get Chrome working properly, anyway.

Comment 55 by jerko.st...@gmail.com, Jan 29 2015

Ubuntu 14.04.1 LTS
i3wm
compton
lenovo x230 (Intel HD 4000)

I have the same issue as #50, started showing after last update.

Comment 56 Deleted

Comment 57 by jeroen.m...@gmail.com, Feb 2 2015

I have the same issue as #50 and #55.

Ubuntu 14.04.1 LTS (32-bit)
i3wm version 4.8-101-g8870edc (2014-09-21)
Compton with the following config https://github.com/fluxw42/dotfiles/blob/master/i3wm/.config/compton.conf
HP EliteBook 8440p (Intel HD Graphics)

Comment 58 by Deleted ...@, Feb 2 2015

#50's issues This started 2 updates ago for me, but I was quite behind prior to that. Aptitude shows that I'm up-to-date at the moment. I've been using the unstable build (42.0.2288.6 dev (64-bit)) and it seems fine with compositing.

Chrome 40.0.2214.94 (64-bit)
Linux Mint 16 Petra
XFCE 4.1
NVIDIA Corporation GK107M [GeForce GT 640M] (rev ff)
Intel Corporation 3rd Gen Core processor Graphics Controller

Comment 59 by Deleted ...@, Feb 2 2015

I can also confirm -- the same problem as #50 started happening once I updated to Chrome 40.  Chrome beta (42) also has the same problem.

Comment 60 by dac.char...@gmail.com, Feb 8 2015

This bug happens to me too, it started a few weeks ago.

Xububtu 14.04.1, Chrome Version 40.0.2214.111 (64-bit)

I'm on a Lenovo X220 with Intel video drivers {Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)} so I'm not sure how this has to do with nvidia?

Regards,

Comment 61 by rentie...@gmail.com, Feb 10 2015

I also have this issue described. To get the behaviour seen in the screenshot, I minimized Eclipse and Chrome, then brought back Eclipse to foreground, then Chrome. Even with Chrome at top, Eclipse shines through. I can see my bookmarks and the other UI elements when I hover over them with the mouse cursor.

Xubuntu 14.04.1 LTS
Google Chrome 40.0.2214.111 
Linux version 3.13.0-45-generic (buildd@phianna) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #74-Ubuntu SMP Tue Jan 13 19:36:28 UTC 2015

I run on a t430, driver for the built-in GPU is  drm/i915.
chrome-artifacts.png
248 KB View Download

Comment 62 by Deleted ...@, Feb 10 2015

I too, am experiencing this bug since the past few weeks, on all 3 of my computers (Xubuntu 14.04.1).

Comment 63 by b...@brillat.net, Feb 15 2015

Just started recently for me, Xubuntu 14.04.1 with Xfwm4 and xfce.  Can't run xcompmgr, get the error: "Another composite manager is already running (Xfwm4)"

Chrome version is 40.0.2214.111 (64-bit).

Comment 64 by Deleted ...@, Feb 17 2015

I am having the same issue on Chromium 40.0.2214.111. I tried xcompmgr and compton and still it tears when switching desktops.

This happens on multiple of my machines.

Comment 65 by Deleted ...@, Feb 27 2015

Confirmed on Linux Mint 17.1 MATE with Google Chrome Beta version 41.0.2274.74 

User agent string:

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.74 Safari/537.36

Command line: 

/usr/bin/google-chrome-beta --user-data-dir=/home/owner/.config/google-chrome-beta --flag-switches-begin --manual-enhanced-bookmarks --flag-switches-end

GPU is Intel HD 4400 on a Core i5-4200U

Comment 66 by Deleted ...@, Feb 27 2015

This happens when I click on the chrome entry in the mate panel

Comment 67 by Deleted ...@, Mar 10 2015

This spontaneously started happening to me recently as well.  Other apps aren't tearing, but Chrome is and I tried a couple different compositors, but the result is the same.
Debian (Ubuntu 14.04), Awesome WM, Chrome 41.0.2272.76 (64-bit)
xcompmgr and unagi were tried

Comment 68 by Deleted ...@, Mar 10 2015

Disabling hardware acceleration in chrome settings solves the problem.
Xubuntu 14.04
Google Chrome 42.0.2311.22 beta (64-bit)

Comment 69 by lrn@google.com, Mar 10 2015

Same problem, xmonad on Ubuntu. Has had the problem for weeks, and xcompmgr doesn't help.

Comment 70 by t4exan...@gmail.com, Mar 10 2015

Indeed, disabling hardware acceleration worked (and doesn't seem to affect performance much). Make sure you close all Chrome processes (including background ones) after making the change, and then restart the browser.

Comment 71 by mdempsky@chromium.org, Mar 10 2015

FYI, I think we have ample "me too" reports across a variety of Chromium versions, Linux distros, GPU models, and desktop environments, so I don't think additional reports are helpful at this point.

What would be really useful is if someone could 1) come up with a simple reliable method to reproduce the issue, and 2) determine when the issue first showed up (or maybe it's always been present, and we only noticed once Chromium started using GLX more often).

As I mentioned in #42, I've reproduced the issue before with just glxgears and uxterm, so I don't think this is even a Chromium-specific issue.  I would suspect something's wrong with the X server and/or GPU drivers, but debugging those is outside of my expertise.

Comment 72 by Deleted ...@, Mar 11 2015

Apologies to post #71, but while I cannot add significantly more detail for reproduction sake, I can confirm that disabling h/w acceleration does resolve the problem.

I am running on Intel Integrated graphics (have not been able to get NVIDIA / bumblebee working recently).

It really does seem like hybrid graphics laptops are heavily represented on this thread.

Comment 73 Deleted

Comment 74 by justin.k...@gmail.com, Mar 11 2015

I have a Core2-class desktop and a Westmere-class laptop, both using Intel graphics chips (no hybrid for me...), and both exhibit the same problem. I can also verify that turning off h/w acceleration resolves the issue.
Both are running xfce on Ubuntu 14.04.

Comment 75 by mdempsky@chromium.org, Mar 11 2015

Labels: -Needs-Feedback HelpWanted
Status: Available

Comment 76 by samuel...@gmail.com, Mar 24 2015

Same problem with version 41.0.2272.101 on intel hd 3000 on Slackware and AwesomeWM.

Comment 77 by mattsha...@gmail.com, Mar 28 2015

Same issue in Xubuntu 14.04 64-bit with 3.13.0-48-generic in Google Chrome 41.0.2272.101. Intel HD 4000 Graphics.

I have xfce's "enable display compositiong" enabled.

This bug is really annoying and I've been living with it for a while now. Is anybody working on this?

Comment 78 by farhado...@gmail.com, Mar 30 2015

This is horrible. This happens after each page load: All other browser windows get totally mixed up with artefacts.

Debian KDE Kwin
Google Chrome stable Version 41.0.2272.101 (64-bit)
Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]

Comment 79 by msimprov...@gmail.com, Mar 30 2015

Please upload a screenshot.

Comment 80 by jonathan.garbee@chromium.org, Mar 30 2015

We don't need screenshots of the issue. What is happening is pretty clear. The problem is solving it since it could be one of any number of things in the graphics stack causing problems.

Comment 81 by denilsonsa@gmail.com, May 11 2015

There is a related bug report on compton repository: https://github.com/chjj/compton/issues/283
That bug report includes a screencast: https://www.youtube.com/watch?v=VG1q6LnAB3M

This may or may not be related to some compton options set in ~/.config/compton.conf

Comment 82 by 7aadit...@gmail.com, May 15 2015

Updating the Intel graphics driver fixed this problem for me.

Xubuntu 14.04.2 LTS
IntelĀ® HD Graphics 4000
xf86-video-intel 2.99.914-1~exp1ubuntu4.2~trusty1
xorg-server 1.16.0-1ubuntu1.2~trusty2
Linux 3.16.0-37-generic

I did this by installing the kernel and X stack of utopic.
See https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Comment 83 by 7aadit...@gmail.com, May 15 2015

Before updating the X stack check whether this xorg.conf solves the problem:

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option "AccelMethod" "UXA"
EndSection

Comment 84 by t4exan...@gmail.com, May 15 2015

What if you don't have an xorg.conf.d/ folder? I can't seem to find any
20-intel.conf file (I do have an intel graphics driver, though).

Also, what is the easiest way to upload the graphics driver? Can it be done
from a repo, or do you have to compile yourself? (I'm assuming that depends
on your OS/distro.) I'm running Chromixium, which is a fork of Ubuntu
(iirc).

Comment 85 by jankamme...@gmail.com, Jun 25 2015

Updating the X11 config worked for me with OpenSUSE 13.1 on ThinkPad X230

Comment 86 by patricke...@gmail.com, Jul 20 2015

google-chrome --dissable-gpu worked for me, but high use of cpu.

Comment 87 by mark.tem...@gmail.com, Jul 23 2015

I use arch linux 64, xmonad, nvidia (latest hardware and everything). I have been having this problem for a couple of weeks. I have fixed it. Quit using Chrome. Firefox always comes  up fine. Go figure.

Comment 88 by roc...@chromium.org, Aug 21 2015

Is there anything specific I can look at to help track down this bug? It's starting to hinder my productivity. D:

Not too familiar with GPU stuff but I might be able to get somewhere with a bit of guidance.

Comment 89 by mdempsky@chromium.org, Aug 21 2015

#88: Sorry, no advice on how to dig into the bug, except maybe to start by trying to see what combinations of software/hardware trigger it.  If you want a quick productivity fix, I suggest just running a compositing manager like xcompmgr.

Comment 90 by th317...@gmail.com, Aug 21 2015

I use xcompmgr myself and that didn't help fix the issue. The only thing that did help for me was editing Xorg.conf as suggested by the helpful user in comment #83. You can also disable hardware acceleration, but this obviously has its drawbacks: http://ccm.net/faq/35743-google-chrome-how-to-disable-hardware-acceleration

Comment 91 by patricke...@gmail.com, Aug 21 2015

To replicate the bug, you can use a debian machine and install 'awesome windows manager', access google chrome and change to another desktop.

Comment 92 by ju.o...@gmail.com, Jun 17 2016

When I switch from one workspace to one containing the chromium window it takes about one second to redraw the chromium window.

This problem started appearing after I switched from the open source Intel driver to the built-in modesetting driver. That is, I uninstalled the xf86-video-intel driver and the 20-intel.conf file.

Comment 93 by thomasanderson@chromium.org, Sep 28 2016

Cc: thomasanderson@chromium.org

Comment 94 by sheriffbot@chromium.org, Sep 28 2017

Project Member
Labels: Hotlist-Recharge-Cold
Status: Untriaged (was: Available)
This issue has been Available for over a year. If it's no longer important or seems unlikely to be fixed, please consider closing it out. If it is important, please re-triage the issue.

Sorry for the inconvenience if the bug really should have been left as Available. If you change it back, also remove the "Hotlist-Recharge-Cold" label.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 95 by thomasanderson@chromium.org, Nov 16 2017

Is anyone still affected by this issue?  If not, I'd like to close it out.

Comment 96 by timothyv...@gmail.com, Nov 17 2017

@thomas

I am still affected by this issue. Hence i am following this thread.

Comment 97 by thomasanderson@chromium.org, Nov 17 2017

c#96: Which chrome version and window manager ("wmtrl -m") are you using?  What graphics hardware?

Also if the issue is reproducible, could you provide us with recent repro steps?

Comment 98 by timothyv...@gmail.com, Nov 17 2017

c#97, Ill  try to reproduce this weekend. I now have a total diffrent
configuration. But am willing to do reproduce

Comment 99 by aga...@chromium.org, Nov 20 2017

Last I checked, I am still affected by this issue. I still have GPU acceleration disabled as a workaround, although that prevents me from accessing all WebGL content.

62.0.3202.29 (Official Build) beta (64-bit)
Linux
Xmonad
Two 24" monitors and one 32" 4K monitor

Comment 100 by robliao@chromium.org, Aug 27

Labels: Hotlist-PopularIssue

Comment 101 Deleted

Comment 102 by woo...@gmail.com, Oct 8

Still affected. It also affects Electron apps.
Graphics is Intel HD Graphics 5500.
Workaround from comment #87 didn't work.
Using: 
Chromium 69.0.3497.100
i3-gaps 4.15 as window manager
compton as compositor
Disabling hardware acceleration or compositor solves it, but then experience is also subpar.

Comment 103 by woo...@gmail.com, Oct 8

Interesting thing I noticed is that this happens only if window fills the screen or in fullscreen, if window has border it works ok.

Comment 104 by opensu...@gmail.com, Nov 15

same issue here
Showing comments 5 - 104 of 104 Older

Sign in to add a comment