New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 19 users

Issue metadata

Status: Fixed
Owner: ----
Closed: May 2014
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug

Sign in to add a comment

Hangouts does not work on Google Chrome beta

Reported by, Apr 14 2014 Back to list

Issue description

Chrome Version       : 35.0.1916.27
OS Version: Kubuntu 14.04
URLs (if applicable) : Any google hangout video chat

What steps will reproduce the problem?
1. Try to do a hangout voice/video chat with someone

What is the expected result?
You should be able to

What happens instead of that?
You can't, because hangouts plugin is NPAPI only, and google chrome no longer supports it (because of Aura). The only way to use Hangouts currently is to use Firefox. 

Please provide any additional information below. Attach a screenshot if

UserAgentString: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.27 Safari/537.36


Comment 1 by, Apr 15 2014

Video Hangouts work for me on Linux 36.0.1933.0 (r262849).
@varkha: do you have a newer version of the Google hangouts plugin? 

$ apt-cache policy google-talkplugin 

Since this is an npapi plugin, it doesn't appear in "chrome://plugins" at all. When I try a video hangout, I'm redirected to a page which asks me to install the plugin. 

Comment 3 by, Apr 15 2014

Yes, same version of plugin here. Note that I am using dev channel (36.0.1933.0).

$ apt-cache policy google-talkplugin
  Version table:
 *** 0
        500 stable/main amd64 Packages
        100 /var/lib/dpkg/status
71.8 KB View Download
@arkha, interesting. Would you mind expanding the "Details" section for the talk plugin? I'll also install m36 and confirm, but I'm surprised an npapi plugin is working. 
Tried "Google Chrome	36.0.1933.0 (Official Build 262849) dev aura" and I don't see google talk plugin in the chrome://plugins. 
56.6 KB View Download
Just found something interesting. I did a reinstall of google-talkplugin, and noticed that it creates /opt/google/chrome/pepper directory with symlinks to 2 files /opt/google/talkplugin, which enable the pepper version of Google talk plugin. It does the same for /opt/google/chrome-unstable. I can confirm that after reinstall, hangouts video chat works in Chrome unstable. 

However, there is no /opt/google/chrome-beta/pepper directory created, which is why Chrome beta can't see the plugin. Any ideas where this directory might be getting created? Would it be possible to add it in /opt/google/chrome-beta too? 
Confirmed that the files come out of the debian package, i.e. they are not installed by a preinst or a postinst script:

$ dpkg -L google-talkplugin  | grep chrome 

I think it's a simple matter of adding /opt/google/chrome-beta to this list too. 

Comment 8 by, Apr 15 2014

I agree with you that it's probably a bug in the google-talkplugin package. If you make symlinks, does it fix it?
@erg: Yes, I can confirm that Hangouts works after creating the pepper/ directory and putting the symlinks manually. 
Labels: nomedia
Any updates? Can someone familiar with linux packaging be included in this bug? Seems like a quick fix to me. Thanks. 
Status: Available
Added phajdan.jr@ who seems to have updated debian/postinst last time.

Paweł, can you take a look?

Why not just make google-talkplugin install into new locations?
This looks like something that would go in the postinst of the google-talkplugin package, not google-chrome. 
Status: ExternalDependency
OK. I searched Google internal bug tracker and found that relevant folks are already working on this issue. There is nothing to do in Chromium side.
Thanks @yukawa! 
This seems to have been fixed in the 23rd April release of google-talkplugin pacakge. 
Status: Fixed
Thank you for verifying the fix. Closing as Fixed.
Hi, I'm not sure that this is fixed.  Using Debian testing.
ii  chromium       35.0.1916.11 amd64        Chromium web browser
ii  google-talkplu    amd64        Google Talk Plugin
Just reinstalled the plugin, but no dice.  I don't see it in chrome://plugins, and when I try to start a Hangout, I get the window asking me to install the plugin.  I'm using the Hangout extension which was mentioned as a workaround elsewhere, but it still doesn't work.
Also not fixed here.

For me, the hangouts plugin was crashing, and I saw there was a pending update, so I tried restarting with the newer version. Now Chromium doesn't see the plugin at all.

ii  chromium                 35.0.1916.114-2     amd64          Chromium web browser
ii  google-talkplugin           amd64          Google Talk Plugin

I even tried rebooting as well as purging and reinstalling the plugin.

Based on this bug report, I tried Firefox and it does work in Firefox. (But I don't want to have to switch browsers.)

Comment 21 by, Jun 14 2014

Debian's chromium package is looking for the plugin in /usr/lib/chromium/pepper unfortunately it is installed in /usr/lib/chromium-browser/pepper. If you create the symlinks where Debian's package expects them, it works.
Same thing here. 

Chromium Version 35.0.1916.114 Built on Debian 7.1, running on Debian 7.5 (270117) [crunchbang waldorf]. 
Asks for installs every time, even with the package installed. 

...$ apt-cache policy google-talkplugin 

  Tabla de versión:
 *** 0
        100 /var/lib/dpkg/status 0
        500 stable/main amd64 Packages

I tried to make the symlink but couldn't make it work. I'm sure it is because my ignorance...
Can you gave me a command line help so I can verify this on my box? 

Comment 23 by Deleted ...@, Jul 10 2014

The exact command is :

ln -s /usr/lib/chromium-browser/pepper/ /usr/lib/chromium/pepper

as root
Worked like a charm, thank you! :)

Comment 25 by Deleted ...@, Jul 28 2014

You're welcome

Comment 26 by, Apr 28 2015

I have to disagree that this problem is solved, having just run into it on Debian 8 installing the current google-talkplugin package.

Is the issue that Google needs to be convinced to modify their package manager to add the links referenced in comment #23, and doesn't see any reason to? Shouldn't Chromium be setup (or at least easily configured) to look for plugins in the places Chrome expects them to be installed, as a general matter?
#26 Agreed
Im experiencing this problem on Version 44.0.2403.89 running on Debian 8.1 (64-bit)
Symlinked from /opt/google/chrome to /usr/lib/chromium-browser/pepper/ , /usr/lib/chromium/pepper & /usr/lib/chromium/plugins
Plugin still undetected...
Broken again

Sign in to add a comment