New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 313438
Owner: ----
Closed: Apr 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Context menu is not shown when invoked on SVG <use> element

Reported by jan.toso...@gmail.com, Mar 28 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Steps to reproduce the problem:
1. Open http://drifted.in/other/areas.svg
2. Right-click on blue or yellow square

What is the expected behavior?
Context menu appears

What went wrong?
Nothing is displayed

Did this work before? No 

Chrome version: 33.0.1750.154  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 12.0 r0

It doesn't work on Ubuntu too.
When graphics is rendered directly, i.e. not referenced using <use> element, it works as expected, see http://drifted.in/other/areas_direct.svg

 

Comment 1 by tkent@chromium.org, Mar 31 2014

Labels: -Cr-UI Cr-Blink-SVG

Comment 2 by pdr@chromium.org, Apr 2 2014

Mergedinto: 313438
Status: Duplicate
Thank you for taking the time to file this.

I looked into why this is happening; it's a hold-over from our old SVG instance tree support. This will be fixed when we rip the instance tree out. Marking as a dupe of that bug.

Sign in to add a comment