New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 31833
Owner:
Closed: Feb 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

font-style ignored in @font-face

Reported by pavel.so...@gmail.com, Feb 14 2010

Issue description

Chrome Version       : 4.0.249.89
URLs (if applicable) : http://soukie.net
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: n/a
         IE 8: n/a

What steps will reproduce the problem?
CSS:
@font-face{font-family:"LidoSTF";src:url(LidoSTF.otf)}
@font-face{font-family:"LidoSTF";src:url(LidoSTFItalic.otf);font-
style:italic}

What is the expected result?
Text formatted as font-family:"LidoSTF" and font-style:italic should be 
displayed using the font LidoSTFItalic.otf

What happens instead?
The italic text is displayed as regular LidoSTF.otf.

Please provide any additional information below. Attach a screenshot if
possible.
You can check the http://soukie.net for examples and compare Firefox/Safari 
with Chrome.
 
Correction!

When CSS is in the order given above, everything works. However, when the order is 
reversed:

@font-face{font-family:"LidoSTF";src:url(LidoSTFItalic.otf);font-
style:italic}
@font-face{font-family:"LidoSTF";src:url(LidoSTF.otf)}

The italic font-style breaks.

Labels: -Area-Undefined Area-WebKit
Status: Assigned
Thanks for the report.
I think this is a dupe of  issue 31833 . Please explicitly specify "font-style: normal;" property for the second @font-face rule, and the problem should be resolved:

@font-face{font-family:"LidoSTF";src:url(LidoSTFItalic.otf);font-style:italic}
@font-face{font-family:"LidoSTF";src:url(LidoSTF.otf);font-style:normal}

The current WebKit behavior matches older CSS draft: http://www.w3.org/TR/2002/WD-css3-webfonts-20020802/#select
and the draft says that the default (initial) value for font-style: inside @font-face is "all" (i.e. normal | italic), NOT "normal".
You have to specify font-face:normal for the second @font-face rule not to override the first rule.
typo:
> You have to specify font-face:normal 
You have to specify font-style:normal 

Ok. Makes sense then.
Mergedinto: 31833
Status: Duplicate
Project Member

Comment 6 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:31833
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 7 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit Cr-Content
Project Member

Comment 8 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment