New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 56 users

Issue metadata

Status: WontFix
Owner: ----
Closed: Apr 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux , Windows
Pri: 1
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Mouse cursor stopped turning into a pointer while hovering over links

Reported by suprf...@gmail.com, Mar 27 2014

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1912.2 Safari/537.36

Steps to reproduce the problem:
1. Place mouse cursor over a link
2. 
3. 

What is the expected behavior?

What went wrong?
Cursor doesn't change into a pointer.

Did this work before? N/A 

Chrome version: 35.0.1912.2  Channel: n/a
OS Version: Ubuntu 13.10
Flash Version: Shockwave Flash 13.0 r0
 

Comment 1 by Deleted ...@, Mar 28 2014

I have the same problem, windows 8.1, chrome 35.0.1912.2 dev-m

Comment 2 by Deleted ...@, Mar 28 2014

Same here, Chrome Version: 35.0.1912.2 dev-m, 6.1 (Windows 7, Windows Server 2008 R2)

Comment 3 by erwinr...@gmail.com, Mar 28 2014

Same here, Windows 8.1

Comment 4 by erwinr...@gmail.com, Mar 28 2014

It does not turn into the text input cursor over text boxes too

Comment 5 by ngy...@gmail.com, Mar 28 2014

Yup, same issue.

Chrome 35.0.1912.2 dev-m
Windows 8.1 x64

Comment 6 by ngy...@gmail.com, Mar 28 2014

Apparently works fine on Chrome 35.0.1914.0 canary.
Same problem, Version 35.0.1912.2 dev-m

Comment 8 by Deleted ...@, Mar 28 2014

Everyone geting same problem,its bug in new chrome -_- i dont like it.

Comment 9 by bil...@gmail.com, Mar 28 2014

Same issue, it's super-annoying :(
:/ I only use this dev version because stupid “Disable developer mode extensions” popup warning https://productforums.google.com/forum/#!msg/chrome/6mmohdZd2Xw/nccD2SVMWy0J

It might be time to give IE a try again (notifications, apps in the desktop, popup warning, ... this is getting too annoying). 
Can confirm as above.

When hovering for the first time on a link the cursor will show some change for a split-second, but is then back to the original plain cursor.
Honestly, Chrome Team, get your shit together. There's no excuse for a bug like this to make it to Stable. I gotta wonder what's the point of even having release channels if not to prevent this type of thing from happening?

Google Chrome: 35.0.1912.2 (Official Build 259847) m
           OS: Windows 
        Blink: 537.36 (@170125)
   JavaScript: V8 3.25.27
        Flash: 13.0.0.168
   User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1912.2 Safari/537.36
Same here.

I also use dev version because of that stupid popup.  Chrome Version 35.0.1912.2 dev-m, Windows 7

Comment 14 by patq...@gmail.com, Mar 30 2014

This has been annoying me for the past couple days.

Windows 8.1

Version 35.0.1912.2 dev-m
Same here.

Windows 8.1
Chrome Version 35.0.1912.2 dev-m

Comment 16 by Deleted ...@, Mar 30 2014

ngyikp is correct, this regression has been fixed in Chrome Canary (35.0.1916.6 canary), so I'll be using that until it's merged into dev/stable (hopefully soon!)

Comment 17 by tkent@chromium.org, Mar 31 2014

 Issue 357595  has been merged into this issue.

Comment 18 by tkent@chromium.org, Mar 31 2014

 Issue 357657  has been merged into this issue.

Comment 19 by tkent@chromium.org, Mar 31 2014

 Issue 357847  has been merged into this issue.

Comment 20 by tkent@chromium.org, Mar 31 2014

 Issue 357907  has been merged into this issue.

Comment 21 by tkent@chromium.org, Mar 31 2014

 Issue 357971  has been merged into this issue.
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1912.2 Safari/537.36

Steps to reproduce the problem:
1. Mouse over a thing (link, text box)
2. Watch mouse cursor not change
3. Be sad

What is the expected behavior?
Mouse cursor should change to a hand over links, or a text input cursor in a text field

What went wrong?
It doesn't change

Did this work before? Yes Until I updated to this version

Chrome version: 35.0.1912.2  Channel: dev
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 13.0 r0

How do you even break this

Comment 23 by cqw...@gmail.com, Mar 31 2014

Same here, always default arrow, no link hand, no resize arrow, no text cursor, not even the busy hourglass, breaks every BASIC INSTINCT homo sapiens has developed in 30 years of mouse navigation.

how do you even manage to break this....amazingly annoying

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1912.2 Safari/537.36

Steps to reproduce the problem:
1. Make a fresh chrome profile
2. Place mouse cursor over a link, text, resizing edge/corner (not the chrome window edges, anything in the client area, i.e. resizing the F12 toolbar)
3. 

What is the expected behavior?
the you know what

What went wrong?
Cursor doesn't change into a pointer.

Did this work before? since Xerox lab

Chrome version: 35.0.1912.2 dev-m  Channel: dev
OS Version: win7 x64
I will add that SOMETIMES when I mouse over a link, the cursor will blink into the hand for a zillionth of a second and then turn back into an arrow. I cannot reliably replicate this, however.

Comment 25 by cqw...@gmail.com, Mar 31 2014

Agree with #24, it seems that when I mouseover a link/text/edge zone, sometimes the cursor will change as it's supposed to do upon ENTERING the zone, and changes back into default arrow when moved by even another pixel.

you need to move the mouse VERY slowly, pixel by pixel, to repro this

Comment 26 by raina...@gmail.com, Mar 31 2014

I can confirm #25
Thirding #25.

Comment 28 by dan.p...@gmail.com, Mar 31 2014

Can someone change the OS flag to "All", please?

Anyone else feeling nauseous because of the unexpected cursor?
Labels: -Pri-2 Pri-1 OS-Windows ReleaseBlock-Stable
Status: Available
Was still working for me in 35.0.1908 so this is a recent regression.
 Issue 358205  has been merged into this issue.
 Issue 358236  has been merged into this issue.
Cc: pkotw...@chromium.org e...@chromium.org jonr...@chromium.org
 Issue 358233  has been merged into this issue.
Labels: M-35 Cr-Internals-Views
 Issue 357573  has been merged into this issue.
 Issue 357667  has been merged into this issue.

Comment 36 by e...@chromium.org, Mar 31 2014

Cc: sky@chromium.org zturner@chromium.org

Comment 37 by kareng@google.com, Mar 31 2014

Labels: Needs-Bisect
Labels: ReleaseBlock-Beta
This works fine on Latest Dev Build - 35.0.1916.6 (Official Build 260417) dev aura
Also fine on ToT on Linux - 36.0.1919.0 (r260618). Could be WontFix but would be interesting if somebody posts which change broke it and what fixed this.
pucchakayala@, could you also see if  bug 357973  is still there in 35.0.1916.6?
 Issue 357582  has been merged into this issue.
Also fixed here in 1916.6.

Comment 44 by cqw...@gmail.com, Apr 1 2014

fixed in 1916.6 dev-m win7x64

Comment 45 by cqw...@gmail.com, Apr 1 2014

re:#41  bug 357973  is fixed here in 1916.6 win7
Cc: rponnada@chromium.org
Labels: -Needs-Bisect
Unable to repro this issue on Windows7 & Linux Ubuntu using: 35.0.1916.7 (Official Build 260709) m.

By hovering on links, able to observed the hand icon

Also, unable to repro  issue 357973  on Windows7 using: 35.0.1916.7 (Official Build 260709) m.

By middle click, mouse cursor is changed and behavior properly. 

Removed the needs-bisect label, since it is unable to repro on latest: 35.0.1916.7
Status: WontFix
Reportedly fixed starting with 35.1916.6.

Comment 48 by Deleted ...@, Apr 1 2014

Great, the new version is fixed, but appeared new bug with selectbox - when scrolling - scrollbar is ok, but values not refreshed... I must mouse over throught values.
kucixx@, thanks for reporting this, would it be possible to please file a separate bug about it and maybe link it here if you think it is related?

Comment 50 by a.hi...@gmail.com, Apr 1 2014

varkha@
I'm experiencing the same problem as kucixx.
Made a report: https://code.google.com/p/chromium/issues/detail?id=358803

Comment 51 by Deleted ...@, Apr 2 2014

We also experience this issue from time to time with Chrome V33.0.1750.154 m

When it happens, the problem remains even when refreshing the page, although it doesn't seem to happen on other websites. The problem goes away when Chrome is restarted.


Today I get this bug on 37.0.2062.3 dev (64-bit Linux) 
I tried starting Chrome with --disable-extensions, the problem is still here.

It looks as if Chrome doesn't know where the cursor is until I click on a link or a button, because there is no hover effect, even on the "back", "forward" or "home" buttons!

Comment 54 Deleted

Comment 55 Deleted

I'm also having this trouble recurring over a period of at least a couple weeks. 
Win7, Chrome 36.0.1985.125 I've also been seeing this but not in all tabs. The cursor fails to change, hover text either missing or coming up for a link on the same horizontal but 100 or so pixels away. Seems particularly common on facebook pages but maybe that's just the density of links. I'm fairly sure I didn't get this on chrome 35.
Note that duplicating the tab and deleting the old one is a fix. For a while anyway. The new tab on the same web page displays the correct mouseover behaviour.

Comment 59 by Deleted ...@, Aug 21 2014

I get same problem as #57 with Version 36.0.1985.143 m , mainly noticeable with Facebook also. Can also confirm that #58 is a decent temporary work around.

Comment 60 by Deleted ...@, Aug 27 2014

I'm getting this on 64bit Linux Mint 17 & Chrome v 37.0.2062.94 (64-bit)

Comment 61 by suprf...@gmail.com, Aug 27 2014

This issue was started for a much older version. If anyone is encountering this behaviour in recent releases I would suggest starting the new bug.
I'm also getting this issue now on Fedora 20 w/ ATI Radeon HD 6570 using OpenSource drivers.  Chrome Version 37.0.2062.94 (64-bit)

The issue is not there on Fedora 20 w/ Intel HD4000 GPU - Chrome Version 37.0.2062.94 (64-bit)

Disabling HW acceleration on the ATI GPU Chrome fixes the issue but totally breaks Hangouts...  

Ugh!

Comment 63 by pedah...@gmail.com, Aug 27 2014

This was fixed (in Chrome 36.x) but now is back in Chrome 37.

Linux, Kubuntu 12.04, Chrome 37.0.2062.94-1

VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 560M] (rev a1), proprietary drivers.
Confirmed.

Linux, Debian 3.14.15-2 (2014-08-09), Chrome Version 37.0.2062.94 (64-bit)
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670], Mesa Project and SGI
Same Problem on Linux Mint Mate and Chrome Version 37.0.2062.94 (64-bit)

Confirmed on 37.0.2062.94 amd64

Ubuntu 14.04.1 LTS - Linux 3.13.0-34-generic
#60-Ubuntu SMP Wed Aug 13 15:45:27 UTC 2014 x86_64 GNU/Linux

Important: Got fixed after rolling back to 36.0.1985.143
Why is this still set as status WontFix and no Owner? This is a P1 and I've completely stopped using Chrome as a result of this bug.
Has anyone with this issue synergy running? I've discovered that with synergy stopped, chrome behaves normally again.
Same problem. Only when Synergy server is working.
For reference, here is the synergy bug entry: http://synergy-project.org/spit/issues/details/3819/
Confirmed that disabling Synergy server "fixes" it. Also, as documented in the Synergy bug, disabling hardware acceleration in Chrome allows Synergy to run, and still have hover-over in Chrome.

Comment 72 by Deleted ...@, Sep 3 2014

Why is this still a bug, chrome crashes then upon reload without closing the browser the mouse cursor won't show hand. only arrow. 
Just disable Chrome hardware acceleration, that should fix it.

Comment 74 by Deleted ...@, Sep 8 2014

After looking for hours, this fixed it immediately. Thanks alot devs.
"disable Chrome hardware acceleration" is a work around, not a fix. But it does seem to have worked on Win7, 37.0.2062.103 I haven't seen the loss of mouseover for a few days although I did see it with v37 at some stage.
Huh, I had the same problem with 37.0.2062.120 (64-bit) on ubuntu and I didn't realize I had left synergy running. Shutdown synergy and it works again. What's the conflict with synergy?
I can confirm the hovering issue in Chrome disappears if the Synergy server is turned off, or if hardware acceleration in Chrome is disabled. Chrome Version 37.0.2062.120 (64-bit), Synergy version 1.5.1, running on Linux Mint 17 Cinnamon edition.

The Synergy folks are aware. Maybe if one of the Chromium devs spoke with one of the Synergy devs you could cook up a fix?

http://synergy-project.org/spit/issues/details/3819
Yep, turning of Synergy fixed it as well for me.

Comment 79 by Deleted ...@, Oct 1 2014

i have the same problem but i don't have Synergy installed

ubuntu : 14.04 64-bit
chrome : Version 37.0.2062.120 (64-bit)

Comment 80 by Deleted ...@, Oct 10 2014

I'm running Synergy server and disabling hardware acceleration in Chrome also fixed the issue for me:

Ubuntu: 14.04.1 LTS (64-bit)
Chrome: 38.0.2125.101 (64-bit)
There is a patch available for Synergy. Its for Ubuntu 14.04.1, and I'm currently having no problems on Linux Mint 17.

Link to instructions - http://synergy-project.org/spit/issues/details/3819#c65 

.deb download (64bit) - https://www.dropbox.com/s/oaobs9p1w6ib4q4/synergy-1.5.1-Linux-x86_64.deb?dl=0 (reshare of Marc Mandel's .deb package, from link above)
Same here for Mac Yosemite V10.10, Chrome Version 38.0.2125.122

Comment 83 by tinga...@gmail.com, Nov 26 2014

I'm getting the same behavior for Mac in Chrome version Version 39.0.2171.65 (64-bit). Interesting that I got the same behavior on FF and Safari too.
On OSX 10.10 I noticed this happens with Photoshop CC 2014 in the background (the window is open, just behind Chrome). Hiding Photoshop solves the issue.

Comment 85 by Deleted ...@, Jan 17 2015

#84, just tried that and now the cursor is working in chrome.  I'm on Yosemite and when I hide Photoshop the problem doesn't occur.

Comment 86 by Deleted ...@, Feb 20 2015

#84, your Photoshop solution did the trick for me as well. WEIRD.

Comment 87 by Deleted ...@, Mar 15 2015

#84, All the same. Now it works, thanks.

Comment 88 Deleted

Comment 89 by Deleted ...@, Apr 16 2015

Quiting Photoshop CC will do the trick. Extremely annoying.

Comment 90 by Deleted ...@, Apr 16 2015

Quiting Photoshop CC did the trick for me.

Comment 91 by Deleted ...@, Apr 29 2015

was photoshop for me
Labels: Restrict-AddIssueComment-EditIssue
This bug was resolved in Synergy 1.6.

If this bug is being seen in a newer version of Synergy, or if a different application is causing similar behaviour please file a new issue.

Synergy Issue: https://github.com/synergy/synergy/search?q=%22Legacy+ID:+3819%22&type=Issues

Sign in to add a comment