New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 35307 link

Starred by 16 users

Issue metadata

Status: WontFix
Owner:
ooo sick
Closed: Feb 2010
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux , Mac
Pri: 1
Type: Bug-Regression
M-5

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Can't save cookie settings

Reported by pcala...@gmail.com, Feb 10 2010

Issue description

Chrome Version       : 5.0.323.0 (38568) Ubuntu


What steps wil`l reproduce the problem?
1. Go to Options -> Under The Hood -> Cookie Settings
2. Select any of the options (I chose accept 'Accept Cookies Only From 
Sites I Visit'
3. Click 'Close'

I expected the settings to persist, however, they didn't.
I was still have problem with sites that utilize cookies.
In addition, I think there might be a correlation between this is the 
"redirect loop" I've seen mention in the forum. I imagine this loop occurs 
as result of authentication, but I'm uncertain about that.

Any ideas or fixes?

 

Comment 1 by krisr@chromium.org, Feb 12 2010

Labels: -Pri-2 -Area-Undefined Pri-1 Area-Internals Internals-Network OS-Linux OS-Mac ReleaseBlock-Dev
Status: Untriaged

Comment 2 by mal@google.com, Feb 12 2010

Labels: Mstone-5 Regression
Status: Assigned
Darin, who should get this. It looks like cookies options changes from the UI are not
getting saved.
Some more info,

- I installed good build which can save cookie settings, set cookie settings to 'block all cookies'.
- Install bad build and open preferences and verify the cookie settings.

Result:
- Bad build couldn't read stored cookie settings. It over-wrote cookie settings to default.

Comment 4 by evan@chromium.org, Feb 16 2010

 Issue 35759  has been merged into this issue.

Comment 5 by max.th...@gmail.com, Feb 18 2010

I can confirm that I'm seeing this issue, and that because it overwrites the cookie
settings, I cannot log into any Google site (or some others).  I had to fire up
Firefox to star this bug and to post this comment!

Comment 6 by darin@chromium.org, Feb 18 2010

Mergedinto: 35775
Status: Duplicate
I suspect this is a duplicate of  issue 35775 .
Hmm, this doesn't really sound like 35775...
Mergedinto: -35775
Status: Assigned
5.0.332.0 (Official Build 39309)

On Mac, Chrome still doesn't preserver the cookie settings changes.
I don't know whether the UI and the backend have been hooked together completely on 
Mac.
Status: WontFix
I think this is just caused by OS X writing the old cookie pref and the content settings 
code rewriting it into the new form, and the UI not being updated. Should be fine on 
linux by now.

Mac part is  issue 34656 . Cookies are broken on mac atm. 

peter: argh, collision.
Labels: -Regression bulkmove Type-Regression
Chrome Version       : 5.0.323.0 (38568) Ubuntu


What steps wil`l reproduce the problem?
1. Go to Options -> Under The Hood -> Cookie Settings
2. Select any of the options (I chose accept 'Accept Cookies Only From 
Sites I Visit'
3. Click 'Close'

I expected the settings to persist, however, they didn't.
I was still have problem with sites that utilize cookies.
In addition, I think there might be a correlation between this is the 
"redirect loop" I've seen mention in the forum. I imagine this loop occurs 
as result of authentication, but I'm uncertain about that.

Any ideas or fixes?
Project Member

Comment 12 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 13 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-Internals -Internals-Network -Mstone-5 -Type-Regression Type-Bug-Regression M-5 Cr-Internals Cr-Internals-Network
Project Member

Comment 14 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment