New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 350753 link

Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 331236
Owner: ----
Closed: Apr 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Compat

Blocking:
issue 176671



Sign in to add a comment

Assigning to the style property initialized to an important value isn't applied

Reported by m.go...@gmail.com, Mar 9 2014

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.146 Safari/537.36

Example URL:
http://jsfiddle.net/m_gol/k9kLu/

Steps to reproduce the problem:
1. Open http://jsfiddle.net/m_gol/k9kLu/
2. 
3. 

What is the expected behavior?
The text should be invisible

What went wrong?
The text is red.

Does it occur on multiple sites: N/A

Is it a problem with a plugin? No 

Did this work before? No 

Does this work in other browsers? No Safari 7 & Nightly, IE11. It works fine in Firefox

Chrome version: 35.0.1880.0  Channel: canary
OS Version: OS X 10.9.2
Flash Version: Shockwave Flash 12.0 r0

This is one of the issues we're currently workarounding in jQuery: https://github.com/jquery/jquery/commit/24e587929f62428e1959b10aace6dc4fd65ab397

Unfortunately, this causes further issues so we'll probably have to revert this commit, see: http://bugs.jquery.com/ticket/14836
 

Comment 1 by m.go...@gmail.com, Mar 9 2014

WebKit bug report: https://bugs.webkit.org/show_bug.cgi?id=129994
Cc: msrchandra@chromium.org
Labels: -OS-Mac OS-All M-35 Cr-Blink
Status: Untriaged
Able to reproduce this issue. This is a Non-Regression Issue.
Can be seen from M16 builds.
Note: Working fine in FF.
Cc: tkonch...@chromium.org
Issue observed  in Safari and IE as well.

Comment 5 by kareng@google.com, Apr 7 2014

Labels: -M-35 MovedFrom-35 M-36
Moving all non essential bugs to the next Milestone.
Labels: -M-36 MovedFrom-36
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.
Blocking: chromium:176671

Comment 8 by timloh@chromium.org, Apr 10 2015

Mergedinto: 331236
Status: Duplicate
Dupe of 331236 (assigning to style.color is equivalent to calling setProperty, see http://dev.w3.org/csswg/cssom-1/#dom-cssstyledeclaration-dashed-attribute)

Sign in to add a comment