New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 21 users

Issue metadata

Status: Assigned
Owner: ----
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 2
Type: Bug



Sign in to add a comment

Wolf: Legacy boot does not work

Reported by xind...@gmail.com, Mar 2 2014

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.117 Safari/537.36
Platform: 5116.88.0 (Official Build) stable-channel wolf

Steps to reproduce the problem:
1. crossystem dev_boot_legacy=1
2. Reboot the system
3. Hit Ctrl-L at the dev screen

What is the expected behavior?
Legacy bios will boot and show "press ESC for boot menu"

What went wrong?
The Chromebook freezes at the dev screen, or it shows a black screen with no text and freezes. In both of these cases, keyboard input does not work anymore and I have to power cycle the machine.

Did this work before? No 

Chrome version: 33.0.1750.124  Channel: stable
OS Version: 33.0.1750.124
Flash Version: 12.0.0.70-r1
 

Comment 1 Deleted

Comment 2 Deleted

Comment 3 Deleted

Comment 4 by xind...@gmail.com, Mar 6 2014

Hello,

After more hacking I have found the issue with SeaBIOS. The VGA option rom is misnamed in the original firmware image; it should be pci8086,0a06 instead of pci8086,0406. I have attached a working seabios.cbfs that one can dd into their original firmware image as per Stefan Reinauer's instructions here: http://www.seabios.org/pipermail/seabios/2013-April/006135.html
seabios.cbfs
2.0 MB Download

Comment 5 by porte...@gmail.com, Mar 6 2014

Thanks! The fix worked for me.

Comment 6 Deleted

Comment 7 by Deleted ...@, Mar 27 2014

I'm also trying to use Control-L to get into SeaBios and it just hangs at the white splash screen. I followed the steps but I get a size mismatch when I try to write the new bios - my backup appears to be 8mb but the new bios appears to be 6mb, and flashrom refuses to write it. 

Here are the instructions I followed (once I downloaded the seabios.cbfs from above):

# flashrom -r bios.rom
# dd if=seabios.cbfs of=image.rom seek=2 bs=2M conv=notrunc
# flashrom -w image.rom -i RW_LEGACY

bios.rom is 8mb, image.rom is 6mb. The full instructions are here:
https://wiki.archlinux.org/index.php/Dell_Chromebook_11

Any ideas?


Comment 8 Deleted

Comment 9 by xind...@gmail.com, Mar 27 2014

Whoops, looks like the first command should be "flashrom -r image.rom". I'll go update the wiki. Nice catch!
Owner: dparker@chromium.org
Status: Assigned
Assigning to Dave so that he can potentially fix this if we do an AU on wolf.

Comment 11 by Deleted ...@, Jan 23 2015

Hello,

I wanted to report a problem I'm having with the dell chromebook 11. I recently received the i3 version of this chromebook. I followed the instructions exactly as stated on this website and the arch linux website; however, pressing ctrl + L, I end up with a black screen where the computer has frozen. Nothing I do can resolve this issue. I have to power cycle the computer. Does this fix only apply for the celeron 2955u version of this chromebook? If so, has anyone encountered the same issue on the i3 version?

Comment 12 by tpor...@gmail.com, Mar 26 2015

Hello old thread,

I'm seconding TBhatt's comment. Running the i3 version of Dell's Chromebook11 this procedure does not work. After crtl + L I receive and error stating:

# [drm:i915_write32] *error* Unknown unclaimed register before writing to a090
# i915 0000:00:02.2
# usb 2-4: string descriptor 0malformed (err = -61), defaulting to 0x0409

Does the RW screw need to be removed to patch this? Am I screwing up something from the arch wiki? Does this just not work for the i3 WOLF? 
Any response would be helpful.
Cc: vapier@chromium.org reinauer@chromium.org
Owner: ----
you do not need to mess with the RW screw to update seabios.  it lives in the RW part of the flash, not the RO.

Comment 14 by xind...@gmail.com, Mar 27 2015

Hi there,

I've only tested this patch with the original Dell Chromebook, and not the i3 version as I don't have one. It (most likely) doesn't work for the i3. Sorry!
Hello,

First of all, many thanks for the contributions.

I have the latest Dell Chromebook 11 (3120, Feb 2015) and I am thinking to apply https://wiki.archlinux.org/index.php/Dell_Chromebook_11 guide along with the patched seabios from here.
 
In case they do not work in my new 3120, is there any way to undo all these changes? Using a recovery image will it set the machine back to its original settings? If not, do you know how to undo them?

Any response will be much appreciated!
as long as you do not open the case and remove the write protect screw, you can safely play around with things.  that includes modifying the RW portion of the firmware via flashrom.
Thanks for the response vapier.

Just to be sure I understood, in order to undo the changes from the "patching the seebios" all I need is to use the recovery image of the chrome os?

Thanks
the RW firmware has multiple sections in it.  one of those is the legacy boot slot, and we currently (by design) do not touch it.  this way you could burn your own build of SeaBIOS or U-Boot or whatever and we wouldn't mess with it.  but the rest of the RW flash a recovery image would recover for you.

however, since Wolf ships with a broken legacy boot slot, it's not like you'd be breaking something that isn't already broken :).

Comment 19 Deleted

Comment 20 Deleted

Comment 21 by kngh...@gmail.com, Apr 27 2015

I also have an i3 version of Dell Chromebook 11
Version 39.02171.96
Platform 6310.68
Firmware Google_Wolf.4389.24.58

I did the patch on seabios.   The process of patching up the BIOS doesn't seems to break anything. *BUT* it didn't enable legacy boot neither.   

we need someone to patch up the BIOS for this i3 version of Chromebook :(

Comment 22 Deleted

Comment 23 Deleted

Comment 24 Deleted

Comment 25 Deleted

Comment 26 Deleted

Comment 27 Deleted

Comment 28 Deleted

here's a seabios.cbfs built from the wolf branch w/pci8086,0a06.  i tested this on my celeron model.  it should work the same as comment #4, but might be less shady (no offense) as i'm a Google employee.

looking at our hw db, it looks like the follow up wolf might be using pci8086,0a16.  so i built another seabios.cbfs with that setting.  can someone using an i3 test it ?

in either case, the method is the same as comment #7.
seabios.i3.0a16.cbfs
2.0 MB Download
seabios.celeron.0a06.cbfs
2.0 MB Download
newer seabios has added symlink support, but that isn't in this branch.  i manually added the same rom with different names though (since there's plenty of space).  hopefully this one should work for both celeron & i3 variants (i only have the celeron one here to test).
seabios.cbfs
2.0 MB Download
@vapier ... Your seabios.cbfs (post #30) fixes it for me. I can now boot from an external usb drive on my dell 11 i3.

Many thanks.

Comment 32 by Deleted ...@, Sep 10 2015

Not sure if this is an Dell Chromebook 11 HW issue or SeaBios. I patched using @vapier patch and booted USB ok,+1 for @vapier, when I install lubuntu to SD card and reboot, Seabios fail to see the SD card. The only way to get it to see and boot is to connect an USB hub and then two usb flash key to the hub, then the SD card appears as the fourth boot device. It boot ok from SD then.

Any idea?
I downloaded and flashed my rom just fine with #30 seabios.cbfs on my Dell Chromebook 11 Celeron but when dev white screen comes on I hit ctrl + l and my machine freezes. I have to power off to try again. I hit TAB on dev white screen and it shows USB boot and legacy boot =1.

 Not sure why any of these seabios dont let me boot into flash drive. I am trying to install Mint Linux instead of ChromeOS.

Any help?
FYI I am running Dell Chromebook 11 Candy (2015) non-touchscreen blue and black model. I think this thread is for the 2014 Dell Chromebook 11.

Any help please.
Anthony
I am having the same issue with the same chromebook as comment #34.  I tried using the updated cbfs from #30 but no luck.  Any advice?
this bug is only for wolf and slippy derived devices.  your firmware should say the model name when it boots ... if it doesn't say peppy/falco/wolf/leon, then this bug is not for you.  please file a new one for your specific device.
For people running Candy like comments #33-35, please see new issue created that is identical to this one but for Dell Chromebook 11 Candy (2015) 3120 Celeron non-touchscreen:

Dell Link: http://www.dell.com/us/p/chromebook-11-3120/pd?oc=dncwyue02s&l=en#overrides=

Issue Link: https://code.google.com/p/chromium/issues/detail?id=544236&thanks=544236&ts=1445021995
Project Member

Comment 38 by bugdroid1@chromium.org, Apr 27 2016

Labels: merge-merged-firmware-wolf-4389.24.B
The following revision refers to this bug:
  https://chromium.googlesource.com/chromiumos/overlays/chromiumos-overlay/+/78fb3c759e13fe9fcac6297d26456579a550b4d7

commit 78fb3c759e13fe9fcac6297d26456579a550b4d7
Author: Mike Frysinger <vapier@chromium.org>
Date: Sat Aug 29 07:41:16 2015

cros-coreboot: get vga settings from .config

If we copied the config file from $FILESDIR, then parsing the config
file from the source tree doesn't make sense.  Make sure we extract
the settings from the right file.

BUG=chromium:348403
TEST=modified $FILESDIR/config and saw changes reflected in output filename

Change-Id: I810a44918cb711041d5e38bc99a247c7402414ac
Reviewed-on: https://chromium-review.googlesource.com/296092
Reviewed-by: Bill Richardson <wfrichar@chromium.org>
Reviewed-by: Randall Spangler <rspangler@chromium.org>
Commit-Queue: Stefan Reinauer <reinauer@chromium.org>
Tested-by: Stefan Reinauer <reinauer@chromium.org>

[modify] https://crrev.com/78fb3c759e13fe9fcac6297d26456579a550b4d7/eclass/cros-coreboot.eclass

Comment 39 by da...@tuppeny.com, Nov 28 2016

I'm having this same issue on an original Dell Chromebook 11 too. Should a fix have been pushed out already or do I need to follow the instructions above?

Comment 40 by da...@tuppeny.com, Nov 28 2016

(Impatient, I went ahead and followed the instructions and all works fine now!)

Sign in to add a comment