New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 33019
Owner: ----
Closed: Feb 2010
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 34814: localStorage for extensions nuked after clearing cookies and other site data

Reported by btlee@google.com, Feb 5 2010 Project Member

Issue description

Chrome Version       : 5.0.307.1 dev

What steps will reproduce the problem?
1. Create an extension that uses localStorage to persist data.
2. Persist data using localStorage.setItem().
3. Google Chrome Options -> Under the hood -> Clear browsing data.

What is the expected result?
localStorage data for extensions should not be cleared.

What happens instead?
localStorage data is cleared.

Please provide any additional information below. Attach a screenshot if
possible.

Our extension uses localStorage to persist options modified by the user.
Clearing browsing data requires the user to reconfigure the extension.

Please fix, or provide an alternative to storing configuration data.
 

Comment 1 by dhw@chromium.org, Feb 6 2010

Labels: FeedbackRequested
In Clear Browsing Data, did you select "Delete cookies and other site data" ?

Comment 2 by phil%bow...@gtempaccount.com, Feb 6 2010

I have same problem.  

also, if you are blocking cookies before or right after you clear your browsing 
data/storage..you must add the extensions string to the whitelist for extensions that 
require storage/updated block lists etc... and they should work fine.  obviously thats 
not a permanent fix but it does the job in the meantime so peoples extensions can work.

Comment 3 by dhw@chromium.org, Feb 6 2010

Then Phil, I have the same question for you:

In Clear Browsing Data, did you select "Delete cookies and other site data" ?

Comment 4 by phil%bow...@gtempaccount.com, Feb 6 2010

Actually, In my case, I was looking at what cookies were present on my machine when I 
decided to just clear them all for a fresh start.. so I had clicked options/content 
settings/show cookies and other site data/ and then just clicked the remove all button 
an that page.  So I did not use the "clear browsing data" tab.  I actually didn't even 
notice the button till you mentioned it.

Comment 5 by phil%bow...@gtempaccount.com, Feb 6 2010

I did notice after I whitelisted the extensions they have since added cookies with 
config date.  my suggestion would be to seperate extension cookies required for 
operation from browsing cookies when using the remove all button..  you would assume by 
the wording of the tab that you are just clicking remove all cookies and site data 
storage not any internal extension data (especially if you have hundreds of cookies).

hope this helps

Comment 6 by btlee@google.com, Feb 8 2010

Yes, I selected, "Delete cookies and other site data".

thanks
Brian

Comment 7 by dhw@chromium.org, Feb 8 2010

Labels: -Area-Undefined -FeedbackRequested Area-Feature
Mergedinto: 33019
Status: Duplicate
Thanks for the feedback.  This is expected behavior then.

Deleting "other site data" includes deleting LocalStorage.  If local storage is 
deleted, then that will erase all extensions settings, because extensions settings 
are saved using local storage.

The question is, should "Delete cookies and other site data" deletion be modified to 
not include the extensions data?

This is a duplicate of  Issue 33019 

Comment 8 by jpap...@gmail.com, Jan 11 2012

There are scenarios where it is desirable to clear a specific cookie or all of the cookies but leave the localStorage intact.

Comment 9 by bugdroid1@chromium.org, Oct 13 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:33019
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Sign in to add a comment