New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 343329 link

Starred by 79 users

Issue metadata

Status: WontFix
Owner:
Closed: Feb 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 3
Type: Feature



Sign in to add a comment

Support Fedora, RedHat and SUSE in Chrome Remote Desktop

Project Member Reported by sergeyu@chromium.org, Feb 12 2014

Issue description

Currently we only build chrome remote desktop packages for Ubuntu/Debian. Ideally we should also supply RPM packages for RPM-based Linux distributions.

This involves not only building the package, but also resolving various Debian dependencies in the code. Specifically there are the following problems that will need to be addressed:
 - gksudo is not available, pkexec should be used instead ( bug 342210 ).
 - /etc/pam.d/chrome-remote-desktop contains Debian-specific includes, so pam auth fails.


 
Labels: M-36
Status: Available
Let's see what feedback we get when we release M34, which will require Ubuntu. We can then consider releasing packages for other distros.
Summary: Support Fedora, RedHat and SUSE in Chrome Remote Desktop (was: Support Fedora, Red and SUSE in Chrome Remote Desktop)
Owner: hbengali@chromium.org
Status: Assigned
Assigning to Husain to monitor feedback once NPAPI goes away to see if we have a significant user-base on these platforms.
Is there any update on providing RPM for Fedora just like you do for Google Chrome, Hangouts and Music Manager?
Labels: -M-36 M-37 MovedFrom-36
Moving all non essential bugs to the next Milestone.
Labels: -M-37 MovedFrom-37
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.
Why was generic Linux support dropped? It used to work, now is doesn't.
> Why was generic Linux support dropped? It used to work, now is doesn't.

It worked in the past only for remote assistance with an NPAPI plugin packaged with the app. But NPAPI support has been dropped in Chrome on Linux.
#8 sergeyu@chromium.org

Okay that makes sense but are their plans to fix this.

Comment 10 by Deleted ...@, Aug 17 2014

I have a FC20 desktop that I would REALLY like to use this with.  Is there anything I can do to help this along?

RHCE, RHVCA, RHCDS
I would really like to see this on Fedora too. Looks like this is open source, and the build instructions here:

https://code.google.com/p/chromium/wiki/ChromotingBuildInstructions

Presumably the build-deb.sh could be adapted to produce an RPM for Fedora.

Comment 12 by talc...@gmail.com, Aug 17 2014

Someone succeeded but it's not a nice solution. Uses alien and fiddles with init scripts/pam.

http://sprackle.org/2014/07/how-to-get-chrome-remote-desktop-beta-working-under-fedora/

Comment 13 by Deleted ...@, Aug 24 2014

Google needs to make this happen.  Not supporting RPM-based distros is missing a huge percentage of what is out there.
joshmule: The trouble is that Google internally uses Goobuntu, an Ubuntu-derived distribution. Having worked at Google, I can say that Google engineers are extremely busy, and very few have time for side projects. This is unlikely to happen unless somebody from outside of Google steps up. 

The good news is that the code builds fine on Fedora, somebody just needs to write a .spec file that generates an RPM for the Chromoting binaries. Then the next step would to be get the .spec file committed to the Chromium repo. The final step would be for someone to apply to the Fedora project to be the official packager/maintainer for the Chromoting RPM, so that it can be added to the Fedora distro.

Failing that, Wayland remoting is coming along, so in a few months it should be possible to very easily log into a Fedora workstation remotely as long as you're running Wayland.

Any update on this? It has been close to 11 months since the bug was filed.
Status: WontFix
It is unlikely we will be able to work on this in the near future.
Is this something that an open source contributor could help out with? If so, it might be worth leaving the bug open and trying to find a taker even if Google isn't planning on doing the work.
Labels: -Pri-2 Pri-3
Yes, this is certainly something external contributors could help with. Given there hasn't been any interest during the year the bug has been open, I'll leave this as won't fix. We'll be happy to re-activate it once we get a strong indication that a contributor wants to work on it.
Cc: hbengali@chromium.org
Owner: rickyz@chromium.org
Status: Assigned
In that case I'll take this one. I may ping some folks on this bug for help with testing on other distros.
Cc: agoode@chromium.org
I can test Fedora.
I'm also happy to test on Fedora, I would use this a lot.
Fedora and centos, ready to test.
Cool, thanks for the testing offers - so far I've sent out https://codereview.chromium.org/907783002/ for  issue 342210 , will update once I get far enough to try building a package.
I'll give this a go as well.
Any more testing since the last patch was committed? 
Ah sorry, I've been a little busy these past few months, but I haven't forgotten about this bug :-) I do plan to keep poking at it once time frees up a little bit.
Labels: hotlist-trend-0701
What's the update on this?
I switched to Fedora from Ubuntu and I'm very disappointed that I can't use Chrome Remote Desktop anymore. I really hope that we will see support for Fedora, RedHat and SUSE happening soon.

Thank you.
Here's another take that uses alien to convert the .deb into .rpm:
http://fedora-centos.blogspot.com/2014/07/using-alien-to-convert-deb-to-rpm-and.html

Hello,
Can we have an update about the support of Fedora, RedHat and SUSE in Chrome Remote Desktop please ?
Thanks
This is not a high priotity for us at the moment. In principle, we would be willing to accept patches to get CRD working on other variants of Linux, but without someone regularly releasing updates, there is no guarantee that it will keep working because we occasionally have to make protocol-breaking changes. In short, this is not a small, short-term undertaking but something someone would need to commit to for the long haul and we don't have the resources to do that right now.

rickyz@, is that the sort of commitment you were signing up for, or would you rather we close this as WontFix, at least for the foreseeable future?
Jamie: How much churn is there in the remote desktop code?  i.e. is it considered stable at this point, or is it actively being worked on still?
It's pretty stable, but the libraries it depends on are under constant development. For example, Chrome recently deprecated a version of ICE that introduced a version incompatibility. There's also a standard check on every connection that the host version is not substantially older than the client, and we show an interstitial if it is recommending that the user upgrade it--that would be a pretty poor UX for users whose hosts are not being regularly updated.

There's also often work needed when a new version of an OS is released, which we wouldn't be doing for non-Ubuntu Linux. That can vary from zero to substantial rearchitecting, depending on how much has changed.
Thanks for the info. I'm considering doing it myself, since I really need this to work on Chrome on Fedora, but I don't know if I can commit to the project long-term.

I'm wondering if some RedHat employee who works on packaging Chromium for Fedora might be able to pick this up... do you happen to know who might be a good contact to ask?
Sorry, I've been a little busy with other stuff lately, but I think it's worth leaving the bug open, especially if there are folks either at or outside of Google that are interested in helping out. (Also more than happy to help any new folks navigate chromium development stuff to make changes for this.)

To Luke, I think Tom Callaway (spot@fedoraproject.org) packages Chromium for Fedora in his free time, so he might be a good person to talk to.
Thanks Ricky. I emailed Tom to see if he's interested.
Luke,

Chromium is not in Fedora repos yet.

https://bugzilla.redhat.com/show_bug.cgi?id=1270322
I know, but even having a dnf repo that you could point to, maintained by someone who works at RedHat, who has an interest in keeping it relatively up to date with upstream development, would be very helpful to most people who have commented on or starred this bug.
Luke, I would gladly help you out if you decide to work on this feature. i want it on fedora. 
indigohe...: that's awesome -- as a starting point, see if you can get it to build. The latest build instructions are here: (I have not tried this myself yet...)

https://chromium.googlesource.com/chromium/src/+/master/docs/chromoting_build_instructions.md
Maybe that can be useful, the Russian Fedora community package Chromium (and a lot of other things) for Fedora.
https://fedoraproject.org/wiki/Russian_Fedora
Any news ?
I know Tom Callaway is looking at this (he emailed me back to ask questions about cert generation), but he is of course under no obligation to complete the work.
Ok thank you, I really hope that will happen !

Comment 46 by Deleted ...@, Nov 25 2015

I am able to test this on any Fedora or RHEL distro.
I followed the instructions above and got as far as this Gnome bug in Fedora 23. Remote desktop shows the 'something went wrong' error screen in Gnome. Is anyone experiencing this?

https://bugzilla.redhat.com/show_bug.cgi?id=1271244
Hi, I triaged your bug a bit in the redhat bz and filed an upstream one:
https://bugzilla.gnome.org/show_bug.cgi?id=758914
Is there anything new about Fedora support ?
It seems that it won't happen...
cube_00: Can you follow up with the request at https://bugzilla.gnome.org/show_bug.cgi?id=758914
Status: WontFix
We don't have the resources to implement and maintain other Linux platforms. Reluctantly, we're going to have to close this.

Comment 53 by reyn...@gmail.com, Feb 3 2016

Chrome is already packaged for Fedora. Google Compute Engine is built on KVM, a RedHat Product whose virtio "Guest Utilities" are hosted on Fedora's website. Torvald's uses Fedora. Fedora is not a second class Linux distro. Teamviewer has a good remote desktop solution packaged for Fedora and Ubuntu, is chromium that stripped down?

Can we at least make it run on a generic modern Linux Desktop stack, X11, Gnome, etc. Ubuntu's a bit of a black sheep, frequently behind on package updates by years.

It would make more sense to target something more generic, and thin take it from there, instead of focusing exclusively the third most popular and least secure Linux distro.
For Fedora, please follow
https://bugzilla.redhat.com/show_bug.cgi?id=1270322

That is the general bug for Chromium inclusion into Fedora. I don't know if that will initially include chromoting, but it is a big step in the right direction.


Also, there is at least one open issue that needs comments:
https://bugzilla.gnome.org/show_bug.cgi?id=758914

Comment 55 by spo...@gmail.com, Feb 3 2016

I have been able to successfully build a chrome-remote-desktop package for Fedora 23from the (work in progress) Chromium package. You can see the result of that here:

https://copr-be.cloud.fedoraproject.org/results/spot/chromium/fedora-23-x86_64/00149833-chromium/

Unfortunately, lately I've been stymied by having to remove hardcoded Ubuntu arm toolchain references from the native_client codebase, so we haven't had a successful set of Chromium Fedora builds in a while. I intend to support chromoting as a Fedora subpackage unless it becomes prohibitive to do so.

Comment 56 by spo...@gmail.com, Feb 3 2016

Oh, and I've tested it successfully with XFCE (echo "exec startxfce4" >> ~/.chrome-remote-desktop-session) with the matching version of Chrome and Chromium. GNOME has the unresolved issue that agoode pointed out in #54.
Tom: thanks for doing this, that's really awesome. You say you tested successfully "with the matching version of Chrome and Chromium" -- so CRD will be built for a specific major version of Chrome and Chromium? Will CRD need to be updated with each major release of Chrome/Chromium, or only when the ABI changes? 

Comment 58 by spo...@gmail.com, Feb 17 2016

Luke, I have no idea. Since the remoting code comes with the chromium source tree, and depends on internal chromium libs, it makes sense to tie it to the matching chromium-libs build at least.
Anyone created an RPM yet? If not, where can I get the source so I can try?
I agree. Found some weird instructions on the dark side of the web on how to build the RPM from the DEB, but it didn't quite work. Some users reported success, though.

Shouldn't be hard to support Fedora. Google, check openbuildservice.org it should do the trick for your CI and solve your problems.
Chromium is now officially in Fedora as a package, and it generates a "chrome-remote-desktop" subpackage. This means that all you should need to do on Fedora is:

dnf install chrome-remote-desktop
wow that's incredible! Very good news, it worked perfectly. Too bad the extension doesn't give that as instructions, instead it simply redirects to a .deb package. Quite counter-intuitive. Many thanks anyway :) 
#61 There is no package named chrome-remote-desktop

You probably meant chromium-libs.x86_64 and it gets installed with chromium package.

$ dnf search chrome-remote
Last metadata expiration check: 19 days, 3:34:23 ago on Sun Jul 24 23:19:26 2016.
====================================================================== N/S Matched: chrome-remote ======================================================================
chromium-libs.x86_64 : Shared libraries used by chromium (and chrome-remote-desktop)
sudo dnf install chrome-remote-desktop

This worked for me on fedora 24. It installed a bunch of other packages as
well thought, but it worked.

Bruno Finger
`sudo dnf install chrome-remote-desktop` worked on Fedora 23 too... sweet:

# dnf search chrome-remote
Last metadata expiration check: 1:39:45 ago on Fri Aug 12 15:53:50 2016.
================================================================================================================================ N/S Matched: chrome-remote =================================================================================================================================
chrome-remote-desktop.x86_64 : Remote desktop support for google-chrome & chromium
chromium-libs.x86_64 : Shared libraries used by chromium (and chrome-remote-desktop

#63, your dnf meta-data is pretty old. Try `--refresh`
My mistake. Sorry about that. :)
Should we open a new ticket to make the CRX ask you to install from your
repo using `sudo dnf install chrome-remote-desktop`? Right now it links to
a .deb that's useless to RHEL based linux users, it takes some googleling
and LOTS of scrolling to get down to these instructions.
Absolutely!
I filed a ticket, and got:

> CRD is not officially supported on Fedora, so at this time we are not going to provide instructions on how to install it.

Comment 70 by m.mcn...@gmail.com, Aug 30 2016

Installing chrome-remote-desktop from the repos works, but actually using the "My Computers" section does not, I get no option to enable remote connections - am I missing something?
On unsupported platforms such as Fedora, the "enable" option only appears if you create a customized session script. See https://bugs.chromium.org/p/chromium/issues/detail?id=343329#c70
(expand the Linux section and follow "step 2")

Comment 72 by tvu...@gmail.com, Aug 30 2016

@lambroslambrou: I think you meant:
https://support.google.com/chrome/answer/1649523?hl=en
I followed the instructions after installing, starting and enabling the chrome-remote-desktop.service.

Now I do get a button to enable remote connections, but after clicking it and typing my pin, it displays a spinning popup saying "Enabling remote connections for this computer..."

Other computers will see my fedora station as "last logged in XX", where XX is the time I clicked the button. How did you get around it?
@fosspr...
The same here. Tried to start the service and the Python script fails with KeyError. Can't find 'HOME' in the environment. 
So it seems

in ~/.chrome-remote-desktop-session
exec /usr/sbin/gdm "env GNOME_SHELL_SESSION_MODE=classic
HOME="/home/amama/" gnome-session --session gnome-classic"

Fixes that problem. But then you have another one, you can't run GDM as a
non root user AND you can't run gdm more than once... ideas?
I got that by looking at journalctl +f while enabling crdp
@tvujec: Thanks for the link correction!

@fossprime: While it's spinning, I think it's trying to run
/opt/google/chrome-remote-desktop/chrome-remote-desktop --add-user
which may be waiting for your typed password on some /dev/ttyXX somewhere.
Try running this command manually yourself - if it succeeds, subsequent runs will no longer require a password.

@mtabolsky: I'm not exactly sure why you are missing the 'HOME' variable. You might have to tweak how the /etc/init.d/chrome-remote-desktop service script starts your session. Maybe the 'sudo -i' command there is not creating $HOME for you, and you'll have to configure it somehow.

@ray: I don't recommend running 'gdm' (or any other X display manager) directly from your session script. You should just run the session part:
gnome-session --session gnome-classic
Some display-managers do provide a session wrapper script that you can use; for example, lightdm provides /usr/sbin/lightdm-session. I don't know if 'gdm' has anything similar?

@everyone: Please consider using this support forum:
https://productforums.google.com/forum/#!topic/chrome/8PMxG69VJ6o/discussion

You might get your questions answered there by others, even if Google doesn't provide official support for your platform.

Please also consider using your distro's support forums. The chrome-remote-desktop package for Fedora/RedHat is not built or provided by Google.

@lambroslambrou The topic in that forum is locked. I tried running the add
user command manually with
    python /usr/lib64/chrome-remote-desktop/chrome-remote-desktop --add-user
and it returns
    2016-08-31 07:57:44,741:INFO:User 'ray' is already a member of
'chrome-remote-desktop'.

After setting the .chrome-remote-desktop-session file to
     exec env GNOME_SHELL_SESSION_MODE=classic HOME=/home/ray gnome-session
--session gnome-classic

and starting the service with
    sudo systemctl start chrome-remote-desktop.service

I get this in the logs ('journalctl -f`)
: Traceback (most recent call last):
Aug 31 08:01:57 CCWks chrome-remote-desktop[30270]:   File
"/usr/lib64/chrome-remote-desktop/chrome-remote-desktop", line 87, in
<module>
Aug 31 08:01:57 CCWks chrome-remote-desktop[30270]:     HOME_DIR =
os.environ["HOME"]
Aug 31 08:01:57 CCWks chrome-remote-desktop[30270]:   File
"/usr/lib64/python2.7/UserDict.py", line 40, in __getitem__
Aug 31 08:01:57 CCWks chrome-remote-desktop[30270]:     raise KeyError(key)
Aug 31 08:01:57 CCWks chrome-remote-desktop[30270]: KeyError: 'HOME'
Aug 31 08:01:57 CCWks systemd[1]: chrome-remote-desktop.service: Main
process exited, code=exited, status=1/FAILURE

It seems I have the same issue as @mtabolsky
Sorry to hear that forum I linked is blocked for posting.

For the KeyError: 'HOME' error, the problem is that 'HOME' is not set in the
Python script's environment. Setting it in ~/.chrome-remote-desktop-session will not help (as you've seen) because that's the wrong process.

The thing that starts the Python script is /etc/init.d/chrome-remote-desktop .
It uses the 'sudo' command to create the login environment for starting the script. See here:
https://cs.chromium.org/chromium/src/remoting/host/installer/linux/debian/chrome-remote-desktop.init?sq=package:chromium&dr=CSs&l=65

The command used is
sudo -u <username> -b -i <path/to/python/script>

You need to either:
Fix the init.d script to use a different method of starting the Python script.
Or:
Configure 'sudo' on your system so it sets $HOME properly when used with '-i' and '-u'. 'sudo' is very configurable, and the details depend on your distro. Please seek help from your distro support if you cannot configure 'sudo' yourself.

@lambroslambrou
I don't think this init script has made it to the package. It appears that systemd version runs the python script on its own.
i.e. from the service file:
[Service]
ExecStart=/usr/lib64/chrome-remote-desktop/chrome-remote-desktop --start --foreground

@metabol
I added the home environment var in the service and it does successfully enable remote connections!

I found the file by doing `sudo systemctl enable chrome-remote-desktop` which echos it's location. My file looks like this:
[Unit]
Description="Chrome Remote Desktop host daemon"

[Service]
# Client Env Vars
Environment=HOME=/home/elonmusk
# defaults
ExecStart=/usr/lib64/chrome-remote-desktop/chrome-remote-desktop --start --fore$
ExecStop=/usr/lib64/chrome-remote-desktop/chrome-remote-desktop --stop
ExecReload=/usr/lib64/chrome-remote-desktop/chrome-remote-desktop --reload
Restart=always
TimeoutStopSec=10

[Install]
WantedBy=multi-user.target
If you change it to:

Environment=HOME=%h

Does that still work? I _think_ that should work for everyone. If so, I'll make that change in the package service file.
`Environment=HOME=%h` Works!

Unfortunately, it seems gnome-panel is dead and gnome-shell can't run
without special gpu stuff. I installed xfce4 and that worked a lot better.
Here's my config:
`sudo dnf install @xfce-desktop-environment`

~/.chrome-remote-desktop-session
```
exec xfce4-session
```
FWIIW, on Fedora 25 I had to manually `dnf install python2-psutils` package post dnf install chrome-remote-desktop for the service to start.  Does that need to be added as a package dependency?
Small correction; it requires 'dnf install python2-psutil'
Hi,

I would like to contribute for this requirement. How do we go about it?

Thanks.,
Datta M
Filed https://bugzilla.redhat.com/show_bug.cgi?id=1478408 for the Fedora 25 issue

Sign in to add a comment