New issue
Advanced search Search tips
Starred by 6 users

Issue metadata

Status: WontFix
Owner: ----
Closed: Mar 2012
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 33971: Chrome Vomits on Hard Drive

Reported by bryan.k....@gmail.com, Feb 1 2010

Issue description

Chrome Version       : 4.0.249.78 (Official Build 36714) beta
URLs (if applicable) : N/A
Other browsers tested: N/A
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: N/A
  Firefox 3.x: N/A
         IE 7: N/A
         IE 8: N/A

What steps will reproduce the problem?
1.  Spend time with Chrome; browse to several hundred pages and download a 
few Chrome updates as they become available.
2.  Check the size of User/Local/Google/, and if possible, file 
fragmentation using PerfectDisk 10 (or something similar).
3.  Gasp in horror.

What is the expected result?

Chrome shouldn't be utilizing ridiculous (read: easily over a gigabyte) of 
storage space for old versions of the browser and assorted cache.

Besides being a bad citizen on my MacBook Pro's Windows 7 partition, I 
wouldn't be surprised if someone far more advanced than I could utilize the 
runaway caching scheme to run a maliciously crafted .exe disguised as an 
older version of Chrome.

What happens instead?

Note the screenshot of PerfectDisk 10 after fully defragmenting my drive, 
and then visiting 3 websites.  Note how there are already dozens of files 
with dozens or even hundreds of fragments.  If I wasn't religiously 
clearing my cache, these files would make a mess of my Windows partition 
and aversely affect drive performance.

Please provide any additional information below. Attach a screenshot if
possible.

http://img.photobucket.com/albums/v219/QuicksilverG4/ChromeFragmentation.jp
g
 

Comment 1 by asvitk...@chromium.org, Mar 25 2012

Mergedinto: 16705
Status: Duplicate

Comment 2 by rvargas@chromium.org, Mar 26 2012

Mergedinto:
Status: WontFix
This bug seems to be mostly about the cache, so I'm just closing it as obsolete.

Comment 3 by bugdroid1@chromium.org, Oct 13 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 4 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-Undefined

Sign in to add a comment