New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 34 users

Issue metadata

Status: Duplicate
Merged: issue 326788
Owner: ----
Closed: Jan 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Feature

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Option to disable Instant Extended API has been removed

Reported by markgoo...@gmail.com, Jan 16 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.29 Safari/537.36

Steps to reproduce the problem:
1. Open new tab, note that Instant Extended API is now back on even though I never enabled it.
2. Go to chrome:flags
3. Discover that the option controlling it has disappeared.

What is the expected behavior?
The option to control Instant Extended API is in the available settings.

What went wrong?
It isn't.

Did this work before? Yes Prior to most recent upgrade.

Chrome version: 33.0.1750.29  Channel: dev
OS Version: 6.3
Flash Version: Shockwave Flash 12.0 r0

This appears to have been reported already, but the bug reports have been closed with no fix applied.
 

Comment 1 by azn...@gmail.com, Jan 17 2014

I'm having the same issue too. This sucks. I hate the new new tab page. It's stoooooopid and redundant.
Yup, change appears permanent in the latest update.  Useless page, I prefer having my Chrome apps on the "New Tab" page for quick access to them.

Comment 3 by azn...@gmail.com, Jan 17 2014

Talk about department of redundancy department.

Comment 4 by Deleted ...@, Jan 20 2014

... There was a way to disable this 'feature' (chrome://flags/#enable-instant-extended-api), this too has disappeared. The new interface also removes (or at least hides) the ability to open a tab that is already open on one of your other devices. Very frustrating and creates extra work.

Comment 5 by bsamwel@google.com, Jan 20 2014

Hides, not removes. The other devices stuff is now hiding under what was formerly the gear menu (which now has three bars), under Recent Tabs.

But it is pretty good hiding. The new new tab page now has everything that was neatly in a couple of pretty discoverable tabs in the old tab page, and more, under three different menus (3x3 black-and-white in the top bar on the actual new tab page for google apps, 3x3 colored in the bookmarks bar for Chrome apps, and in a submenu in 3x1 bars at the top right). Having three menus that look somewhat the same is not a very discoverable UI.
Cc: ashej...@chromium.org
Labels: -Type-Bug Type-Feature Cr-UI-Browser-Instant-Extended
Status: Untriaged
Mergedinto: 326788
Status: Duplicate
This has been flagged as a duplicate, but the problem still exists and the issue it has been merged into remains unresolved. This is not a helpful response.
#8 Agreed. It is not resolved. Putting their fingers in their ears and singing "nanana, we're not listening" is not going to work. They'll just lock this discussion too because they can't hack constructive criticism.

https://productforums.google.com/d/topic/chrome/GU9zkV6dIDc/discussion
600 posts and 25 pages of complaints.

https://productforums.google.com/d/topic/chrome/KSa1CJ9aoEc/discussion
1000 posts and 41 pages of complaints, but was subsequently locked rather than merged with the above topic — Google trying to make it look like there's less complaints.

https://productforums.google.com/d/topic/chrome/3NqrNecHbhs/discussion
426 posts and 18 pages of complaints but was subsequently locked rather than merged with the above topics — Google trying to make it look like there's less complaints.

https://productforums.google.com/d/topic/chrome/Y4iA3eS22EE/discussion
13 posts from original canary testing of the NTP — locked, of course.
Ok so its hidden, rather than removed, but its still a big step backwards. They have removed useful things and replaced them with useless ones... Why cant we just have the other functionality show up again if you hover over the bottom where it used to be?

'Other devices' is particularly bad now because it shows so few tabs- and that was a seriously useful feature that meant you didn't have to email web links to yourself just to open them on the device sitting next to you...

PLEASE can we have that back- properly not just so it shows a miniscule number of tabs...! 
Yes, te flag has been removed in Revision 236116 and you cannot do anything about it. Google is ignorant and forced us to use the new NTP. They restricted commenting on  Issue 326788  and they probably do the same here.
> This has been flagged as a duplicate, but the problem still exists and the issue it has been merged
> into remains unresolved. This is not a helpful response.

It's marked as a duplicate because it is a duplicate; having a second copy of the same bug isn't helpful either. There's no reason the same discussion in a new bug would lead to a different outcome.

This bug tracker is intended for tracking work, not as a feedback forum (that's what the forums mentioned above are for), which is why the original bug was locked to comments.
It's a shame that there must be a bunch of product managers who are obstinate, and it's resulting in annoyance for developers on a bug tracker :-P

That litany of distaste catalogued in #9 is nothing short of amazing.
From a UI perspective, this is a bug. A bug tracker is, therefore, an appropriate place to raise the issue. Fixing the bug would be relatively simple; just roll back the changes which disabled the options. We should not need to use the feedback forum to deal with a commit which was clearly made in error.
This is very annoying.  I use google chrome daily.  When I want to quickly open a google app I instinctively click the new tab.  What was the logic when removing the workaround flag to restore this functionality?
Workaround found.

Install New Tab Redirect Extension

https://chrome.google.com/webstore/detail/new-tab-redirect/icpgjfneehieebagbmdbhnlpiopdcmna?hl=en

Set new tab to chrome://apps

Fin

That's not a workaround, and we're not 'fin'.

 We're not solely interested in the functionality of the chrome://apps page, but also the chrome://newtab page available in the previous NTP. This afforded the ability to customise recently visited sites (they were also much larger as they weren't obstructed by a gaudy search box), and also the ability to access recently 'closed tabs' and 'other devices'. Both of which are now hidden in the 'hamburger' menu. 

Peter Kasting, you stated here: https://code.google.com/p/chromium/issues/detail?id=298409#c27 "For better or worse, this has been wontfixed; further comments aren't going to change that.  Locking so people don't get their hopes up.". Whose decision was it to not fix this blatant disregard for UIX? Who at Google is trying to justify their role by breaking things which weren't broken? Who must we escalate this issue to? 

Is "Tyler Odean", product manager for Google Chrome, responsible for forcing this change? He was, afterall, the owner of the bug report you locked.
Labels: Restrict-AddIssueComment-EditIssue
As comment 12 said, the bug tracker is not a discussion forum.

Consider that, when we make a change and then test it extensively, we have a lot of data at our disposal to tell us whether it's a positive change in the aggregate.  If you're going to claim that someone is "trying to justify their role by breaking things which weren't broken", you had better have similarly good data, from hundreds of millions of users, that shows that, indeed, we made things worse overall; and you had also better be privy to the actual design conversations that happened so you know when people are acting in bad faith.  I don't believe either of those things is true.

When you claim that we "blatantly disregard" the user experience, or "can't hack constructive criticism", what you're really saying is "the team didn't do what I want on this issue".  But equating "I didn't get what I want" to us being malicious and incompetent does not give you the moral high ground; it just makes you sound shrill and makes your opinion less likely to be thoughtfully considered, except by people who are already inclined to agree.

We _have_, in fact, considered the various issues people have raised with the new NTP, and suggestions have been kicked around as to how to address those issues, so you may see changes in the future.  Completely reverting the NTP, however, is not one of those suggestions, because the new NTP is massively improved on all kinds of important user satisfaction metrics.  Reverting it, in our opinion, would harm the overall UX for a large fraction of our userbase, and we have a moral duty to consider their well-being, _not just the opinions of the few who complain_.

Frankly, in the end, we can't make everyone happy with Chrome.  Inevitably, everything we do is going to feel like a net loss to some group of people.  Our goal is to not make that group larger than we have to, but it's never going to be empty.  If you're not one of those well-served by Chrome's design decisions, you may be better served by another browser, and if so, by all means, use it.  The goal in the end is for everyone to have good choices among many good browsers.

And regarding locking threads: at some point, we're not going to continue arguing endlessly.  There is nothing to be gained by it; if our actions for the last six years as stewards of Chrome's user interface have not convinced you that we have our users' best interests paramount, then a few more paragraphs on some discussion thread aren't either.  So yes, we can and will lock bugs and feedback threads, so we can stop spending time Arguing On The Internet (see relevant memes) and go back to work trying to fix bugs and make Chrome better.

I'm sorry that nothing I say above is going to make you any happier.  I would prefer to make you happy rather than not.  But I'm not going to do it by making Chrome worse overall.

Locking.

Sign in to add a comment