New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 132 users

Issue metadata

Status: Fixed
Owner:
Closed: Jun 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug

Blocked on:
issue 25541
issue 311488



Sign in to add a comment

Windows 8.1 Color Emoji on Segoe UI Emoji is not supported on Chrome

Reported by ebrami...@gmail.com, Jan 9 2014 Back to list

Issue description

Chrome Version 33.0.1750.5

What steps will reproduce the problem?
Open data:text/html;charset=utf8,<div style="font-family: 'Segoe UI Emoji'; font-size: 1000%;">%F0%9F%91%B9 %F0%9F%91%BA %F0%9F%99%88 %F0%9F%99%89 %F0%9F%99%8A %F0%9F%92%80 %F0%9F%91%BD

What is the expected result?
Like Internet Explorer 11, colorful Emoji for Segoe UI Emoji that is meant for colorful emoji

What happens instead of that?
Is not colorful Emoji instead even with DirectWrite enabled: `chrome --enable-direct-write --no-sandbox --enable-experimental-web-platform-features --enable-logging --v=1`

See also:
* http://msdn.microsoft.com/en-us/goglobal/bb688099.aspx
* http://msdn.microsoft.com/en-us/library/windows/desktop/hh802480%28v=vs.85%29.aspx
* http://www.getcodesamples.com/src/712F9685/B41B1957
 
Emoji.png
88.5 KB View Download

Comment 2 Deleted

Comment 3 by sits...@gmail.com, Jan 13 2014

Possible dup of  Issue #151840  ... 

Comment 4 by tkent@chromium.org, Jan 14 2014

Cc: kenjibaheux@chromium.org
Labels: Cr-Blink-Fonts
Mergedinto: 151840
Status: Duplicate
I believe that this is a dupe.

Comment 6 by ebrami...@gmail.com, Jan 14 2014

This is about color emoji possibly through DirectWrite and that is about supporting emoji glyphs through fallback system of font rendering (#26). Seems I must track that bug and when the simple back and while emoji added for win8 I should ask for color emoji for win8.1...

Comment 7 by js...@chromium.org, Apr 1 2014

Cc: e...@chromium.org behdad@chromium.org bunge...@chromium.org
 Issue 358760  has been merged into this issue.

Comment 8 by js...@chromium.org, Apr 1 2014

Blockedon: chromium:151840
Mergedinto:
Status: Available
I'm unmerging this one from  bug 151840  because there are additional requirements for color support. I couldn't find this bug and filed  bug 358760  because this one was duped away (I knew that color font is not supported by Chrome on Win 8.1 and didn't search closed bugs as well). 

Comment 9 by Deleted ...@, Apr 1 2014

Thank you jshin. Possibly this can considered blocked on  Issue 25541  also
Blockedon: chromium:25541
@byagowi, I agree based on bungeman's comment in  bug 358760 . 

Blockedon: chromium:311488
Cc: scottmg@chromium.org yosin@chromium.org
Today I played with new DirectWrite API for color Emoji support on Windows and realized that this issue is also blocked on  Issue 311488  since colored Emoji rendering requires new DirectWrite APIs that are available in Windows SDK 8.1 and later.

CCed scottmg@ and yosin@ just for the heads up.
If using Windows SDK 8.1 API for emoji is that much far, probably landed patches on https://bugzilla.mozilla.org/show_bug.cgi?id=889401 Mozilla bug can be considered as it would be platform independent also
Blockedon: -chromium:151840
Cc: js...@chromium.org
 bug 151840  is just about color font support on Mac and Windows. It does not make sense to block this bug on that one. 

@bungeman, does Skia support Windows 8-style color font (with outline as opposed to bitmap color fonts such as Google's and Apple's)?  


 Issue 311488 , last blocker, is fixed. Can we expect progress on this issue now?
https://bug889401.bugzilla.mozilla.org/attachment.cgi?id=8424617 seems doable also on Skia, isn't?
Yes, it's definitely not rocket science.  I want to implement it in FreeType, but a native Skia implementation will be more useful since it will be available on all Chrome platforms.

Comment 17 by ebra...@gnu.org, Apr 14 2015

Just a [perhaps dumb] idea, if supporting this is that much hard, maybe shipping and installing "Noto Color Emoji" font which Chrome already supports for Android, along with Chrome would be easier [temporary] workaround? I saw there is plan to disable Mac emoji support because of crashes so this will help on that and this also will support older OSs that don't have color emoji fonts and also prevents spread of unnessary hack that Twitter/Telegram/.../everyone is doing on replacing plain text Emoji characters with images.
Does Chrome even fall back to normal B&W emoji? I heard that on Chrome Mac you don't see anything, not even a square box or anything. On Windows right now it looks like if you set the right fonts, you can get B&W emoji at least. Pretty terrible considering FF/IE/Safari all display the color emoji just fine on any OS with support. I've been using them on live sites already, so if Chrome user's can't even see B&W fallbacks, that's going to be a pretty big issue for them.

Comment 19 by behdad@google.com, Apr 16 2015

Chrome will use the B&W emojis by the virtue of those being backward-compatible TrueType fonts.

Using the Google emoji format on Windows isn't trivial as we would need to ship FreeType (or portion of!) and instruct Skia to use that for CBDT/CBLC fonts...

Easier to implement MS format in Skia I'd say.

Mac is a different beast.
Maybe it's just a flaw with http://www.browserstack.com/screenshots but when I test Chrome on Mac there, emoji are completely blank. All other combination of OS or browser works fine. Chrome is always B&W which sucks, and the rest are color if the OS supports it.

Comment 21 by behdad@google.com, Apr 16 2015

I don't remember what the status of Chrome emoji support on Mac is.  Anyway, someone / team needs to assume ownership of this.758

@Comment #20. Color emoji on Mac started being supported in Chrome 41. The site you link to only goes up to Chrome 40. On Windows, there was an issue with font fallback which prevented a number of even B&W emoji glyphs from being found which I believe is fixed in 42 (I'm not sure about 41).
Color emojis are not supported on both Chrome 42 Stable and Chrome 44 Canary (Windows). What is the status of this bug? 

I can also say that emojis on Mac and iOS are way better than all other platforms emojis.
Is there any update on this issue? when will color emojis be supported on Chrome for Windows?
Country flags still don't work at all. Just rectangles appear.
There is no emoji that works, not only country emoji.
Many others work, in black and white. I checked on http://emojipedia.org/.
I'm using Version 42.0.2311.152 m (64-bit)
Hi, are there any updates on this issue? 

Comment 29 by ebra...@gnu.org, Jul 17 2015

Cc: drott@chromium.org kojii@chromium.org
Issue 516287 has been merged into this issue.
Cc: jsc...@chromium.org
Labels: Proj-Windows10 Cr-Internals-Skia
Adding the Windows 10 flag, since this is close enough (win 8.1+). and adding a skia flag, since we need the support there.

Comment 32 by say...@saylas.ru, Aug 12 2015

May be it is possible to set the higher priority for this issue as it's old enough, really lot of people encounter it every day and it seems there is no progress?
I am seeing black and white emoji on Win since M44, though emoji in title shown on tab strip is still black square fallback, as reported in  crbug.com/520559 .
^ is more related to  Issue 396415  than this.

This issue is not even directly related to emoji (non-emoji glyphs can be colored on a custom font), have a look at https://bug889401.bugzilla.mozilla.org/attachment.cgi?id=8424617 it just needs renderer read color layers of the glyph then use them to render a glyph. This easily can be done platform independently so the issue is not Windows specific and has not to have a Chromium/Skia developer use Windows to fix it (simply copy seguiemj.ttf from a Windows 8 system and use it for development purpose).
Segoe UI Emoji uses COLR/CPAL tables. Chrome does not seem to support it. The issue still stands. 
You guys do not want color emojis? There is no progress on this for months.

Comment 37 by Deleted ...@, Sep 21 2015

This is shameful.
Cc: ananta@chromium.org
ananta@ - Do you want to take a look at adding support for this?

Comment 39 by ebra...@gnu.org, Sep 24 2015

Cc: caryclark@chromium.org
Would someone please CC more people from Skia team to finally find an intrested owner? Also have a look again at  http://crbug.com/333011#c34 
Cc: -bunge...@chromium.org reed@chromium.org
Owner: bunge...@chromium.org
Ben, care to comment?
Owner: ananta@chromium.org
Status: Assigned
Taking up for investigation
Ben, perhaps we can look into this together next week?

Comment 43 by ebra...@gnu.org, Sep 29 2015

Cc: bunge...@chromium.org
^

Comment 44 by ebra...@gnu.org, Sep 29 2015

I just hope with learning from https://bugzilla.mozilla.org/show_bug.cgi?id=889401 you won't go to hack Skia dwrite  backend path and do this platform neutrally finally.  http://crbug.com/333011#c34 
Labels: Cr-Internals-PlatformIntegration
Considering how prevalent emoticons are today I'm surprised this is not being addressed faster. The emoticons we have today are quickly becoming part of a universal language taking on meanings far beyond what any word could portray.

Is there a chance the Android icon set would be shipped with Chrome for optional use in place of the OS native icons? The windows 8.1/10 icons are abysmal representations.
So is this happening any day or?
How can Mac get it like 6 months ago, but Windows and Linux are still waiting.
Owner: kulshin@chromium.org
kulshin@ - We talked about adding this to your font work. ananta@ has the context.

Comment 49 by say...@saylas.ru, Mar 4 2016

2016, March.
Chrome doesn't support normal emoji's on Windows.
F*c**ng ridiculous!
Sigh. Can somebody please restrict comments on this bug so that I only receive relevant, constructive notifications?
Labels: Restrict-AddIssueComment-EditIssue
Given the repeated violations of the Chromium Code of Conduct <https://dev.chromium.org/conduct> I'm restricting public comments from this issue.

kulshin@ - When you start working on this and need feedback, you can remove the restriction flag if you want.
Labels: -Restrict-AddIssueComment-EditIssue
Status: Fixed
Project Member

Comment 54 by bugdroid1@chromium.org, Jun 3 2016

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/6f6cdebd94b05e905af25e412eec1c87a4e2418b

commit 6f6cdebd94b05e905af25e412eec1c87a4e2418b
Author: Rebaseline Bot <blink-rebaseline-bot@chromium.org>
Date: Fri Jun 03 23:11:04 2016

Auto-rebaseline for r397752

https://chromium.googlesource.com/chromium/src/+/91e2b1e30

BUG= 333011 
TBR=kulshin@chromium.org

Review URL: https://codereview.chromium.org/2036203006 .

Cr-Commit-Position: refs/heads/master@{#397835}

[modify] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/TestExpectations
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/android/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/android/fast/text/color-emoji-expected.txt
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/linux/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/linux/fast/text/color-emoji-expected.txt
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/mac-mac10.10/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/mac-mac10.9/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/mac-mac10.9/fast/text/color-emoji-expected.txt
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/mac/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/mac/fast/text/color-emoji-expected.txt
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/win7/fast/text/color-emoji-expected.png
[add] https://crrev.com/6f6cdebd94b05e905af25e412eec1c87a4e2418b/third_party/WebKit/LayoutTests/platform/win7/fast/text/color-emoji-expected.txt

Cc: kulshin@chromium.org
 Issue 620419  has been merged into this issue.
Cc: -kenjibaheux@chromium.org

Sign in to add a comment