Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 35 users
Status: Fixed
Owner:
Closed: Feb 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug

Blocking:
issue 338516

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
Close X tab button doesn't work
Reported by maze.sh...@gmail.com, Jan 8 2014 Back to list
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.72 Safari/537.36

Steps to reproduce the problem:
1. open chrome
2. try to close by using the "x" button on the tab's header
3. 

What is the expected behavior?
The tab (or chrome itself, if there is only one tab) should close.

What went wrong?
The button doesn't respond, no indication is given that the click was made.

Did this work before? N/A 

Chrome version: 32.0.1700.72  Channel: n/a
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 12.0 r0

1. You can right click the tab and choose the close option, and the tab will close.
2. I used chrome a few hours ago, and there was no problem, only now. (8/1/14 11:00 Israel format)
3. I added chrome users a few hours ago, expanded my google accounts.
4. Chrome says he is up to date.
 
Cc: ashej...@chromium.org
Labels: Needs-Feedback
Unable to reproduce the above issue on Windows 7, with chrome version "32.0.1700.72". 
Request you to fresh installing the same version & disable all extensions, except default & try reproducing the above issue & let us know if issue persists.
Thank you!
Comment 2 by Deleted ...@, Jan 8 2014
Same problem for me. When clicking the X it does not close the tab. This is on ym home computer and my work computer since last night
Comment 3 by Deleted ...@, Jan 8 2014
Version 32.0.1700.72 m
 
Google Chrome is up to date.
Comment 4 by kareng@google.com, Jan 9 2014
Cc: melodychu@chromium.org kareng@google.com
 Issue 332790  has been merged into this issue.
Comment 5 by kareng@google.com, Jan 9 2014
Labels: M-32
Owner: ashej...@chromium.org
Status: Assigned
can u please try once more?
Comment 6 by kareng@google.com, Jan 9 2014
Labels: ReleaseBlock-Stable
Owner: ----
Hello Karen,
Tried again & the same result, not able to reproduce the above issue on Windows 7, SP1
with chrome version "32.0.1700.72". I am able to close the tab using "x" on the the tab header.

Thank you!
Comment 8 by kareng@google.com, Jan 9 2014
could you try on a few different machines? we have over 30 reports of this...
Cannot reproduce this in win 7 using - 32.0.1700.72 (Official Build 243157) .

Assuming this might be a Hidpi display issue , 
pls see - https://code.google.com/p/chromium/issues/detail?id=332464

It might be similar to the hi DPI issue, but given that we have a meaningful yet still small number of reports I'm guessing it might also be third-party software.

Can anyone who has reproduced this problem please post their exact machine model number and configuration, including screen resolution?
Cc: ligim...@chromium.org
Can you repro with Win8? 
I mentioned this in  crbug.com/332790 :  
Version: 32.0.1700.72
OS: Win 8.1, Win7

What steps will reproduce the problem?
1. Bring cursor to a tab, hover over x to close

What is the expected output? What do you see instead?
Expected - x turns red and you can click it to close a tab 
Actual - x is not highlighted, you can't close a tab

- Users can close tabs by right-click menu or Ctrl+W
- Applicable feedback reports sample: #1725652426, #1734116094
- Received at least ~30 reports in a day today

I haven't been able to repro yet. Please QA.

Cc: nikeda@chromium.org
Labels: Hotlist-ConOps
Need a repro for this before we can fix
I still haven't been able to repro. What is more, throughout the day, we got more reports from Win7, XP, Win8... 
Cc: nagamalathi@chromium.org jaisimha@chromium.org maxu@chromium.org viswanatha@chromium.org chrome-test@chromium.org ananthak@google.com
Labels: GoogleFeedback
20+ users have reported this issue in 'GoogleFeedback' in last 2 days having chrome 32 Stable version. 

Version : 32.0.1700.72 Stable

User's reports that that are unable to close tab using 'X' button. 

Additional Info: 
1. 'X' button does not respond to mouse click. 
2. many users reported that they are able to close tab using shortcut 'Ctrl+W'. 
3. Some users reported that are able to close by right clicking on tab and selecting 'Close Tab' option from the context menu.
4. Issue observed only in M32 Stable version having Win Os.

NOTE: We could not reproduce the issue on Chrome 31.0.1650.63 on Linux.

Sample user reports:
https://goto.google.com/1526929300
https://goto.google.com/1106284337
https://goto.google.com/1525675785
https://goto.google.com/1734116094

For more user reports refer the cluster URL:
https://goto.google.com/closetab
Cc: mangalampalli@chromium.org
Hello Karen,
I Tried the above issue on 3 different Windows 7 machines & was not able to reproduce the above issue with chrome version 32.0.1700.72. 
when mouse hover 'x' button color changes to red & when click on the same the tab gets closed.
Do let me know, if anymore information is required.
Thank you!
 
Comment 20 by ity...@hotmail.com, Jan 13 2014
I noticed I couldnt close the tab with the X about a week ago, or there about.  The x on the far right still works, but not the tab x.  Also I tried out some apps for page notes and also to change the new starting page, but have turned them all off and still get the same challenge.

Did one of those apps do this when it was turned off?

Bigger Notes [ANTP] 
Self-stick notes 1.5.0.0

There were two other ones i tried but I tossed in the trash can.  
Comment 21 by ity...@hotmail.com, Jan 13 2014
Im running xp latest updates.
 Issue 333990  has been merged into this issue.
Comment 23 by Deleted ...@, Jan 15 2014
same issue on Windows 8 machine.
following extensions:

voice
put.io
ABP
Lastpass
Chromecast
Print Friendly


Comment 24 by Deleted ...@, Jan 16 2014
i dont know what wrong with this 32 version 31 was ok 
on Windows 7 is everything ok 
but on Windows 8.1 is problem do something with this ! 
Comment 25 by Deleted ...@, Jan 16 2014
Hi
I have exactly the same problem with the X to close a tab not working while Ctrl-W still works properly. The problem has arisen only after I upgraded from Windows 8 to 8.1. I had some other problems with Google Chrome browser after the upgrade - Chrome browser was unusable because the window containing Chrome would not open properly - but I managed to fix those by checking "Disable display scaling on high DPI settings" in Google Chrome properties. My system is an HP P7-1418.
Not a huge problem but extra keystrokes are a nuisance. Hope you find a solution!
Comment 26 by ity...@hotmail.com, Jan 16 2014
screen rez: 1920x1080

"Can anyone who has reproduced this problem please post their exact machine model number and configuration, including screen resolution?"  Not sure what you want here?  

But....
Time of this report: 1/16/2014, 15:27:07
      
   Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_qfe.130704-0421)
           Language: English (Regional Setting: English)
System Manufacturer: INTEL_
       System Model: DH55HC__
               BIOS: BIOS Date: 03/26/10 13:44:50 Ver: 08.00.10
          Processor: Intel(R) Core(TM) i3 CPU         540  @ 3.07GHz (4 CPUs)
             Memory: 3318MB RAM
          Page File: 1347MB used, 5125MB available
        Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
     DxDiag Version: 5.03.2600.5512 32bit Unicode

------------
DxDiag Notes
------------
  DirectX Files Tab: No problems found.
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
          Music Tab: No problems found.
          Input Tab: No problems found.
        Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (n/a)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------
Display Devices
---------------
        Card name: NVIDIA GeForce 9500 GT
     Manufacturer: NVIDIA
        Chip type: GeForce 9500 GT
         DAC type: Integrated RAMDAC
       Device Key: Enum\PCI\VEN_10DE&DEV_0640&SUBSYS_094319F1&REV_A1
   Display Memory: 1024.0 MB
     Current Mode: 1920 x 1080 (32 bit) (60Hz)
          Monitor: Plug and Play Monitor
  Monitor Max Res: 1600,1200
      Driver Name: nv4_disp.dll
   Driver Version: 6.14.0012.9610 (English)
      DDI Version: 9 (or higher)
Driver Attributes: Final Retail
 Driver Date/Size: 2/29/2012 16:58:00, 4309760 bytes
      WHQL Logo'd: Yes
  WHQL Date Stamp: n/a
              VDD: n/a
         Mini VDD: nv4_mini.sys
    Mini VDD Date: 2/29/2012 16:58:00, 13417632 bytes
Device Identifier: deleted this

        Vendor ID: 0x10DE
        Device ID: 0x0640
        SubSys ID: 0x094319F1
      Revision ID: 0x00A1
      Revision ID: 0x00A1
      Video Accel: ModeMPEG2_C ModeMPEG2_D 
 Deinterlace Caps: {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(YV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {6CB69578-7617-4637-91E5-1C02DB810285}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
         Registry: OK
     DDraw Status: Enabled
       D3D Status: Enabled
       AGP Status: Enabled
DDraw Test Result: Not run
 D3D7 Test Result: Not run
 D3D8 Test Result: Not run
 D3D9 Test Result: Not run


Comment 27 by ity...@hotmail.com, Jan 17 2014
for xp I went to chrome://flags and enabled:

HiDPI Support Windows
If enabled, application size and layout will adapt to the operating system's DPI settings. #high-dpi-support

And it worked, however the font is huge and when a new page opens, the font doesnt remain at the size i put it.
Same problem here.  Can't close tab by clicking on X.

Windows 7 64-bit

Comment 29 by data...@yahoo.com, Jan 17 2014
oh come on, google people are paid way too much money to deal with this. and then when they have to, they steer you in a different direction to defer the issue. it'll be better to use another browser like IE, then use the site google.com. there you will be able to use "x" to close the tab. it's much easier than relying on google.
Comment 30 by Deleted ...@, Jan 17 2014
Same issue here.  
Using Windows 7 Home Edition, 
Chrome: 32.0.1700.72 (Official Build 243157) m, 
Extensions Avast! Online Security, Facebook Comment Fixer, Kaboodle & Revert FB Photo Viewer installed & enabled.   

Started last week or so, and after a few days of not seeing any improvement, did an uninstall and reinstall.  That fixed the problem for a few days, but now the problem's back again, no matter how many times I un-and-re install.  Tonight however, I noticed that Chrome had spontaneously pinned a tab I'd not chosen to pin.  Last time this happened, something similar happened, but I'd thought I'd accidentally hit the wrong button.  Tonight I -know- I haven't (to prevent this very problem), but it still happened on its own, and now nothing I do will get rid of it.  A fix would be awesome, 'cause I adore Chrome.  IE is slow as poo for me, so I want my Chrome back.   Cheers! ♥
Comment 31 by Deleted ...@, Jan 17 2014
I have the same problem I was able to fix it once by uninstalling and reinstalling google chrome browser.  Now the problem will not go away no matter what. 

What is the problem?

Tabs will not close when you use a mouse to point and click on x in the top right of each tab. These little x's used to gain a highlighted red circle when I hovered the mouse point over them, but now, nothing and the clicking the x will not close the individual tabs.

Other options that suck?

Yes, Ctrl+W works and right-clicking the tab brings up a menu that allows for the tab to be closed.

I am only experiencing this problem on WINDOWS 8.1

I have also tests this problem on windows 8 and have no issue there.
Comment 32 by Deleted ...@, Jan 17 2014
i have this problem and uninstalling and installing back didn't fix the problem,

HELPPPPP 
Comment 33 by j...@voorn.eu, Jan 17 2014
I've got the same problem, using a high resolution screen at 2560 x 1440 (asus zenbook infinity UX301LA) on Windows 8.1. Problem started after enabling and disabling the HiDPI option (which resulted in Chrome being unusable). Removing Chrome and / or appdata has no effect.
CTRL+W works

Comment 34 by Deleted ...@, Jan 17 2014
SAME HERE

Windows 7 64-bit
Chrome: 32.0.1700.76 m
Windows dpi: 150%
screen size: 2560*1440

but I set Windows dpi: 125%
It's works!
Comment 35 by Deleted ...@, Jan 17 2014
OK Guys/Girls

Had the same issue

I am visually impaired and have a DPI of 177%

The Tab X does not work

Set to window 100% Fine

Set to Windows 125% fine

Set to Windows 150% Does no work

So I guess it is a scalling issue with DPI

Chrome Version 32.0.1700.76 m

Win 7 Build Version  6.1.7601 Service Pack 1 Build 7601


Now I, as I said amd Visually impaired and thisissues is a biggy for me....

Cheers Strudders
Comment 36 by Deleted ...@, Jan 18 2014
My wife's pc started having this same issue too.  It started "a couple of days ago"  Her specs are:

Windows 8.1
Screen resolution is 1920x 1080
Asus Zenbook: UX31L

Using chrome ver: 32.0.1700.76 m
She turned on her enlarged font in MS Windows about a few weeks ago.  Thus, this makes me suspect it's a DPI issue as other users have posted.

BTW, when she hovers over the x, it does not acknowledge the hover either.  On my chrome, the mouse would make the x turn into a red x with a circle around it.  Her hover does not even acknowledge the mouse over the x.


Comment 37 by bwe...@gmail.com, Jan 18 2014
Windows 8.1. Can't close tabs using X since yesterday.
Comment 38 by the3...@gmail.com, Jan 18 2014
HP h8-1240t
Windows 7 Home Premium 64 bit
1920 x 1080

The problem began for me while viewing a google image, I was automatically redirected to a different site. A google dialogue box popped up which stated that a malware attack had been detected. I did not respond to the prompt. I closed the window and ran a Norton virus scan and nothing was detected. Since the prompt I have been unable to close any open tab by left clicking the "x". I now have to right click and manually choose from my list of options to close tabs. I've tried uninstalling and re-installing chrome.
Comment 39 by Deleted ...@, Jan 18 2014
Hey guys, i'm new here and I had the same problem, and after reading the posts #35 gave me and idea. 
My screen is  13.3" touchscreen  and 1600x900 resolution so i set the dpi to 125% (when i got the laptop). Now I tried putting it to 100% and the X button started working again. I said ok , lets put it back to 125% and see if the problem comes back ... well it did not. Now i have the original 125% dpi and have no problem closing the tab. I will be more careful and when/or if the problem comes back, and i will write you here.
Hope it helps!

Chrome Version 32.0.1700.76 m 
Windows 8.1
Lenovo Yoga 13
Comment 40 by the3...@gmail.com, Jan 18 2014
Following the suggestion in post #39 does correct the problem with dpi set to 100%, but in my case the problem returned immediately when i adjusted back to the original 200%.

HP h8-1240t
Windows 7 Home Premium 64 bit
1920 x 1080
I'm having the same issue. For me, it began about a week or two ago. (isn't always about a week or two ago ago when you're not paying attention?) It was certainly 2014 when I first noticed it.

Anyway, in addition to the "close tab" button not working, the "close application" and "minimize" buttons do not work. Basically, anything that is a button in the title bar area does not work and does not show visual mouseover feedback. Keyboard shortcuts and right-click context menus do work, however. Something MUST have changed in the code for left-clicking and mouse hovering these buttons in a recent update.

Someone threw out the idea that this was being caused by high dpi settings. My PC is hooked up to high def TV, so naturally I had raised the DPI settings so as not to make myself go blind. I first did as someone else suggested and went to Chrome://flags and adjusted the settings for HiDPI support. The problem persisted irrespective of whether that setting was set to Default, Enable, or disable.

Next I went into the display settings in WIndows and adjusted the DPI from 120 back to the default of 96. After the very long restart this change prompted, the buttons worked. Then I changed the dpi back to 120--buttons stopped working after the restart. Went back to 96 again, buttons work now. It must be related to DPI and it must be a recent update--prior to when this issue started in January 2014, my DPI had been set to 120 since attaching it to the high def TV in 2012. Never a problem with Chrome from 2012 until this started.

But it's so weird to be tied to DPI and it is only affecting the left-click and mouseover, and not the right-click. And only in the title bar area.

To Google:  In case it matters, I have a Vista x64 PC and it's attached to LG 46" LCD TV (1080p) via a DVI cable (with an RGB adapter because my tV only has an RGB-in). Resolution set to 1920 x 1080. DPI 96--title bar buttons work, DPI 120--title bar buttons do not work.

To Everyone else: If you have this issue, go into your windows settings and play with DPI. You might need to set it to 96 DPI or 100%--setting will depend on what version of windows you use. Of course, if you have a high def screen, the text will be teeny-tiny after you do this. See if it helps. If it helps more people than just me it might help them narrow down the bug.
Randomly, it just started working again. I did not change any settings in Windows or Chrome since I typed the last message. Weird.
Correction: tab close works, application close/minimize do not work.
Comment 44 Deleted
Comment 45 by Deleted ...@, Jan 18 2014
I have the same problem with the tab 'x' being unclickable and not turning red on hover, and I was able to fix it with the following steps:

* Right-click the Chrome icon from the desktop or Start menu and select "Properties"
* Click on the "Compatibility" tab
* In the Settings section, uncheck "Disable display scaling on high DPI settings"
* Close and reopen Chrome

Unfortunately, when I enable display scaling by unchecking the box, full-screen videos (e.g., YouTube) get covered up by the Start menu.

Details:
Self-built HTPC with Windows 7 Home Premium SP1
Chrome 32.0.1700.76 m
1920x1280 resolution, 175% DPI in Windows Display settings, output to HDTV via HDMI
Comment 46 by Deleted ...@, Jan 19 2014
I, too, would like to see these changes. We enjoy our steppers, and this new sidebar is VERY hard to see. It's somewhat nice that it's hidden until you need to find it. My eyes end up looking across the entire webpage wondering where they may have gone, its that hard to see.
The same issue started for me yesterday afternoon, 1/18.

Steps to reproduce the problem:
1. open chrome
2. try to close tab by using the "x" button on the tab's header


What is the expected behavior?
- X tab should highlight and close

What went wrong?
- X tab does not respond.

Did this work before? 
Yes, up until yesterday.


I'll provide as many details as I can.

Computer type:  Asus notebook, I think the model is Q501L

Windows Magnification and Google Chrome Magnification: 125% 

Resolution: 1920 x 1080



Google Chrome	32.0.1700.76 (Official Build 244343) m
OS	Windows 8
Blink	537.36 (@164518)
JavaScript	V8 3.22.24.10
Flash	12.0.0.41
User Agent	Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36


Extensions that are enabled:

Kapersky Anti-Banner 13.0.1.4190
ezLinkPreview 5.33
Google Docs 0.5
Image Hover 1.0
Reddit Enhancement Suite 4.3.1.2
SwiftPreview 2.2.4







Comment 48 by Deleted ...@, Jan 19 2014
Same problem for me. When clicking the X it does not close the tab. I am using windows 8.  It happened after the windows update.
Been having this issue now for about 2 weeks. Very frustrating. Am running windows 8.1 with all updates. Only use Malwarebytes Pro, Security Essentials, & Wind Firewall for security; turning them all off doesn't solve the issue. Am now noticing that many streaming sites now state "unable to load network"; don't know if this is related, but everything works fine using IE. AND I HATE IE!!!
Comment 50 by Deleted ...@, Jan 19 2014
I was able to fix this issue in Win 8.1 on my HP spectre x2 13.  It is an issue with Chrome and the Windows scaling.  I had been using 125% scaling, plus some custom font sizes.  Taking it back to 100%, logging out then back in fixes it.  I was also able to bring it back to 125% and confirm the tabs still work.  The only thing I have not had time to do is go back to my custom font scaling.  I will try it when I have more time.
Maybe the font has something to do with it--I never resized the fonts after
switching the DPI settings. Also, suddenly the close application and
minimize buttons work again. It seemed to happen in stages, but all of the
buttons work now.
Glorious! I just scaled from 125 to 100, logged out, went back to 125 and my custom font size, and it works!!!

Using Windows 8 for reference (also mentioned above)

I'm curious why this started happening out of nowhere though.
My feedback is to provide my Google Galaxy nexus, my Google account,
Google's latest version and all services.

Kyaw
Comment 54 by Deleted ...@, Jan 19 2014
Under "Change only text sizes"  having a size higher than 11 for "Message boxes" breaks the "x".  That font setting controls the size of the tab text and the bookmark text size.
Comment 55 by Deleted ...@, Jan 20 2014
Further to saxlyl...@gmail.com

They are correct in it is only the message box font size that causes the issue (thanks) 

On my version It can not be set to more than 14

Windows Colour and metics

Message box Font size 14

Acrive title bar size 17

Menu size 17

Active Title Bar 17 

Inactive menu bar 17


So my testing is its the Message box font that causes my issue with the X with 14 being the largest text size that can be used. 

Win & home premium 

Build Version: 	6.1.7601 Service Pack 1 Build 7601

Google Chrome : Version 32.0.1700.76 m

Hi I have the same issues as stated above running windows 7 and chrome 32.0
this is a major issue for me and has basically rendered chrome unusable.
 I've tried un-re install messed with font sizes changed the compatibility hidpi setting still wont work    
I concur.  The issue is the message box font size.  I had it at 18 and when I changed it to 14 it worked fine.  Unfortunately, keeping it at 14 is not an option as I can't see anything.

Everything is optimized to look good on phones, at the expense of desktop and laptop users.  Everytime google pushes an update, I have to figure out how to make if work, whether it's learning about css style sheets to adjust scoll bar width or return features that were replaced with new "improved" ones that require more clicking to accomplish the same goal.

After google fixes this problem, I'm going to stop automatic updates.  Chrome is too much work to keep it usable.
Mine doesn't even work if I change all font sizes to 10!! But your right Google pushes the browser for phones as it's hard coded into most new phones these days but my stock browser on my HTC one is better than chrome. I'm uninstalling until a fix occurs :(
Comment 59 by Deleted ...@, Jan 21 2014
I had the same issue start happening a few weeks ago, I've just been living with it right clicking on each tab then closing but finally did a search and found this thread...

I'm running Windows 8 (not 8.1 fwiw) and chrome Version 32.0.1700.76 m with a custom DPI scale set to 190% @ 1920x1080 over hdmi (this system is used on a tv screen far from the bed I'm laying on so everything needs to be huge for me to see it at this distance).

Anyway I was able to fix it just now by changing my Message Box size from 9 to 7 and now I when I hover over the close tab buttons they highlight red and work once again!
Comment 60 by Deleted ...@, Jan 21 2014
Also my scroll bars (in chrome only) are very thin and tiny, hard to see most of the time
This is how I made my scroll bars wider.

http://www.gtricks.com/chrome/scroll-bar-without-extension/


Cc: wiltzius@chromium.org
Hi Tom, hope to bring this back on your radar - it does sound like it is a scaling issue - can you help find an owner for this or should we ask any more questions to narrow down?
Cc: cpu@chromium.org
Owner: msw@chromium.org
Yeah I can repro now. 

Mike can you take a crack at this?
Comment 64 by msw@chromium.org, Jan 21 2014
How frustrating! I apologize to everyone experiencing this issue, I'll look into it.
Comment 65 by msw@chromium.org, Jan 21 2014
Status: Started
I can repro on Win7 with Chrome 32.0.1700.76 (Official Build 244343) m and ToT.
1. Visit Control Panel\All Control Panel Items\Personalization
2. Click "Window Color" to open the "Window Color and Appearance" dialog.
3. Switch to Item: "Message Box", set Font: to "Tahoma", Size: "17" (or larger).
4. Open Chrome, notice the tab close (x) will not glow red or respond to clicks.

This does not repro on M-31, and might be related to Aura, I'll try to bisect.
WORKAROUND: Choose a smaller font, use CTRL-W, or right-click menu -> "Close Tab".
I'll try to find a good solution, but this might not be fixed until M-33.
Comment 66 by msw@chromium.org, Jan 21 2014
Cc: tdander...@chromium.org sadrul@chromium.org sky@chromium.org ben@chromium.org
I suspect r232797 from the bisected regression range:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=232771%3A232818
I'd ask Terry to take a look, but he's out until the 27th.
Related issues:  http://crbug.com/306186  and  http://crbug.com/129794 
Comment 67 by cpu@chromium.org, Jan 21 2014
Cc: shrikant@chromium.org
Shrikant, please assist msw (if he needs it) on fixing this bug. Thanks.

Upping to P1.

msw@ can we stay at a fixed font size ? This might not be the best fix but it would be easy to test and probably easy to merge.
Comment 68 by msw@chromium.org, Jan 21 2014
Labels: -Needs-Feedback
Clamping tab text size might affect usability and would only be a workaround.
Worse, we'd need to specify a reasonable size limit for each individual font.
(Tahoma breaks at sizes 17 or greater, Comic Sans breaks at sizes 15 or greater, etc.)
Maybe we could cap the font height (not size), but I'd rather find the right fix.
I'll look for a minimal fix, but doubt it'll make the second M-32 stable release.
Comment 69 by msw@chromium.org, Jan 22 2014
I have a WIP local fix CL: https://codereview.chromium.org/143803010/
Thanks to Sadrul for suggesting this fix and offering other info/advice.
If it helps, I use Candara 18.  

I went back to 31.0.1650.63 and stopped auto updates.  

CCleaner has an option to stop updates or try the portable app, UpdateFreezer.  




My feedback is to update my Google Galaxy nexus, my Google account, the
latest of Google's services and all features.
Kyaw
Comment 72 by Deleted ...@, Jan 22 2014
I am having the same problem! I even tried uninstalling and reinstallling google chrome and it did not help
Comment 73 by Deleted ...@, Jan 23 2014
I am also experiencing this same exact issue. It began AFTER I upgraded to Windows 8.1 from Windows 8. This issue is approaching a two week old issue at this point. I have no third party extensions and very minimal trust worthy third party software. This is a new pc. I am not experiencing this issue on my XP desktop, my HP laptop With Vista; or my Windows Vista Desktop. This issue is only present on my new Windows 8 Desktop; now upgraded to 8.1. The primary x all the way to the right works. The x's on the tabs do NOT work. I sign in to Google Chrome via my gmail account so all my browsers on each computer is/are synchronized. For me, this issue is exclusive to the windows 8.1 OS. Don't know if this matters, but this is a 64bit platform. Please do what ever you can to fix this ... It's very annoying and up until this issue reared it's ugly face, I've favored Google Chrome over all other browsers and I used to love it. 
My feedback is to enhance my Google smartphone, my Google account, the
latest of Google's services and all features.
Comment 75 by Deleted ...@, Jan 23 2014
Hello, I have the same problem. The X button doesn't close my tab. Here is my computer specs:

Windows 8 v1.3.0

Chrome Version 32.0.1700.76 m

DELL laptop 
Intel(R) Core (TM) i7-3517U CPU @
1.9Ghz 2.4Ghz
Ram 8GB 
64bit OS, x64-based processor

OK, thank.

Kyaw
Project Member Comment 77 by bugdroid1@chromium.org, Jan 23 2014
------------------------------------------------------------------------
r246686 | sky@chromium.org | 2014-01-23T21:13:45.819206Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/views/tabs/tab.cc?r1=246686&r2=246685&pathrev=246686

Temporary fix for bad hit testing of tab close button

The problem is the close button ends up saying it has a hit test mask,
but returns an empty hit test mask. The code was checking for
containment, when it should be checking for intersection.

My fix isn't ideal, we really need to return the intersection, but
this should be good for now.

BUG= 332334 
TEST=see bug
R=msw@chromium.org, sadrul@chromium.org, tdanderson@chromium.org

Review URL: https://codereview.chromium.org/134203004
------------------------------------------------------------------------
Comment 78 by cpu@chromium.org, Jan 24 2014
If I understand Shrikant correctly, clamping the text/font height would be desirable anyways but of course not at 16px.

Comment 79 by msw@chromium.org, Jan 24 2014
Cc: -sky@chromium.org msw@chromium.org
Owner: sky@chromium.org
This appears fixed on the latest 34.0.1803.2 (Official Build 246787) canary, passing to Scott for merging.
I agree that fonts should be clamped by height (and layout fixed), I filed Issue 337850 for separate followup.
Comment 80 by sky@chromium.org, Jan 24 2014
Labels: Merge-Requested
Comment 81 by Deleted ...@, Jan 24 2014
This "Close X tab button doesn't work" issue started on my 
Widows XP SP3 desktop, after the last update to Chrome 
Version 32.0.1700.76 m.

I discovered the solution in this forum and can confirm that 
changing the “Message Box Font Size” solved this issue for me. 
In Windows XP, right click on Desktop and choose Properties – Appearance – 
Advance - and select Message Box under the Item drop down menu.

I found that the font chosen will effect the maximum size that 
varied from one style to another. Also note that choosing between 
“Normal, Large, and Extra Large Fonts” under the desktop - 
Display Properties – Appearance – Font size
may also have an effect.

With my screen resolution set at 1600x1200, I chose to use
Extra Large Fonts - New Times Roman - size 18 and now clicking 
the X closes the tab as it should.
 

I would like to report this problem also.I have Windows XP. This problem started this session on my home laptop. Tried #81 fix, didn't work. Jerry
Blocking: chromium:338516
Comment 84 Deleted
Followed the steps in comment #65 but was unable to repro the issue on win7 reported version 32.0.1700.76 (Official Build 244343) - The x on the tab when mouse hover turned to red (somewhat missing the red glow ie dull red color displayed) but it is responding to the mouse click and closing the tab.

msw@, Could you please let us know if i am missing something here. This would be helpful to verify the fix.
Comment 86 by msw@chromium.org, Jan 28 2014
Labels: -Needs-Feedback
Try using a larger font size, or any other font with a very large size.
Completely restart Chrome after applying the new "Message Box" font/size.
Using Windows classic or glass might affect the specific size cutoff.
Let me know if you still have trouble reproducing and I'll gladly help.
Labels: TE-Verified-34.0.1810.0
Issue was reproduce on 32.0.1700.77 (Review Actual) and fixed on Latest Canary i.e. 34.0.1810.0 (Review Fixed)
Actual.mp4
833 KB Download
Fixed.mp4
684 KB Download
Comment 88 by kareng@google.com, Feb 5 2014
there will be no more 32s, please make sure to request merge to M33 instead
Cc: rbyers@chromium.org
https://codereview.chromium.org/147623004/ is in the commit queue at the moment. Once it lands and is verified in canary I would like it to be considered as the merge candidate for 33 instead of r246686. It not only fixes this issue, but also prevents the regression for touch users described in  issue 338516 .
Project Member Comment 90 by bugdroid1@chromium.org, Feb 6 2014
------------------------------------------------------------------------
r249331 | tdanderson@chromium.org | 2014-02-06T10:17:20.128111Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/views/tabs/tab.cc?r1=249331&r2=249330&pathrev=249331
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/views/tabs/tab_strip_unittest.cc?r1=249331&r2=249330&pathrev=249331
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/views/tabs/tab.h?r1=249331&r2=249330&pathrev=249331
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/views/tabs/tab_strip.h?r1=249331&r2=249330&pathrev=249331

Tab close buttons can only be targeted with touch if the whole button is visible

As a result of r246686 landing, tabs can be too easy to close with
touch in stacked tab mode when rect-based targeting is enabled.
This patch changes the behaviour so that:

(1) Hit tests in response to a mouse event will always consider the
    region of the tab close button that is visible.
(2) Hit tests in response to a gesture will only consider the tab
    close button to be a valid target if the entire button is
    visible to the user.

Note that if there is any vertical clipping of the tab
close button, we do not consider the clipped
region to be a part of the button's bounds.

BUG= 338516 , 332334 
TEST=TabStripTest.ClippedTabCloseButton, also manually tested on Windows when tab close buttons are vertically clipped

Review URL: https://codereview.chromium.org/147623004
------------------------------------------------------------------------
Comment 91 by Deleted ...@, Feb 6 2014
Hola anoche pude solucionarlo disminuyendo el tamaño de letra desde win 8 en cuadros de mensaje le puse 10 ya que tengo la pc conectada a un lcd de 42 pulgadas...ya aparece el boton rojo y me deja cerrar.... muchas gracias!!!!!!
Labels: -M-32 M-33
Updating milestone to M33 in response to comment #88. r246686 does fix this issue, but will cause a regression for touch users (see 338516). So I would instead like to request a merge of r249331 into M33. It fixes this issue while at the same time preserves the existing behavior for touch users.

I have verified the fix in:
* 34.0.1827.0 (Official Build 249550) Win canary
* ToT on Win (at 249743)
* ToT on ChromeOS (at 249743)

Impact:
High. Not being able to click/tap tab close buttons for the scenario described in this issue is a major problem and is extremely frustrating to Windows users, so I feel that at least one of r246686 or r249331 needs to be merged into 33. But I am suggesting the latter because otherwise it will be easy for ChromeOS touch users to close a tab by accident if the close button is hidden behind another tab, which is also a very frustrating problem.

Risk:
Fairly low. The fix is a simple one and is entirely contained within a single function. The new code is likely to only have an effect in cases such as the one described here where the tab close button is clipped due to an enlarged message box font size.
Cc: laforge@google.com
Labels: -Pri-2 Pri-1
+laforge@ for consideration of the merge request (see comment #92).
Comment 94 by laforge@google.com, Feb 10 2014
Labels: -Merge-Requested Merge-Approved
Project Member Comment 95 by bugdroid1@chromium.org, Feb 10 2014
Labels: -Merge-Approved merge-merged-1750
------------------------------------------------------------------------
r250156 | tdanderson@google.com | 2014-02-10T18:24:27.545486Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1750/src/chrome/browser/ui/views/tabs/tab.cc?r1=250156&r2=250155&pathrev=250156
   M http://src.chromium.org/viewvc/chrome/branches/1750/src/chrome/browser/ui/views/tabs/tab_strip_unittest.cc?r1=250156&r2=250155&pathrev=250156
   M http://src.chromium.org/viewvc/chrome/branches/1750/src/chrome/browser/ui/views/tabs/tab.h?r1=250156&r2=250155&pathrev=250156
   M http://src.chromium.org/viewvc/chrome/branches/1750/src/chrome/browser/ui/views/tabs/tab_strip.h?r1=250156&r2=250155&pathrev=250156

Merge 249331 "Tab close buttons can only be targeted with touch ..."

This change will resolve  issue 332334  in branch 1750 (M33) and will
also prevent the regression described in  issue 338516 . See
comment 92 in  issue 332334  for a full description.

> Tab close buttons can only be targeted with touch if the whole button is visible
> 
> As a result of r246686 landing, tabs can be too easy to close with
> touch in stacked tab mode when rect-based targeting is enabled.
> This patch changes the behaviour so that:
> 
> (1) Hit tests in response to a mouse event will always consider the
>     region of the tab close button that is visible.
> (2) Hit tests in response to a gesture will only consider the tab
>     close button to be a valid target if the entire button is
>     visible to the user.
> 
> Note that if there is any vertical clipping of the tab
> close button, we do not consider the clipped
> region to be a part of the button's bounds.
> 
> BUG= 338516 , 332334 
> TEST=TabStripTest.ClippedTabCloseButton, also manually tested on Windows when tab close buttons are vertically clipped
> 
> Review URL: https://codereview.chromium.org/147623004

TBR=tdanderson@chromium.org

Review URL: https://codereview.chromium.org/149753007
------------------------------------------------------------------------
Status: Fixed
r250156 merged into branch 1750, so this issue should now be fixed in M33 beta.

QA: please verify on M33 beta as well as on M34 dev channel.
Comment 97 by Deleted ...@, Feb 19 2014
I'm having the same issue...
Comment 98 by Deleted ...@, Feb 19 2014
This problem affects users who have adjusted their computer's DPI settings. I run a high resolution display and have modified the DPI to adjust the scaling. To fix Google Chrome, try this:

-Enter chrome://flags into the browser address/search field
-Locate the option for "Touch Optimized UI"
-Enable this option
-Relaunch Google Chrome

I hope this helps some people out there. Good luck.
#98 suggestion works for me. I also have a non-touch, high res display(2560x1440),DPI adjusted to %175.
It was really disruptive to deal with the buildup of non-closable tabs.
Thankyou for this work around.It helps a great deal!
Cc: -tdander...@chromium.org sky@chromium.org
Owner: tdander...@chromium.org
To everyone experiencing this issue: Version 33 has gone stable, which means that updating to the latest version will fix this problem. You should now be able to close tabs on Windows regardless of your text size preferences.

I'd also like to apologize for the inconvenience this has caused in version 32 and thank everyone for the extra information they provided in this bug report.
Comment 102 Deleted
zx

Comment 104 by Deleted ...@, Jul 23 2014
Similar issue, may be separate. I cannot close tabs on tablet by touch, but can by clicking on x with mouse. Was able to close tabs by touch 2 days ago at max.
OS: Windows 8.1 Pro
Resolution: 1280x800
Version: 36.0.1985.125 m
Extensions: Dictionary of Numbers

If this isn't the issue, where should I put this?
Hi Rick, sorry to hear that you're experiencing problems with touch on Chrome. Given that the issue tracked here was resolved in M33 and your problem is in M36, it's probable that they are separate issues.

The best thing to do here is to file a new bug to track the issue, which you can do by going to crbug.com and then clicking on "New Issue". Be sure to include all of the same information you listed here.
Comment 106 by Deleted ...@, Nov 9 2014
same here, i went to
C:\Users\(USER)\AppData\Local\Google\Chrome SxS\Application
and copied all 40.0.2214.0 files to 40.0.2214.2 and opened chrome , it still uses old version , hey atleast it has maximize and minimize buttons 
@rohithkumarsp: The problem you are experiencing is almost certainly a separate issue from this one, which was resolved in M33. First try updating Chrome to the latest version on your system and see if the problem reproduces. Updates should happen automatically, but if they don't, you can go to chrome://help and click "Check for and apply updates".

If you still see the problem then the best thing to do would be file a feedback report. This can be done from the hot dog menu > help > report an issue... or by using the keyboard shortcut Alt+Shift+I.

Also, from your description it seems as though you may be having problems with the browser window's close button instead of the close buttons on individual tabs. Please be sure to specify this in your feedback report description.
Comment 108 by Deleted ...@, Jan 28 2015
I have same problem.  I can not close tabs or change tabs. I also can not open the settings menu at the far right.  It highlights the button but will not select.

I just did an update.  I have problems with two computers both are:
Ubuntu 64bit 14.04
Both are touchscreen only.
re #108: this issue with touchscreen on linux is being addressed in  issue 443667 
Comment 110 Deleted
Same here with the last Chrome version of yesterday (Is not chromium, I mean the stable version of the main website), MacOS X
Labels: Restrict-AddIssueComment-EditIssue
kernel.no.found@, the issue tracked here is a specific Windows-only problem that was resolved in M33. For the issue you're experiencing, the best thing to do is to file a feedback report. This can be done from the Chrome menu > Help > Report an issue.

Any other user who is experiencing an issue related to tab close buttons should also file a feedback report so that it can be properly tracked separately.
Sign in to add a comment