New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 8 users

Issue metadata

Status: Fixed
Owner:
Closed: Mar 2011
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

square block characters display if local() font used from @font-face

Reported by paul.ir...@gmail.com, Jan 26 2010

Issue description

Chrome Version       : unknown

This is not known to also fail in Safari.

What steps will reproduce the problem?
1. use a local reference in the @font-face declaration like local('Grablau 
Web')
2. have the font installed locally
3. view the page with that @font-face declaration

What is the expected result?
Chrome uses the local font, doesnt download the remote font, and displays 
the text using the font.


What happens instead?
Boxes! 
screenshot: http://skitch.com/grahamb/n1g5p/grahamballantyne.com-the-ride-
to-conquer-cancer

 
Labels: -Area-Undefined Area-WebKit
Status: Assigned
@paul.irish
Can you please let me know what platform did you use? 

Paul filed this based on something I tweeted. I've encountered this on OS X (Chrome 4.0.249.30 and 
4.0.302.2 dev).
The font in the screenshot is District Thin (http://www.fontsquirrel.com/fonts/District-Thin). The CSS 
is:

@font-face {
     font-family: 'AlexandriaFLFBold';
     src: url('../fonts/AlexandriaFLF-Bold.eot');
     src: local('AlexandriaFLF Bold'), local('AlexandriaFLF-Bold'), url('../fonts/AlexandriaFLF-Bold.woff') 
format('woff'), url('../fonts/AlexandriaFLF-Bold.otf') format('opentype'), url('../fonts/AlexandriaFLF-
Bold.svg#AlexandriaFLF-Bold') format('svg');
} 

If you have the font installed locally, it displays boxes as in the earlier sceenshot. Remove the local() 
references to force the font to download and it displays normally.

Chrome 4.0.249.78 on Windows XP with the OpenType version of the font installed works with the 
local() references. I haven't tried the TrueType version under windows.

You can see this in-situ at http://grahamballantyne.com/ridetoconquercancer with the text in the red 
box. The fonts are in http://grahamballantyne.com/ridetoconquercancer/fonts if you want to install 
locally for testing.


Comment 3 by Deleted ...@, Feb 2 2010

There is a problem with the names in the name table of the font file itself. The 
Full Font name is not "AlexandriaFLF Bold" it's "AlexandriaFLF-Bold", the same as 
the Postscript name being used in the second local() descriptor-value pair.
It may not be the cause of Chrome's behavior but it might hold a clue. In any event, 
the TTF should be fixed so that the Full Font Name is the family name 
(AlexandriaFLF) plus the style name (Bold) with a space in between. The Postscript 
name needs to remain the same. Spaces are not allowed.
Have these names been tried in a  normal font stack outside of @font-face?
@graham.ballantyne

Does this issue still reproduce on your end? I just tried to reproduce this with Google 
Chrome for Mac 5.0.307.5 (official release) + Mac OS X 10.5.8, but I had no luck.

Labels: OS-Mac
Yes, it is still occurring on 5.0.307.5 dev & OS X 10.6.2
I see. Will retry with Snow Leopard. Thanks.

Comment 8 by Deleted ...@, Feb 15 2010

I believe this is not a @font-face issue. It seems to occur with a "normal" font stack as well. Here's my theory: If a 
font is activated outside the normal "Mac" way then it doesn't work. For instance I just visited a page that spec'd 
Calibri in the font stack. I have that font installed and activated but all I get are boxes. 

So here's the kicker: Calibri was activated on my system by FontXplorer, not in one of the system's font folders.

I don't know if this is limited to FontXplorer but I can confirm that it does happen with at least this application. 
I've had this happen a multiple of times on various sites. Hope this helps.
@fonthead,
Thanks for the information.

I'm still having a hard time getting Snow Leopard Mac for some reasons. Can someone in 
Chromium team who is familiar with Mac font handling and has a Snow Leopard box work on 
this issue?
And @graham.ballantyne,

> If you have the font installed locally, it displays boxes as in the earlier sceenshot.
Please let me know how did you install the font.


Comment 11 by karen@chromium.org, Feb 16 2010

Labels: Mstone-X kglater

Comment 12 by Deleted ...@, Mar 8 2010

Confirming here, on Google Chrome 5.0.307.11 beta. If you have the fonts active
locally (here, via FontExplorerX) @font-face is spit out similar to the earlier
poster's screenshot.

Comment 13 by Deleted ...@, Mar 24 2010

This exact thing happens to me as well. Running 5.0.356.2 dev build.
Fec7R.ChromeError.png
218 KB View Download

Comment 14 by Deleted ...@, May 10 2010

Disable user fonts (assume the computer has it). 
Font book -> have all fonts for Computer -> Disable user fonts
I'm seeing an A in a square in quite a few websites, and also in Gmail rich text messages.

I'm using Google Chrome 5.0.375.99 beta on the Mac.
Screen shot 2010-07-12 at 20.07.01.png
79.1 KB View Download

Comment 17 by Deleted ...@, Jul 13 2010

i agreed with james .. i also using Google Chrome 5.0.375.99 having the same issue
Screen shot 2010-07-14 at 12.40.59 AM.png
654 KB View Download
I'm fairly sure this issue has been ironed out in the upcoming dev channel release.
It was primarily tracked in  Issue 29729 .
Watch http://googlechromereleases.blogspot.com/ and in the next dev channel release the fix there should be present.

Comment 19 by Deleted ...@, Jul 19 2010

thanks paul, ive use the dev version .. seem its been fixed. :) 

Comment 21 by bashi@chromium.org, Feb 25 2011

It seems that this issue was fixed, right? If so, I'd like to close this issue.
Status: Fixed
It seems to be fixed.
Project Member

Comment 23 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 24 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit Cr-Content
Project Member

Comment 25 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment