New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 328761 link

Starred by 22 users

Issue metadata

Status: Fixed
Owner:
Email to this user bounced
Closed: Jan 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 1
Type: Bug



Sign in to add a comment

Black flashes on Verizon Galaxy S4

Project Member Reported by aelias@chromium.org, Dec 16 2013

Issue description

Version: 31.0.1650.59 [also reproducible on M32 beta]
OS: Android 4.3.0 (JB MR2) JSS15J.I545VRUEMJ7
Device: Qualcomm Galaxy S4 SCH-I545

chrome://gpu info and screenshots attached.

A friend of mine wrote me the following bug report: "Almost every time when resuming Chrome the screen goes black. Open a web page, press home then press the Chrome icon. The content of the tab will show for a fraction of a second, then the content of the tab becomes black for less than 1 second then the content appears again.

Something similar happens with the tab selection screen: the area where the tabs should be is black. This stays that way until I press and start moving my finger. Then the tab selection screen is rendered. To reproduce this, open the tab selection screen, press the power button to turn off the screen, then power to turn on the screen. Enter the lock pattern to find the tab view content black.

Occasionally, only one square of ~200 px by 200 px of a new tab is rendered and the rest is black. After a press and move, the whole tab renders.

There are a lot of other very fast flickering to black that are not reproducible.

All these issues started with the latest release (31.0.1650.59) and were not present before. The issues happen with the current Chrome Beta as well."



Additionally, on  http://crbug.com/288238  melodychu@ from Conops reported "This issue is being reported by users on: 31.0.1650.59 on many devices (including the Galaxy series, HTC One). Switching tabs will cause the screen to flicker, it also seems to occur when users are on the tab switcher view."  This sounds like the same problem.  However, I couldn't reproduce on an HTC One Google Play Edition running KitKat; it might only reproduce on other OS versions.
 
chrome-gpu-galaxys4.html
11.3 KB View Download
screenshot swipe left on first tab's url bar.png
40.2 KB View Download
screenshot one block only.png
44.4 KB View Download
screenshot in a tab, press home then press chrome icon.png
30.4 KB View Download
screenshot build info.png
139 KB View Download
Labels: M-32

Comment 2 by klo...@chromium.org, Dec 16 2013

Hmm, this seems the issue reported in https://b.corp.google.com/issue?id=10937655. We were believing the issue not affecting JB MR2 drivers. It seems it is not true any more.

Comment 3 by aelias@chromium.org, Dec 18 2013

The reason we didn't observe it in our internal testing is that there are multiple Qualcomm Galaxy S4s.  This bug reproduces on the SCH-I545, but our test device is a GT-I9505G.  We should buy a SCH-I545 and add it to our testing rotation.  It looks like it's the Verizon variant of the S4.

Comment 4 by klobag@google.com, Dec 18 2013

Have we tried the workaround suggested in https://b.corp.google.com/issue?id=10937655#ISSUE_HistoryHeader24? 

Comment 5 by k...@google.com, Jan 7 2014

Updates here?
Labels: -M-31
Summary: Black flashes on Verizon Galaxy S4 (was: [M31] Black flashes on Qualcomm Galaxy S4)
We're blocked on trying to find a Verizon Galaxy S4.  We'll try workarounds once we have one.
I think this problem is not just for the S4. I can see the same problem on the Moto G of my wife. And many oters reporting that the problem (link below) is present on the Moto X and many other device. Maybe you guys can try it with those. Easy to reproduce if you open many heavy sites like verge.com and switching between tabs.

http://productforums.google.com/forum/#!topic/chrome/D34433Gz1dY
The problem happens on Moto G/X with KK.

Comment 10 by feng@chromium.org, Jan 8 2014

Cc: feng@chromium.org

Comment 11 by feng@chromium.org, Jan 8 2014

Re#7, it is reproducible on M32 on my Moto X (verizon).
I got a Moto G with KitKat and can repro with M31 and M32 builds, but cannot repro with ToT@243567.

Comment 13 by caspe...@gmail.com, Jan 13 2014

Can confirm this issue on my Nexus 7 2013 (flo, 4.4.2 stock not rooted)
This problem occurs for my Nexus 5 as well.

Comment 15 by mha...@gmail.com, Jan 13 2014

I have the same issue on my Galaxy S4 i337m, running Android 4.3. Carrier is Bell Canada.
Seeing the same issue, not consistently when click on tab switcher when both normal & and incognito tabs are opened on Note 3/N9005 /JS15J.

Comment 17 by Deleted ...@, Jan 17 2014

Same issue on my S3

Version: 31.0.1650.59
OS: Android 4.3 JSS15J.I535VRUCML1
Device: Verizon Samsung Galaxy S3 SCH-I535
Labels: -M-32 M-33
I wasn't able to reproduce on trunk either. It might be because there is something else happening (I see a noticeable transition from low to high res going back to the app) that cause more updates after resume.

I sync'd my tree back to r241080 and can reproduce but the driver bug workaround suggested by Qualcomm does not seem to help.
Forgot to mention: As expected the problem goes away with ubercomp though (the incomplete rendering bug has to do with the intermediate transport FBO).
Project Member

Comment 22 by bugdroid1@chromium.org, Jan 17 2014

------------------------------------------------------------------------
r245660 | sievers@chromium.org | 2014-01-17T23:45:41.321060Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/image_transport_factory_android.cc?r1=245660&r2=245659&pathrev=245660

Android: Shallow instead of deep flush after texture consume

The deep flush is not necessary anymore since we don't modify texture
state anymore and it looks like it might avoid a driver bug with
 incomplete draws.

BUG= 328761 
R=piman@chromium.org

Review URL: https://codereview.chromium.org/142003006
------------------------------------------------------------------------
Labels: Merge-Requested
Status: Fixed
Requesting merge rightaway, since
- the problem does not reproduce on trunk anymore
- the change is a rather harmless Android-only oneliner

Will be useful to find out asap on the branch if this fixes it across devices.

Comment 24 by laforge@google.com, Jan 18 2014

Labels: -Merge-Requested Merge-Approved
Appreciate the background, Approved for M33 (1750)
Project Member

Comment 25 by bugdroid1@chromium.org, Jan 21 2014

Labels: -Merge-Approved merge-merged-1750
------------------------------------------------------------------------
r246083 | sievers@google.com | 2014-01-21T19:01:08.286013Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1750/src/content/browser/renderer_host/image_transport_factory_android.cc?r1=246083&r2=246082&pathrev=246083

Merge 245660 "Android: Shallow instead of deep flush after textu..."

> Android: Shallow instead of deep flush after texture consume
> 
> The deep flush is not necessary anymore since we don't modify texture
> state anymore and it looks like it might avoid a driver bug with
>  incomplete draws.
> 
> BUG= 328761 
> R=piman@chromium.org
> 
> Review URL: https://codereview.chromium.org/142003006

TBR=sievers@chromium.org

Review URL: https://codereview.chromium.org/141033004
------------------------------------------------------------------------

Comment 26 by misti...@gmail.com, Jan 24 2014

This happens on T-Mobile's Samsung Galaxy S4 variant too for a long time, so not just limited to Verizon's.
If you still see it in the latest Chrome beta, 33.0.1750.48, please update here with the device model and android OS model.

Comment 28 by Deleted ...@, Jan 28 2014

This happens for me on a GT-I9505, on android 4.3 with whatever extensions Samsung adds onto it.

Comment 29 by Deleted ...@, Jan 28 2014

Same for me Gt-I9505 on andy 4.3
Can confirm that this happens as well on AT&T Samsung Galaxy S4 Active (SGH-I537), but only since updating From 4.2.2 to 4.3
Running Chrome 32.0.1700.99
I can reproduce this running Chrome 32.0.1700.99 on my dutch Samsung Galaxy Note 3 (model SM-N9005) running the OTA-updated Android 4.4.2, build KOT49H.N009XXUENA6.

I never had the problem upto a certain date, back then using out of the box Android 4.3, with auto updating Chrome. I never had the problem before.

Reproducing:
Use switcher to go back to browser instance. For a moment website content is rendered, but in ~150ms the tab contents suddenly becomes black.

Findings:
As mentioned in a topic regarding a (this?) chrome black tab bug: https://productforums.google.com/forum/#!category-topic/chrome/DmSUGZKFgoE%5B151-175-false%5D
I have tried disabling chrome://flags/#delegated-renderer but that did not fix my problem so i reverted that setting to default. 
However .. now the black is only flashed for ~150ms, after which the page is rendered again.

Sign in to add a comment