Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 12 users
Status: WontFix
Owner:
Closed: Jan 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug
M32



Sign in to add a comment
Chrome conflict with ccleaner (ccleaner does not support Beta versions of Chrome)
Project Member Reported by melodychu@chromium.org, Dec 9 2013 Back to list
Potential conflict with ccleaner - this seems to corrupt or wipe Chrome user data in some way, although users are describing symptoms differently. 

Quote: Just to inform you that after updating chrome to "32.0.1700.41 m aura" version, ccleaner deletes all chrome settings and all chrome extensions. i've never had such an issue with ccleaner and chrome, which i both use for several years. please fix those problems asap :)

Quote: running CCleaner destroyed (NOT deleted) the Google Chrome user's profile. Chrome reported the problem with the user's profile after launching the Browser (can't remember exactly what chrome has reported) and thereafter a new user's profile had been created automatically and the old (destroyed one) deleted -> all user data lost. Lucky, that I had a backup.

Could be an external dependency, as Ccleaner apparently does not support Beta versions:
http://forum.piriform.com/index.php?showtopic=39964&p=242743
 
Cc: vkomonduri@chromium.org mbollu@chromium.org
Labels: M32
@Mrudula --> Can you please try to reproduce the bug?
Labels: -Restrict-View-EditIssue Hotlist-ConOps
Comment 3 Deleted
Comment 4 by mbollu@chromium.org, Dec 10 2013
Reproducible on Chrome 32.0.1700.41 - Win7. See attachment. Restarting chrome gives message "Your preferences file is corrupt or invalid". Unchecking "Internet History" and "Last Download Location" for Chrome doesn't remove user preferences.

Good Build: 31.0.1650.63
Bad Build: 32.0.1700.39

Checking bisect info..
Comment 5 by mbollu@chromium.org, Dec 10 2013
Please ignore above Good & Bad range.

So far found the range as
Good Build: 32.0.1700.19 
Bad Build: 32.0.1700.39.

Tomorrow morning I will check and update the bisect.
Comment 6 by mbollu@chromium.org, Dec 11 2013
Bisect using chromium builds and tried to find closer range between 232870 and 239419

Good version: 236805
Bad version: 236823

Narrow bisect:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=%2Ftrunk%2Fsrc&range=236805%3A236823&mode=html

Blink Roll: 162541:162549

http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog_blink.html?url=/trunk&range=162542:162549&mode=html
Comment 7 by kareng@google.com, Dec 11 2013
Owner: gab@chromium.org
Status: Assigned
gab this is due to 238122
Comment 8 by gab@chromium.org, Dec 11 2013
Cc: robertshield@chromium.org
Labels: Needs-Feedback
Status: ExternalDependency
Err... all this CL does is write a few empty list/dicts instead of pruning them out (a simple version of https://codereview.chromium.org/81183005 since I wanted to merge it up).

Why would CCleaner choke on this?! Seems like a bad bug on their end; can we contact them about it? This is the way Chrome will work going forward (no pruning of empty list/dict) for all preferences.

FWIW, playing with Chrome's Preferences directly isn't supported and we shouldn't encourage anybody to do so; they are meant solely for Chrome's internal storage, not as a public API into Chrome's settings. And the WORST thing such a tool can do if it detects a change with the Preferences file which it doesn't support is to delete the profile... this is not a Chrome bug, it's a very bad CCleaner bug...

Please ping me if you require more details.
Comment 9 by gab@chromium.org, Dec 11 2013
So, here is the bug on their end:

They parse our entire Preferences file, strip out the "dns_prefetching" pref and rewrite it.

When re-writing there are 2 differences (besides the removed "dns_prefetching" pref):
1) They use a JSON indent of 4 instead of 3 (that's fine, still valid json)
2) For empty lists they write nothing instead of '[  ]'.

i.e., the pinned_tabs entry goes from
   "pinned_tabs": [  ],
to
    "pinned_tabs": ,

This is invalid JSON and this is what Chrome chokes on.

Looks like a bug in their JSON encoder when faced with empty lists.

FWIW, I'm okay with them clearing out "dns_prefetching" for privacy reasons (which is what the tool appears to be all about), but they could just delete that entry without decoding and re-encoding the entire pref file..

Also, apologies for my earlier statement prior to looking deeper into this: they do NOT delete the profile, Chrome simply starts with a fresh set of Preferences (saving the old one at %localappdata%\Google\Chrome\User Data\YOUR_PROFILE\Preferences.bad) upon being unable to load the existing Preferences.

A workaround for users who got their prefs clobbered is to (while chrome is closed) edit Preferences.bad -- replacing instances of ": ," with ": []," -- and replace the existing Preferences file with this fixed file which should now be able to load.

Cheers,
Gab
Comment 10 by grt@chromium.org, Dec 11 2013
i just tried this out. in a fairly fresh profile, i found that ccleaner replaces:
  "pinned_tabs": [  ],
with:
  "pinned_tabs": ,
which isn't valid JSON.
Comment 11 by grt@chromium.org, Dec 11 2013
Hey, Gab already said what I said! :-)
Comment 12 by gab@chromium.org, Dec 11 2013
Highlighting the workaround I mentioned in #9 above:

1) Close Chrome
2) Open %localappdata%\Google\Chrome\User Data\YOUR_PROFILE\Preferences.bad
3) Replace ": ," with ": [],"
4) Save as %localappdata%\Google\Chrome\User Data\YOUR_PROFILE\Preferences
5) Relaunch Chrome with your old settings.
Was this fixed? Doesn't look like it has been reported lately. Wondering if we can update status of the bug. Thanks!
Was this fixed? Doesn't look like it has been reported lately. Wondering if we can update status of the bug. Thanks!
Comment 15 by gab@chromium.org, Jan 21 2014
Status: WontFix
Summary: Chrome conflict with ccleaner (ccleaner does not support Beta versions of Chrome) (was: Aura conflict with ccleaner (ccleaner does not support Beta versions of Chrome))
Just tested, ccleaner appears to have fixed the bug on their end.

Nothing to fix in Chrome; marking as WontFix for us.

(and changing title FWIW, this had nothing to do with Aura)

Cheers,
Gab
Labels: -Hotlist-ConOps
Comment 17 by Deleted ...@, Jan 23 2014
Thank you for that - CCCleaner was the culprit. I had recently updated it. Downloaded the latest version and it now leaves Chrome alone.
Comment 18 by Deleted ...@, Jan 27 2014
Hi.

This workaround:

===
1) Close Chrome
2) Open %localappdata%\Google\Chrome\User Data\YOUR_PROFILE\Preferences.bad
3) Replace ": ," with ": [],"
4) Save as %localappdata%\Google\Chrome\User Data\YOUR_PROFILE\Preferences
5) Relaunch Chrome with your old settings.
===

didn't work for me.
Chrome launches succesfully, but there is no extensions (i mean, they are not installed, i can't found their data - i see only their names in the extension manager).

What should i do? 
There was important data for me, and seems like i have no backup of AppData folder :(
Comment 19 by gab@chromium.org, Jan 27 2014
If you'd been signed in to Chrome, then the sync server would have a backup of your data; otherwise if a third-party program deletes some of your settings (intentionally or by accident) there is no magic for Chrome to recover it out of thin air :(.

Third-party modification of Chrome's Preferences is not a supported feature of Chrome, any version of Chrome can change how the Preferences system works and inadvertently break such tools that attempt to modify Preferences.

I suggest you either sign in to Chrome or make a backup of "%localappdata%\Google\Chrome\User Data" before using such tools.

Best of luck,
Gab
Comment 20 by Deleted ...@, Jan 27 2014
Thanks for the answer.

So, what do we have: CCleaner damaged my Preferences file, then i reloaded Chrome, and then browser overwrote all its internal "preferences" file structure, and left a copy only of "preferences.bad".

As for the Chrome, it is an expected behavior in such conditions (damaged config file).
As for the CCleaner - i had already uninstall this p* of s* from my computer, and will try to do my best to promote it as a software you can't trust.

Shame on CCleaner developers - user should not take care of such things as "a bug in chrome JSON encoder when faced with empty lists."

P.S.
Spent all this day recovering my data. 
Just included a folder "Google\Chrome\" to my backup list.
Comment 21 by Deleted ...@, Mar 18 2014
Hello, replacing ": ," with ": []," did not do it for me. Are there any other things I can try? I'm comparing the my old file with the new one through Total Commander. Thanks.

Comment 22 by Deleted ...@, Mar 18 2014
By the way, I've ran it through a few FSON verifier and this JSON editor and it is supposed to be valid: http://www.jsoneditoronline.org/
Comment 23 by gab@chromium.org, Mar 18 2014
If you send me your Preferences file (here or via email) I can see what is tripping Chrome.

Was this as a result of running CCleaner?

Cheers,
Gab
Comment 24 by jsco...@gmail.com, May 23 2014
FYI I just updated CC to 4.14 and ran without affecting Chrome preferences.  My older version, 4.04, did corrupt my preferences file by not including '[ ]'.  Thank you for this thread.  Solved a major headache.

Scott
Sign in to add a comment