New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 325919 link

Starred by 2 users

Issue metadata

Status: Fixed
Owner:
User never visited
Closed: Dec 2013
Cc:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

First time in each Chrome session a non-default profile is selected in Ash it opens in desktop instead of Win8

Reported by wiltzius@chromium.org, Dec 4 2013

Issue description

Chrome Version       : 32.0.1700.39
OS Version: 6.2 (Windows 8)

0. Make sure you have at least two profiles
1. Open up process explorer and make sure all Chrome processes are dead (important, this only happens the first time)
2. Open a chrome window in Ash/Metro
3. Go to the profile switcher in the upper left corner of the window, try switching profiles

The new profile opens in Desktop instead of Metro. Restarting Chrome on the desktop and then again into Win8 mode and it works as expected.

Shrikant / Trent can you make sure this is fixed in M-33 by the changes that've gone in? I'm not sure this case is covered or not.
 
Ah, good find. It should be fixed already for m33.

I had theorized that this would be an issue, but each time I tried to repro it seemed to work correctly. The problem is in profile_window.cc, and I have an uncommitted patch (with a TODO, not a fix) here:

https://codereview.chromium.org/72303002/diff/60001/chrome/browser/profiles/profile_window.cc#newcode#120

Instead of that CL, I went with r235906 since this was just one of the many moles to whack.

I just tried to repro in 33.0.1726.0 dev-m and it seems fixed -- I could only get browsers in Ash.

However, if the policy is ever relaxed to allow browsers both in Metro and Desktop, then this will need to be addressed. Along with things like the devtools corner case in  Issue 315894 .
Status: Fixed
OK let's punt then for M32, the intersection of Ash and multi-profile users is small; most of them will likely hit this but I don't think it'll be that big of a deal. Glad it's fixed in M33. Thanks!
Note that this is actually a bit worse than I realized, because you need to actually relaunch Chrome into desktop mode and then again into Metro mode before the issue is resolved. Still OK for M32 I think.
This might be worth a known issue though. I'll contact ConOps.

Sign in to add a comment