New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 236298
Owner: ----
Closed: Dec 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 325734: Web fonts on pages loaded off-screen are ignored

Reported by kwpol...@gmail.com, Dec 4 2013

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1712.4 Safari/537.36

Example URL:
http://trello.com/ http://github.com/

Steps to reproduce the problem:
1. Load a page with webfonts off-screen (restore tabs at browser startup, middle-click, etc.)
2. Notice the webfonts don’t load.

What is the expected behavior?
Webfonts load and show properly.

What went wrong?
Webfonts are not loaded, and are instead replaced with a different font family (the one later in CSS).

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? Yes Chrome older than 32 (or so?)

Does this work in other browsers? Yes Firefox 25

Chrome version: 33.0.1712.4  Channel: dev
OS Version: Arch Linux
Flash Version: Shockwave Flash 11.9 r900

Selecting or hovering the characters can sometimes fix the problem.  Doesn’t happen with on-screen loading (the user is watching the page load).
 

Comment 1 by tkent@chromium.org, Dec 6 2013

Labels: -Cr-Content Cr-Blink-WebFonts

Comment 2 by richard0...@gmail.com, Dec 6 2013

I'm sorry, for the time replying I cannot reproduce your problem through middle clicking the links, but this issue sometimes happens to me, too.

I have a problem similar to yours, maybe related: load a page and put it background and later return, fonts of some text on the page will fallback to (the default) DejaVu Sans. Doesn't happen every time, but still quite often.

Two screenshots attached. One is http://wiki.cyanogenmod.org/w/Odin_Info and the other is http://wiki.cyanogenmod.org/w/Yuga_Info
DeepinScreenshot20131206233324.png
77.1 KB View Download
DeepinScreenshot20131206233345.png
79.3 KB View Download

Comment 3 by kwpol...@gmail.com, Dec 6 2013

I’ve also seen similar behavior.  Screenshot from https://github.com/getnikola/nikola/pull/928/files.
ghbug1.png
147 KB View Download

Comment 4 by ksakamoto@chromium.org, Dec 13 2013

Mergedinto: 236298
Status: Duplicate
Looks like the  bug 236298 . Please reopen if it's not related.

Sign in to add a comment