New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 32557 link

Starred by 4 users

Issue metadata

Status: Verified
Owner:
Email to this user bounced
Closed: Feb 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Resizing window overlaps the empty BMB description text with "Other Bookmarks"

Reported by ismail@chromium.org, Jan 18 2010

Issue description

Platform:
  Hostname: testings-macbook-pro-15.local
  Mac OS X Version 10.6.2 (Build 10C540)
  Processor: 2 Intel 2.33 GHz
  RAM: 2048 MB

Chrome:
  Chrome version: 4.0.295.0 r35884  <<<Release>>>
  QuickTime Player: <unknown>
  QuickTime PlayerX: 90.3.1
  Flash Player: 10.0.42.34

Precondition: Make sure we have no bookmarks showing in the bar (The text "For quick access, 
place your bookkmarks here in the bookmarks bar." should be showing.)

What steps will reproduce the problem?
1. Resize the Window 

Actual: The text "For quick access, place your bookmarks here in the bookmarks bar." overlaps 
with "Other Bookmarks" folder. ( Screen shot attached )

Expected: Overlap should not happen, add (....) and shorten to the text on resize.

Note: Other platforms on resizing, it doesn't overlap.

 
BMB_ResizedWindow.png
165 KB View Download

Comment 1 by krisr@chromium.org, Jan 19 2010

Labels: Mstone-5
Status: Assigned
Labels: -Area-Feature Area-UI

Comment 4 by karen@chromium.org, Mar 9 2010

Labels: Mstone-X wasm5kg

Comment 5 by jrg@chromium.org, May 24 2010

To mrossetti by request.

Comment 6 by bugdro...@gmail.com, May 26 2010

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=48316 

------------------------------------------------------------------------
r48316 | mrossetti@chromium.org | 2010-05-26 13:09:18 -0700 (Wed, 26 May 2010) | 13 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/app/nibs/BookmarkBar.xib?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/bookmark_bar_controller.h?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/bookmark_bar_controller.mm?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/bookmark_bar_controller_unittest.mm?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/bookmark_bar_view.h?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/bookmark_bar_view.mm?r1=48316&r2=48315
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/cocoa/hyperlink_button_cell.mm?r1=48316&r2=48315

Resize the "For quick access..." and "Import bookmarks now..." components shown in the bookmark bar when there are no bookmarks in the bar, when the window resizes. Show ellipses when each gets trimmed and hide them when they get too small.

BookmarkBar.xib changes: Connect the "Import bookmarks now..." button up to the importBookmarksButton_ outlet in the BookmarkBarView.

BUG= 32557 
TEST=1) Start up a browser with no bookmarks on the bookmarks bar.
2) Verify that the "For quick access..." and "Import bookmarks now..." test fully shows.
3) Start shrinking the width of the browser window.
4) Verify that the "Import bookmarks now..." text is shrunk/clipped and finally disappears as the window gets narrower.
5) Continue shrinking the width and verify that the "For quick access..." text is shrunk/clipped with ellipses as the window gets narrower.
6) Grow the window and verify that the "For quick access..." reappears and then the "Import book now..." does.

Review URL: http://codereview.chromium.org/2243002
------------------------------------------------------------------------

It seems, that the resizing issue is fixed... but it still happen while a cold-start. See the enclosed screenshot.

11.0.661.0 (73925) on Mac OS 10.6.6.
overlap.png
115 KB View Download
I had a this issue, or another that looked much like it. This occured when I dragged a website icon to the bookmarks bar. I've included a screenshot. Take note that, although it isn't apparent in the screenshot, this isn't due to the window being too narrow. The browser was maximized so there was more than enough place for bookmarks and the other bookmark buttons.

Using Chrome 11.0.672.2 (Build officiel 75134) dev
overlap.png
36.9 KB View Download

Comment 9 by meh...@chromium.org, Feb 19 2011

@tristanl...: Your bug is  issue 73137 .
Status: Fixed
Can't repro anymore, not even as described in comment 7. I think I fixed this some time last year.

Marking as Fixed. Please re-open if you're still seeing this.
Status: Verified
Verified fixed with Chrome 19.0.1046.0 canary on Mac OS 10.6.8.

(Issue from comment 7 is also fixed - thanks.)
Bildschirmfoto 2012-02-19 um 11.09.31.png
78.4 KB View Download
Project Member

Comment 12 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 13 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-UI Cr-UI

Sign in to add a comment