New issue
Advanced search Search tips
Starred by 49 users

Issue metadata

Status: Duplicate
Merged: issue 236298
Owner: ----
Closed: Nov 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: ----



Sign in to add a comment
link

Issue 323876: Wikipedia entries font changing when switching between tabs in Chrome?

Reported by jhgpor...@gmail.com, Nov 27 2013

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Example URL:

Steps to reproduce the problem:
Try and load several Wikipedia entries in tabs and then switch between them and see what happens

What is the expected behavior?
Wikipedia pages displaying correctly!

What went wrong?
When I switch between tabs (and sometimes when I'm scrolling down pages), the font in sections of Wikipedia pages switches for a split second from normal to something resembling Times New Roman, and only changes back to normal when I move my mouse. Why is this, and what can be done to fix it? It didn't used to do this! Tried re-setting my Chrome fonts to default, hasn't seemed to help. My Chrome is Version 31.0.1650.57. My system is OS X 10.7.5.

Does it occur on multiple sites: No

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? N/A 

Chrome version: 31.0.1650.57  Channel: stable
OS Version: OS X 10.7.5
Flash Version: Shockwave Flash 11.9 r900
 

Comment 1 by meh...@chromium.org, Nov 28 2013

Labels: -Type-Compat Cr-Blink

Comment 2 by goo...@mspacek.mm.st, Nov 28 2013

I can confirm basically the same behaviour, in my case on Xubuntu 12.10 (amd64), with the same version of Google Chrome: 31.0.1650.57

Some sections of text (usually section headers or other non-body text) randomly change their usual font (FreeSans is my default) to some other font that's too big to fit in the space (looks like it might be Ubuntu's sans-serif font, which seems very similar to Bitstream Vera Sans). It's very transient, but usually if I refresh the page, or move the mouse, or scroll it offscreen and then back, then it disappears.

The other thing I've noticed is that sometimes descenders, in the normal font, are clipped a tiny bit, like they don't have enough space.

All of this only started happening fairly recently in Chrome, within the last month or so.

I've never seen this on any other website, and I've never seen it in Firefox.

In Chrome settings, I have font size set to "Medium", default page zoom 125%, and standard and sans-serif fonts set to FreeSans. The size in that dialog is set to 16. I tend to view wikipedia at 175% zoom.

It's hard to induce the behaviour, but I managed to take a screenshot (attached). The section title and the article contents links show the replacement font.
chrome_font_problem2.png
211 KB View Download

Comment 3 by jhgpor...@gmail.com, Nov 28 2013

That's exactly what's happening to me. I too have never seen it on any website other than Wikipedia. It only started for me in the last week or so when I updated my Chrome. This NEVER happened before I updated the browser. Tried re-setting my Chrome fonts to default, hasn't seemed to help. Wish there was a fix for it, it's more an aesthetic problem than anything else but it is annoying! Several people on the Google Chrome Forum have reported the same thing as well. Wish there was a way a report could be sent on this to the Google tech people

Comment 4 by dglazkov@chromium.org, Nov 28 2013

Mergedinto: 236298
Status: Duplicate

Comment 5 by Deleted ...@, Dec 2 2013

I have been seeing this behavior on Wikipedia for a few weeks, but I also just started seeing this on a site I'm developing. We are using a web-font that falls back to Calibri and then sans-serif. When this behavior happens, Chrome seems to completely ignore all of these and change to Times (the system default, I believe).

Comment 6 by skoc...@gmail.com, Dec 10 2013

Same happens here! When scrolling the Wikipedia page font suddenly switches to something that resembles "Times' which makes it look ugly. Compare the both attached screenshots.
bad_font.png
636 KB View Download
right_font.png
598 KB View Download

Comment 7 by skoc...@gmail.com, Dec 10 2013

Specs for the above:

OS X 10.9
Chrome 31.0.1650.63

Comment 8 by fuzzycas...@gmail.com, Dec 12 2013

I'm also experiencing this issue regularly. OS X 10.9, Chrome 31.0.1650.63. In addition to Wikipedia, I've seen the behavior on HN (news.ycombinator.com)

Comment 9 by ske...@gmail.com, Dec 12 2013

I've been noticing this recently as well, most often when switching tabs and mostly with WIkipedia and Feedly.  When switching from one tab to a Wikipedia/Feedly tab, the fonts appear as Times (or something similar) and after a second or two change to what they are supposed to be.

OSX 10.9
Chrome Version 31.0.1650.57

Comment 10 by Deleted ...@, Dec 17 2013

I've noticed the very same behaviour when for some weeks on Mac OS X 10.8.5 with Chrome 31.0.1650.63 (and possibly earlier version). I've only noticed this behaviour on Wikipedia, when switching tabs.

Comment 11 by micahbuc...@gmail.com, Dec 22 2013

I have a similar problem quite often on OS X 10.7.5 / Chrome  31.0.1650.63.
As others have mentioned Wikipedia headings are a common culprit - 

Also, the majority of text in monospace font (such as code example blocks) I see in pages are rendered in Times at first. Sometimes upon clicking or scrolling they revert to a monospaced font, sometimes they do not.

Comment 12 by jhgpor...@gmail.com, Dec 22 2013

Hope there's a fix soon

Comment 13 by michael....@gmail.com, Dec 29 2013

Same on 10.9.1, Chrome Version 31.0.1650.63

Comment 14 by leslie.o...@gmail.com, Dec 29 2013

Experiencing the same here on Mac OS X 10.9, Chrome 31.0.1650.63

Comment 15 Deleted

Comment 16 by pleasedo...@gmail.com, Jan 9 2014

this happens to me too. i've noticed it happening on reddit too. I've definitely seen some monospace text inside code tags replaced with non-monospace serif text. other sites as well that i can't think of atm.

Mac OS X 10.9.1
Chrome 31.0.1650.63

Comment 17 by kakty3.m...@gmail.com, Jan 11 2014

Same on 10.9.1, Chrome Beta 32.0.1700.72

Comment 18 by Deleted ...@, Jan 12 2014

I am also getting the exact issue when I surf wikipedia on my computer.
OSX: 10.9.1
Chrome: Version 31.0.1650.63

Comment 19 by jhgpor...@gmail.com, Jan 14 2014

Looks like it still isn't fixed in the latest version of Chrome, 32.0.1700.77

Comment 20 by st...@checkout51.com, Jan 15 2014

Yup, I'm also still getting this glitch.

Comment 21 by jhgpor...@gmail.com, Jan 15 2014

On another thread one guy said the fix would be ready for version 33... sigh. Guess we'll just have to put up with it till then...

Comment 22 by goo...@mspacek.mm.st, Jan 15 2014

I just upgraded to 32.0.1700.77 on Xubuntu 12.10. I have yet to see the font replacement behaviour, though letters with descenders (like g and y) still often get cut off.

I have noticed something new though: all the links on Wikipedia pages now show up as underlined, instead of just blue. Yuck! Firefox isn't doing this, nor did previous versions of Chrome. Has anyone else noticed this?

Comment 23 by i...@3rd-eden.com, Jan 17 2014

I'm experiencing the same issues, but not just for Wikipedia. This is an internal project we're working on which shows the fonts as serif font when it comes back from being backgrounded in a tab. It requires a hover over the elements or a forced redraw of the screen in order to render it correctly again (like opening and closing the web inspector)
fuckup.jpg
90.8 KB View Download

Comment 24 by Deleted ...@, Jan 19 2014

Experiencing the same on OS X Mavericks on a Retina Macbook Pro for the past several months, all the while regularly updating.

Comment 25 by Deleted ...@, Jan 20 2014

Evidently this is going to be fixed in the next issue of Chrome. It's a Chrome thing. There is a help page from Google about this issue, but I haven't checked if it's still doing it. It did this for me with Cracked.com, Reddit.com, and Wikipedia.

Comment 26 by Deleted ...@, Jan 24 2014

same problem ....

Comment 27 by jhgpor...@gmail.com, Jan 24 2014

Is there any way I can be deleted from Chromium and Google Code? I don't
want to use them anymore.

Comment 28 by Deleted ...@, Jan 31 2014

Chrome version 32.0.1700.102 was released yesterday (January 30 2014) and it is still not fixed. That means that what post #25 said was wrong --> "Evidently this is going to be fixed in the next issue of Chrome."

Comment 29 by Deleted ...@, Feb 1 2014

Still an issue in Chromium 33.0.1724.0

This particular time it stayed way longer than usually, even when I switched between English and German Wikipedia. It went away when I opened developer tools.
Schnappschuss (2014-02-01 21.55.14).png
78.3 KB View Download

Comment 30 by Deleted ...@, Feb 3 2014

This is especially obvious when the page uses icon fonts such as font-awesome.

Chrome Version 32.0.1700.102
Software  OS X 10.9.1 (13B42)
capture 2014-02-02 at 10.53.11 PM.png
82.6 KB View Download
capture 2014-02-02 at 10.53.49 PM.png
55.7 KB View Download

Comment 31 by anthonyt...@gmail.com, Feb 3 2014

Also experiencing this issue. Started just on Wikipedia around November, but has recently started appearing on other sites as well.

Comment 32 by j...@zerocrates.org, Feb 3 2014

As said in #21, there's a fix for this, it's set to come out with version 23.

Also just FYI: this particular issue's been marked as a duplicate since November, and the "main" issue this is a duplicate of is already marked Fixed, so continued reporting here won't really accomplish much.

Comment 33 by Deleted ...@, Feb 4 2014

Dear #32, 

I think you're referring to version 33, and also as said in #29,

"Still an issue in Chromium 33.0.1724.0"

Comment 34 by j...@zerocrates.org, Feb 4 2014

Yes of course, it's version 33, not 23.

As for the problem still existing in 33, here's the latest from a Chromium team member on this ( issue 236298 ):

"For anyone new to this bug:

This bug was present in M31 and M32, but should be fixed in M33.  If your seeing this or anything like it in M33, please file a new bug."

If there's really still a problem, comments here aren't likely to get noticed.

Sign in to add a comment