New issue
Advanced search Search tips
Starred by 7 users

Issue metadata

Status: Duplicate
Merged: issue 29427
Owner: ----
Closed: Apr 2010
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 31448: rounded corners and inset box shadow cannot be used together

Reported by startups...@gmail.com, Jan 2 2010

Issue description

Chrome Version       : 
Google Chrome	4.0.249.43 (Official Build 34537)
WebKit	532.5
V8	1.3.18.16
User Agent	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) 
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.43 Safari/532.5

URLs (if applicable) :
N/A

Other browsers tested:

Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: Not Tested
  Firefox 3.x: OK
         IE 7: N/A
         IE 8: N/A

What steps will reproduce the problem?
1. Test -webkit-box-shadow: inset 0 0 10px rgba(0,0,0,0.1) on a div - works
2. Test -webkit-border-radius: 5px on a div - works
3. Test both on a single div

What is the expected result?
An div with both an inner shadow and rounded corners.

What happens instead?
The div ignores the border-radius and only applies box-shadow.

Please provide any additional information below. Attach a screenshot if
possible.

It should be noted that the combination of the border-radius and box-shadow 
work if the box-shadow is not an inner shadow (i.e. no "inset" option).
 

Comment 1 by startups...@gmail.com, Jan 2 2010

The Firefox was tested with the respective -moz switches

Comment 2 by manuel....@gmail.com, Jan 14 2010

I can confirm this behavior and also i'm confident we could close this issue since it's 
a dupe of #29427 (http://code.google.com/p/chromium/issues/detail?id=29427).

Comment 3 by manuel....@gmail.com, Jan 16 2010

If this report remains opened i'd suggest to change the "What happens instead" text: in 
fact (Skia?) *is* rendering a rounded border, but what's wrong is the color being used. 
That is, instead of using the destination background color it seems to always use 
black.

Comment 4 by lafo...@chromium.org, Feb 19 2010

Labels: -Area-Undefined Area-WebKit autoclass
Using an automated filter to classify this issue into an area...gulp

Comment 5 by lafo...@chromium.org, Feb 19 2010

Labels: -Area-WebKit -autoclass Area-Undefined

Comment 6 by senorblanco@chromium.org, Apr 27 2010

Mergedinto: 29427
Status: Duplicate

Comment 7 by salmanab...@gmail.com, Nov 29 2010

WTH how much more time to fix this small bug? damn!
Didnt expected this from chrome :(

Comment 8 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:29427
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 9 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-Undefined

Sign in to add a comment