New issue
Advanced search Search tips

Issue 310983 link

Starred by 16 users

Issue metadata

Status: Untriaged
Owner: ----
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

choppy sound playing videos within RDP session (not only Flash, also HTML5)

Reported by madcow...@gmail.com, Oct 24 2013

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.66 Safari/537.36

Example URL:
http://www.youtube.com/watch?v=trj1pikOS5Y

Steps to reproduce the problem:
1. logon through RDP to a Windwos 2008 R2 terminalserver
2. play the video with chrome
3. 

What is the expected behavior?
sound should be played corectly on remote client

What went wrong?
sound is played choppy.

Did this work before? No 

Is it a problem with Flash or HTML5? Both

Does this work in other browsers? Yes Firefox 10.0

Chrome version: 30.0.1599.101  Channel: stable
OS Version: 2008 R2
Flash Version: 

Seems chrome tries to sync video an audio. But this does not work through rdp.
 

Comment 1 by madcow...@gmail.com, Oct 24 2013

You need to switch between flash and html5 to test both.
-> www.youtube.com/html5
Status: Untriaged
Confirmed with RDP session to Win 7. Chrome audio is choppy. Other audio, including other browsers, is  not choppy.
Confirmed. I connect to a virtual machine running win 7.
HTML5 based video is not choopy. But flash based is choopy. 
Flash 11 in IE 10 is not choopy.

Comment 4 by xhw...@chromium.org, Feb 13 2014

Labels: -Cr-Internals-Media Cr-Internals-Plugins-Flash

Comment 5 by jhis...@gmail.com, Oct 21 2014

Note: this is a regression
Tested builds of Chromium to find out at which revisions things broke.
OS: Windows Multipoint 2011 (basically 2008 R2 w/ local RDP terminals)

tldr:
between rev 169488 => 169564 sound became choppy
rev 163439 video broken
rev 163757 video was working
rev 169564 sound became choppy

before revision 163201
video works, out of sync, sound seems fast?

revision 163298
introduced ffmpegsumo.dll?
video works, out of sync, sound seems smooth

revision 163439
video is broken, sound seems smooth

revision 163507
video is broken, sound seems smooth

revision 163757
video works, sound seems smooth, out of sync

revision 163997
video works, sound seems smooth, out of sync

revision 169488
video seems good, sounds seems slower?, out of sync

revision 169564 => latest
video seems good, sound is choppy

Cannot find a version of pepperflash that doesn't have choppy sound (maybe it exists, if someone has the earlier version of pepperflash I can test it).

Comment 6 by cmcla...@gmail.com, Mar 15 2015

I have reproduced this issue in multiple environments. In addition to what was tried above, I can reproduce with a Win 8.1 Pro endpoint via RDP with remoteFX. If I use an addon to force chrome to use flash on youtube, then launch chrome with --disable-bundled-ppapi-flash, the video and audio are good and perform as expected. Both FireFox and IE work as expected. Host machine is 2008R2 SP1. I can confirm issue exists as of Chrome 40.0.2272.89, but it has existed for at least a few months if not more.

Comment 7 by Deleted ...@, Apr 15 2015

This issue has been driving me nuts for a while.  I have to copy the URL of any video and paste it into IE to watch videos. 

I found that adding -audio-buffer-size=8192 to the command line fixed my problem for youtube and some other sites.  Some sites still are choppy though.

Comment 8 by ivan@ludios.org, Apr 15 2015

I had this issue when RDPing into 2008R2 SP1 (Aero off), but don't have it when RDPing into Windows 8.1 (Aero on).  The RDP client was RDP 7.0 on XP in both cases.

Comment 9 by Deleted ...@, Apr 15 2015

I found another solution that seems to be working.  Looks like enabling RDP 8 fixes the issue as well.

http://blogs.msdn.com/b/rds/archive/2013/04/09/get-the-best-rdp-8-0-experience-when-connecting-to-windows-7-what-you-need-to-know.aspx

Sign in to add a comment