New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 145 users

Issue metadata

Status: ExternalDependency
Owner: ----
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment

OSX Maverick: Scrolling stops working when using the mouse gesture to switch to the previous page

Reported by michael....@gmail.com, Oct 23 2013

Issue description

Chrome Version: 30.0.1599.101
Mac OSX Maverick (10.9)

What steps will reproduce the problem?
1. Swipe on the touchpad to the right with two fingers to switch back to the previous webpage
2. Now scrolling is not working anymore

There is no error messages in the console when I perform this action.
 

Comment 1 by m...@tyderia.net, Oct 23 2013

See: https://discussions.apple.com/thread/5467320?tstart=0

Resetting PRAM has worked for me (so far).

Comment 2 by m...@tyderia.net, Oct 23 2013

I wrote too soon. The problem for me has returned after about 15 minutes.

Comment 3 by meh...@chromium.org, Oct 23 2013

Labels: OS-Mac Mavericks
Status: Untriaged
Marking as untriaged for more attention.

Can you reproduce it with Chrome Canary? Download at: https://www.google.com/intl/en/chrome/browser/canary.html

Thanks in advance.

Comment 4 by m...@tyderia.net, Oct 23 2013

I'm having trouble reproducing it at all after removing magicprefs and rebooting. I'll give it a shot though.
I found that disabling the "Swipe between pages" options for both the Mouse and Trackpad in System Preferences fixes this for me.

It seems that all scrolling (horizontal and vertical) is disabled once a user does a two finger sideways swipe (on trackpad) or single finger sideways swipe (magic mouse) in Chrome. The up/down scrolling is enabled again after restarting Chrome and will break after repeating the sideways scrolling action.

The settings to disable to temporarily restore sanity are shown in the following links:
http://cl.ly/image/3p1a460P2u2g
http://cl.ly/image/0C162R2Q390h

I verified this behavior and workaround on both of these Chrome versions:
Version 30.0.1599.69
Version 32.0.1678.0 canary

Ideally these options can be turned on again once fixed.
Labels: Hotlist-ConOps
Issue is being discussed on the forum:
https://productforums.google.com/forum/#!topic/chrome/FjjdquTVNBE

User describes issue:
I have Chrome Version 30.0.1599.101.  Since updating from Snow Leopard to Mavericks on my 2009 MacBook Pro, I can't scroll pages up or down using the trackpad, and can't use swiping left/right as a shortcut to go forward/back a page.  
I also can't find a scroll bar on the righthand side of most pages (e.g., NYTimes, Facebook) in order to scroll with the mouse.  I can see the scroll bar about half the time in gmail, and it does work when I click and drag, old-school style.

Scrolling works like it always used to in Safari.
Cc: nikeda@chromium.org jackyhayward@chromium.org
Owner: karen@chromium.org
+Karen, can you help us find an owner for this? It seems there are scrolling issues with Mac users who have updated to Mavericks. Thank you!

Comment 8 by m...@tyderia.net, Oct 24 2013

I'm not sure this is actually a chromium bug now. I've seen it in Firefox too. Removing jitouch and restting magicprefs to default and adding my custom settings back has solved it for me for the time being.

Comment 9 by meh...@chromium.org, Oct 24 2013

 Issue 310830  has been merged into this issue.
 Issue 311209  has been merged into this issue.

Comment 11 by Deleted ...@, Oct 24 2013

I confirmed that turning off "Swipe between pages" option on Apple Magic Trackpad got two finger scrolling working again for me on Mavericks 10.9 2011 MBA 
 Issue 311240  has been merged into this issue.
Cc: rsesek@chromium.org
Hi rsesek@. Is this a known issue? 
No, but it sounds like this is an interaction with third-party software like jitouch and magicprefs? Is this happening to users who do not have some kind of gesture adjustment program running?

Comment 15 by Deleted ...@, Oct 24 2013

I'm having this issue and I'm not using any third party software for input. Mavericks on a 13inch late 2011 MBP.
@dwcoltri: Thanks for your feedback.

Please, could you describe the detailed steps (incl. an example page), so that we can try to reproduce the issue.

Which Chrome version are you using? Please also attach screenshots from your Trackpad preferences to this report.

Thanks in advance.

Comment 17 by Deleted ...@, Oct 24 2013

I wrote that turning off two finger page swipe solved the problem. It quick working after a short time. Turning on then back off didn't re-solve the issue. Still broken.

Comment 18 by Deleted ...@, Oct 24 2013

I wrote that turning off two finger page swipe solved the problem. It quick working after a short time. Turning on then back off didn't re-solve the issue. Still broken.
Cc: asvitk...@chromium.org
Cc: ccameron@chromium.org
Cc: telukuntak@chromium.org chrome-test@chromium.org melodychu@chromium.org jaisimha@chromium.org ananthak@google.com
Labels: GoogleFeedback
Trackpad/two finger scrolling lags or not working

30+ users have reported this issue  in 'GoogleFeedback' since 23rd october 2013.

Version : 30.0.1599.101

Additional Information: 

1.Most of the users have reported that the issue occurs only after upgrading to OS X Mavericks 10.9.
2.Few users have reported that the issue occurs after chrome has upgraded to M30 .
3.Few users have mentioned that restarting chrome resolves the issue.
4.74% reports are from L-EN-US.

NOTE:
We are unable to reproduce the issue in Chrome:Version 30.0.1599.114 on Ubuntu OS.

For more details, refer the report URLs below:
https://goto.google.com/978791837
https://goto.google.com/981204902
https://goto.google.com/1271303275
https://goto.google.com/1390665336

For more user reports, refer the cluster URL below:
https://goto.google.com/02601989

Comment 22 by Deleted ...@, Oct 25 2013

Macbook Late 2010
New MacOsx Maverick
Chrome version Version 30.0.1599.101

Same happens for me after Mavericks clean install. No possibility to fix this for me until now. Problem not solved after restart. Not solved after disabling horicontal scrolling. No third party software installed.  

Comment 23 by Deleted ...@, Oct 25 2013

MacBook Pro late 2011
Mac OSX Maverick
Chrome  30.0.1599.101

Same problem here. Restarting chrome fixes it, but the error occurs several minutes later again. 

Comment 24 by kbr@chromium.org, Oct 25 2013

Cc: a...@chromium.org thakis@chromium.org kbr@chromium.org
 Issue 311592  has been merged into this issue.
Cc: ligim...@chromium.org vclarke@chromium.org vkomonduri@chromium.org

Comment 27 by jason...@gmail.com, Oct 25 2013

+1 for this issue.

Can confirm it's triggered by the swipe back / forward gesture (failing)

I've also noticed that roughly 10px of the swipe back bezel is still visible on the left after the swipe fails.
Is there a reliable repro? e.g. a specific page where this can happen consistently (or at least pretty often) after following some set of steps?

So far, I've not been able to repro on my 10.9 MBP.

Comment 29 by jason...@gmail.com, Oct 25 2013

As far as I can tell it's not specific to any particular pages.

For me it's happening immediately after the swipe left or right gesture on a page with the relevant history stack.

I've turned off the swipe left/right gestures in the Apple System Preferences, which stops the problem happening. 

Once turned off I can inexplicably use 4 finger swiping (in the opposite direction) to get Chromium to go through the history stack without the side-bezel images showing up... Possible clue? (IDK)

Comment 30 by jason...@gmail.com, Oct 25 2013

Also note that when the bug does present, (for me) all other Apple OSX TrackPad Gestures fail. However the trigger is only happening with Chromium. (fyi: Version 30.0.1599.101 (227552))

Comment 31 by jason...@gmail.com, Oct 25 2013

FYI : After switching off the swipe left/right - in Apple Sys Prefs - and then re-enabling it, the bug is not presenting if Chromium was already open.

(Quickly trying again with Chromium closed)

Comment 32 by jason...@gmail.com, Oct 25 2013

Attempted again with Chromium closed / reopened after disabling/enabling swipe left/right.

Bug no longer presents.

(Will try again after restart)

Comment 33 by jason...@gmail.com, Oct 25 2013

After restart - works ok ... looks like a hairy one to reproduce.

Comment 34 by Deleted ...@, Oct 26 2013

Switchig off left/right swipe doesn't change anything in my case. Scrolling is still deactivated when trying to swipe.

Comment 35 by jason...@gmail.com, Oct 26 2013

Once the gestures stop working (you'll probably notice all of them aren't working anywhere.)

You'll need to restart after switching off the swipe left/right page gesture.

For me switching it back on after starting Chromium/Chrome has (inexplicably) fixed it.

Comment 36 by Deleted ...@, Oct 26 2013

Should I restart the computer? Because restarting Chrome doesn't solve the problem.

Comment 37 by Deleted ...@, Oct 26 2013

WORKAROUND:

I've experienced the same problems, but instead of getting rid of software using accessibility features (jiTouch, BetterTouchTool, etc.), I used it to my advantage.

Turning off Swipe between pages in System Preferences prevents the issue from re-occurring.  To get the functionality back, I used BetterTouchTool to use a Single Finger Swipe Right gesture to send a command-left keystroke and a Single Finger Swipe Left gesture to send a command-right keystroke.

Version 30.0.1599.101
OS X Mavericks version 10.9 Build 13A603
15" Mid-2010 MacBook Pro
2.66GHz Intel Core i7
8GB 1067 MHz RAM

Comment 38 by Deleted ...@, Oct 26 2013

Same problem using a trackpad with both Safari and Firefox: Safari locked when swiping to go back a page, Firefox wouldn't scroll at all after the first attempt. 
SOLUTION FOUND:
Go to: System Preferences—>General. Under "Show Scroll Bars" select either "always" or "when scrolling". This solved the problem for me and several others on other forums. Mine had been set to 'automatically' and apparently that no longer works as it should with Mavericks. 
Enjoy! 
For info, this issue is also being tracked for Firefox via:
https://bugzilla.mozilla.org/show_bug.cgi?id=927702

The issue has been reported to Apple via Radar #15313540

Comment 40 by Deleted ...@, Oct 26 2013

Problem resolved after swiching off swipe left/right function, restarting the computer and re-enabling it. Thanks Jason ;)

Comment 41 by Deleted ...@, Oct 26 2013

I was able to fix the two finger scrolling in Chrome by using the "Show Scroll Bars --> Always" but now my problem is I can't get it to scroll the way I want to.

I use "Scroll Direction: Natural" (found under Trackpad settings in System preferences) but with Chrome it's not working. So if I use any other app or the finder the trackpad will work one way, but if I use Chrome, it works just the opposite. 

It's very disorienting! Anyone have a fix?

Comment 42 by Deleted ...@, Oct 27 2013

Hi,
I was having the exact same issue. It appeared after I moved two finger toward right or left.
I changed this and get your scroll bar back by going to:
System Preferences > Trackpad > More Gestures > and turn off "Swipe between pages".
The problem is solved for me.

Hope that helps!

Comment 43 by gyfis...@gmail.com, Oct 27 2013

Hello everyone,
I'm having the exact same issue, and it don't happens when I turn the settings (Preferences > Trackpad > More Gestures > Swipe between pages) off, however I'd like to have this functionality. Can someone post this issue to apple, if it haven't been done yet? Also, if I try to replicate this issue in Canary, it does not work as well, however a bit of an arc appears on the left side (as if it wanted to work, but something happens to prevent it). Picture in the attachment.

If someone has a fix which will keep this functionality, it would be greatly appreciated, as I've used it really frequently!
chromeArc.png
27.9 KB View Download

Comment 44 by Deleted ...@, Oct 27 2013

Can't scroll either. I can reproduce the results. I am running dual monitors. I have Firefox open and swipe over to Pixelmator running full-screen when I swipe back to Firefox I lose the ability to scroll via track-pad and side-scroll bar.

Comment 45 by Deleted ...@, Oct 28 2013

I was experiencing this; no scrolling on gestures in Chrome on Mavericks. I tried starting the gesture (vertical scroll) from off the trackpad and it worked (it didn't when performed within the trackpad). It now seems fine. Can't explain why. 
Recently upgraded to Mavericks and I can consistently replicate in Chrome 30.0.1599.101 and so far this is the only app affected.

I have a MagicPad and a normal wheel mouse attached and no 3rd party software 

On using 2 finger swipe between pages in Chrome all mouse gestures within Chrome stop functioning and the scroll wheel on the standard mouse ceases to to function.

Restarting Chrome restores scrolling until I next forget and try swiping left-to-right or right- to-left.

The work around for me is to change the "Swipe between pages" (Trackpad -> More Gestures) setting to "Swipe with three fingers" which seems to disable "Swipe between pages" completely in Chrome (in fact a whole bunch of other apps to) which isn't idea, but at least I can scroll pages, which is the more important function consistently.

I imagine that disablingly "Swipe between pages" will also solve the problem, but in a more drastic fashion,


Comment 47 Deleted

Comment 48 by mark@chromium.org, Oct 28 2013

Status: ExternalDependency
Looks like an Apple bug.

https://bugzilla.mozilla.org/show_bug.cgi?id=927702
Cc: hayato@chromium.org
 Issue 320461  has been merged into this issue.
HI, 

Checking if we have heard back at all from Apple on this issue. We continue to get reports daily from users in the forum about this issue. 

Comment 52 by kareng@google.com, Feb 4 2014

per mark's link. this bug is still open by apple and not resolved. :(
Labels: Hotlist-Recharge Hotlist-Recharge-Stale
This issue likely requires triage.  The current issue owner maybe inactive (i.e. hasn't fixed an issue in the last 30 days).  It has also not been modified in a year (prior to this update).  Thanks for helping out!

-Anthony
Owner: pinkerton@chromium.org
Cc: pinkerton@chromium.org shrike@chromium.org
Owner: ----
Can anyone comment on if the following workaround from Mozilla works? They went and closed the bug because of it. https://bugzilla.mozilla.org/show_bug.cgi?id=927702#c99

Comment 56 by bokan@chromium.org, Mar 10 2016

 Issue 593276  has been merged into this issue.
Cc: rbyers@chromium.org
Components: UI>Browser>Navigation
Labels: -Restrict-AddIssueComment-EditIssue -hotlist-recharge -Hotlist-Recharge-Stale
Firefox users are saying the following helps them (https://bugzilla.mozilla.org/show_bug.cgi?id=927702#c99):
"If you open up the trackpad settings, disable every gesture, then quit Firefox, then enable the gestures you want, then open Firefox, and the bug should go away.".

Can anyone who has seen this comment on whether or not this helps?

 Issue 446246  also has some suggestions for information we could use to track this down further if anyone is able to repro.
Cc: tkonch...@chromium.org erikc...@chromium.org
 Issue 446246  has been merged into this issue.

Comment 59 by sdy@chromium.org, Apr 14 2017

Components: UI>Shell>GestureNav
I've noticed this as far back as then and I've been wrestling with it today at work. It is 2018. 

My workaround has been that if I grab the Chrome tab from the Chrome window, then it resets it enough that i can start to scroll again. A Chrome close/restart or grabbing the URL and loading in a new tab works, obviously. 

I have apparently fixed it more permanently for now, by removing Chrome.app and re-installing it.

When I encounter it next I shall also test by connecting/disconnecting my Magic Touchpad 2. 

Sign in to add a comment