Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 30975 Implement E4X Support for scripts and extensions
Starred by 19 users Reported by adman....@gmail.com, Dec 22 2009 Back to list
Status: Duplicate
Owner: ----
Closed: May 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 3
Type: Feature

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Chrome Version       : 4.0.266.0 (Official Build 33992)
URLs (if applicable) : http://en.wikipedia.org/wiki/E4X
https://developer.mozilla.org/en/e4x
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: FAIL
  Firefox 3.x: OK
         IE 7: FAIL
         IE 8: FAIL

This bug is to track the progress of E4X implementation, allowing 
Greasemonkey scripts which use it to be run in Chromium.

 
Finally, someone noticed! I have been waiting for E4X support in Chrome since the very 
first version. E4X is such a critical feature which makes development so much simpler. 
E4X has been there since Firefox 1.5 and I simply cant wait to have its support in 
Chrome. Please don't let it die. If E4X isn't supported in another major browser, we 
wont be seeing it used in any web development project.
please support e4x?
Why is this still "unconfirmed"? It's definitely true.
Support for the latest ECMAScript standard should be higher priority. It's not like 
it's new - it's been around since 2005:
http://www.ecma-international.org/publications/standards/Ecma-357.htm
Is there some chromium developer forum we can post this so that web developers know
that this issue is being raised and they can vote to do something about it? I am sure
this issue will get many votes when devs become aware of it.
Comment 5 by adman....@gmail.com, Dec 31 2009
See also http://code.google.com/p/v8/issues/detail?id=235 as E4X is an ECMAScript 
extension, it will need to be implemented in V8 (the JavaScript engine) rather than 
Chromium.
Labels: -Area-Undefined Area-WebKit autoclass
Using an automated filter to classify this issue into an area...gulp
Labels: -autoclass -Area-WebKit Area-Undefined
Comment 8 by cfi...@gmail.com, Mar 29 2010
E4X support would make my porting of ScribeFire to Chrome much easier.
There ius a good summary of why E4X makes a lot of sense here :
http://www.theopensourcery.com/keepopen/?p=2157
I am afreaid E4x is at a tipping point if Chrome or IE9 don't do it some great code
is lost - in French the expression is C'est dommage.
Comment 10 by stac...@gmail.com, May 11 2010
Beside server side uses, e4x would also handle client side SVG needs quite nice too. 
Comment 11 by aa@chromium.org, May 11 2010
Labels: -Type-Bug -Pri-2 -Area-Undefined Type-Feature Pri-3 Area-Internals
Status: Duplicate
This is a dupe of v8 bug: http://code.google.com/p/v8/issues/detail?id=235
Project Member Comment 12 by bugdroid1@chromium.org, Oct 12 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 13 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals Cr-Internals
Sign in to add a comment