New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 309256 link

Starred by 159 users

Issue metadata

Status: Duplicate
Merged: issue 629871
Owner: ----
Closed: Jul 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 3
Type: Feature



Sign in to add a comment

Overview Mode: Multiple workspaces

Reported by kenny.st...@gmail.com, Oct 19 2013

Issue description

UserAgent: Mozilla/5.0 (X11; CrOS i686 4825.6.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1671.8 Safari/537.36
Platform: x86-zgb_he

Steps to reproduce the problem:
This is a feature request, so this does not apply.

What is the expected behavior?
Again, N/A as this is a feature request.

What went wrong?
Nothing. Do I have to say it again? This is a feature request, not a bug.

Did this work before? N/A 

Chrome version: 32.0.1671.8  Channel: dev
OS Version: 4825.6.0
Flash Version: Shockwave Flash 11.9 r900

Working with relatively limited screen real-estate on a Chromebook, I can assure that the issue of not having enough screen real-estate really bugs me. Overview Mode was a nicely welcome solution to this problem, but still, being restricted to only one workspace for a boatload of packaged apps and browser tabs is stifling.

Then again, the real question is how they're implemented. If Overview Mode is to be consistent, however, integrating a workspace switcher into it would be one of the best moves. And of course, I know exactly how consistent it can be if implemented: if the "workspace scrubbing" using three-finger vertical scrolling (in chrome://flags) is any indication, using a vertical workspace switcher to the left of the Expose-like window overview is probably the best move, since that way Apple can relax knowing it isn't a blatant ripoff of Mission Control and the GNOME developers can also relax knowing that their work is getting credit where it's due.

Mockup attached...
 
AshWorkspacesMockup.png
1.7 MB View Download
Attaching another mockup to describe how autohiding the workspace switcher would work...
AshWorkspacesMockupAutohide.png
1.7 MB View Download
... And this is the mockup for adding a new workspace:
AshWorkspacesMockupAddSpace.png
1.7 MB View Download

Comment 3 by krisr@chromium.org, Oct 28 2013

Labels: Cr-UI-Shell-WindowManager
Status: Untriaged
Owner: kuscher@chromium.org
Status: Assigned
Hey Alex, you mentioned the other day that folks have been mumbling about multiple workspaces lately. Is there a place where those requests/mumbling are getting aggregated already?

Seems like we should have a single issue where people can say "Hey! Chrome OS needs multiple workspaces!" :-)
Cc: jennschen@chromium.org
Labels: M-33 Cr-Design
+jennschen ... we should discuss this :)
Labels: -M-33 M-34
On 34 Canary, and so far don't see this implemented...
Someone please mark this as M-35, because apparently this milestone of 34 has already come and gone...
Labels: -M-34
We haven't committed to this. Thanks for taking the time to build the mocks, but it isn't as simple as just taking your mocks and hacking something together. If we decide to do something like this it'll have to go through the full UI design and review process and isn't trivial to implement.
Labels: -Cr-UI-Shell-WindowManager Cr-UI-Shell-OverviewMode
Labels: -Cr-UI-Shell-OverviewMode Cr-UI-Shell-WindowManager
Any updates on this?

If this does happen i have a few suggestions.
Have 3 finger trackpad gestures to switch workspaces when in the zoomed out expose mode to switch between workspaces. 

So to switch workspaces you would just do a 3 finger swipe up then a 3 finger swipe left or right to go to the next or previous workspace.

Extra feature request: integrate this with external monitor support so we can have one workspace mirrored on external screen. This enables users to switch to a workspace that is projected to class/meeting/etc. on Chromebook monitor and switch back to a private workspace for other things.
Labels: -Pri-2 Pri-3
Owner: ----
@matthews...: There is (or was) a "chrome://flag" that supposedly enables (or enabled) "workspace scrubbing" at one point which is exactly what you describe, only with a caveat: it is a three-finger vertical swipe, not a horizontal one, based on the flag's description.

That's precisely why I thought of designing those mocks that way: a vertical workspace pager to go with a vertical gesture. Although I would consider updating those 2-year-old mocks to add elements of Material Design ("floating" workspaces, for instance, and perhaps making that surrounding black border completely transparent, not to mention making full use of Material Design icons) to the mix.
A three finger vertical swipe up will bring up a side-by-side overview of all windows and give you the ability to select between them.

The window titles appear to suffer from some font rendering issues.  It's like behind every white letter there's some sort of roughly letter sized black rectangle or collection there-of.  Looks pretty terrible.

However, the three finger gesture detection is *extremely* *exceedingly* poor.

On a pixel 2 running 44.0.2403.156, I have to place my three fingers just right or it thinks I'm using only two of them.

What appears to work (sometimes) is three fingers organized in a triangle, the sides of which are a little less than an inch, and the triangle points upwards.  Even then it usually takes a couple attempts of swiping upwards with my triangle before it reacts.

The natural (to me) gesture with three fingers side by side roughly an inch apart never seems to work.
Coming from a Linux  and OSX background not having multiple virtual desktops / workspaces this is a deal killer for me.   Heck, even Windows 10 has multiple workspaces.
This is one of the missing features that is keeping me from using a Chromebook as my dedicated engineering laptop for work.
Related:  Issue 580942 
Updated mock with more Material Design in it, including replacements for the (currently hideous) close buttons
AshWorkspacePagerMockupMD.png
1.6 MB View Download
Another voice chiming in, I would love to see workspaces on Chrome OS. I currently use ALT + TAB to switch windows but it really leaves a lot to be desired. 


Android apps on Chrome OS make this all the more critical. More than one Android app and browser window with only one workspace to choose from makes for a *highly* cluttered experience to say the least.
Along similar lines, I also think that the Ash desktop itself has the opposite problem ― namely, too *little* information at a glance ― so decided to file Issue 625333 in that regard.

Comment 24 Deleted

Comment 25 Deleted

Fundamentally redesigning mock in response to *actual* MD redesign of the overview mode
AshMDWorkspacesMock.png
754 KB View Download
This wouldbe awesome. Please make anything like that happen. Chrome OS will be far more interesting for professionals with such a feature.
Cc: tbuck...@chromium.org
Mergedinto: 629871
Status: Duplicate (was: Assigned)
It would be really cool to have workspaces like those in macOS. I know it would take some effort, but I think it would be worth it in the long run.

Thank You,
 Jeremy
I was thinking more of a GNOME 3-like implementation @circuitk..., but Mac-like works too. Working with only one desktop can be rather stifling coming from MacOS like in your case, or even from another Linux distribution, like Ubuntu/Ubuntu GNOME which is my other main OS.

Comment 32 Deleted

This may look an awful lot like Chrome OS, but it's actually GNOME 3 with customizations. It is indeed very close to the ideal fulfillment of this feature request and the one that it's a duplicate of, with the exception, of course, of GNOME's default "all apps" icon which looks like the old Chrome OS icon, not the new one.
Screenshot from 2017-02-16 08-35-38.png
1.3 MB View Download
yes, this is a must!
Consider the following feature request.
https://bugs.chromium.org/p/chromium/issues/detail?id=736601

Comment 36 by dic...@dictvm.org, Oct 8 2017

Considering that Android apps are now supported on Chrome OS, they add additonal clutter to a single workspace. Is this still being worked on? A short update would be awesome. Especially since I'm eyeing to purchase a Pixelbook. :)
Definite necessity, especially if you're low on display real estate. Having multiple users to switch in between is just a hack for actually having multiple workspaces.

Comment 38 by sffc@google.com, Oct 16 2017

Note that this ticket was marked as a duplicate of issue 629871, so upvotes are more likely to get noticed if they go onto that ticket.  Unfortunately that ticket has a permission setting that does not allow comments.
chrome OS definitely needs this feature. Would prefer Linux-style to MacOs-stye desktops.
As someone who would love this feature, I'm putting my two cents in. The issue that +sffc@google.com listed stated that some users might accidentally trigger the feature and not know what it's all about, that is something to consider. 

What should be done is that either this feature should be either a flag that is disabled by default or a toggled feature hidden deep under Advanced features. 

Another consideration I would like to add is that this should be added /after/ running multiple android apps at the same time comes to stable. I personally use a ton of chat clients within ARC. Makes transitions easier for me personally.   
Right but cros has a whole about your cb app. Maybe display a notification
on the first workspace change to let users know how it works. I'm thinking
this wouldn't be enabled by default though.

Comment 42 by dic...@dictvm.org, Feb 4 2018

Hiding this as a pro-feature is a terrible way to sell Chrome OS developers this idea because doing this for a few power users who might stumble upon a feature flag is a waste of resources and it will never happen. It's also far too mainstream a feature to actually confuse users, considering that macOS and Windows 10 have been shipping this for years already. 

This should be front and center and the UX should be accessible enough for newcomers to understand the concept: 

Make it predictable which app will autostart on which workspace
Allow binding apps to specific workspaces
Make it seemless to fullscreen apps and treat them as their own workspace
Make it and easy to find the feature itself
Integrate it into the tab switcher
Integrate it into the window manager (which currently allows to pin apps to screen edges)
etc.

However, considering the development of Fuchsia, Ledger and the story-concept of apps that are grouped together (see https://9to5google.com/2018/01/26/google-fuchsia-os-stories-and-modules/), I don't think the workspace concept is still of interest to the Chrome OS team.
Today Windows 10 and macOS have workspaces too, so right now only Chrome OS doesn’t have them.

Totally needed, especially, after Linux app support in Chrome OS 70.
Utterly untested, and no guarantees about usability or non-virus-ness, but I recently ran across: https://gitlab.com/EduCampi/chromewm which links to https://chrome.google.com/webstore/detail/chrome-windows-manager/gophpkegccafhjahoijdembdkbjpiflb - so far I've been too chicken to try it.

Sign in to add a comment