New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 12 users

Issue metadata

Status: Duplicate
Merged: issue 377847
Owner: ----
Closed: Jan 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug



Sign in to add a comment

Incorrectly calculates 100% width of tables when parent width is an odd pixel value

Reported by nic...@stubbornella.org, Oct 13 2013

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

Example URL:
http://jsfiddle.net/stubbornella/2z3Zc/5/

Steps to reproduce the problem:
1. Create a parent element with a width of 75% and a border (so you can see the edges)
2. Put a table inside with a width of 100% and a background color (so you can see the edges)
3. Expand and shrink the browser window

What is the expected behavior?
A table set to width: 100% or height: 100% should always fill it's parent element.

What went wrong?
At even widths, the table will fill the parent, at odd widths, it will not. Height works the same way. When the height or width of the parent are an odd pixel value, there is a 1px gap between the edge of the parent and the table inside.

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? Yes Safari 6.0.5, Firefox 22, Firefox 23.01, 

Chrome version: 30.0.1599.69  Channel: stable
OS Version: OS X 10.8.5
Flash Version: Shockwave Flash 11.9 r900

This is broken for twitter bootstrap. There is a discussion around it here:

https://github.com/twbs/bootstrap/issues/11000#issuecomment-26221844
 
Screen Shot 2013-10-13 at 10.47.34 AM.png
13.0 KB View Download

Comment 1 by Deleted ...@, Oct 14 2013

IE9 and IE10 also render this correctly
Chrome 31.0.1650.16 has the same issue, on its mobile version too
Dup of #241198, but adds additional information re: height.
Cc: ranjitkan@chromium.org
Labels: -Cr-Content -OS-Mac Cr-Blink OS-All M-32
Status: Untriaged
Able to reproduce the issue on mentioned chrome version, it exists from M23 - 23.0.1271.110. Untriaging it as per comment #3

Comment 5 by tkent@chromium.org, Oct 17 2013

Cc: jchaffraix@chromium.org
Labels: -Cr-Blink Cr-Blink-Rendering

Comment 6 by kareng@google.com, Nov 8 2013

Labels: -M-32 M-33 MovedFrom-32
Moving all non essential bugs to the next Milestone.
Project Member

Comment 7 by bugdroid1@chromium.org, Dec 17 2013

Labels: -M-33 MovedFrom-33
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.

Comment 8 by laforge@google.com, Jan 9 2015

Labels: -Cr-Blink-Rendering Cr-Blink-Layout
Migrate from Cr-Blink-Rendering to Cr-Blink-Layout
Labels: Cr-Blink-Layout-Table
Status: Available
Probably have the same root cause as issue 241198 but keeping them separate for now.

Comment 10 by e...@chromium.org, Jan 22 2016

Mergedinto: 377847
Status: Duplicate

Comment 11 by alex...@gmail.com, Mar 20 2016

Still no fix for this :(

Sign in to add a comment