Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 159 users
Status: WontFix
Owner: ----
Closed: Jul 2010
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Disable annoying javascript
Reported by regis.de...@gmail.com, Dec 11 2009 Back to list
Chrome Version       : 4.0.249.22 (Build officiel 33427)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: ?
  Firefox 3.x: OK
         IE 7: ?
         IE 8: ?
        Opera:
    Konqueror:

What steps will reproduce the problem?
1. Open a page where javascript blocks right-clic/contextual menu
2. Right-clic


What is the expected result?

I would like an option to avoid annoying javascript.


What happens instead?

Right-clic is blocked indeed

Please provide any additional information below. Attach a screenshot if
possible.

Firefox has this option in Options | Content > Enable Javascript | 
Advanced...

Opera has this option in Preferences | Advanced > Javascript Options...

Konqueror has the option in Settings->Configure Konqueror... Java & 
JavaScript. On the JavaScript | Global JavaScript Policies
 
Comment 1 by mkte...@gmail.com, Dec 12 2009
At least for that particular annoyance, an extension now exists to counter it.  Ta-da!

https://chrome.google.com/extensions/detail/abggamgimoochjeciiaamoiedhapldjh
Comment 2 by mkte...@gmail.com, Dec 16 2009
Unfortunately, it looks like the extension doesn't work (at least for one type of 
blocking):
http://code.google.com/p/recontext-crx/issues/detail?id=1

Are there actual, legitimate uses for context menu blocking (i.e., besides irritating 
attempts at DRM) that keep browser makers from dropping support for it outright?
Mergedinto: 1748
Status: Duplicate
Comment 4 by mkte...@gmail.com, Dec 22 2009
Wait, this isn't a duplicate of  Issue 1748 .  We're asking for a way to disable 
*specific* Javascript functions globally, NOT a site black/whitelist for all 
Javascript.  As regis.decamps described, the former is built into many browsers. (see 
attached)
Konqueror-javascript-options.gif
63.3 KB View Download
Opera-javascript-options.png
30.4 KB View Download
Firefox-javascript-options.png
34.2 KB View Download
Mergedinto: -1748
Status: Untriaged
Looks like I mis-understood. Reopening and leaving untriaged.
I have wriiten an extension to provide a workaround to this
https://chrome.google.com/extensions/detail/hompjdfbfmmmgflfjdlnkohcplmboaeo
Comment 7 by mkte...@gmail.com, Feb 27 2010
Thanks!  Seems to be working on sites that foiled the other one :)
I'd like a keyboard modifier (Ctrl+Right Click say) to always bypass the webpage right-
click handler.

Some sites have useful right-click menus (eg: Google docs) so I wouldn't want to 
totally disable them. But sometimes I'd like to be able to bypass those same menus, and 
a keyboard modifier would let me do it.
Labels: not-extensions
Comment 10 by kerz@chromium.org, Jul 9 2010
Labels: -Area-Misc Area-UI
Status: WontFix
Comment 11 by Deleted ...@, Mar 7 2011
yep me too!
Comment 12 by Deleted ...@, Jun 21 2011
mee to !
why has this been marked as "won't fix" without comment?
Yes, this is a serious issue that needs fixing, ignoring the problem is not a solution at all.
nick.lot's suggestion of using a modifier key with the right-click to display the browser's native context menu instead of the script's seems the way to go. This would allow sites that rely on programmable context menus to function as expected, and allow access to normal browser functionality at the same time. There then would be no need for the user to burrow through preference panels to toggle a setting.

---
Please do not post "me too". Click the star button to the left of the issue number.
honestly i thought thats  why we have people liek this to help us or should i say me
i have reapeatdly tried to understand coding  and   blah blah blah but 
i am dyslexic at best and my  brian  jsut  doesnt  comprehend. 
and  i dont see how they  can  "not fix the app or extion or ad on" that they are getting credit for  and lets not  even begin to mention the money  they  make. cause  i belive when  people use them advertiers  make money....    
 any  way 



I REMEMBER A FEW YEARS AGO  WHEN THIS AND OTHER EXTENSIONS ETC  ACTULAY WORKED INSTEAD OF  JUST SLOWING YOU DOWN AND  BLOATING  YOUR PC

I  REEMEMBER A FEW  
Please implement a option to disable javascript right click action...
 
Project Member Comment 18 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 19 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-UI Cr-UI
Sign in to add a comment