New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 283616 link

Starred by 7 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Sep 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Bug

Blocking:
issue 286248



Sign in to add a comment

After Chrome update, Swype enters double words when touching space bar, delete with backspace word reappears

Reported by cynthiat...@gmail.com, Sep 2 2013

Issue description

Steps to reproduce the problem:
1. Go to gmail, swype, "hello" touch space bar, word hello shows up again
2.enter email address in "To" box, adds another "to" box with two email addresses in it
3. Backspace, "Hello" and when backspacing the "H" another Hello shows up. 

What is the expected behavior?
Should move from To box to where you have touched in the message box. Should only enter one Hello and then a space if you touch the space bar. Should backspace and eliminate the entire word

What went wrong?
After updating Chrome this problem occurred.

Did this work before? Yes Prior to Chrome update

Chrome version: 29.0.1547.62  Channel: n/a
OS Version: 4.0.4
Flash Version: 

I have an LG Spectrum. Switching to LG keyboard this problem does not occur. Thank you for any help.
 
Cc: tedc...@chromium.org vinodkr@chromium.org
Labels: Cr-UI-Input-Text-IME M-30
Owner: aurimas@chromium.org
Status: Available
Status: Assigned
CynthiaTodd222: Could you give us more details about this bug? 

- Which field did you type in "Hello" to?
- Could you attach some screenshots of Chrome in the broken state?
- Which version of Swype are you using?
- Could you try to reproduce the same bug using Chrome Beta (https://play.google.com/store/apps/details?id=com.chrome.beta)

I tried to reproduce the problem using Chrome 29.0.1547.59 using Swype 1.5.14.19480 and I could not see the text doubling issues.
Hi:
Hello was typed into the message box.
The Version of swype is 3.26.920.29238.39244.13227.VS920_ICS
I do not know how to take screen shots from my phone. If you tell me how I will be happy to send some to you.
I do not know how to check the version of Chrome I am using so I did not update the version of Chrome that I am using when I sent you the last email I used the default value that was preset when filling out the form. I will try using beta chrome.
I appreciate you looking into this
Cindy

CynthiaTodd222: you can take a screenshot by pressing Power (on/off) button and Volume Down button at the same time. The screenshot will then show up in the gallery app.

To find the Chrome version, you need to press the menu button, then select settings, then press the menu button again, choose about chrome. The version should be listed in that screen.

Considering that you have a pretty old version of Swype, would you consider switching to another keyboard? Google Keyboard is free on the Play Store and should not have the issue you are having (https://play.google.com/store/apps/details?id=com.google.android.inputmethod.latin).

I will still look into this issue if we have this device in our office.
Labels: Hotlist-ConOps
Hi, thank you. Attached is a screen shot of issue. I have chrome ver. 29.0.1947.59. I will try google keyboard. 
2013-09-03 20.14.55.png
122 KB View Download
This issue still occurs with google keyboard.the word,"this" repeated upon my touching the space bar. i tried tapping past the double entry of the word, "this" and it just repeated. ThisThis
Cc: yosin@chromium.org
I managed to reproduce this bug on Motorola Razr M 4.1.2 with Swype 3.26.92Q.39407.39469.14451.SMq_JB_V1. It makes Chrome really unusable with this keyboard.

After the debugging it seems like this bug is caused by the fact that InputConnection#setSelection confirms composition, even though according to the Android IME API it should not do that.

See here: http://developer.android.com/reference/android/view/inputmethod/InputConnection.html#setSelection(int, int)

AdapterInputConnection#setSelection calls WebViewImpl::setEditableSelectionOffsets to actually change the selection. This selection triggers a call to InputMethodController::cancelCompositionIfSelectionIsInvalid. We need to figure out how to skip cancelCompositionIfSelectionIsInvalid call if the selection change is triggered by setEditableSelectionOffsets and not by JavaScript, Touch Input, Keyboard, or some other way. 

yosin: do you have any ideas how we could fix this?
An example set of steps that Swype takes:
1. WebViewImpl::setComposition("Hello", 5, 5)
2. WebViewImpl::setEditableSelectionOffsets(0, 0)
3. WebViewImpl::confirmComposition("Hello")

The issue is in step 2 where we confirm composition.
We should get: "Hello|"
Insead we get: "Hello|Hello" (where | is the cursor)

Cc: kochi@chromium.org
Do we still keep m_compositionStart = 0 and m_compositionEnd = 5 after step 2?
After step 2:
m_compositionStart = 0 and m_compositionEnd = 5

However InputMethodController::hasComposition() returns false because m_compositionNode is null.
Labels: ReleaseBlock-Stable
There is a pending CL in review that seems to fix this issue https://chromiumcodereview.appspot.com/23848007/
Project Member

Comment 15 by bugdroid1@chromium.org, Sep 6 2013

The following revision refers to this bug:
    http://src.chromium.org/viewvc/blink?view=rev&rev=157345

------------------------------------------------------------------------
r157345 | aurimas@chromium.org | 2013-09-06T04:57:19.874923Z

Changed paths:
   M http://src.chromium.org/viewvc/blink/trunk/Source/web/tests/WebViewTest.cpp?r1=157345&r2=157344&pathrev=157345
   M http://src.chromium.org/viewvc/blink/trunk/Source/core/editing/InputMethodController.cpp?r1=157345&r2=157344&pathrev=157345

Fixing the bounds check in cancelCompositionIfSelectionIsInvalid.

Selection move to the start or the end of the composition node should
not cancel the composition.

BUG= 283616 

Review URL: https://chromiumcodereview.appspot.com/23848007
------------------------------------------------------------------------
Blocking: chromium:286248
Labels: Merge-Requested
I would like to merge this small CL to the M30 branch.

Comment 18 by kareng@google.com, Sep 10 2013

Labels: -Merge-Requested Merge-Approved

Comment 19 by kareng@google.com, Sep 10 2013

Labels: -Merge-Approved Merge-Merged
Committed revision 157551
Project Member

Comment 20 by bugdroid1@chromium.org, Sep 10 2013

Labels: merge-merged-1599
The following revision refers to this bug:
    http://src.chromium.org/viewvc/blink?view=rev&rev=157551

------------------------------------------------------------------------
r157551 | karen@chromium.org | 2013-09-10T21:29:35.207294Z

Changed paths:
   M http://src.chromium.org/viewvc/blink/branches/chromium/1599/Source/web/tests/WebViewTest.cpp?r1=157551&r2=157550&pathrev=157551
   M http://src.chromium.org/viewvc/blink/branches/chromium/1599/Source/core/editing/InputMethodController.cpp?r1=157551&r2=157550&pathrev=157551

Merge 157345 "Fixing the bounds check in cancelCompositionIfSele..."

> Fixing the bounds check in cancelCompositionIfSelectionIsInvalid.
> 
> Selection move to the start or the end of the composition node should
> not cancel the composition.
> 
> BUG= 283616 
> 
> Review URL: https://chromiumcodereview.appspot.com/23848007

TBR=aurimas@chromium.org

Review URL: https://codereview.chromium.org/23526038
------------------------------------------------------------------------
Status: Fixed
Status: Assigned
Verification Attempt:

Chrome Version: 30.0.1599.38
Device: Razr M / JZO54K

Verification Succeeded: NO

Comments:
The issue of text repetition or random addition of characters is still happening in the To, CC, Bcc fields of gmail's compose window.
Issue in the compose field (normal text field) seems to have fixed though.

Logs and demo @ http://go/chrome-androidlogs/283616 
After look at gmail case more, it seems like the issue is with the fact that mobile gmail website keep modifying the selection through JavaScript which cancels the composition.
Status: Fixed
My CL fixed the issues with regular input fields and text areas.

Gmail is a special case issue (filed a bug to the gmail team b/10712591) so I filed a separate bug to track that issue  crbug.com/289768 

Please only verify text input for regular text field (not gmail address input fields).
Labels: Verified-M30
Yes, this fix works fine for other text fields except the gmail To, CC, Bcc fields.
Thanks!
Folks following this bug - we just pushed out a possible fix on the Beta channel. You can install it side by side with Chrome. Can you please give it a shot and let us know if the problem goes away? If things look good, expect to change come thru to "Chrome" in a few weeks !!

Beta can be downloaded @ https://play.google.com/store/apps/details?id=com.chrome.beta
Thanks, the fix on Chrome Beta seems to work for me (LG Lucid). I had been having trouble with the duplication issue when using backspace in the google.com search box on standard Chrome for Android since the last update.  It seems like a few times in my testing on Chrome Beta, when I am backspacing the cursor seems to do a quick bounce to the front of the word and then back to its expected position, but I am not having much luck narrowing down the circumstances where I've seen that or in reproducing it reliably, and it isn't causing me any duplication or usability issues.  I am looking forward to the fix being integrated to Chrome, and will be using Chrome Beta in the meantime for making google searches on my Android phone.  Really appreciate how the two usability issues that came through for me in the latest Chrome update have been quickly handled and fixed by the Chrome team--thanks!
This ThisThis
Did not work for me. work Did
Work WorkWorkWork
WorkWork
CynthiaTodd222: are you using Chrome Beta 30.0.1599.38?

Comment 30 by Deleted ...@, Sep 14 2013

Chrome Beta worked for me!

I had the same problem as Monica.s -> typing any text into a form (including the Google search box) in Chrome while using Swype resulted in repeated words to infinity. This was especially frustrating using a form to enter numerical digits (phone #, credit card). 

I could use Chrome if defaulted back to the Android keyboard, but I much prefer Swype. 

Installing the updated Chrome Beta right now allowed me to enter any text into any form or text box without the problem. Thanks!!

Comment 31 by kld...@gmail.com, Sep 23 2013

I had this issue when updating chrome recent on my S2 i777, primarily using the included swype keyboard. When I'd backspace, it would replicate the entire word...

I downloaded chrome beta and I can't replicate the issue again. Yey!
 Issue 300641  has been merged into this issue.

Sign in to add a comment