New issue
Advanced search Search tips
Starred by 7 users
Status: Duplicate
Merged: issue 349543
Owner: ----
Closed: Mar 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug



Sign in to add a comment
WebAudio API, AudioBufferSourceNode, onended event crashes
Reported by bernhard...@gmail.com, Aug 28 2013 Back to list
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

Example URL:
http://jsfiddle.net/p7W4A/6/

Steps to reproduce the problem:
There is a sample on jsFiddle which plays an audio file with the WebAudio API. Go to jsFiddle and try it.

What is the expected behavior?
The "onended" events opens an alert window telling the user that the sound has ended. 

What went wrong?
On Chrome Canary it works a few times okay, but at some point the "onended" event does not fire anymore. If you press "Run" in jsFiddle again you get an "Aw Snap".

It works fine in Firefox Nightly.

Did this work before? N/A 

Is it a problem with Flash or HTML5? HTML5

Does this work in other browsers? Yes Firefix Nightly 26.0a1 (2013-08-28)

Chrome version:  31.0.1613.1  Channel: canary
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 11.8 r800
 
Labels: -Pri-2 Pri-1
Status: Untriaged
Verified not only on Canary, but on Beta and Dev Channel too. 31.0.1612.2. Reproed 4 times in a row, but still not getting a crash id. 
Comment 2 by rtoy@chromium.org, Sep 4 2013
Cc: rtoy@chromium.org
I don't know if it is related but for me the onended event listener doesn't trigger at all. 
It does work on firefox - To check if it was a problem in my code, i've checked this site which uses the ended event listener at some point. 

http://forestmist.org/blog/html5-audio-loops/

Chrome Version:

Version 28.0.1500.71 Ubuntu 12.04 (28.0.1500.71-0ubuntu1.12.04.1) 


Comment 4 by rtoy@chromium.org, Sep 6 2013
I don't think Chrome 28 has the onended listener.  This was a relatively recent addition.

Also, I have been unable to reproduce this on Linux with Chrome 30.0.1599.22. Maybe this only happens on Windows?
Yes it may be a windows related issue. I just tested it with Version 31.0.1622.7 canary Aura and the crash is still happening.
the oldest comment on http://forestmist.org/blog/html5-audio-loops/ is from 3 years ago... and I had this working in a HTML5 game that was also done years ago...
a little below in the comments section...


Today, in Chrome 11.0.696.68 on OS X, all of these examples loop absolutely perfectly!! :)


@Alexandre: You are talking about the HTML Audio element, right? We are talking about the Web Audio API and the event on the AudioBufferSourceNode class. Those are two completely different things.
In my particular case, I'm creating an Audio Object with "new Audio()" but I never add it to the DOM... but since the problem is the same (onended event doesn't fire), maybe they could be related.

Code snippet:

audioMessage = new Audio();
audioMessage.setAttribute('autobuffer', 'true');
audioMessage.preload = 'auto';
if (endedCallback) audioMessage.addEventListener("ended", endedCallback);

audioMessage.src = messageSrc;

Comment 10 by rtoy@chromium.org, Sep 9 2013
ajscarvalho:  In your example, you're not using webaudio, so perhaps you can file new bug with your test case.
Comment 11 by rtoy@chromium.org, Oct 10 2013
Status: WontFix
Closing this issue since it's not a webaudio issue.

ajscarvalho: Please file a new bug for audio element if that is still an issue.
Please reopen this issue because it is a Webaudio problem. ajscarvalho started to talk about the audio element but the original problem is the onended event of the AudioBufferSourceNode. 
Comment 13 by rtoy@chromium.org, Oct 11 2013
Status: Available
Sorry about that! Reopening.

I tried running this on Chrome 31.0.1650.12 beta on Linux. I pressed Run about a dozen times; no crashes.

Perhaps this is only an issue on Windows? I'll try there.
I tested it with Version 32.0.1666.0 canary Aura
After the forth "Run" the browser crashes.
Windows 7, 64 bit
Comment 15 by rtoy@google.com, Oct 11 2013
Thanks for testing again. I can confirm that it crashes on Win7, Chrome 32.0.1666.0 canary Aura.  I also tried Chrome 31.0.1650.16 beta-m on the same machine, which doesn't crash.
Comment 16 by rtoy@chromium.org, Oct 11 2013
I cannot reproduce this issue with ToT chromium from today.
Comment 17 by rtoy@chromium.org, Oct 31 2013
For the record I tried this again with Chrome 32.0.1687.2 canary.  No problems after pressing Run about 20 times.
I confirm that it does not crash anymore on Chrome 32.0.1687.2 Canary on Windows 7. On the downside, the onended event only triggers every now and then - which means that the alert window is shown only in about 50% of all playbacks.


Comment 19 by rtoy@chromium.org, Nov 1 2013
That's odd. I can't reproduce that on my Windows 7 machine. Every run triggered the alert window.
Comment 20 by jonko...@gmail.com, Feb 18 2014
I'm having this problem running Chrome 32.0.1700.107 on Fedora 20.
I was able to reproduce no alert on http://jsfiddle.net/p7W4A/6/ twice out of 10-12 tries on Windows M33.

jonkoops: Are you experiencing the original crash or the lack of ended events? If the latter, are you running 32-bit Chrome on x64 Linux? If so, this may be caused by  bug 313032 .


ddorwin: I was experiencing the ended events not triggering, however the problem went away after a reboot. As far as I know I downloaded the x64 RPM. 
On Linux x64, I also able to reproduce this once in 10+ attempts with 33.0.1750.117 (Official Build 252094). I was not able to reproduce it with 35.0.1860.0 (Developer Build 253249) aura, though that doesn't mean it doesn't exist there.
Mergedinto: 349543
Status: Duplicate
Moving all ended issues to  bug 349543 .
Sign in to add a comment