New issue
Advanced search Search tips
Starred by 19 users

Issue metadata

Status: Duplicate
Merged: issue 5751
Owner: ----
Closed: Nov 2009
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 27842: NPAPI does not preserve object identity

Reported by tamplinj...@gmail.com, Nov 16 2009

Issue description

Chrome Version       : 4.0.237.0 (Official Build 31086)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
  Firefox 3.x: OK (both NPAPI and XPCOM)
         IE 7: OK (as an ActiveX control)
IE 8:

What steps will reproduce the problem?
Reproduction is complicated, contact me at jat@google.com for details


What is the expected result?
The same JS object passed multiple times into an NPAPI plugin should 
maintain identity, ie the same NPObject should be received each time.


What happens instead?
Each call with the same object passes a new NPObject instance.  Even 
looking into the NPObject private data, the address of npobject_ptr_ isn't 
stable either.


Please provide any additional information below. Attach a screenshot if
possible.
This is for a Chrome extension for the GWT DevMode plugin, which allows 
debugging of GWT apps in Chrome.  The current solution requires adding a 
property to every JS object ever passed to Java to store a unique 
identifier, but this has a few probelms:
 - JS code can mangle the property, clone it between different JS objects,
   or be confused by its presence
 - Accessing the property from the NPAPI plugin on every call to Java for
   every JS object is passed to Java is very slow, since this results in
   an RPC call.  Using Chrome for GWT development is roughly twice as slow
   as using Firefox presently, and a significant part of this slowdown is
   having to lookup object ids.
 

Comment 1 by jam...@chromium.org, Nov 16 2009

Mergedinto: 5751
Status: Duplicate

Comment 2 by da...@sogeeky.net, May 3 2011

We are now on Chrome 11 and GWT 2.3.0 and the GWT Dev Mode plugin for Chrome is still painfully slow because of this issue.  This ticket has existed for two years now!  Please fix this issue!  See also: http://code.google.com/p/google-web-toolkit/issues/detail?id=4493

Comment 3 by da...@sogeeky.net, May 3 2011

For the benefit of those arriving here from a thread discussing the GWT Dev Mode plugin performance on Chrome, please see this discussion for more info: http://code.google.com/p/google-web-toolkit/issues/detail?id=4493

Comment 4 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:5751
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Sign in to add a comment