New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 26451 link

Starred by 5 users

Issue metadata

Status: Fixed
Owner:
Closed: Nov 2009
Cc:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression
M-4

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

REGRESSION: Java SE6 U10/11 plugin never starts (U13 works OK)

Project Member Reported by pkasting@chromium.org, Nov 1 2009

Issue description

about:plugins shows Java SE 6 U10 installed, but if I visit a page that uses 
it, e.g. http://weegames.com/clues.php?PAGE=3 , the plugin never starts.
 
I just synced to tip and tried this. It worked fine. This may have been fixed by r30676 
I will try to repro tomorrow with both Dev channel and ToT to verify that I can repro 
this with one and not the other.
Hmm.  I can't repro with the Dev channel at work.  Perhaps my profile at home is hosed, 
or the plugin install.  I will wait until the next Dev channel push, and if it's not 
fixed by then, try with a clean profile.
I had Java SE 6 U11 and it didn't load with Google Chrome 4.0.232.0 (Official Build 
30790). After updating the plugin version to Java SE 6 U17, it worked.
 Issue 24193  has been merged into this issue.
Another instance where U17 works but not U11 is 
http://www.java.com/en/download/help/testvm.xml
 Issue 23665  has been merged into this issue.
Summary: REGRESSION: Java SE6 U10/11 plugin never starts (U17 works OK)
Confirmed that upgrading from U10 to U17 fixes things.

U10 used to work, and Sun hasn't pushed updates broadly to users of it AFAIK, which 
means that this will be a visible regression for many users.  This broke fairly 
recently (within the last month, I believe), so it would suck to ship M4 stable with 
it.

Comment 9 by jam@chromium.org, Nov 5 2009

Summary: REGRESSION: Java SE6 U10/11 plugin never starts (U13 works OK)
I tested with 13, and it works on the above links.

I couldn't find the installer for U10/11, does anyone have one?

I suspect this is due to removing support for faking XPCOM support which is what 
earlier versions used.  That code was unnecessary after I added the new NPAPI 
functions that newer version of the plugin use.  I didn't test with U10.

If older versions don't work, we can block them from loading and that'll trigger the 
plugin installer UI which will upgrade users to newer versions of Java if they visit 
the site.

You can get the older versions from http://www.oldapps.com/java.php
FYI, those versions of Java work with 3.0.195.27
Might be a little confusing but would be better than nothing.

Was the fake-XPCOM stuff complex?  I'm wondering whether we could put it back in for a 
while longer (with big disclaimers that it's only needed by earlier versions of the 
Java plugin).

Comment 12 by jam@chromium.org, Nov 5 2009

Yeah the XPCOM stuff was pretty complex, and removing it simplified the code quite a 
bit.  I had talked to Ken and he also agreed that it was hacky and we shouldn't do it.

Ken just pointed me towards older versions, I'll test now: 
http://java.sun.com/products/archive/

Comment 13 by jam@chromium.org, Nov 5 2009

Note: to clarify my comment above: it was still good that we did it originally, so we 
can launch with Java support.  But it's not needed anymore now that Sun worked with 
browser vendors to add equivalent APIs from XPCOM that they needed into NPAPI.

Comment 14 by jam@chromium.org, Nov 5 2009

Status: Started

Comment 15 by jam@chromium.org, Nov 5 2009

Status: Fixed
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=31159 

------------------------------------------------------------------------
r31159 | jam@chromium.org | 2009-11-05 15:26:43 -0800 (Thu, 05 Nov 2009) | 4 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/glue/plugins/plugin_constants_win.h?r1=31159&r2=31158
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/glue/plugins/plugin_list_win.cc?r1=31159&r2=31158

Don't load the Java plugin prior to update 12, since they don't work in Chrome anymore.  By blocking loading them, the plugin installer UI is triggered.

BUG= 26451 
Review URL: http://codereview.chromium.org/371001
------------------------------------------------------------------------

Labels: -Area-Plugins Area-Internals Internals-Plugins
Labels: Internals-Install
Labels: -Area-Internals -Internals-Install
Fixing a bulk edit. Looks like the search query was not correct.
Labels: -Regression bulkmove Type-Regression
about:plugins shows Java SE 6 U10 installed, but if I visit a page that uses 
it, e.g. http://weegames.com/clues.php?PAGE=3 , the plugin never starts.
Project Member

Comment 21 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 22 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Mstone-4 -Type-Regression M-4 Type-Bug-Regression
Project Member

Comment 23 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment