New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 30 users
Status: Fixed
Owner:
User never visited
Closed: Feb 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug



Sign in to add a comment
Pressing and releasing ctrl, then scrolling causes zoom
Reported by chevro...@gmail.com, Jun 26 2013 Back to list
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

Steps to reproduce the problem:
1. Make sure chrome has focus. Press ctrl
2. release ctrl
3. Scroll using touchpad or (scroll button)

What is the expected behavior?
The page should scroll without changing the zoom level

What went wrong?
The page zoomed out when scrolling down
The page zoomed in when scrolling up

Did this work before? N/A 

Chrome version: 27.0.1453.116  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 11.7 r700

This is a Lenovo L430 using the UltraNav drivers. I reproduced on another L430 with a fresh install of chrome. I have not observed this behavior on another laptop.
I have not observed this behavior with an external mouse.
I have disabled all features of the touchpad except scrolling and it still occurs.
 
Cc: srsridhar@chromium.org
Labels: Needs-Feedback
Not able to repro the issue on Windows7 OS chrome version 27.0.1453.116 with NVIDIA drivers installed. Also no touch input is enabled.

Will let you know the behavior on  Lenovo L430 using the UltraNav drivers soon.
Comment 2 by Deleted ...@, Aug 30 2013
I can confirm this behavior on an L430 with fresh installation of Windows 7 64bit with all updates, Chrome version 29.0.1547.62 and UltraNav drivers 11.4.15.2. Tried to disable pinch to zoom and related settings. Even with all options disabled, the Touchpad and Trackpoint still seem to generate zoom events in Chrome, but only AFTER Ctrl has been pressed once while Chrome window is focused. For instance, pressing Ctrl-0 to reset the zoom level will trigger the zoom the next time I scroll using the touchpad or Trackpoint. After pressing Ctrl-0 and Alt-Tab switching to another window and back to Chrome will not trigger the zoom action when scrolling. Pressing and releasing Ctrl will trigger the behavior again.
Comment 3 by Deleted ...@, Sep 4 2013
I believe this is some odd behaviour of the touchpad driver (UltraNav drivers have a history of weird scrolling bugs). This specific model of Thinkpads doesn't have the usual Synaptics touchpad, but a new "Elan Tech" model. I also noticed that scrolling doesn't even work in some programs (Thunderbird for example). Although this is probably a driver bug, a solution would be very desirable. This is slowly driving me insane.
Even I am unable to reproduce the issue, can you please update screen recording of the same ?
Comment 5 by Deleted ...@, Sep 13 2013
Here you go. There's a typo in the screencast. "No pressing" was supposed to be "Now pressing". It's on a German Windows 7 with Lenovo UltraNav Elantech, current version, zooming disabled in the driver settings.
http://www.screenr.com/Jl4H
Comment 6 by Deleted ...@, Sep 13 2013
Could you tell us the version of Windows, Chrome and the UltraNav drivers you're using to reproduce this issue? Maybe you found the winning combination. Thanks in advance!
Comment 7 by Deleted ...@, Sep 13 2013
I found out that setting the track point middle mouse button to smooth scrolling in the UltraNav settings, the driver emulates a middle mouse button and the ctrl bug disappears for track point scrolling. However, this does not affect touch pad scrolling.
Comment 8 by Deleted ...@, Sep 22 2013
I can confirm this bug on Windows 8 (64-bit) with newest touchpad drivers, very annoying... Have to press Shift after using the Ctrl key to "release" it or something... No sticky keys configured or anything, also tried to disable nearly every function of the touchpad, but it's still happening...
Comment 9 Deleted
Comment 10 by Deleted ...@, Sep 27 2013
I also reported this as a bug on the Lenovo forums: http://forums.lenovo.com/t5/R-and-L-Series-ThinkPad-Laptops/L430-ElanTech-UltraNav-Scrolling-broken-in-Chrome/td-p/1248831 . It's hard to tell if this is a driver bug or a bug in Chrome as this does not appear to happen with any other browser or any other laptop.
Cc: wiltzius@chromium.org cpu@chromium.org
Status: Available
Hi,

Can anyone who previously was able to reproduce this problem try the latest Chrome canary and let us know if its fixed? We recently made some changes for the Synaptic drivers.

Canary is here:

https://www.google.com/intl/en/chrome/browser/canary.html

Comment 13 by Deleted ...@, Jan 16 2014
Thank god it's not just me. Reproducible on windows 7 64 bit acer 5755g with synaptic drivers. About to try out canary now.
Comment 14 by Deleted ...@, Jan 16 2014
Tested it in canary, the problem still persists :(
I started having this issue this morning, using Chrome Version 32.0.1700.76 m
Windows 7
Happens only on Chrome and not on any other application. Happens using both my mouse wheel (Smartfish mouse) and my trackpad (HP laptop).
Tried it using Canary just now and it still happens.
The behavior is as follows - 
1. Press ctrl or ctrl+<anything>.
2. Roll the mouse wheel - zoom is changed.
There's no way to "cancel" this behavior, even if I press ctrl again before rolling the wheel.

I have the same problem. In the case if i close tab #2 using 'ctrl' + 'w'. Then if i try to scroll page on tab #1, zoom of the page is changed instead.
Comment 17 by Deleted ...@, Jan 16 2014
As far as I know, this has nothing to do with Symantech. This specific 
line of Thinkpads, at least my model, uses Elantech touchpad drivers 
that are still labeled UltraNav.

Am 16.01.2014 12:42, schrieb chromium@googlecode.com:
This popped up for me suddenly today.  Happens with an external USB mouse but not with my laptop touchpad's 2-finger scroll.  Kind of driving me nuts...

Google Chrome Version 32.0.1700.76 m
Dell Latitude E5540
Windows 7 Pro 64-bit
Dell touchpad made by Alps Electric
Dell optical mouse M-UVDEL1

Comment 19 by friz...@gmail.com, Jan 16 2014
Happened to me, very annoying.

Google Chrome Version 32.0.1700.76 m
Windows 8
Generic USB HID mouse
Installed Bamboo Pen tablet drivers, but it is inactive and not connected.

Looks like something is blocking the ctrl button release event.

When i press ctrl, release it and then scroll, it zooms in or out one time.
If i press ctrl, release it, press shift and release, then the zoom is not occuring.
The shift key is the only one i found to be canceling the effect.
Comment 20 by Deleted ...@, Jan 17 2014
This is a regression, comes with the Google Chrome version: 32.0.1700.76 m
In the prev version it was ok.

Happens on:
- Desktop computer with Windows Vista Business 32 bit, usb mouse
- Desktop computer with Windows 7 Professional 64 bit, usb mouse

This problems has appeared after update to Version 32.0.1700.76 m.
Windows 7 Enterprise. Mouse A4Tech X6-287D. Driver version 6.0.6000.0.
Comment 22 by Deleted ...@, Jan 17 2014
The same problem here too

Windows 7 Enterprise + Chrome 32.0.1700.76 m

Very annoying issue because I do a lot CTRL + Link to open it in a new tab following by a wheel scroll in the new page
Comment 23 by Deleted ...@, Jan 17 2014
This is abundantly annoying because I use Ctrl+Tab, Ctrl+Shift+Tab to change tabs....  :-/
Comment 24 by cpu@chromium.org, Jan 17 2014
Labels: -Pri-2 -Needs-Feedback Pri-1 M-34
Owner: shrikant@chromium.org
Status: Assigned
shrikant, please take a look.

This might be a side effect of iyengar's changes trying to fix the synaptics trackpad issues.

Comment 25 by Deleted ...@, Jan 18 2014
I'm also having this issue in 32.0.1700.76. Using Windows 7 Home Premium 64-bit and a generic USB mouse.
Cc: ananta@chromium.org
Labels: -M-34 M-33
We should try to fix this in M33 if we can
Also have this issue:  32 .0.1700.76 m, Windows 8.1 Regular 64-bit and SteelSeries Raw USB Mouse.
Possible solution in review (https://codereview.chromium.org/142253002/). I am not able to repro actual problem, so this solution is based on just theory.
For me the issue has strangely disappeared this morning (it's an office PC and I haven't used it since Thursday evening). Oddly enough, the version hasn't changed - still 32.0.1700.76m.

Comment 30 by friz...@gmail.com, Jan 19 2014
I fiddled with the issue, and I discovered the forgotten tool "KatMouse" i installed long time ago and got used to its (better) behavior. When i turned it off, everything started to working fine in chrome (currently I have a filter for chrome windows). Still, chrome version 32.0.1700.76 is the only application I noticed to behave oddly with this tool. Every version of Firefox and previous versions of chrome does work corretly.
Comment 31 by dun...@gmail.com, Jan 19 2014
I tried using the Canary version and the problem persists.
I think the responsible in my case is "WizMouse" (a tool that i use to scroll windows without focus). It had an option to convert mouse wheel commands into scrollbar commands enabled. Disabling it solved the issue.
I am unable to reproduce this issue on Latest Canary#34.0.1794.5 & on Reported version#32.0.1700.76 of chrome on Win7(Lenova X230, T410) & Win8(Lenova X1Corbon) with 'UltraNav' drivers.

Could you please disable any specific extensions installed on chrome (chrome://extensions) and give a try?

Thank you.


Comment 33 by Deleted ...@, Jan 20 2014
Experienced this annoyance several days after 32.0.1700.76 m update. Zoom changed after pressing Ctrl+<anything> and then scrolling (using both: touchpad and USB mouse). HP Probook 4520S Laptop, Windows 8.1 Enterprise, Synaptics touchpad drivers v7.4.

Solution - complementing comment #31, solved issue after disabling WizMouse function "enable mouse wheel for applications without mouse wheel support".

Now Chrome behaves as expected.
Can confirm that the problem disappears when KatMouse is disabled.  Workaround for now is to set KatMouse to ignore Chrome.  (Settings... -> Applications -> chrome.exe -> Don't handle window at all)
 Issue 335873  has been merged into this issue.
Project Member Comment 36 by bugdroid1@chromium.org, Jan 21 2014
------------------------------------------------------------------------
r246028 | shrikant@chromium.org | 2014-01-21T13:24:18.197419Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/input/web_input_event_builders_win.cc?r1=246028&r2=246027&pathrev=246028

Added checking for higher bit being set in GetAsyncKeyState return value.
This is an experimental fix, as it is difficult to repro actual bug.

BUG= 254545 
R=cpu
TBR=nduca

Review URL: https://codereview.chromium.org/142253002
------------------------------------------------------------------------
Comment 37 by tonym...@gmail.com, Jan 21 2014
As a keyboard shortcut fanatic + webdev, this is maddening! :) After every ctrl+tab when scrolling with the middle button + trackpoint down, chrome zooms!  Windows 7 ultimate, ThinkPad SK-8855 USB keyboard, Trackpoint drivers set to standard scrolling.
Version 34.0.1788.0 dev-m - Similar problem for about four days now, but not quite the same...  For me the zoom level only gets smaller, never larger, and it mainly seems to happen on Google search pages, very rarely on other sites. I have a Motion J3400 tablet with Win7, so it has Wacom drivers active. Also has Synaptic drivers, not active. Problem was appearing with the touch scroll function of my Apple Magic Mouse, which uses their driver from BootCamp. 

And it has WizMouse...  I just turned off the "enable mouse wheel for applications without mouse wheel support" function, and can't intentionally duplicate the problem any more. Could it be that simple? Thanks so much for the suggestion!
Can anyone reproduce this problem *without* katmouse or wizmouse or another 3rd-party mouse software?
 Issue 335158  has been merged into this issue.
I don't have any 3rd party mouse software and have been suffering this since about 4 days ago, just with google Chrome, and just when scrolling. Alt+Tab or changing windows doesn't seem to help, not always at least. 

I'm using an external USB keyboard with trackpoint (Lenovo Thinkpad ThinkVantage). This is the driver http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-73235
I have the spanish version but the driver is the same, have tried previous versions of the driver, but no change. 

I'm using the keyboard on a Dell M6600 with Windows 8 (8.0 haven't "updated" to 8.1) which also has a trackpoint device, but scrolling on Chrome with the Dell trackpoint doesn't reproduce the issue, it just happens with the external Lenovo keyboard on Chrome. Uninstalling the Dell driver or deactivating the Dell trackpoint while using the external keyboard has no effect either. 

It never happened before until 4 days ago (probably with the Chrome update) and the keyboard is in mint condition. Uninstalling everything I had installed or updated on the last week (other than the automatic Chrome update) doesn't improve anything either.

Comment 42 by Deleted ...@, Jan 22 2014
Since yesterday (at least the time when I really realized that chrome is zooming) it has this zooming issue. Before I did not recognized this behaviour.

I've installed a driver for my mouse, but nothing fancy and it did work before.

Windows7 AMD desktop, Chrome 32.0.1700.76 m
Comment 43 by tonym...@gmail.com, Jan 22 2014
This seems to be fixed for me in Canary with my ThinkPad USB keyboard, Win7 on  Version 34.0.1799.0 canary!  Thanks!

Have not seen the zoom issue since turning off the "enable mouse wheel for applications without mouse wheel support" function in WizMouse. But since doing that, I can't control Flash videos in Chrome with a regular left-click! (Right clicks are received normally.) The buttons animate on rollover, but clicking them seems to be totally ignored. But _Control_+clicking them works! I only thought to try it because of this Control key issue...  

That happened 100% on many tries last night, and was verified on several different sites just before I began writing this. But I just checked again and the problem is now gone! I can't imagine what changed, I didn't leave this Chrome window or touch any other settings, just opened new tabs to video sites. 

Hmmm...  I now show Version 34.0.1797.2 dev-m instead of Version 34.0.1788.0 dev-m. The update arrived at 3:54 PM yesterday, so it was available during last night's problems. I've noticed before that Chrome updates don't take effect immediately when they are installed. Sometimes it takes hours before the new version is actually used. Is it even remotely possible that the update took effect for newly opened tabs while this tab remained open? I can't think of anything else that could have changed! 
Comment 45 by dun...@gmail.com, Jan 23 2014
I tried to revert the WizMouse option but i'm not able to reproduce it in the last canary version (v34.0.1799.0 canary). The issue seems fixed.

I am not experiencing the problem with left-clicks on flash players.
The Lenovo trackpad drivers are, I think, an unrelated issue. We're working
on that too, but does anyone have this particular issue without a Lenovo
trackpad _and_ without any mouse extensions?
Comment 47 by tonym...@gmail.com, Jan 23 2014
Wiltz, fwiw, it may be semantics, but my ThinkPad SK-8855 USB keyboard only has a touchstick, not a trackpad.  But i'll assume it's still lumped in with the unrelated Lenovo driver issues...   Thanks!
Also,  a couple of webs (jus a couple but enough for 4 days, and it didn't happen before) have frozen while scrolling. The scrolling bar dissapeared (at least the last time). I don't recall this happening before the zoom issue started... 

I have this same issue, since Chrome 32, on three different Windows 7 x64 systems. I use Logitech wireless mice on two of the three (a standard PS/2 mouse on the third), and Katmouse on all three.

On one system, I solved the problem by updating the Logitech SetPoint software to the newest version (but at the cost of that update resetting all of my browser configurations - I doubt it's supposed to do that, and I don't know why it did, but it was definitely the Logitech update which did it).

On another system I solved it by opening Katmouse settings, going to the Classes tab, dragging the class finder icon over Chrome, and saving the setting. (Not necessary to select "do not handle", oddly).

On the third (with a standard PS/2 mouse) the same solution above - Katmouse class handling for Chrome - solved it.

I have this same problem, also on a Lenovo Thinkpad L430 with Elantech Ultranav drivers. Problem for both trackpoint scrolling and for two-finger/edge touchpad scrolling; not for external USB mouse though.
I also had this problem, I also use a Logitech mouse and Katmouse. Disabling katmouse for chrome solved the problem.
Comment 52 by Deleted ...@, Jan 24 2014
For initial comment, look at #33.

As no Chrome update was released, version is still current: 32.0.1700.76 m. I tried to *update* WizMouse to 1.7.0.3 version (newest now), but as long as faulty setting is checked, problem is reproducable instantly.

I even reproduced it on another old HP laptop at home (HP nx6XXX-something), so it's not any drivers conflict but rather WizMouse (or I read somewhere else that KatMouse behaves the same) with Chrome.

So that's that, some of us disabled settings and can carry on, but for other unlucky ones develop a fix. Good luck!
It might be totally unrelated but strange enough to write about it just in case... 

On the windows 8 notification area I have Google Chrome Hangouts icon, which is displayed as a... trackpoint (! - see pic 1 the one on the bottom). 

I have tried uninstalling both the Google Talk Plugin for windows and the Hangouts Entension for Chrome on the user displayed on pic 1 (the only user I had it installed on) to see if it had any effect... Reinitiated... no luck. Problem continues (I don't have any of those Katmouse or similar plugins). It might appear to be unrelated then, but the Google Chrome Hangout extension still shows up on the notification area, which it shouldn't... (see pic 2 on the right); the only change being that that it doesn't show a trackpoint icon now, so the hypothesized relation may persist...

Just adding with whatever I can contribute, cause this is really hindering my work flow... 
1. Chrome zoom issue. Hangouts.PNG
28.0 KB View Download
2. Hangouts Chrome valmamusic.PNG
33.8 KB View Download
I meant a touchpad, not a trackpoint, icon. But it shouldn't matter much.
Any one still experiencing this ctrl zoom issue after Chrome v34.0.1799.0 update? 
Comment 56 by Deleted ...@, Jan 28 2014
I have same issue since Chrome 32 on desktop PC. No one from mentioned software wasn't instaled.
Chrome 32.0.1700.102 m
Windows 7 x64 SP1
Comment 57 by Deleted ...@, Jan 28 2014
34.0.1808.0 canary - is ok
32.0.1700.102 m - zoom annoyingly changes
Windows 7 x64 SP1
mouse drv: advanced wheel mouse

Problem began with new scrollbar (in canary is different). It looks like chrome doesn't receive "ctrl up" event.
Just downloaded 34.0.1813.0 canary, and the problem seems to be gone. Thanks! 

The problem still persists, though, on the latest beta version of Chrome (33.0.1750.58 beta-m) as well as the latest standard version. Like most of the other people on this thread, I have a Lenovo Thinkpad L430 with Elantech (not Synaptic) drivers. I do not have any third-party mouse software, such as Katmouse or Wizmouse, installed.

Thanks to ye good Google folks for developing workarounds for what seems to be a Lenovo/Elantech bug.
Comment 59 by Deleted ...@, Jan 31 2014
I don't think it's a matter of Lenovo or Elantech. Toshiba has the same problem with latest stable versions of Chrome (32). Any other browser works good.
No problems with Canary 34.0.1814.2 tested today. Good...
Windows 8 64, Thinkpad external keyboard, no Katmouse or Wizmouse. 

Yet would this take 3 months to get to stable (6 week on dev + 6 week on beta)?
Status: Fixed
With most the comments suggesting that last CL seem to have fixed the issue in latest builds, closing the issue. Please reopen if you continue to see this issue with latest builds.
Thanks shrikant! Echoing cmval's comment, though—how will I know when this Canary version will get issued as a stable build? (I'm strictly running Canary right now, since the scrolling issue is much more important to me than minor bugs/instability.)
Version 33.0.1750.70 beta-m

STILL HAVING THIS ISSUE. 
I also do not have a lenovo or elantech computer, I have no idea what that has to do with this issue. 
Schuyler, yes, the beta version still has the issue. It's the Canary version that has the fix.
@shrikant: updated Chrome Canary to the latest version (34.0.1833.0 canary) a couple days ago, and now UltraNav touchpad/trackpoint scrolling is completely broken. It had been working perfectly on the previous Canary build. 

Lenovo L430, Elantech ultranav touchpad, Windows 8.1 64-bit.
NB: When I say "completely broken," I mean that I can't scroll using my touchpad AT ALL now in Canary (34.0.1836.3). It's much worse than the old Ctrl + zoom problem, which is still present in the current beta version (33.0.1750.70 beta-m).

External mouse scroll wheel still works fine in all builds.
Comment 68 Deleted
Are you KIDDING ME? Google released another update to the beta channel but didn't fix this bug? 

"External mouse scroll wheel still works fine in all builds."
That is completely incorrect. 
Received Version 34.0.1833.5 dev-m today, replacing 34.0.1825.4 which had seemed to scroll normally. 

I'm seeing a new strangeness in mouse scrolling response! I'm using an Apple Magic Mouse with their BootCamp driver in Win7, along with WizMouse and the chromeTouch 3.2 extension. 

My tablet screen with Wacom input and chromeTouch still does perfect smooth scrolling like always. 

1. At all times, mouse scrolling in Chrome is wildly hair-triggered, like smooth scrolling is broken and line scrolling is set to jump about 1/2" per pulse. At the end of many moves it seems to ricochet back, or jitter/hunt back and forth several times for the stopping point. This is especially noticeable when you hit the bottom of a page. 

2. On many pages (especially eBay!) mouse scrolling just suddenly stops. It will be working, I'll click a button or link, and the scroll is just stuck there. The cursor still moves, and it seems the only solution is to find some area on the page that would allow scrolling (rather than selecting text) in chromeTouch with the "Auto" setting. I'm not sure what the difference is, but some apparently blank space triggers selection and some triggers scrolling...  Put the cursor over a "scrolling" area and suddenly page scroll responds to the mouse scroll signals again. 

I could swear Chrome used to have a "Setting" for smooth scroll - I disabled the Chromium Wheel Smooth Scroller extension because the built-in smooth scroll seemed better. But this Setting is not in my current version! 

There used to be flags about it, too, but I can't say how recently. Now the only mention of smooth scroll in Flags is for the Linux version.

The only flags left for Windows are:

Accelerated overflow scroll Mac, Windows, Linux, Chrome OS, Android
When possible, puts the scrolling contents of an overflow scrolling element onto a composited layer for faster scrolling. #force-accelerated-composited-scrolling

Universal accelerated overflow scroll Mac, Windows, Linux, Chrome OS, Android
Puts scrolling content in composited layers, even in those cases where promoting the overflow scrolling element to a stacking context and a containing block would have broken stacking or clipping. #force-universal-accelerated-composited-scrolling

I had never seen those before. I'm guessing they relate to what I call "infinite scroll", which keeps downloading more page content when you hit the bottom of the page? Probably nothing to do with my mouse scroll? 

I just turned the Chromium Wheel Smooth Scroller extension back on. It only affects newly loaded pages, not already open ones, but it totally still works. Perfect smooth scrolling instead of the disaster I've struggled with all day. 
Schuyler, I'm just reporting external mouse behavior on my own computer, where it's acting fine. If your external mouse wheel (not just touchpad/trackpoint) is causing you problems, say so.
Oh OK, I thought you were stating that it had been fixed in all builds. 

I am definitely experiencing this issue with an external USB mouse and it's making want to break things. 
Ug, not cool. (By "all builds" I meant stable build, beta build, and canary [developer] build.)
Hmmm...  Looks like part of today's scroll problem was "intentional":

 Issue 335495 :	Can't enable "Smooth Scroll" flag @ Windows OS
https://code.google.com/p/chromium/issues/detail?id=335495

https://src.chromium.org/viewvc/chrome?view=rev&revision=241761

Some of us were happily using smooth scroll in Windows! Until today... 


But the no-scroll condition is back! Right here! If I move my cursor anywhere across the whole page width below the bottom edges of the "Save Changes" and "Discard" buttons, mouse scrolling is disconnected. Move the cursor above that invisible line and scrolling works again! 

Scrolling via Wacom and chromeTouch always works over the entire area. The attached screencap shows what chromeTouch will select - not sure it is precisely related, since the mouse scroll fail area overlaps the chromeTouch select area by one line, but there does seem to be a connection. 
Wacom - chromeTouch selection limits.JPG
74.3 KB View Download
Comment 75 by ort...@gmail.com, Feb 14 2014
I'm experiencing this issue again in Chrome Version 33.0.1750.91 beta-m

I don't even need to perform a command; simply tap Ctrl once and then scroll up or down on my mousewheel using a wireless USB mouse (Logitech G602, latest drivers as of today).

Chrome zooms!

This is particularly infuriating if I'm copying/pasting text, selecting all, or generally doing anything :( I thought it was my mouse doing it, then I realized this only happens in Chrome!
I am also having this problem, recently installed Chrome for the first time on a new Windows 7 install. I frequently use the Ctrl key for various shortcuts, and any time I do that, and then use the mouse wheel, zoom is adjusted. 

Very annoying, I am 99.9% sure that it is not a stuck Ctrl key (as I have no evidence of this key being stuck in any other programs). 

Chrome Version: 32.0.1700.107 m 
It is not fixed. I still can reproduce it.
PLEASE REOPEN THIS ISSUE. The latest version of Canary destroyed the fix, and no longer scrolls AT ALL. Beta version still exhibiting the Ctrl + scrolling zoom bug.

34.0.1846.0 canary
33.0.1750.91 beta-m

Windows 8.1, 64-bit
Lenovo Thinkpad L430
Elantech UltraNav touchpad/trackpoint
Project Member Comment 79 by bugdroid1@chromium.org, Feb 19 2014
------------------------------------------------------------------------
r251889 | ananta@chromium.org | 2014-02-19T00:07:30.314879Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/legacy_render_widget_host_win.cc?r1=251889&r2=251888&pathrev=251889
   M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/renderer_host/legacy_render_widget_host_win.h?r1=251889&r2=251888&pathrev=251889

Forward WM_VSCROLL and WM_HSCROLL messages from the LegacyRenderWidgetHostHWND class to its parent.

BUG= 254545 
R=cpu@chromium.org
TBR=jam

Review URL: https://codereview.chromium.org/165353006
------------------------------------------------------------------------
Ok, the latest version of Canary (35.0.1856.0) works fine again (scrolls normally, no Ctrl + scroll --> zoom problems).
This is unbelievable... when is regular beta going to get this fix? Why is this marked as fixed? 
Do the google programmers just not bother to test their own products before release? It's still very much broken in Version 33.0.1750.117 beta-m 

How can it get marked as "Fixed" when the fact that it's still broken is so obvious? 
Schuyler, slow down. Canary is the development version, which is a couple steps ahead of beta (which is a couple steps ahead of stable). The issue is fixed in the Canary build, which is what I'm currently running. If this issue matters to you, download Chrome Canary and use it as your main browser until that version gets released as beta.

So I can set Canary as my default browser? This is news to me. 
Not so that it'll automatically open web links. But it's the browser that's pinned on my taskbar, and it's the only one I use.
New Chrome stable version (34) fixed the scrolling/zoom issue but not it prevents the trackpoint (thinkpad) to run smoothly: the trackpoint of my USB keyboard is configured to response to pressure as sensible as it can, but now it is like the configuration is blocked or behaves as if I hadn't changed it to be as sensible as it can. When I load the mouse/trackpoint driver application (properties) it continues to behave ok...
it should say: "but it now prevents" 
Hi there,

Just wanted to report that this problem was present on two separate lenovo laptops, a Y510p and a U430 touch, and both of these systems are operating on Ubuntu Trusty Tar 14.04. Problem persists via both wireless mouse and touchpad.

Disabling two finger scroll via the basic settings is just not an option for me given how much I use it. Till a solution is found, I will just continue delaying my tab transitions between ctr zooms.
Sign in to add a comment