New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 25288 link

Starred by 9 users

Issue metadata

Status: Verified
Owner:
Last visit > 30 days ago
Closed: Nov 2009
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug-Regression
M-4

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Mouseover / Mouse input to flash window does not work as expected

Reported by caro...@gmail.com, Oct 20 2009

Issue description

Chrome Version: Chromium 4.0.223.5 (29495), Flash 10.0 r32
URL: http://www.handdrawngames.com/DesktopTD/DesktopTD15k.swf
OS version: 10.5.8
Behavior in Chrome for Windows: working as intended

What steps will reproduce the problem?
1. Wait for Ads to finish.
2. Click on 'English', then click on 'Easy'. You may need to click many
times for something to happen. This is a bug in chrome.

3. Press '1'. Details for a pellet tower now appear on the right hand side.
(Thank you, Amanda!). Press '1' to deselect again.

4. Try to use mouse to click on pellet tower. Most of the time, the details
will appear shortly and disappear again. This is a bug in chrome.

5. Place the mouse on the middle of the field. Use the keys '1' - '3' to
cycle through units. Move the mouse on the field. Placeholder and range
indicator should move with the mouse. They do not. (Compare to firefox or
safari, or windows chrome, to see expected behaviour).

Thank you for your consideration!
 

Comment 1 Deleted

Chrome version: 4.0.225.0 r30036

Comment 3 by caro...@gmail.com, Oct 27 2009

I am looking at my Mac right now:
Safari is Version 4.0.3 (5531.9)
Chrome is 4.0.226.0 (30165)

Step #5 described above clearly behaves differently on Safari and Chrome.
Do you want me to post a video so you can see the difference?
Please reopen.

Comment 4 by amanda@chromium.org, Oct 27 2009

Labels: -Area-Misc Area-Plugins
Status: Unconfirmed
This appears to have been closed by mistake (r30036 is unrelated), so I'm re-opening.

Comment 5 by rice.c...@gmail.com, Oct 29 2009

I can confirm this problem in 4.0.228.0 (30388) Mac OS X 10.6.0. This mouse focus bug 
is present in all tested Flash applications as well as no hand cursor when expected.
The box-and-circle follows the mouse for me (which I assume is the placeholder and 
range indicator referred to in step 5) in 223.11. Does this always happen, or are there 
specific things you have to do to get into the no-mouse-tracking state?

Comment 7 by caro...@gmail.com, Oct 30 2009

Stuart, did you try this on Mac with Leopard?
It *never* works for me there, albeit Linux & Windows are fine. 

Comment 8 by caro...@gmail.com, Oct 30 2009

Okay, I just tried it on Google Chrome 4.0.223.11 specifically, and now feel like a 
total idiot -- it does actually work.
Let me re-try the latest chromium: 4.0.229.0 (30561) -- fail. It does not work.
So it works in Google Chrome, but not Chromium? How weird?!
Yep, it's broken as described in a recent trunk build, so it looks like we have a mouse-
handling regression. I'll try to narrow the window.
Labels: Mstone-4 ReleaseBlock-Beta
Status: Assigned
Labels: Regression
Hrm. I've dug back through the Chromium build archives and haven't found one that 
works yet. Maybe we have something stranger than a regression.

Comment 13 by caro...@gmail.com, Oct 31 2009

I was wondering if google chrome was maybe linked against a different version of
webkit, and if that would make a difference?

Chromium	4.0.229.0 (Developer Build 30561)
WebKit	532.4
V8	1.3.16.2
User Agent	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US) AppleWebKit/532.4
(KHTML, like Gecko) Chrome/4.0.229.0 Safari/532.4

Google Chrome	4.0.223.11 (Official Build 29902)
WebKit	532.3
V8	1.3.16.1
User Agent	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US) AppleWebKit/532.3
(KHTML, like Gecko) Chrome/4.0.223.11 Safari/532.3
It's broken in a very recent branded build, so it looks like it's a regression after all; 
maybe there was only a very small window of time where it actually worked, or maybe 
the branch the working dev channel was built from had a unique combination that 
made it work.
Status: Started
I built Chromium in Release mode from the 223 branch at 29902, and ran with a copy 
of my Chrome profile, and it still doesn't work. So I'm back to thinking this is weirdness, 
not due to a specific change.
Does anyone have examples of other sites with the same bug... ideally ones that are 
simple flash examples with source code? Mouse tracking works fine in a couple of other 
Flash games I've tried, so there must be something related to how this game does 
mouse-following.
My best example of this is in google reader.

With a subscription to an audio feed (like a podcast for example), there is a button 
marked "popput" which opens that episode into a new window with a small 
embedded 
flash player.  The play button on that widget can be clicked... but it takes an amazing 
strength of will.  Often it requires a frantic flurry of clicks to engage the player.

Also... this is probably a dupe of 24615, which is a MAC bug, ... even though that 
bug seems to have been recently hijacked by people reporting things related to linux 
versions of chromium.

(There are also several versions of this bug that seem to be linux issues, and talk 
about compiz and such, which may or may not be related).
Okay, I finally have results that make sense: whether it works or not has nothing to 
do with the build, but with other Flash interaction in the browser.

Reliably fails:
- Launch
- Go directly to http://www.handdrawngames.com/DesktopTD/DesktopTD15k.swf

Reliably works:
- Launch
- Go to YouTube and start playing a video
- Go to http://www.handdrawngames.com/DesktopTD/DesktopTD15k.swf (in the 
same or a new window)

So it's likely an activation problem, where something gets set in normal interaction 
that carries over to make the test case work. It may well be that the fact that it's not 
embedded content is what makes it behave differently than most Flash.
Interesting.   I have also noticed a (minor) bug that I have ben ignoring until now 
which may be related in light of your new info.

If you a situation in which a youtube video page is displayed when chrome starts, it 
shows an error message.   Reloading (and all subsequent youtube videos) works fine.

So for example, open a youtube video, then kill the browser (Force quit for example).  
When you restart chrome it will offer to restore your state, but when it does, the 
video will display an error message.

Perhaps the "initial state" of flash is strange?
 Issue 24615  has been merged into this issue.
Status: Fixed
Fixed by http://codereview.chromium.org/373015 (r31297); I put the wrong bug 
number in the CL description by accident.

Comment 23 by caro...@gmail.com, Nov 8 2009

Verified. Thank you very much for tracking this nasty bugger down!
Status: Verified
4.0.241.0 (Official Build 31417)
Labels: -Area-Plugins Area-Internals Internals-Plugins
Labels: -Regression bulkmove Type-Regression
Chrome Version: Chromium 4.0.223.5 (29495), Flash 10.0 r32
URL: http://www.handdrawngames.com/DesktopTD/DesktopTD15k.swf
OS version: 10.5.8
Behavior in Chrome for Windows: working as intended

What steps will reproduce the problem?
1. Wait for Ads to finish.
2. Click on 'English', then click on 'Easy'. You may need to click many
times for something to happen. This is a bug in chrome.

3. Press '1'. Details for a pellet tower now appear on the right hand side.
(Thank you, Amanda!). Press '1' to deselect again.

4. Try to use mouse to click on pellet tower. Most of the time, the details
will appear shortly and disappear again. This is a bug in chrome.

5. Place the mouse on the middle of the field. Use the keys '1' - '3' to
cycle through units. Move the mouse on the field. Placeholder and range
indicator should move with the mouse. They do not. (Compare to firefox or
safari, or windows chrome, to see expected behaviour).

Thank you for your consideration!
Project Member

Comment 27 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 28 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Mstone-4 -Area-Internals -Type-Regression Type-Bug-Regression M-4 Cr-Internals
Project Member

Comment 29 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment