New issue
Advanced search Search tips
Starred by 13 users

Issue metadata

Status: Duplicate
Merged: issue 650456
Owner:
Closed: Feb 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 3
Type: Bug



Sign in to add a comment

Center images when viewed

Reported by pr.dor...@gmail.com, Jun 13 2013

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31

Steps to reproduce the problem:
1. Go to an image page: http://i.imgur.com/CxQ4fP9.gif
2. See the image on the top left corner

What is the expected behavior?
The image should be centered (and maybe with a light dark background)

What went wrong?
I have the image not centered, I have to move my eyes, and it would feel more natural and easy for the eye (and also a better design and UX in general) if the image was centered (like in the second screenshot)

Did this work before? No 

Chrome version: 26.0.1410.63  Channel: stable
OS Version: 26

I use a Chrome extension: https://chrome.google.com/webstore/detail/image-to-center/kcpejamelebpigblebnbabhndaaffjok?hl=en

It's the default behavior in Firefox.

I don't break any existing workflow, page design, ect…, it's just an improvement for the final user.
 
chrome image not centered.png
95.3 KB View Download
chrome image centered better.png
104 KB View Download

Comment 1 by pr.dor...@gmail.com, Jun 13 2013

And in the example, there is a little shadow applied to the image.
Cc: nyerramilli@chromium.org
Labels: -OS-Linux OS-All M-29
Status: Untriaged
Able to reproduce this issue on Win 7 with chrome 29.0.1537.1 (Official Build 206000) canary Aura,Stable 27.0.1453.110 and on Macbook pro with 29.0.1537.0 Canary

Not a regression, Issue existing from M24 build.

FF 21.0, Opera 12.15 - Ok
IE 9, Safari 5.1.7, Chrome - Fail

Comment 3 by benhenry@google.com, Jun 26 2013

Labels: -M-29 MovedFrom-29 M-30
Moving all non essential bugs to the next Milestone.

Comment 4 by kareng@google.com, Aug 19 2013

Labels: -M-30 MovedFrom-30
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.
Almost two years... Any news about this thing? Will definitely improve user experience!
Labels: Cr-Design

Comment 7 by roma@chromium.org, Nov 12 2015

Labels: -Pri-2 Pri-3
Status: ainslie

Comment 8 by roma@chromium.org, Nov 12 2015

Cc: bettes@chromium.org
Labels: Hotlist-Polish
Owner: ainslie@chromium.org
Status: Assigned
[Marked for Polish Fixit]

@ainslie @bettes, is this something that we should or shouldn't do from a UX perspective?

Comment 9 by ivan@ludios.org, Jul 19 2016

I would really like to see this in Chrome, because the extensions that center images don't work properly when you click to zoom: you're not centered on the part you clicked on.

e.g. open https://upload.wikimedia.org/wikipedia/commons/4/43/ESO-VLT-Laser-phot-33a-07.jpg in Firefox, click on the star, and it's centered on screen as expected.

Do the same thing in Chrome with an extension that centers images, and you end up zoomed in somewhere else.

Comment 10 by dam...@dam.io, Jul 19 2016

> Comment 9 by i...@ludios.org
> Do the same thing in Chrome with an extension that centers images, and you end up zoomed in somewhere else.

I've made an extension that should fix this issue: https://chrome.google.com/webstore/detail/view-images-centered-like/damadkdlkdhpeeehnobhpeifjnmfkkjg

Comment 11 by ivan@ludios.org, Jul 19 2016

Unfortunately, not the case (I just tested again on Windows instead of Linux).  Widen the browser window like this:

[empty viewport     image      empty viewport]

In Firefox, you'll see that it actually centers where you click.  With view-images-centered-like, you're centered far to the right of where you clicked, because Chrome processed the click as if the top-left of the image was at the top-left of the viewport.

Comment 12 by dam...@dam.io, Jul 19 2016

Thanks, I've reproduced it and I think it can be fixed within the extension [bug filled]. Also, making the zooming code of the page more generic would fix it [2]

[bug filled]: https://github.com/mdamien/chrome-extension-image-center/issues/13
[2]: https://cs.chromium.org/chromium/src/third_party/WebKit/Source/core/html/ImageDocument.cpp?l=298

Comment 13 by dhw@chromium.org, Feb 15 2017

Mergedinto: 650456
Status: Duplicate (was: Assigned)
This has been done in Issue 650456

Sign in to add a comment