New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 178299
Owner: ----
Closed: Jun 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug-Regression



Sign in to add a comment

cubic-bezier values > 1 are not applied to CSS transforms

Project Member Reported by mihaip@chromium.org, May 31 2013

Issue description

http://persistent.info/chromium/test-cases/cubic-bezier.html is a simple test case that uses "cubic-bezier(.64, .57, .75, 1.81);" as the timing function (note the >1 value at the end). When pressing the "toggle()" button, the two boxes should move in unison. However, only the green box (which is animating the "left" property) overshoots the gray line, while for the red box (which uses transforms) the value seems to be clamped to 1.

This appears to be a regression. Things work as expected in M26. bisect-builds gives this regression range:

http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=186743%3A186778

The change that stands out the most is http://crrev.com/186775, which enabled hardware-accelerated animations for more cases. 
 

Comment 1 by ajuma@chromium.org, May 31 2013

Cc: vollick@chromium.org
This should be fixed by https://chromiumcodereview.appspot.com/16112002, which landed very recently (2 days ago). Are you seeing this issue in a ToT or Canary build?

Comment 2 by mihaip@chromium.org, May 31 2013

I'm seeing this in 29.0.1524.0, which was branched at 203291

Comment 3 by ajuma@chromium.org, Jun 1 2013

Mergedinto: 178299
Status: Duplicate
Merging this into  bug 178299 , which I've reopened.

Sign in to add a comment