New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 87 users

Issue metadata

Status: Verified
Owner: ----
Closed: May 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 242861: no internet connection in voice search

Reported by plackhor...@gmail.com, May 22 2013

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36

Example URL:
https://www.google.com/

Steps to reproduce the problem:
1.i removed google.com media access 
2.allowed it again 
3.opened  the search icon  

What is the expected behavior?
google voice search should work

What went wrong?
"no internet connection" message appears 

Did this work before? N/A 

Is it a problem with Flash or HTML5? N/A

Does this work in other browsers? N/A 

Chrome version: 27.0.1453.93  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

my internet connection and my mic are fine
 
Showing comments 112 - 211 of 211 Older

Comment 112 by Deleted ...@, May 22 2013

same here, chrome

and yes i use the internet connection to search and it's bring me here too =-=

Comment 113 by tiagojra...@gmail.com, May 22 2013

same problem: no internet connection

and my connection is just fine

Comment 114 by Deleted ...@, May 22 2013

Same here, Window7 and Macbook pro.

Comment 115 by Deleted ...@, May 22 2013

Same issue here using Ubuntu 13.04

Comment 116 by Deleted ...@, May 22 2013

Version 27.0.1453.93 m
Windows 8 Pro 64 bit
Same issue: "No Internet connection"

Comment 117 by j...@pracplay.com, May 22 2013

same  issue 27 .0.1453.93 m xp pro sp3 32bit

if i retry enough times, it will work but it's a bit fininky

Comment 118 by Deleted ...@, May 22 2013

Same issue for me as well...

Comment 119 by yannick....@gmail.com, May 22 2013

About whether or not it worked before. The day after Google IO I tested the feature in chrome canary on windows 7 and it worked just fine for me. Now it suddenly stopped working.

Comment 120 by gshires@google.com, May 22 2013

Trying to decipher all the reports above.

Original to reproduce steps were:
1. removed google.com media access  (which I presume means go to chrome://settings/contentExceptions#media-stream and click "x" to dismiss www.google.com permissions).

However, others seem to be reporting issues without this step. And others seem to be reporting finicky (intermittent) problems?

Am I interpreting these correctly?

Comment 121 by Deleted ...@, May 22 2013

Same issue, I am online but voice search reports 'no internet connection'.

Comment 122 by airsupre...@gmail.com, May 22 2013

@gshi...@google.com

It should work without removing media access for google.com. Either way though, as far as I know, it will bring up an error (removing media access or not removing media access)

I always allowed media access for google.com (worked fine on the canary, dev and beta builds before the update to the stable build which allowed the new interface). Then this afternoon it stopped working and gave a "No Internet connection" message. I had not used my computer in the morning, so I assume the functionality was broken for a while, presumably just after the update to stable builds of Chrome. 

Intermittently, Voice Search does work. However, about 90% of the time it does not, and displays the "No Internet connection" message.

Comment 123 by star...@gmail.com, May 22 2013

@ #120

It seems like it may be vaguely related to permissions. 
I opened google.com after updating to 27.0.1453.93, and tried voice search. 

After clicking "Allow", it worked once, however attempting to search again did not, giving the "No internet connection" error

I then manually set voice/video permissions to "Always allow" on the Google domain, and again the voice search worked once and once only.

Note that unlike the OP, I never removed permissions

Comment 124 by Deleted ...@, May 22 2013

Same issue here.

Comment 125 by Deleted ...@, May 22 2013

same here

Comment 126 by Deleted ...@, May 22 2013

I also tried on macosx which resulted in the same issue.

Comment 127 by Deleted ...@, May 22 2013

Same issue....   Multiple x.

Comment 128 by Deleted ...@, May 22 2013

Same here, worked once and now I am getting the error over and over again.

Comment 129 by Deleted ...@, May 22 2013

same issue here

Comment 130 by Deleted ...@, May 22 2013

Add me to the list.  Just updated Chrome to the latest, tried it once, worked, now only get 'No internet connection'.

Comment 131 by Deleted ...@, May 22 2013

and also same for me.

Comment 132 by Deleted ...@, May 22 2013

same problem here! it works sometimes, usually it works once or twice when chrome first open but then stops working and I can't get the "ok google" to work

Comment 133 by Deleted ...@, May 22 2013

Same issue..

Comment 134 by Deleted ...@, May 22 2013

Also same issue here, version 27, win7 64bit.

Comment 135 by Deleted ...@, May 22 2013

Same issue:
Windows 7 64 bit Enterprise
Google chrome Version 27.0.1453.93 m
10 Mbps fiber broadband.
Internet works fine, but when I click on the microphone icon in the google search box, it pops up the error: No internet connection.
(Bangalore, India)

Comment 136 by Deleted ...@, May 22 2013

Same Error. Removing permission and re-allowing doesn't seem to make any difference. Have had it work, but very intermittently.

Comment 137 by Deleted ...@, May 22 2013

Same issue on ~ 27.0.1453.93 (Official Build 200836)
OS ~ Windows 8 64-bit

Comment 138 by mattyjo...@gmail.com, May 22 2013

Same issue:

Chrome Version 27.0.1453.93 m
Windows 8 ver6.2.9200

Internet connection working fine. (Shrewsbury, UK)

Comment 139 by sayomanz...@gmail.com, May 22 2013

I never followed the reproduce steps, after updating chrome to Version 27.0.1453.93 beta-m (win 7 64bit) and coming across a persistent no 'internet connection' when attempting to dictate a search query I looked to report it here. It worked randomly once or twice but 90% of the time it reports an internet connection error. the error persists on all the domains I tried like google.co.jp

Comment 140 by Deleted ...@, May 22 2013

Same here:  latest Chrome 27 on OS X.  it worked only once.

Comment 141 by Deleted ...@, May 22 2013

And the same here on google.co.uk, Chrome version 27.0.1453.93 m on Windows 7 SP1 64bit.

Comment 142 by Deleted ...@, May 22 2013

Quick fix is to end task for all Chrome instances.  It will then work for a few tries and return to the error.  I have tested on several versions of Windows (7 pro, 32 and 64; 8 pro).

Comment 143 by Deleted ...@, May 22 2013

Same issue. MacMini OSX 10.8

Comment 144 by Deleted ...@, May 22 2013

Anyone has a an actual solution to this?

Comment 145 by Deleted ...@, May 22 2013

same issue. Windows 8 64bit. Taguig, Philippines

Comment 146 by Deleted ...@, May 22 2013

same issue. resolved by closing the browser, opening in again, and logging into google account

Comment 147 by chris.wh...@gmail.com, May 22 2013

Just started working for me - didn't do anything

Comment 148 by gshires@chromium.org, May 22 2013

I believe this is now resolved.
The API Key used by Chrome M27 did not have enough QPS provisioned, so it was throttling.
The API Key was not the API Key that was provisioned for Chrome usage (and thus, did not have sufficient QPS).
I increased the QPS of the API Key now used in Chrome M27.
I will write a post-mortem.

Comment 149 by Deleted ...@, May 22 2013

Hmm. I updated Chrome to version 27.0.1453.93 m on another Windows PC, and the audio search feature works on that one.

Different versions of Windows 7 - one Ultimate 64bit (the one that doesn't work), the other Pro 32bit (that does work) - and Chrome has different extensions in each install. More likely, I think, is different audio hardware setup on each computer?

Comment 150 by Deleted ...@, May 22 2013

Ah, as per previous comment, it's now working - just tried it on the PC where it didn't work, and now it does. Thanks whoever fixed it!

Comment 151 by star...@gmail.com, May 22 2013

Yep, resolved here; Thanks.

Comment 152 by jocdelad...@gmail.com, May 22 2013

Fixed here!

Comment 153 by Deleted ...@, May 22 2013

Confirmed. Works perfectly even with my heavy cold. Very impressed.

Comment 155 by gshires@chromium.org, May 22 2013

Status: Fixed

Comment 156 by agautam@chromium.org, May 24 2013

Cc: agautam@chromium.org
Labels: TE_verified_27.0.1453.93
Status: Verified
this issue is fixed and verified in 27.0.1453.93  Channel: stable, win7

Comment 157 by Deleted ...@, Jul 8 2013

Running Comodo Dragon V26 (Chrome), Lenovo Thinkpad, Windows 7 Ultimate, not working on 8 July 2013.
This extension works. Go to tools/extensions/get more extensions and search "voice search". Install "Voice Search" (search by speaking) and "add to Chrome". Installs a microphone icon on top RH toolbar. Select microphone icon and speak. Will work for Google Maps/Images/Videos/Youtube and others.

Comment 158 by Deleted ...@, Jul 28 2013

I'm still getting this in Linux 64-bit Chromium: Version 28.0.1500.11 (199640)
Is it a speech-dispatcher issue? No error at all from Chromium when run on command line.

Comment 159 by twhiting...@gmail.com, Dec 24 2013

still getting this issue 
Version 31.0.1650.63 m
Win 8.1

Comment 160 by wa0...@gmail.com, Jan 7 2014

Same thing here, Windows 8.1 and latest version of Chrome.  It also happens on other machines, to the point where I have quit bothering with the voice search since it is so unreliable as to require typing the search string into the form field anyway. Might as well just type it in from the get-go.

Comment 161 by Deleted ...@, Jan 15 2014

Version 32.0.1700.76 m

Still not working. Same message displayed "No Internet Connection" when doing voice search. This thing never works.

Comment 162 by wooddrg...@gmail.com, Feb 15 2014

This issue seems to be closed but I am still receiving the same error, No internet connection, yet clearly, I am connected.

Comment 163 by qwerty...@gmail.com, Mar 19 2014

Issue reoccuring in Version 34.0.1847.60 beta-m. See system specs here: http://speccy.piriform.com/results/hkngUyi3BqY5Blmy1wxjcwV

Comment 164 by Deleted ...@, Mar 21 2014

same problem her,what is going on?

Comment 165 by Deleted ...@, Mar 22 2014

Same problem. Both mic and internet are working fine on their own...

Comment 166 by Deleted ...@, Mar 24 2014

Same problem.It seems that google do things bigger than his ability.

Comment 167 Deleted

Comment 168 by jacker1...@gmail.com, May 7 2014

This issue has been going on for ages now.

Comment 169 Deleted

Comment 170 by fairfax....@gmail.com, May 8 2014

Well, I've got search by voice to work. 
It may be a flash player issue although I'm not sure. I recently updated flash player and it wasn't too long after that search by voice failed to initialize. I restored my computer to a previous date, (before the flash update). I then uninstalled Chrome completely., including all browsing data. re-installed Chrome and it now works.

I hope this helps for you, cheers!

Comment 171 by wooddrg...@gmail.com, May 24 2014

Thank you. I'll try it.

Comment 172 by Deleted ...@, Aug 15 2014

Mine wasn't working up until I came here to post;
 tested it one more time and it worked.
 (tested "maniac" (it was the first thing that came to mind in that moment))
Tried my original voice search that brought me here to begin with:
 no connection.
Now I'm really wtf
Test search again,
 Works.
Original search again,
 Works.

Did, did I just fix Google..
google error - wood.png
386 KB View Download

Comment 173 by amboy3...@gmail.com, Sep 11 2014

Im having this issue, was trying it for translate with voice and Google search, not working.....

Comment 174 by Deleted ...@, Sep 17 2014

hoping I will have the same luck as fiatlux...@gmail.com.

Comment 175 by Deleted ...@, Sep 22 2014

Please fix this issue Google. I am having a huge problem. I really need this.

Comment 176 by jjg...@gmail.com, Sep 24 2014

This is to let Google personnel know that the problem is back. My "Search by Voice" gets a "No Internet Connection" about 70 % of the time I try to use it. About 30% of the time it works great. I make no changes to anything on my system and yet sometimes it works and two minutes later it will not work. I tried turning off all my extensions to see if one of them was causing the problem but that did not help resolve the problem. I tried starting a new Google Chrome session but that didn't help. The problem is very intermittent and I am sure that will make it harder for you to resolve but I wanted to give you as much information as I could to help you.

I thank your staff for an otherwise GREAT product.

Comment 177 by rsout...@gmail.com, Sep 24 2014

Use this on my phone all the time have not been able to use it on my new Lenovo at all using windows 8.1 & Chrome Version 37.0.2062.120 m in desktop mode. Just keeps saying no Internet connection.

Comment 178 by jjg...@gmail.com, Sep 24 2014

Anyone having problems with this after September 24, 2014 might want to add comments to a new  Issue #417304  that I opened today because this  issue #242861  was closed a long time ago and might not be monitored anymore.

Comment 179 by Deleted ...@, Oct 5 2014

Same problem as everyone else, no internet - but I do have connection - see lots of posts with problem - no answers - does this problem ever get addressed???

Comment 180 by cristofe...@gmail.com, Oct 8 2014

Ditto here.  Windows 7 64bit

Comment 181 by Deleted ...@, Oct 28 2014

Yep. Same.

Comment 182 by Deleted ...@, Nov 4 2014

Just tried as well. Says no internet connection when clearly I have one.

Comment 183 by Deleted ...@, Dec 2 2014

Add me to the list of "yesterday it worked, today it won't" crowd. I honestly think the whole net may be under some sort of attempted cyber infiltration. Lots of companies having issues. But issue for this is the same..."no internet connection" though I'm obviously on it right this second.

Comment 184 by Deleted ...@, Jan 26 2015

same here no internet connection

Comment 185 by Deleted ...@, Feb 2 2015

same issue

Comment 186 by rsout...@gmail.com, Feb 2 2015

I don't think Google has any intention of fixing this issue despite that it obviously exists. Looking forward to Windows 10 and Cortana if it works well I think I'll migrate back to office 360...

Comment 187 by Deleted ...@, Apr 15 2015

I have the same problem here 
Windows 7 32 bit

Comment 188 by heflin...@gmail.com, Jul 25 2015

same issue here

Comment 189 by rsout...@gmail.com, Jul 26 2015

I fixed the problem on my PC (Windows 8.1) by going into settings and changing my google default search page to www.google.com from my country specific page.

Comment 190 by Deleted ...@, Aug 4 2015

same problem...

Comment 191 by jason...@gmail.com, Aug 4 2015

I fixed the problem on my PC (Windows 8.1) by downloading the newest Google Chrome, saving it, uninstalling the Google Chrome completely, then installing the downloaded Google Chrome exe file.

Comment 192 by jason...@gmail.com, Aug 4 2015

Sorry.  Small change on the sequence.  Uninstalled the Chrome completely first, used Internet Explorer to download the newest Chrome, then installed it.

Comment 193 by Deleted ...@, Oct 29 2015

since this has been going on since May 2013, I really don't think Google shives a git.

Comment 194 by Deleted ...@, Dec 3 2015

no internet connection

Comment 195 by leolujoh...@gmail.com, Jan 6 2016

same problem encountered here....

Comment 196 by mrs-brig...@live.com, Jan 20 2016

Can anybody hepl us!Its necessary for some people!

Comment 197 by rsout...@gmail.com, Jan 20 2016

I fixed the error last July and it is still working for me in Windows 10...
Go to Chrome settings page chrome://settings/ and click on the Manage search engines under "Search" chrome://settings/searchEngines Make your default search engine google.com I read that the voice recognition only works with that domain none of the country specific google search engines like google.ca.
Gsearch.JPG
32.8 KB View Download

Comment 198 by markhama...@gmail.com, Mar 11 2016

To begin, I would respond to @rsout in Comment 197. I'm afraid that this is still a problem in spite of your recommendation: I visited chrome://settings/searchEngines as you recommended, and my browser's default search engine is already set to google.com.

In fact I experience this problem frequently of late in both Chrome and Chromium. "No Internet Connection" when I try to do a Google voice search.

But the problem is broader than that. Neither does dictation.io work nor the "voice typing" tool in Google Docs.

Rebooting my computer may help, but I can't say whether there's a strong correlation, as I reboot infrequently.

Thank you.

Comment 199 by steveren...@gmail.com, Apr 2 2016

Voice search works, but i am limited to about 3 seconds voice terms. Anything over 3 sec. I get the Message "No internet Connection"  
I tried, clearing all settings to default "Chrome Clean program" 
Removed latest Ver. 50.0.2661.49 beta-m (64-bit)
Installed beta Ver. ???
removed Beta ver. "Same Problem"
reinstalled latest Ver. 50.0.2661.49 beta-m (64-bit)

Comment 200 by lewis.l...@gmail.com, May 31 2016

Same or similar problem found, but no answer from google support team...

OS: Chrome 45, 48, 49 and 50
Machine: Raspberry Jessie (Pi2/3)

#1 Chrome "No internet connection", when click search by voice from google search
#2 Red "Mic" flash once and gone, when i use "turn on speech input" 
#3 The problem only happened during around UTC 23:00 to 07:00, Monday to Friday (not sure Sat, but sure Sunday works fine)
#4 Chrome has been updated to available version 50, has tried incognito mode and clean the cache/cookies but with same result 

I have confirm the audio resource (mic/speaker) connected is working well with the said Browser, via test - https://www.onlinemictest.com/ during the "No internet connection" reports. And the same hardware and software works fine within UTC 0800 to 2300.

Comment 201 by grg.g...@gmail.com, Aug 10 2016

I have the same problem with google search by voice. I'm using Chrome Version 51.0.2704.79 on Linux Mint 18 Cinnamon. Every now and then it will start working then stops again for a long period.

Comment 202 by akgreen...@gmail.com, Sep 20 2016

no internet connection keeps popping up.fix or I switch browsers

Comment 203 by rice.r...@gmail.com, Oct 25 2016

So, somebody's working on this??? More than 3 years have passed, and it's still a problem.

Comment 204 by wooddrg...@gmail.com, Oct 26 2016

My issue was remedied a few years ago.

connection in voice search

still a problem.

Comment 205 Deleted

Comment 206 by craigj...@gmail.com, Feb 26 2017

only just got this issue but have removed and re installed chrome but still the same.

Comment 207 by steal...@gmail.com, May 10 2017

I have this issue today which popped up a couple of days ago. No sure why. This was working fine, my guess is another app over wrote files needed. I'm using:
Win7SP1 fully updated
Chrome Version 58.0.3029.110 (64-bit)
Removed/reinstalled Chrome several times. 

If someone could post a fix it would be useful.

Comment 208 by umlungu...@gmail.com, Jun 14 2017

Hello Google Idiot-techies... I say that because you work for Satan.... although your intentions are good, the results will affect your offspring in a most negative way...
Seems like your stupid chrome mic is still not working after 4 years.

Old CIA agents regret their wasted lives - but who cares right.

Comment 209 by mjon...@gmail.com, Jun 29 2017

Ummm this is going to be fixed in 2013, and it is now 2017.

Its not fixed. 

Really guys?

Not any kind of help at all? The Mic is just useless? Really?

I have checked many google results on this...no help anywhere. Really?

Comment 210 by technat...@gmail.com, Apr 19 2018

Using Version 65.0.3325.181 (64-bit) on Chakra Linux.

Any attempt to use voice search, dictation.io, Voice Notebook etc. etc. results in "No Internet Connection".

Obviously not suffering from any of the Windows maladies and thus unable to use any of the "fixes".

Log attached.
chrome-net-export-log.json
199 KB View Download

Comment 211 by spearhea...@gmail.com, Sep 2

same issue
chromium-browser --version
Chromium 68.0.3440.106 Built on Ubuntu , running on (K)ubuntu 18.04
Thinkpad T410 x86_64 Kubuntu Kernel: 4.15.0-33-generic
KDE Plasma Version: 5.12.6 KDE Frameworks Version: 5.47.0
Qt Version: 5.9.5
Intel i5 CPU M 540 @ 2.53GHz
4GB RAM
lsb_release -a :
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:        18.04
Codename:       bionic
Showing comments 112 - 211 of 211 Older

Sign in to add a comment