Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 239401 Add a way to hide/filter out extension resources in the network tab of web inspector
Starred by 87 users Reported by m...@markashleybell.com, May 9 2013 Back to list
Status: Duplicate
Merged: issue 258421
Owner: ----
Closed: Jan 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Feature



Sign in to add a comment
UserAgent: Mozilla/5.0 (Windows NT 6.0; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce the problem:
1. Install the Readability Chrome extension (just an example, this happens with other extensions as well)
2. View an HTML page with the web inspector network tab open

What is the expected behavior?
There should be some way to filter out resources fetched using the chrome-extension:// protocol. This could be made more generic to allow filtering on any protocol, or it could simply be a 'do not show extension resources' button.

What went wrong?
Network tab lists resources from installed extensions as well as those from the current page.

Did this work before? N/A 

Chrome version: 26.0.1410.64  Channel: stable
OS Version: 6.0 (Windows Vista, Windows Server 2008)

This is a feature request rather than a bug, but listing all extension resources in addition to page resources can get very lengthy and confusing, particularly when you have a lot of extensions installed.
 
web-inspector.png
17.7 KB View Download
Labels: -Type-Bug Type-Feature
Comment 2 by eustas@chromium.org, May 23 2013
Owner: eustas@chromium.org
Status: Assigned
Comment 3 by eustas@chromium.org, May 23 2013
 Issue 240072  has been merged into this issue.
Comment 4 by eustas@chromium.org, May 23 2013
Also take care of dataURIs.
Comment 5 by eustas@chromium.org, May 28 2013
 Issue 180122  has been merged into this issue.
Comment 6 by eustas@chromium.org, May 31 2013
 Issue 245697  has been merged into this issue.
Comment 7 by Deleted ...@, Jan 2 2014
The filter when finding would help for now if it allowed us a way to filter by the protocol or other columns.

May I propose columName:filterstring?
Comment elsewhere recommended using Incognito, that only works if you have the Extensions disabled in Incognito...
Mergedinto: 258421
Status: Duplicate
I'd like to extend the sentiment of this issue to also suppress chrome-extension:// output from Web Inspector's console log, as illustrated in this question on Super User:

http://superuser.com/questions/394213/how-can-i-suppress-chrome-extension-output-from-web-inspectors-console-log/
There's a way of filtering out all these requests. In the network tab filter box, use the string "-Scheme:chrome-extension" (quotes for clarity).

It would be a good thing to be able to activate this filter (or other filters) by default (as part of the configuration settings). Note that this filter will not filter the http/https requests made by an extension, if any. The real solution is for the network waterfall to have separated channels for the page and each of the extensions.
Comment 12 by anrk...@gmail.com, May 1 2015
A simple "hide extension resources" checkbox next to "preserve log" and "disable cache" in network view of the dev tools would do wonders here.
A fix for this would be awesome!
Longing for this! Vimium keeps interfering with my debugging ;-)
Please implement a fix for this.
Comment 16 by Deleted ...@, Sep 1 2015
FInd it valueable - debugging is harder when you have several extensions with 10-20 scripts loading.
Plus it would be cool to make turn on/turn of long living - should not repeat after reload (e.g. like checkbox for cache disabling).
Any update on this?
Owner: ----
It also gets annoying when the frame switches from top, to the last extension, I've had this bite me too many times lately while testing (currently a test engineer). Just to realize I'm in the wrong scope due to a random extension frame being selected :(
Please add this feature. Especially for Console. It's really annoying for developers to change the drop down in console each time from "extension" to "top" to be able to test JS codes. (This happens when extension writes something in console). It would be nice if we can disable/filter any kind of logging from extensions.
It is very inconvenient to insert the string each time. Please add a checkbox "hide chrome ext req"
Sign in to add a comment