New issue
Advanced search Search tips
Starred by 34 users

Issue metadata

Status: Duplicate
Merged: issue 232299
Owner: ----
Closed: Jun 2013
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Add "--disable-new-menu-style" to "Touch Optimized UI" in about:flags

Reported by zzm...@gmail.com, Apr 18 2013 Back to list

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce the problem:
1. Open about:flags
2. Set "Touch Optimized UI" to "disabled"
3. Restart Chrome
4. Open any context menu

What is the expected behavior?
Context menu should use OS default

What went wrong?
Context menu uses "white" style touch friendly layout

Did this work before? No 

Chrome version: 26.0.1410.64  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

The new context menu style seems to have been added for touch devices, as it's much more sparse than the OS default. You can disable it by adding "--disable-new-menu-style" to the launcher shortcut, but if you start Chrome at login, or by clicking a different link or shortcut, it won't have this flag.

As it's essentially an optimization for touchscreen devices, the new menu should be part of the touch optimized UI, and its usability controlled by this flag.
 

Comment 1 by ty...@mango.net.nz, Apr 30 2013

alredy 59 million pages about this in google. First 6 pages how to turn this off. And you are getting rid of the way to turn this off... Hmmmm. Bad Programmers.

Comment 2 by ty...@mango.net.nz, May 1 2013

This doesn't work. Still had to use command line flag to get rid of touch optimized menus on my non-touch laptop. 

Comment 3 by ty...@mango.net.nz, May 1 2013

Version 26.0.1410.64 m

Comment 4 by rossi...@gmail.com, May 1 2013

Works on Chrome 28.0.1490.2 dev-m Win7 64-bit. 

Disabling "Touch Optimized UI" compacts the menus to ('normal') mouse sized hit areas. However the Chrome stylized UI remains.

*Feature Request*
It may be desirable for some to have the Windows UI style context menus and a flag or option should be present for that.
***

Comment 5 by Deleted ...@, May 3 2013

28.0.1496.0 (Official Build 197749) dev-m

Setting this to Disabled does not fix the menus to normal.

Comment 6 by rossi...@gmail.com, May 3 2013

Define, 'normal'.

My comment #4 is still applicable to 28.0.1496.0

It doesn't set them to OS styling however, I think you'll have to use a different browser if that is what you are after as Google never really played by those rules.

However, I've come to the conclusion (after discussion on  Issue 181293 ) that the bug is in the amount of spacing between items and how that spacing scales in relation to font size. Because at 8pt font size (OS Menu font settings) the difference between the OS and Chrome menus is indistinguishable regarding spacing and size. But if I change the font size to default (9pt or 10pt) the difference becomes apparent and makes the menus a bit large with too much spacing.  

Comment 7 by Deleted ...@, May 4 2013

By normal I mean how it was before the decision was made to waste screen space with nothingness.

Comment 8 Deleted

Comment 9 by bau...@gmail.com, May 5 2013

When the chrome starts to rust, it's dead!
No change with Version 28.0.1496.0 dev-m and all touch flags disabled.
It's even worse! - disable-new-style-menu does not work!

It is time to go to a real browser optimized for users with a true popup blocker; easy access to settings... (can found sync with other browser now)

Must always scroll and scroll down.. settings it's same. Test access to advanced settings!! Must create bookmark to go directly to cookies manager.



goog disable-new.png
93.4 KB View Download
goog bad style.png
103 KB View Download
goog-dev_w7.png
132 KB View Download
Since this one (https://code.google.com/p/chromium/issues/detail?id=178764) is locked I’m posting here.  This new menu style is broken.  If you click the menu button on a 13" laptop with low resolution (actually it’s not low in general, but compared to HD resolutions I guess it is) the entire context menu takes up so much room, and basically goes off the screen at the bottom.  Regular context menu is the same.  It just takes up too much space.  No option in Chrome://flags works.  Only –disable-new-menu-style works.  Here is my resolution, and here are two screen shots of each.  I’m sure you can tell which ones are what. 

I think this has to do with it too: https://code.google.com/p/chromium/issues/detail?id=181293&q=context%20menu%20spacing&colspec=ID%20Pri%20M%20Iteration%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified

And just an FYI I'm running Windows 7 with an Ubuntu theme.
Screen Resolution.png
68.7 KB View Download
New Menu Style Disabled.png
149 KB View Download
New Menu Style Enabled.png
135 KB View Download
I'd expect this kind of behavior from Microsoft (Metro UI) but not from Google. If they're going to follow suit and force the end user to suffer these usability issues, she's time to make the switch back to Firefox.
They even removed --disable-new-menu-style talk about stupidity :(

Comment 13 by rphar...@gmail.com, May 15 2013

Make sure when you add it all instances of Chrome are stopped via Task Manager before closing and reopening Chrome.  If you have the setting checked to allow apps to run when Chrome is closed then Chrome never really does "close" when you close it, and reopen it.  Either use the task manager, or log off/reboot, or uncheck that setting in the settings menu under Advanced.


Chrome Background.JPG
11.0 KB View Download
Didn't have background apps allowed, but seems like chrome didn't restart properly so was still running preventing the cmd line option taking effect.

Thanks for the info, that's a major relief :)
 Issue 245112  has been merged into this issue.
Seeing pink cut copy past in the main menu now.
Switched back to Firefox... Ahhhh hello choice! It's nice to have my browser behave the way "I" want it to. :)
thanks google, going back to mozilla

Comment 19 by Deleted ...@, Jun 1 2013

Seriously considering going to Firefox if there is no option to remove this new context menu style. It's garbage. Get it together.

Comment 20 by Deleted ...@, Jun 2 2013

I have swapped back to Firefox too until this is fixed. Seriously, how hard can it be to put a option in?
Honestly I'm tired of waiting, and tired of using a command to do what should have already been FIXED.  The current stable version is the only one it works in anyway, and I like to use the betas, so I'm done with Chrome for now until it is FIXED.  Hello Firefox, nice to meet you again.  :-)
This is such a crock of shit. Normally when a decision gets overwhelmingly negative feedback, that change is reversed, not shoved down our throats. 

Comment 23 by Deleted ...@, Jun 6 2013

I've turned off notifications on this issue.  Why?  I no longer use Chrome... Google is more and more evil and less and less deserving our trust.  hey turn off features we use (Reader, Notebook, etc) and they change things for the worse and outright ignore the users- going as far as ACTIVELY REMOVING the feature that let us see things the way we wanted. 

I'll be working on migrating everything off of Google platforms over the coming months. 
It really is a shame. Google seems to be ignoring user input and rather than give us the option to turn things off or configure the browser the way we want it work (hell, give me a flag instead of checkbox), they are forcing a lot of these unwanted changes on us. Terrible Google, I am thinking about migrating all my Google services as well.
They didn't acknowledge the copious amount of negative feedback received in regards to the imbecilic YouTube layout now being left aligned. What makes anyone think the Chromium team will be any different? They're already forging ahead with the NTP even with the overwhelmingly negative reception. Google are the new MSFT. Less choice. Less options.
Hey is the Chromium team working on getting this into About:Flags the option --disable-new-menu-style or being able to again add it to the target when staring Chrome Beta or is this issue dead?  I haven't seen any info from the developers on it?  Does anyone know? 
The issue is dead. They're not doing it. Someone needs to fork the code and make a "people's version".
#27 dhryst...@gmail.com  Where did you find out the issue is "Dead" someplace official or thats just your take?  Thanks for any further info?
Defect is here:
https://code.google.com/p/chromium/issues/detail?id=178764
Marked as "wontfix".

Comment 30 by mkte...@gmail.com, Jun 28 2013

Mergedinto: 232299
Status: Duplicate (was: NULL)
Merging into an assigned bug.  Hopefully it goes somewhere!

Comment 31 by cska...@gmail.com, Jul 11 2013

You can download the last decent version of Chrome for windows here:
http://commondatastorage.googleapis.com/chromium-browser-snapshots/Win/190904/chrome-win32.zip

Move C:\Users\%USERNAME%\AppData\Local\Google\Chrome\User Data
to 
C:\Users\%USERNAME%\AppData\Local\Chromium\User Data

And you won't lose any stored passwords, form data, bookmarks, etc.  It also will not  auto-update to an inferior version.
So I take it the developers have totally ignored user feedback and removed the option to disable this horrific new styling?

Comment 34 Deleted

Comment 35 by Deleted ...@, Jul 14 2013

New disable for google chrome menu 

https://www.youtube.com/watch?v=HLb0oYsWHuA
Fix by adding --force-fieldtrials="NewMenuStyle/Compact2/" to the shortcut target for Chrome in the newer builds. Works great.
Type "about:flags" in the omnibox (URL box in chrome) press enter.  Find "enable touch events" and choose disable.  If you have a touch screen, this will disable it while using only Chrome.  You can always go back and turn it back on if you need it.

Comment 38 by oldec...@gmail.com, Aug 28 2015

Please have the drop down menus and xontex menus use the OS default of current theme. If I use a dark theme for Windows the menus in Chrome should be dark as well like in Firefox.

Sign in to add a comment