New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 408481
Owner: ----
Closed: Nov 2015
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment

Able to access Browser when Save as Window is open

Reported by smokana@chromium.org, Apr 17 2013

Issue description

Version: 27.0.1453.56
OS: Linux

What steps will reproduce the problem?
1. Launch Chrome and navigate to any website (Ex: Youtube)
2. Open the save as window using shortcut Ctrl+S
3. When this window is open, try to access youtube.com (Click any url.)

Browser should not be accessible when save as window is open.

Working fine in Windows and MAC. This is a Non Regression issue. 
 

Comment 1 by hufra...@tpg.com.au, Jun 23 2014

IMO the best fix would be to make the Save As dialog officially non-modal on all platforms.

I think modal dialogs are bad for two reasons, one affecting usability and one affecting program correctness.

Firstly, sometimes you actually want to interact with the "parent" window of a dialog. For example, moving/resizing/changing z-order, or in the current instance, copying some text from it to use as a filename for your Save As.

Secondly, programmers making the assumption that displaying a modal dialog is a synchronous operation leads to bugs when that turns out not to be the case. For example, you expect Windows's MessageBox() to have no side-effects, but it has its own message loop running in the current thread, which can lead to unexpected reentrancy. (a fact not documented on MSDN!) You are supposed to pass it a handle to an "owner window" which gets temporarily disabled to mitigate this, but many programmers are lazy and pass NULL, and anyway it doesn't help if the current thread has more than one top-level window. Also, disabling a window only prevents the user interacting with it, but it can still receive messages, either sent by programs or the system (eg. most obviously WM_PAINT).
Mergedinto: 408481
Status: Duplicate

Sign in to add a comment