New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 230761 link

Starred by 15 users

Issue metadata

Status: Duplicate
Merged: issue 160223
Owner: ----
Closed: Apr 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Compat



Sign in to add a comment

Fixed position elements do not behave correctly when scrolling in Chrome 27 on Android

Reported by olejo...@gmail.com, Apr 12 2013

Issue description

Example URL:
http://www.olejon.net/code/bug-demos/chrome-android-fixed-position/

Steps to reproduce the problem:
1. Go to the URL provided with Chrome 27 on Android
2. Scroll up and down

What is the expected behavior?
The bottom actionbar should stay permanent at the bottom when scrolling.

What went wrong?
The bottom actionbar moves when scrolling and snaps akwardly back into position after scrolling is finished.

Does it occur on multiple sites: N/A

Is it a problem with a plugin? No 

Did this work before? Yes Chrome 26 on Android

Does this work in other browsers? Yes Chrome 26 on Android, stock Android browser since Gingerbread, etc

Chrome version: 27.0.1453.49  Channel: beta
OS Version: 4.2.2

Chrome 27 introduces fullscreen when scrolling. The behaviour is exactly like the stock Android 4 browser. The address bar disappears when scrolling down, and reappears when scrolling up, no matter what the scroll position is. While the stock Android 4 browser handles this perfectly without breaking fixed position elements, Chrome 27 does not.

This is a huge step backwards for mobile web apps development, where fixed position elements are necessary to create a good app-like experience. In my example fixed position are used to create two actionbars like many native Android apps have.

The stock Android browser has handled fixed position elements correctly since Gingerbread. Before Gingerbread, and in older versions of mobile browsers like Firefox, fixed position elements would behave like this, akwardly snapping back into position after scrolling. It just makes the experience terrible. Please fix.
 

Comment 1 Deleted

Oops..typo above. Related to  Issue 160223 ? 

Comment 3 by olejo...@gmail.com, Apr 23 2013

No, I wouldn't say that, because in this case I have set user-scalable=no, which means zooming is disabled. I should have mentioned that in the report. This is only about scrolling + Chrome 27 on Android.

As I mentioned, this behaved correctly in Chrome 26 (the one where the address bar doesn't disappear), and it also behaves correctly in the stock Android browser.

Comment 4 by aelias@chromium.org, Apr 23 2013

Mergedinto: 160223
Status: Duplicate
The fix for 160223 will also fix this, marking as duplicate.  The fix will arrive in M28.

Comment 5 by olejo...@gmail.com, Apr 23 2013

Great, thanks!

Comment 6 by Deleted ...@, Sep 16 2013

This issue is still present & causing me a lot of grief. What is worse is there doesn't seem to be any work arounds/hacks available! My fixed sidebar does not update it's 'fixed' position unless the chrome address bar has fully disappeared. Any update would be wonderful. Thanks, Rich.

Comment 7 by tris...@code7.co.uk, May 22 2014

Did anyone manage to figure this one out as I'm having the same issue too. Scrolling down fixed header works fine, scrolling up and it disappears until the URL bar is gone.

Comment 8 by Deleted ...@, Dec 23 2014

Still getting the same bug, so its not solved properly...
This issue is not resolved yet :(

Sign in to add a comment