New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 22989 link

Starred by 2 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Nov 2009
Cc:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug
M-4

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Google Image search shows white box when displaying Chrome Frame sites

Reported by jackson@chromium.org, Sep 25 2009

Issue description

What steps will reproduce the problem?

Load http://images.google.com/imgres?
imgurl=http://www.collinjackson.com/me.jpg&imgrefurl=http://www.collinjacks
on.com/&usg=__JOA4uCze7Zby86N3AiscUeWxeLI=&h=450&w=300&sz=33&hl=en&start=1&
sig2=HZ3jnCYzveBzx61bKEE6gQ&tbnid=pQ0n9sF36-KpbM:&tbnh=127&tbnw=85 with 
Chrome Frame. This is a page you'll get to if you search for me on Google 
Images.

What is the expected output?

My home page displayed in the lower frame.

What do you see instead?

White box in the lower frame, because my home page enabled Chrome Frame 
but Google Images did not.
 
Status: Assigned
Frame loading issue, shouldn't load Chrome Frame
Labels: Mstone-4
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=30782 

------------------------------------------------------------------------
r30782 | tommi@chromium.org | 2009-11-02 17:14:45 -0800 (Mon, 02 Nov 2009) | 2 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/protocol_sink_wrap.cc?r1=30782&r2=30781
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/protocol_sink_wrap.h?r1=30782&r2=30781
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/chrome_frame_unittests.cc?r1=30782&r2=30781
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/data/chrome_frame_tester_helpers.js?r1=30782&r2=30781
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/data/full_tab_sub_frame1.html
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/data/full_tab_sub_frame2.html
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/data/full_tab_sub_frame_main.html
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome_frame/test/data/full_tab_sub_iframe_main.html

Don't switch to CF's active document for frames or iframes.This fixes an issue where a page that uses CF would be loaded in an IFRAME on Google Images.Instead of attempting to load CF (not supported), we now defer to the host browser.  Previously a blank page was displayed.TEST=Run new unit tests: FullTabModeIE_SubIFrame and FullTabModeIE_SubFrameBUG=22989
Review URL: http://codereview.chromium.org/343086
------------------------------------------------------------------------

Comment 6 by tommi@chromium.org, Nov 3 2009

Status: Fixed
Labels: -Area-ChromeFrame bulkmove Feature-ChromeFrame
Project Member

Comment 8 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 9 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Mstone-4 -Feature-ChromeFrame M-4 Cr-ChromeFrame
Project Member

Comment 10 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment