New issue
Advanced search Search tips
Starred by 79 users
Status: Fixed
Owner:
Closed: May 2013
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
Google Chrome can not install in Ubuntu 13.04
Reported by hanshia...@gmail.com, Apr 3 2013 Back to list
Chrome Version (from the about:version page): 26.0.1410.43 (Official Build 189671)
Is this the most recent version: Yes
OS + version: Ubuntu 13.04
CPU architecture (32-bit / 64-bit): 64-bit
Window manager: Unity

What steps will reproduce the problem?
1.Download google-chrome-stable_current_amd64.deb 
2.Google Chrome can not install in Ubuntu 13.04

What is the expected result?
Error: Dependency is not satisfiable: libudev0(>=147)
Google Chrome requires libudev0 in order to install, 
yet it has been removed from all repositories(Ubuntu 13.04) 
and is reported as DELETED.

 
Also fails using 64-bit Desktop Ubuntu d07-1304 3.8.0-16-generic #26-Ubuntu SMP Mon Apr 1 19:52:57 UTC 2013 obtained from the 2013-04-02 daily build.

This is a fairly recent failure. I will attempt to install Chrome Stable using the 2013-03_28 daily build. The result of that effect should provide a useful data point.
libudev0 for chrome unstable old package change pls
Chrome depends on `libudev0`, but it has been superseded by `systemd`. `libudev.so.0` has been replaced by `libudev.so.1.0.2` (or thereabouts) provided by the package `systemd-services`.

Until chrome is patched, the debs below can be installed.
i386: http://launchpadlibrarian.net/132294322/libudev0_175-0ubuntu19_i386.deb
amd64: http://launchpadlibrarian.net/132294155/libudev0_175-0ubuntu19_amd64.deb
1. Using a slightly modified 2013-03_28 install (checked BOTH boxes, installed Ubuntu restricted extras), I was able to begin an installation of google-stable 26.0.1410.43-r189671.

2. Reformatting and reinstalling using the same iso (unchecking BOTH boxes and NOT installing Ubuntu restricted extras provided an environment where the installation of google-stable that had just worked in the case above failed.

I have provided this data to encourage thorough testing of any potential fix.
Cc: mmoss@chromium.org thestig@chromium.org
Labels: Cr-Internals-Installer
Status: Untriaged
http://packages.ubuntu.com/search?searchon=contents&keywords=libudev.so&mode=filename&suite=raring&arch=any says libudev.so.1 is in the libudev1
Cc: -thestig@chromium.org
Owner: thestig@chromium.org
Status: Assigned
... libudev1 package, built from systemd. Anyway, this is annoying, but fixable.
Could you roll out a fix for stable ASAP? Can't install Chrome like this and I have no access to my bookmarks/sync data now.
We are working on it. If you really need your bookmarks / sync, please consider not installing a beta Linux distro, or install the beta distro on a test machine.
Remember that at April 25 is no longer a beta...  
Project Member Comment 11 by bugdroid1@chromium.org, Apr 9 2013
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=36021

------------------------------------------------------------------------
r36021 | thestig@google.com | 2013-04-09T23:02:34.886856Z

------------------------------------------------------------------------
>We are working on it. If you really need your bookmarks / sync, please consider not installing a beta Linux distro, or install the beta distro on a test machine.

i want raring ubuntu and dev chrome, but libudev0 in aptitude show old lib if i remove libudev0, i remove same chrome and more nothing only chrome depends libudev0 in system. is good?

thx.
I'm putting in the fixes as we speak. Please wait a few days for the changes to hit dev channel. Patience please.
Project Member Comment 14 by bugdroid1@chromium.org, Apr 9 2013
------------------------------------------------------------------------
r193265 | thestig@chromium.org | 2013-04-09T23:53:09.482099Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/chrome_installer.gypi?r1=193265&r2=193264&pathrev=193265

Add a new file for the Chrome Linux installer.

BUG= 226002 
Review URL: https://codereview.chromium.org/13725026
------------------------------------------------------------------------
Status: Started
Just waiting for the fixes to go out in a dev channel release. Version 28.0.1473.0 or higher.
>I'm putting in the fixes as we speak. Please wait a few days for the changes to hit dev channel. Patience please.

ty for reply chromium
When will the fix hit chrome-stable 64-bit debian linux?
The latest dev channel release (28.0.1478.0) is working for me on Ubuntu-GNOME 13.04 Beta 2. Previous releases were not working. Thanks heaps for the fix! :-)
Status: Fixed
Glad to hear it's working.
ty chromium all work, but if remove libudev0 for ubuntu that need make

sudo dpkg-reconfigure google-chrome
Success installing and executing chrome dev on Ubuntu 12.04 64-bit desktop using amd64.iso 2013-04_15_08:50.
Success installing and executing chrome dev on Ubuntu 13.04 64-bit desktop using amd64.iso 2013-04_15_08:56.

First attempts with Ubuntu 12.10 and chrome dev were not good.  I will try again in the morning.
Ubuntu-13.04 Desktop DAILY amd64.iso 2013-04_15_08:56 AND chrome 28.0.1478.0 dev (unstable).png
674 KB View Download
Success installing and executing chrome dev on Ubuntu 12.10 64-bit desktop following a clean install and application of updates.

nut one errror in xsession-seerrors

Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[1003:1028:0418/190152:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[1003:1003:0418/190154:ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
STRONGLY suggest installing Ubuntu from a recent daily build to validate whether or not Chrome can be installed and executed as expected. Tools which claim to repair Ubuntu have failed me in the past.
Comment 25 by csred...@gmail.com, Apr 22 2013
Ubuntu 13.04 released 25 April, but bug don't fix :(
Perfectly shows the state of the "Linux Desktop" in 2013.
It's a joke. Been that, will be. Sorry.
Status: Started
Hmm, we still need to merge the fix back to Chrome 26.x and 27.x.

Reminder - this is a bug tracker and not a discussion forum. Discuss the state of the Linux desktop elsewhere. File separate bugs for other problems.
Comment 28 by mmoss@chromium.org, Apr 23 2013
Labels: Merge-Requested M-27
Please merge r193265 into m26 and m27.
Comment 29 by mmoss@chromium.org, Apr 23 2013
Note, this merge also requires the 'src/chrome/installer/linux' entry updated in the branch DEPS to:

  (Var("svn_url")) + '/chrome-internal/trunk/chrome/installer/linux@36427',

Comment 30 by kareng@google.com, Apr 24 2013
mike, can we let this go to dev first and make sure it's fixed or is it 100% sure?
This went to dev channel last week.
Here is another data point.

The date-time stamp of the downloaded Chrome dev that I successfully installed and executed on Ubuntu 12.04, 12.10 and 13.04 follows:

google-chrome-unstable_current_amd64_2013-04_14_02:41

I used Beyond Compare to compare an older and the current version of the downloaded deb files and was presented with date-time stamps for each. When I compare a current version of the Chrome deb download with and older one, it is easy to seem when a change occurs.
Comment 33 by dghub...@gmail.com, Apr 25 2013
I'm getting the Error: Dependency is not satisfiable: libudev0(>=147) problem on the official 13.04 64-bit release. 
Using this source: https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
and the same issue from https://www.google.com/intl/en/chrome/browser/


Stable doesn't comes with the fix yet. You can use "unstable", until the fix gets merged back. (see the other comments.)
Comment 35 by kareng@google.com, Apr 26 2013
Labels: -Merge-Requested Merge-Approved
Project Member Comment 36 by bugdroid1@chromium.org, Apr 26 2013
Labels: -Merge-Approved merge-merged-1453
------------------------------------------------------------------------
r196847 | mmoss@chromium.org | 2013-04-26T21:54:50.271739Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1453/src/chrome/chrome_installer.gypi?r1=196847&r2=196846&pathrev=196847

Merge 193265 "Add a new file for the Chrome Linux installer."

> Add a new file for the Chrome Linux installer.
> 
> BUG= 226002 
> Review URL: https://codereview.chromium.org/13725026

R=thestig@chromium.org

Review URL: https://codereview.chromium.org/14335009
------------------------------------------------------------------------
Comment 37 by Deleted ...@, Apr 27 2013
success installing and excuting chrome on ubuntu 13.04.

Install libudev0_175-0ubuntu19_i386.deb first.

https://launchpad.net/ubuntu/+source/udev/175-0ubuntu19/+build/4325790/+files/libudev0_175-0ubuntu19_i386.deb


Screenshot from 2013-04-27 10:54:12.png
163 KB View Download
Simpler way:
sudo ln -s libudev.so.1 libudev.so.0

No install, just a quick and dirty fix. It should work.
Comment 40 by pitli...@gmail.com, Apr 29 2013
Weird... I am using chrome-dev channel (so Chrome 28.x) on my home machine, and after upgrade to 13.04 this weekend, Chrome does not start, complaining about missing libudev.so.0. And I don't see any broken/missing dependencies in Synaptic package manager.
Pitli...@gmail.com

sudo dpkg-reconfigure google-chrome
This doesn't appear fixed for any of the downloads on the getting involved page - at least not for Ubuntu/Debian 64-bit.

http://dev.chromium.org/getting-involved/dev-channel
Re: #42

I can confirm that the 64-Bit Ubuntu/Debian Dev channel does work. The beta does not as it has not yet been updated, but I do not have the libudev.so.0 dependency failure with the Ubuntu/Debian 64-bit dev channel. (I myself am running Ubuntu 13.04 64-Bit).
Beta channel update should be coming out this week. Google Chrome 27.0.1453.71 and newer should support Ubuntu 13.04. Or you can do the symlink trick if you really can't wait.
Project Member Comment 45 by bugdroid1@chromium.org, Apr 30 2013
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=36625

------------------------------------------------------------------------
r36625 | mmoss@google.com | 2013-04-26T21:53:12.540702Z

------------------------------------------------------------------------
Comment 46 by Deleted ...@, May 3 2013
Same here. How can the Linux community expect the common user choose Ubuntu or whatever another distro as your primarily Desktop OS with these stupid bugs? I don't want to type terminal commands to fix this things, I want to double click in the installer and the installer do the rest. I can't afford to expend so many time to search for a solution just to install a browser! We are in the 2013 and this is not acceptable nowadays. I tried Ubuntu and Xbuntu for 5 days, and I honestly give up. Back to Windows OS and try again in 2014.
1. Chrome has EXCELLENT security (sandboxing) AND the latest updates from Google!
2. Chromium has good security but always lags behind Chrome because it is a massaged version of Chrome.
3. Chromium installs via the software center with no need to touch the command line.
4. This forum has indicated MULTIPLE times that chrome-dev (officially chrome-unstable) can be installed in 13.04 with ONE click.
5. Chrome stable will be released with required patched AFTER thorough testing.
Comment 48 by Deleted ...@, May 4 2013
Just a reminder.. Bug tracker. Not a forum here guys! https://code.google.com/p/chromium/issues/detail?id=226002#c27
Hey guys.  I was running google-chrome-stable with libudev0 (from an upgrade) just fine.  I decided to try and test this bug with this command: `sudo apt-get install google-chrome-beta libudev0-`

(fyi, that - removes libudev0)

So far, no good.  Chrome seems unable to load pages, specifically it is stuck waiting to download the initial webpage.  I'm running 13.04 32bit.  Maybe I need to reboot?
ok, nm, a reboot fixed the issue.
Struck this problem after upgrading to 13.04 and just trying to reinstall Chrome from https://www.google.com/intl/sv/chrome/browser/.

Beta download of worked for me now: https://www.google.com/chrome/intl/en/eula_beta.html?dl=beta_amd64_deb
Status: Fixed
It looks like we are probably not making any more updates for Google Chrome 26.x. (aka google-chrome-stable as of this writing) So the earliest version that will work in 27.x, (currently google-chrome-beta) which I hope will become the new stable channel sooner rather than later. Since this is as much work as we are going to get done, I'm marking this bug fixed.

If you really want Google Chrome on Ubuntu 13.04 now, please either install google-chrome-beta instead, or do the symlink workaround. When 27.x becomes stable, and before 28.x becomes beta, you can safely install google-chrome-stable over google-chrome-beta. You can also remove the symlink workaround at that point.

Thanks to everyone for reporting this bug. In the future, we will try to test new Ubuntu releases earlier in their release cycle to prevent problems like this. You can help by doing the same and reporting any problems on this bug tracker.

ErnestBoyd: Rather, Google Chrome is a massaged version of Chromium. Ubuntu's Chromium release may be behind either (a) slightly behind because they are waiting for a Google Chrome release and trying to match its release schedule, or (b) further behind because they are not releasing as fast.
Comment 53 by Deleted ...@, May 8 2013
I don't believe that this bug should be marked as fixed since it has not been "Fixed" Can you please mark this as closed or canceled.. if any one starts Google-ing a fix for this they will be inaccuracy led to believe this has been fixed by by the Chrome team without reading the log.

Thanks!
Comment 54 by Deleted ...@, May 8 2013
The problem is not related to Chrome or Google itself. I installed successfully in Linux Mint 14 with no additional effort. Just downloaded, double click and finish! So, I guess is correct to close the bug since is not related to Chrome but to (crap) Operating System. 
Re: comment 53, we oftentimes mark bugs as fixed, even though the fix may not roll out to users for a period of time. As I said already, this bug is as fixed as it is going to be. Please either wait or go with the alternatives in comment 52.
@Disk1, stop being so negative.  You are taking a very good situation (on Ubuntu, bugs fixed and latest versions are easily installable), and somehow making it a bad.  Don't do that!  Just install the beta, and be happy.
After it is fixed now: This is NOT A FORUM, it is an ISSUE TRACKER. People interested in getting an issue fixed, STAR THE ISSUE or if they have any information that helps getting it fixed comment on it. Everyone who has starred the issue is of course interested in getting information on its progress - that is why everyone who has starred it receives a notification mail for every comment. It is safe to assume that those people do however not want to receive random rants and personal opinion of random people. If anything writing rants or opinion here will lead to people unstarring the issue (or not star it at all in the first place) which in turn will give it less attention by the developers, thus reducing the probability of and increasing the time until a fix gets released. Writing rants or opinion here doesn't help anyone - including yourself. 
@marcelo: You seem a bit confused...what you do not realize is that Mint 14, which is based on ubuntu that you love so much, is running on ubuntu 12.10 NOT ubuntu 13.04, so therefore it doesn't have the problem...once Mint 15 comes out you going to have the SAME PROBLEM as we are experiencing in Ubuntu 13.04 (which is not "crap" as you say...you are using mint and that is based on it...wake up!)...
    Anyway, even though the fix won't be filtering down to Chrome Stable, i am glad to hear that once Chrome 27 hits the stable channel, the fix will be there and we won't have to take the extra step of adding the dependency...
   Also, glad to hear that the Chrome developers will check for compatibility for new versions of Ubuntu from now on...which will help ubuntu and all the distros based on it (like marcelo's "precious Linux Mint")....thanks for the update!
How will i know when chrome 27 stable is out so i can install on ubuntu?
Comment 61 by Deleted ...@, May 13 2013
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libxss1; however:
  Package libxss1 is not installed.

Mine is complaining of the libxss1 .deb 
the libudev0 is solved after installing the link posted above.
hey sean, that sounds like an Ubuntu problem.  You may want to try regular Ubuntu support channels, like IRC or the forums.
M27 should go to stable sometime next week.

Sean, try installing libxss1.
Comment 64 by Deleted ...@, May 19 2013
After upgrade to ubuntu 13.04 yesterday, chrome-beta no longer opened.

Reinstalled the latest chrome-beta as per post #51 above.
https://www.google.com/chrome/intl/en/eula_beta.html?dl=beta_amd64_deb

Problem solved. Thanks.
Comment 65 by pdknsk@gmail.com, May 31 2013
This problem is not fixed in the continuous Chromium builds.

http://commondatastorage.googleapis.com/chromium-browser-continuous/Linux/203408/chrome-linux.zip

libudev.so.0: cannot open shared object file: No such file or directory

We have no intentions of fixing the continuous build. Please apply one of the workarounds mentioned above.
Comment 67 by Deleted ...@, Jun 2 2013
A provisional solution: copy libudev.so.0 in usr/lib or usr/lib64
https://mega.co.nz/#!kBAxET6R!X5pSy0POAit-I6ERafQmWUcXK6phi8nSQn3ben5LcRM
libudev.so.0
61.3 KB Download
Please stop posting random files.
The issue is fixed. Current stable installs perfectly.

People: Do NOT download the file.
If you really need a file for your installation, search the Ubuntu repository, Ubuntu packages, etc. But never ever trust random posted ones.
ISSUE IS FIXED, CAN BE CLOSED!
^ Note for maintainer !
@#69, this report has already been marked fixed(closed).  Comment #52 is really the last comment.  (and I do agree that asking folks to install something from an untrusted sourced, as in #67, is really not good)
Labels: Restrict-AddIssueComment-EditIssue
Please open new bugs for new problems. This is a bug tracker, not a discussion forum.
Sign in to add a comment