Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 220115 Daisy : kernel crash on running platform_ExternalUSBBootStress test.
Starred by 2 users Reported by chiraggupta@chromium.org, Jan 16, 2013 Back to list
Status: Invalid
Owner: ----
Closed: Jan 2014
Cc: krisr@chromium.org
Components:
OS: Chrome
Pri: 2
Type: Bug


Sign in to add a comment
OS Version         :  3428.69.0
Type of computer   :  Daisy
Network info       :  Ethernet

Please specify Area- Platform

What steps will reproduce the problem?
1. Run platform_ExternalUSBBootStress test with USB Headphones and USB Microphone connected.

What is the expected output?
Test passes

What do you see instead?
Kernel crashes


Please provide any additional information below.
<5>[   40.357205] ------------[ cut here ]------------
<2>[   40.357218] kernel BUG at /home/chrome-bot/trunk/src/third_party/kernel/files/drivers/iommu/exynos-iommu.c:319!
<0>[   40.357236] Internal error: Oops - BUG: 0 [#1] SMP ARM
<5>[   40.357250] Modules linked in: i2c_dev uinput isl29018(C) industrialio(C) rfcomm sbs_battery btmrvl_sdio btmrvl spidev bluetooth fuse qcserial usb_wwan gobi nf_conntrack_ipv6 nf_defrag_ipv6 snd_usb_audio ip6table_filter snd_hwdep snd_usbmidi_lib snd_rawmidi snd_seq_device xt_mark ip6_tables smsc95xx mwifiex_sdio mwifiex cfg80211 uvcvideo videobuf2_vmalloc asix usbnet joydev
<5>[   40.357527] CPU: 0    Tainted: G         C    (3.4.0 #1)
<5>[   40.357552] PC is at default_fault_handler+0x80/0x98
<5>[   40.357573] LR is at console_unlock+0x1c4/0x1e0
<5>[   40.357587] pc : [<803d9ee8>]    lr : [<8002cadc>]    psr: 60000193
<5>[   40.357591] sp : 80749da0  ip : 80749cc8  fp : 80749dbc
<5>[   40.357607] r10: ef1cb800  r9 : 410fc0f4  r8 : ef1c37a8
<5>[   40.357620] r7 : 21bb0000  r6 : 0000021b  r5 : eeb5c000  r4 : 21bb0000
<5>[   40.357633] r3 : 271ae91c  r2 : 271ae91c  r1 : 20000193  r0 : 0000004c
<5>[   40.357651] Flags: nZCv  IRQs off  FIQs on  Mode SVC_32  ISA ARM  Segment kernel
<5>[   40.357666] Control: 10c5387d  Table: ac58406a  DAC: 00000015
<0>[   40.357679] Process swapper/0 (pid: 0, stack limit = 0x807482f8)
<0>[   40.357694] Stack: (0x80749da0 to 0x8074a000)
<0>[   40.357707] 9da0: 803d9e68 ef1c3780 00000000 00000000 80749de4 80749dc0 803d98fc 803d9e74
<0>[   40.357722] 9dc0: ef1c5540 80752d40 000000ba 00000000 00000000 80775628 80749e1c 80749de8
<0>[   40.357737] 9de0: 80083b88 803d97d0 ffff3523 ffff3529 00000009 80752d40 80752d94 ef1c5540
<0>[   40.357752] 9e00: 0000001a 00000000 410fc0f4 80775628 80749e3c 80749e20 80083dc0 80083b48
<0>[   40.357767] 9e20: 00020000 80752d40 80752d94 000000ba 80749e54 80749e40 80086c7c 80083d80
<0>[   40.357782] 9e40: 000000ba 807710e8 80749e6c 80749e58 800834e4 80086b98 000000a0 8074bc00
<0>[   40.357797] 9e60: 80749e8c 80749e70 8001fc84 800834c0 00000023 00000000 8076a060 80749f14
<0>[   40.357812] 9e80: 80749ea4 80749e90 800834e4 8001fba4 00000225 00000023 80749ebc 80749ea8
<0>[   40.357827] 9ea0: 8000f244 800834c0 80749ee0 f8810000 80749edc 80749ec0 80008574 8000f1c8
<0>[   40.357842] 9ec0: 80068ba4 803af32c 60000013 ffffffff 80749f5c 80749ee0 8000de80 80008534
<0>[   40.357856] 9ee0: 80749f28 00000000 6517a221 00000009 64323397 00000009 818683e0 00000000
<0>[   40.357871] 9f00: 00000000 410fc0f4 80775628 80749f5c 00000027 80749f28 80068ba4 803af32c
<0>[   40.357886] 9f20: 60000013 ffffffff 6517a221 00000009 00f76cd2 00000000 818683e0 807b630c
<0>[   40.357901] 9f40: 807b62a8 00000000 80775628 00000000 80749f6c 80749f60 803aea28 803af2e0
<0>[   40.357915] 9f60: 80749f94 80749f70 803aef8c 803aea18 00000000 80748000 804fd624 81865580
<0>[   40.357930] 9f80: 807702ec 4000406a 80749fac 80749f98 8000f7b8 803aee60 8076b528 00000000
<0>[   40.357945] 9fa0: 80749fbc 80749fb0 804e1454 8000f72c 80749ff4 80749fc0 80705924 804e13f4
<0>[   40.357960] 9fc0: 00000000 00000000 80705338 00000000 00000000 8072b00c 00000000 10c5387d
<0>[   40.357975] 9fe0: 8076a05c 8072b008 00000000 80749ff8 40008044 807055b4 00000000 00000000
<5>[   40.358005] [<803d9ee8>] (default_fault_handler+0x80/0x98) from [<803d98fc>] (exynos_sysmmu_irq+0x138/0x1b4)
<5>[   40.358028] [<803d98fc>] (exynos_sysmmu_irq+0x138/0x1b4) from [<80083b88>] (handle_irq_event_percpu+0x4c/0x238)
<5>[   40.358051] [<80083b88>] (handle_irq_event_percpu+0x4c/0x238) from [<80083dc0>] (handle_irq_event+0x4c/0x6c)
<5>[   40.358072] [<80083dc0>] (handle_irq_event+0x4c/0x6c) from [<80086c7c>] (handle_level_irq+0xf0/0x12c)
<5>[   40.358091] [<80086c7c>] (handle_level_irq+0xf0/0x12c) from [<800834e4>] (generic_handle_irq+0x30/0x40)
<5>[   40.358112] [<800834e4>] (generic_handle_irq+0x30/0x40) from [<8001fc84>] (combiner_handle_cascade_irq+0xec/0x108)
<5>[   40.358133] [<8001fc84>] (combiner_handle_cascade_irq+0xec/0x108) from [<800834e4>] (generic_handle_irq+0x30/0x40)
<5>[   40.358156] [<800834e4>] (generic_handle_irq+0x30/0x40) from [<8000f244>] (handle_IRQ+0x88/0xc8)
<5>[   40.358175] [<8000f244>] (handle_IRQ+0x88/0xc8) from [<80008574>] (gic_handle_irq+0x4c/0x70)
<5>[   40.358194] [<80008574>] (gic_handle_irq+0x4c/0x70) from [<8000de80>] (__irq_svc+0x40/0x60)
<5>[   40.358207] Exception stack(0x80749ee0 to 0x80749f28)
<5>[   40.358220] 9ee0: 80749f28 00000000 6517a221 00000009 64323397 00000009 818683e0 00000000
<5>[   40.358235] 9f00: 00000000 410fc0f4 80775628 80749f5c 00000027 80749f28 80068ba4 803af32c
<5>[   40.358248] 9f20: 60000013 ffffffff
<5>[   40.358269] [<8000de80>] (__irq_svc+0x40/0x60) from [<803af32c>] (cpuidle_wrap_enter+0x58/0xa4)
<5>[   40.358288] [<803af32c>] (cpuidle_wrap_enter+0x58/0xa4) from [<803aea28>] (cpuidle_enter_tk+0x1c/0x24)
<5>[   40.358304] [<803aea28>] (cpuidle_enter_tk+0x1c/0x24) from [<803aef8c>] (cpuidle_idle_call+0x138/0x2b4)
<5>[   40.358323] [<803aef8c>] (cpuidle_idle_call+0x138/0x2b4) from [<8000f7b8>] (cpu_idle+0x98/0x100)
<5>[   40.358348] [<8000f7b8>] (cpu_idle+0x98/0x100) from [<804e1454>] (rest_init+0x6c/0x84)
<5>[   40.358372] [<804e1454>] (rest_init+0x6c/0x84) from [<80705924>] (start_kernel+0x37c/0x3d8)
<0>[   40.358389] Code: e5931000 eb0460df e59f0014 eb0460dd (e7f001f2)
<4>[   40.358407] ---[ end trace fb51799ba380ad17 ]---
<0>[   40.358827] Kernel panic - not syncing: Fatal exception in interrupt
"kernel.20130115.232630.0.kcrash" 1899L, 138270C                                                                                                                                           1837,1        Bot



 
System logs and test logs at the location
http://cros-hwqual-5.mtv.corp.google.com/bugs/37959/
Comment 2 by arscott@chromium.org, Jan 24, 2013
Labels: -Mstone-25 Mstone-26
Bulk punt of Pri-2 issues.
Labels: -Mstone-26 Mstone-27 MovedFrom-26
This issue is P1 but has already been moved once, therefore lowering to P2 and moving to next milestone.
Project Member Comment 4 by bugdroid1@chromium.org, Mar 7, 2013
Labels: OS-Chrome
Project Member Comment 5 by bugdroid1@chromium.org, Mar 10, 2013
Labels: -Area-Platform -Mstone-27 Cr-OS-Kernel M-27
Comment 6 by ddrew@chromium.org, Apr 9, 2013
Labels: -M-27 MovedFrom-27
Bulk edit to remove milestone from issues that are Pri-2 or lower and have already been moved at least once.
Project Member Comment 8 by bugdroid1@chromium.org, Sep 17, 2013
Labels: autofiled-count-2
[bvt] login_CryptohomeUnmounted failed on daisy_spring-release/R31-4700.0.0

This bug has been automatically filed to track the following failure:
Test: login_CryptohomeUnmounted.
Suite: bvt.
Chrome Version: None.
Build: daisy_spring-release/R31-4700.0.0.

Reason:
Autotest client terminated unexpectedly: DUT rebooted during the test run..
build artifacts: https://storage.cloud.google.com/?arg=chromeos-image-archive/daisy_spring-release/R31-4700.0.0.
results log: http://cautotest.corp.google.com/tko/retrieve_logs.cgi?job=/results/4791142-chromeos-test/chromeos2-row5-rack4-host3/debug/.
buildbot stages: http://chromegw.corp.google.com/i/chromeos/builders/daisy_spring%20canary/builds/545.


ANCHOR  TestFailure(bvt,login_CryptohomeUnmounted,Autotest client terminated unexpectedly: DUT rebooted during the test run.)

Comment 9 by diand...@chromium.org, Sep 17, 2013
@8 seems to have nothing to do with this bug.  Filed bug #293491 to track why this bug was chosen.  Looking for the right bug to handle @8, though it looks like perhaps a machine was chosen for the test that hadn't finished rebooting yet...
Forked @8 to bug #293495.
Comment 11 by beeps@chromium.org, Sep 18, 2013
It's because https://code.google.com/p/chromium/issues/detail?can=2&q=255153&colspec=ID%20Pri%20M%20Iteration%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified&id=255153 was duped to this, and that was for the same test/reason. 

I guess that was for a crash though. So we should start looking through crashes when we dedupe also.
Status: Invalid
Sign in to add a comment