New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 15 users

Issue metadata

Status: Verified
Owner:
Last visit > 30 days ago
Closed: Jul 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 1
Type: Bug



Sign in to add a comment
link

Issue 214926: Chrome OS Image Creator fails to open USB stick on Mountain Lion

Reported by a...@chromium.org, Jul 18 2012 Project Member

Issue description

From internal report, http://b/6830151 :

-----
Displays Message:

Sorry an error occurred (Failed to open the USB stick, Permission Denied). Would you like to try again?
-----

This is due to the fact that in Mountain Lion, the /dev/disk objects are now owned by root, even if the user plugged them in. The recovery tool will need to use a privileged helper.
 

Comment 1 by sumit@chromium.org, Jul 18 2012

Cc: nirav@chromium.org

Comment 2 by a...@chromium.org, Jul 24 2012

Fixed with v2.0.1.

Comment 3 by a...@chromium.org, Jul 24 2012

Status: Fixed

Comment 4 by Deleted ...@, Jul 27 2012

i have the same problem how do you get version 2.0.1?

Comment 5 by a...@chromium.org, Jul 27 2012

We are currently testing it.

Comment 6 by krisr@chromium.org, Aug 6 2012

Labels: Area-Installer

Comment 7 by krisr@chromium.org, Aug 6 2012

Status: Verified

Comment 8 by fenton@chromium.org, Aug 16 2012

Cc: jessj@chromium.org
8/16/12 - Still having this issue on OS X.8, with the same error.

Comment 9 by jessj@chromium.org, Aug 16 2012

@Nirav - Did this go through QA? When will it be live?

Comment 10 by a...@chromium.org, Aug 16 2012

fenton:

What version are you running? If it's not 2.0.1 then it certainly will not work. If you _are_ running 2.0.1, please provide me more information about your machine and setup.

Comment 11 by nirav@chromium.org, Aug 16 2012

Pushing through QA now. Kris will update as necessary on the QA side and file appropriate bugs. Hopefully we can push this live this week.

Comment 12 by fenton@chromium.org, Aug 16 2012

Re #10
I am using the version that is available to the public on the recovery web site.

Comment 13 by a...@chromium.org, Aug 16 2012

On a feature bug, "fixed" means fixed in the source code. I don't know what we're using to track public deployment.

Comment 14 by nirav@chromium.org, Aug 17 2012

Labels: -Pri-2 Pri-1 Mstone-22
Owner: krisr@chromium.org
Status: Assigned
Kris, can you please verify and close? 

Thanks!

Comment 15 by chiraggupta@chromium.org, Aug 22 2012

Not able to create a image using Chrome OS Image creator on Mountain Lion OS.
Logs of the mac attached.
http://cros-hwqual-5.mtv.corp.google.com/bugs/32701/log_image_creator.rtf

Comment 16 by nirav@chromium.org, Aug 22 2012

Owner: a...@chromium.org
Avi, 

Can you take a look at this when you have some time? 

Thanks!

Comment 17 by krisr@chromium.org, Aug 23 2012

From the system log:

Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com com.apple.SecurityServer[15]: UID 501 authenticated as user testing (UID 501) for right 'sys.openfile.readwrite./dev/rdisk1'\
Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com com.apple.SecurityServer[15]: Succeeded authorizing right 'sys.openfile.readwrite./dev/rdisk1' by client '/usr/libexec/authopen' [1345] for authorization created by '/usr/libexec/authopen' [1345] (3,0)\
Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com coreservicesd[62]: Application App:"Chrome OS Image Creator" [ 0x0/0x139139]  @ 0x0x7ffa65c363e0 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x13c13c:) ), so denying.\
Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com WindowServer[97]: [cps/setfront] Failed setting the front application to Chrome OS Image Creator, psn 0x0-0x139139, securitySessionID=0x186b0, err=-13066\
Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com com.apple.SecurityServer[15]: Succeeded authorizing right 'system.volume.removable.unmount' by client '/Users/testing/Desktop/Chrome OS Image Creator.app' [1336] for authorization created by '/Users/testing/Desktop/Chrome OS Image Creator.app' [1336] (100013,0)\
Aug 22 16:33:29 dhcp-172-22-75-5.mtv.corp.google.com com.apple.SecurityServer[15]: Succeeded authorizing right 'system.volume.removable.unmount' by client '/usr/sbin/diskarbitrationd' [16] for authorization created by '/Users/testing/Desktop/Chrome OS Image Creator.app' [1336] (100002,0)}

Comment 18 by a...@chromium.org, Aug 23 2012

Was this with v2.0.1? Can you provide more info about your setup? The bit about "tried to be brought forward, but isn't in fPermittedFrontASNs" seems to be some weirdness in the OS X that isn't related to me.

Comment 19 by joshwoodward@chromium.org, Aug 30 2012

Just following up on this: I'm on Mountain Lion, and the Chrome OS Image Creator is not working for me. Is there anything I can provide to help debug this?

Comment 20 by jessj@chromium.org, Aug 30 2012

@josh if you're using the external image creator failure is expected. 2.0.1 (where we found a bug in QA) should work on Mountain Lion but QA experienced an error in testing and hasn't been released yet.

Comment 21 by joshwoodward@chromium.org, Aug 30 2012

When is 2.0.1 being released? Is there another way to create images?

My old steps in Terminal (below) have stopped working, too.

diskutil list

diskutil unmountDisk diskN

dd bs=4m if=chromeos-recovery.bin of=/dev/rdiskN

Comment 22 by nirav@chromium.org, Sep 4 2012

Cc: krisr@chromium.org
Kris, can you provide Avi with the necessary info?

Comment 23 by nirav@chromium.org, Sep 4 2012

Waiting for Avi to update us with the latest build for this. We'll QA again to see if this bug is reproducible.

Comment 24 by a...@chromium.org, Sep 4 2012

There have been no changes since the last build. I cannot repro and have no details to help me do so. What do you need from me?

Comment 25 by ddrew@chromium.org, Sep 4 2012

Labels: -Mstone-22 bulkmove Mstone-23
Bulk punting non-blocking issues from Mstone-22 to Mstone-23.

Comment 26 by krisr@chromium.org, Sep 5 2012

When we do about ChromeOS Image Creator it says 2.0.1.  If needed I can give you access to the Mac we are testing on.

Comment 27 by joshwoodward@google.com, Sep 5 2012

When I go to the link below, I download the image creator and get version 0.8.8, which does not work on Mountain Lion.

1. Go here: http://support.google.com/chromeos/bin/answer.py?hl=en&answer=1080595
2. Click the Mac link: https://dl.google.com/dl/chromeos/recovery/chromeosimagecreator.dmg
Screen Shot 2012-09-04 at 5.21.28 PM.png
132 KB View Download

Comment 28 by nirav@chromium.org, Sep 5 2012

Josh, that's the old version. We haven't uploaded the newest 2.0.1 release just yet. It's in the process of being QA'ed. It's blocked on a bug at the moment.

Comment 29 by krisr@chromium.org, Sep 5 2012

We tested 2.0.1 and we still see the problem reported in comment 15.  We can get avi access to our machine if that will help.

Comment 30 by a...@chromium.org, Sep 5 2012

Contact me directly off-bug. I'm in NY so that would have to be remote access.

Comment 31 by a...@chromium.org, Sep 5 2012

There is indeed a problem. I can reproduce it on my Mac when double-clicking a release build. Investigating further.

Comment 32 by a...@chromium.org, Sep 5 2012

Owner: krisr@chromium.org
Status: Fixed
Fixed with 2.0.2. Really.

Comment 33 by krisr@chromium.org, Sep 10 2012

Status: Verified
Verified fixed with 2.0.2.

Comment 35 by nirav@chromium.org, Sep 18 2012

There is a bug open (http://code.google.com/p/chromium-os/issues/detail?id=34296). We're trying to get it live ASAP.

Comment 36 by Deleted ...@, Feb 13 2013

you can use the current mac image creator if you just type 

sudo "/Applications/Chromium OS Image Creator.app/Contents/MacOS/Chromium OS Image Creator" 

into the terminal with the image creator app in the applications folder.  the target image you want to use has to exist somewhere off the root harddrive

Comment 37 by Deleted ...@, Feb 19 2013

"sudo /Users/***/Downloads/Chromium\ OS\ Image\ Creator.app/Contents/MacOS/Chromium\ OS\ Image\ Creator" worked perfectly for me (it was in my downloads folder, obviously.) on Mac OS 10.8.2.

Comment 38 by Deleted ...@, Feb 23 2013

Thx it worked for me..

Comment 39 by Deleted ...@, Feb 24 2013

worked with Su

Comment 40 by Deleted ...@, Feb 28 2013

Terminal command worked for me too

Comment 41 by bugdroid1@chromium.org, Mar 7 2013

Project Member
Labels: OS-Chrome

Comment 42 by bugdroid1@chromium.org, Mar 10 2013

Project Member
Labels: -Area-Installer -Mstone-23 Cr-Internals-Installer M-23

Comment 43 by Deleted ...@, Mar 17 2013

Command line worked for me. Ta.

Comment 44 by Deleted ...@, Apr 13 2013

Terminal command also worked for me. Thanks!

Comment 45 by Deleted ...@, Apr 20 2013

I finally got it to work, using one of the above links.

Now I got a new problem concerning the model number. I don't have an actual chromebook that I'm restoring, instead I'm trying to make my Dell Latitude D420 into a chromebook. I've already done it successfully on my Acer Aspire One ZG5, but that was a bit easier since there are a few models that are close to the Acer and they actually say Acer. 

So does anyone know what models to use on different non-chrome computers?

Thanks!

Comment 46 by Deleted ...@, May 29 2013

hexxeh_CHROMIUM OS需要的程式

1.準備容量4GB以上usb一支
2.下載最新usb隨身碟映象檔 (http://chromeos.hexxeh.net/vanilla.php)
3.下載軟體 Image writer for windows
(https://sourceforge.net/projects/win32d ... t/download)
4.把usb隨身碟映象檔寫入usb碟
將Image writer for windows 打開,並按 " win32disk Imager " 執行檔
5.在 " Image file" 選擇 chromium OS 映象檔,並在 " Divice" 選usb隨身碟代號
6.映象檔寫入後用製作好的usb隨身諜開機 , 就可進入chromium os 中
7.開機後只要按下 " crtl+alt+t" , 就可以叫出 chromium os中 內建終端機
8.轉入shell指令叫出shell介面 
9.輸入 /usr/sbin/chromeos-install 指令,並輸入ROOT密碼 facepunch
10.按提示安裝即可將 Chromium OS 安裝至本機硬碟
*******
安裝: Flash, PDF, MP3/MP4, hangouts and Netflix! for some Chromium OS builds
https://gist.github.com/rikels/4031126
how to install?
start Chromium OS.
log in.
press alt+ctrl+F2.
log in as user: chronos password: facepunch.
enter the command: sudo su, and log in with the password: facepunch.
enter the following: curl -L http://goo.gl/Ue6VQ | bash (if you don't want to have Hangouts and Netflix, you can still use the version without hangouts and Netflix link: curl -L http://goo.gl/JjY4W | bash)
wait for it to finish, you will automatically be taken back to the login screen and everything should be working.
******
安裝marvel yukon 網卡【宏碁L480網卡】出現問題
1.下載marvell yukon網卡的驅動程式
http://www.marvell.com/support/download ... 3&action=1
2.安裝過程到./install.sh出現 權限不足問題 permission denied

Before the sk98lin driver installation script can be invoked, the 
installation package needs to be unpacked:

1. Login as 'root'.

2. To unpack the driver installation package, execute the command

# tar xfvj install_A.B.C.D.tar.bz2
or
# bunzip2 -c install_A.B.C.D.tar.bz2 | tar xfv -
5 Driver Installation

1. After the driver installation package is unpacked, execute the following
commands to start the sk98lin driver build process:

# cd DriverInstall
# ./install.sh
出現 權限不足問題 permission denied

請教linux大師如何解決
謝謝

Comment 47 by Deleted ...@, Jan 3 2014

Hi, on i found this solution and it worked for me on OS 10.9.1
http://superuser.com/questions/542246/installing-chromium-os-on-usb-throws-error
placed the app in application folder, then opened terminal and pasted the code line the n password and it worked
cheers guys

Comment 48 by chris.go...@gmail.com, Apr 8 2014

Thanks sameeryo...@gmail.com! This worked for me too on OS X 10.9.2

Comment 49 by m.sunder...@gmail.com, May 6 2014

TheEpicE...@gmail.com were you able to find a recovery that worked for your D420

Sign in to add a comment