New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 2069 link

Starred by 5 users

Issue metadata

Status: Verified
Owner:
Email to this user bounced
Closed: Oct 2008
Cc:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Regression: Shelves (infobar / download shelf) not hidden correctly after tab close

Reported by rig9...@gmail.com, Sep 10 2008

Issue description

Product Version      : 0.2.152.0
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 3:
Firefox 3:
IE 7:

What steps will reproduce the problem?
1. Download something
2. Close the tab
3. Click your download button's arrow to get menu with "open, show in 
folder"

What is the expected result?
Should show the menu

What happens instead?
Entire download bar becomes unresponsive until you double click it to 
restore screen.

Please provide any additional information below. Attach a screenshot if 
possible.
 
 
Labels: -Area-Unknown Area-BrowserUI
Status: Assigned
Please repro on the dev channel + trunk builds.

Comment 2 by goo...@gmail.com, Oct 3 2008

Same here, and once double-clicked, the bar disappear. Tested on 0.2.153.1
Status: Duplicate
This is dupe of  Issue  1904 .

-Venkat.
Status: Untriaged
oops..sorry..wrong duping... 2979 is dupe of this.

-Venkat.
Labels: -Pri-2 Pri-1
Summary: Regression: Download bar becomes unresponsive
Consistent Repro Steps:

--Go to any webpage(Eg: google.com)
--Copy and paste any URL which points to download in the same tab (eg: http://www.download.com/3001-2239_4-10891365.html?
spi=1ec293304541968b88b9408ec6cfc3ad)
--Close the tab.
I can reproduce this in 154.0.  It appears to be a redraw issue involving the
Download Bar (the bar is not really there).  Use repro steps in bug # 1904.
Comments from Glen:
Problem appears to be because frame::shelf_view_ is killed without calling Layout() 
when the tab is closed, and when ShelfVisibilityChangedImpl is subsequently fired 
for 
the new tab as part of ShowTabContents, it thinks that no shelf view was visible, so 
it doesn't detect any change and doesn't call Layout().

Not yet sure why this doesn't affect infobars.

Comment 9 by glen@chromium.org, Oct 14 2008

Summary: Regression: Shelves (infobar / download shelf) not hidden correctly after tab close
This bug affects infobars as well.
Labels: Mstone-1.0
This regression needs to get fixed before 1.0. Ideally before we push the next Beta 
update, if it can get fixed this week.

Comment 11 by glen@chromium.org, Oct 16 2008

Fix is approved, waiting on me being around while the tree is open, sorry.

Comment 12 by glen@chromium.org, Oct 17 2008

Status: Fixed
Fixed with r3528
Status: Verified
Verified in 0.3.154.5 (Official Build 3584).

Comment 14 by jon@chromium.org, Dec 5 2008

 Issue 3865  has been merged into this issue.
Project Member

Comment 15 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Sign in to add a comment