Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 53 users
Status: WontFix
Owner: ----
Closed: Jun 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 3
Type: Bug



Sign in to add a comment
IcedTea Java plug-in doesn't work
Reported by teej...@gmail.com, Aug 23 2009 Back to list
Chrome Version       : 4.0.203.0~svn20090823r24088-0ubuntu1~ucd1~jaunty
OS + version : Ubuntu 9.04 Jaunty
CPU architecture (32-bit / 64-bit): amd64
window manager : Gnome
URLs (if applicable) :
Behavior in Firefox 3.x (if applicable): Works
Behavior in Chrome for Windows (optional): N/A

What steps will reproduce the problem?

1. Start using "LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.1.3pre/ chromium-
browser --enable-plugins" to ensure IcedTeaPlugin.so finds libmozjs.so, 
libxpcom.so and libxul.so from the xulrunner-1.9.1 package (can also use 
LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.0.13/ for xulrunner-1.9).

2.about:plugins lists "File name: libjavaplugin.so" without the "IcedTea 
Java Web Browser Plugin" title and doesn't show any MIME type table 
entries.

3. Java applets don't work



What is the expected result?

about:plugins should show the plug-in name and list several MIME types such 
as:
MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	IcedTea 	class,jar 	Yes
application/x-java-applet 	IcedTea 	class,jar 	Yes
application/x-java-applet;version=1.1 	IcedTea 	class,jar 	Yes
application/x-java-applet;version=1.1.1 	IcedTea 	class,jar 	
Yes
...

What happens instead? The java plugin is not loaded.


Please provide any additional information below. Attach a screenshot
and backtrace if possible.

"/usr/lib/mozilla/plugins/libjavaplugin.so" is a symbolic link:

libjavaplugin.so -> /etc/alternatives/xulrunner-1.9-javaplugin.so

which is in turn a symbolic link to:

/etc/alternatives/xulrunner-1.9-javaplugin.so -> /usr/lib/jvm/java-6-
openjdk/jre/lib/amd64/IcedTeaPlugin.so

The fact that about:plugins shows the original symbolic link name suggests 
that chromium isn't using 'readlink' to resolve to the final shared object 
library:

readlink -f /usr/lib/mozilla/plugins/libjavaplugin.so
/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
 
Comment 1 by teej...@gmail.com, Aug 23 2009
I should have mentioned that at some point chromium-browser *does* find 
IcedTeaPlugin.so because if the LD_LIBRARY_PATH isn't set to find the three libraries 
mentioned, chromium-browser reports:

chromium-browser --enable-plugins

[17295:17296:27695374134:ERROR:/build/buildd/chromium-browser-
4.0.203.0~svn20090823r24088/build-tree/src/base/native_library_linux.cc(19)] dlopen 
failed when trying to open /usr/lib/mozilla/plugins/libjavaplugin.so: libmozjs.so: 
cannot open shared object file: No such file or directory

Comment 2 by gke...@gmail.com, Aug 24 2009
Might be dup of  issue 16787  in which it seems like chromium is not following the link 
down to actual file before loading.
Comment 3 by estade@chromium.org, Aug 25 2009
Mergedinto: 16787
Status: Duplicate
Comment 4 by teej...@gmail.com, Sep 8 2009
I've followed the discussion on  issue 16787  which is now reportedly fixed for Sun 
Java.

It hasn't fixed this issue with IcedTea/OpenJDK as of 4.0.207.0 (Ubuntu build 25598).

This issue should be re-opened and the duplicate status removed.
I can confirm that this is still the case on Ubuntu with IcedTea/OpenJDK. Who can 
remove duplicate flag?
another confirmation that this still persists with IcedTea/OpenJDK on Chrome 4.0.211.2
Comment 7 by evan@chromium.org, Sep 24 2009
Labels: -Area-Misc Area-Plugins Pri-3
Mergedinto: -16787
Status: Available
Summary: IcedTea Java plug-in doesn't work (was: NULL)
Comment 8 by teej...@gmail.com, Sep 25 2009
I've been doing some research and debugging on this. I found that the call to dlsym()
fails to find NP_GetMIMEDescription:

NP_GetMimeDescriptionType NP_GetMIMEDescription =
      reinterpret_cast<NP_GetMimeDescriptionType>(
          dlsym(dl, "NP_GetMIMEDescription")); 

The issue is one identified by Evan in comment 18 of  issue 16767  "Java Plugin not
working"

http://code.google.com/p/chromium/issues/detail?id=16787#c18

Basically, the current IcedTeaPlugin does *not* use the NPAPI interface. Instead it
uses the Open JVM Integration (OJI) interface:

http://www-archive.mozilla.org/oji/

This blog post by an author of IcedTeaPlugin explains the background and situation:

http://dbhole.wordpress.com/2009/05/11/the-future-of-icedtea-plugin/

The key sentence is "...IcedTea plugin, which uses LiveConnect/OJI."

In summary, the original Netscape Plugin API (NPAPI) didn't support scripting and
therefore the Java <> Javascript bridge called LiveConnect was developed.

This is what IcedTeaPlugin uses - on Linux it is libnpjp2.so - that provides a
wrapper for the NPAPI interface:

objdump -x /usr/lib/jvm/java-6-sun-1.6.0.16/jre/lib/amd64/libnpjp2.so | grep MIME
0000000000007720 g     F .text	0000000000000008              NP_GetMIMEDescription

which in turn calls the methods in the IcedTeaPluginFactory:

objdump -CT /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so | grep -i mime
0000000000011330 g    DF .text	00000000000000b1  Base       
IcedTeaPluginFactory::GetMIMEDescription(char const**)

To complicate matters Mozilla is planning to remove LiveConnect/OJI from Gecko soon:

http://groups.google.ca/group/mozilla.dev.planning/browse_thread/thread/8741dfad2f92a59/f22f486d57707f8a?hl=en&q=&lnk=ol&

and therefore IcedTeaPlugin is being rewritten to use the NPAPI scripting extension,
NPRuntime:

https://developer.mozilla.org/en/Gecko_Plugin_API_Reference/Scripting_plugins

All this leads to some perplexing issues in relation to supporting existing (now
'legacy') plug-in & JVM scenarios, or commiting to only the NPAPI/NPRuntime interface.

The good news is Deepak recently reported having a revised IcedTea  NPAPI/NPRuntime
plugin working in Chromium and Firefox 3.6:

http://dbhole.wordpress.com/2009/08/26/icedtea-java-plugin-with-chromium-and-firefox-3-6a1/

There's a note that the plugin needs to be built against xulrunner 1.9.2 alpha or later.

The initial patch-set for IcedTea6 is:

http://icedtea.classpath.org/hg/icedtea6/rev/8353f4e67ec1


Comment 9 by teej...@gmail.com, Sep 25 2009
Follow-up regarding the new IcedTeaNPPlugin.

I built the current mercurial head (r1719) of the IcedTeaNPPlugin against the current
Ubuntu xulrunner-1.9.1.x headers, fixed a work-in-progress
failed-to-build-from-source issue, stripped the resulting binary and placed it in
/usr/lib/chromium-browser/plugins/.

Chromium about:plugins reported:
-----
IcedTea NPR Web Browser Plugin (using IcedTea) 1.7pre

File name: IcedTeaNPPlugin.so
The IcedTea NPR Web Browser Plugin (using IcedTea) 1.7pre-r1719 executes Java applets.
-----

followed by a long list of supported MIME types.

The Java test applet (http://www.java.com/en/download/help/testvm.xml) tries to load
but currently seems to get confused and fails to complete applet loading:

GCJ PLUGIN: thread 0x7f97dad6c790: NP_Initialize: using
/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/../../bin/java
GCJ PLUGIN: thread 0x7f97dad6c790: NP_Initialize return
GCJ PLUGIN: thread 0x7f97dad6c790: Mutexs 0x306c428 and 0x306c400 initialized
GCJ PLUGIN: thread 0x7f97dad6c790: Mutexs 0x306c4e8 and 0x306c4c0 initialized
GCJ PLUGIN: thread 0x7f97dad6c790: Subscribing 0x306b600 to bus 0x306c400
GCJ PLUGIN: thread 0x7f97dad6c790: Subscribing 0x306a930 to bus 0x306c4c0
GCJ PLUGIN: thread 0x7f97ccd23950: Queue processor initialized. Queue = 0x3068b80
GCJ PLUGIN: thread 0x7f97cc522950: Queue processor initialized. Queue = 0x3068b80
GCJ PLUGIN: thread 0x7f97cbd21950: Queue processor initialized. Queue = 0x3068b80
GCJ PLUGIN: thread 0x7f97dad6c790: GCJ_New
Looking for 0x3071010 0x3071e00 0x3071e90 (document)
GCJ PLUGIN: thread 0x7f97dad6c790: Got variant 0x7fffe2da6fb0
GCJ PLUGIN: thread 0x7f97dad6c790: plugin_data_new
GCJ PLUGIN: thread 0x7f97dad6c790: plugin_data_new return
GCJ PLUGIN: thread 0x7f97dad6c790: Checking JVM status...
GCJ PLUGIN: thread 0x7f97dad6c790: No JVM is running. Attempting to start one...
GCJ PLUGIN: thread 0x7f97dad6c790: GCJ_New: creating input fifo:
/home/tj/.icedteaplugin/icedteanp-appletviewer-to-plugin
GCJ PLUGIN: thread 0x7f97dad6c790: GCJ_New: created input fifo:
/home/tj/.icedteaplugin/icedteanp-appletviewer-to-plugin
GCJ PLUGIN: thread 0x7f97dad6c790: GCJ_New: creating output fifo:
/home/tj/.icedteaplugin/icedteanp-plugin-to-appletviewer
GCJ PLUGIN: thread 0x7f97dad6c790: GCJ_New: created output fifo:
/home/tj/.icedteaplugin/icedteanp-plugin-to-appletviewer
GCJ PLUGIN: thread 0x7f97dad6c790: plugin_start_appletviewer
GCJ PLUGIN: thread 0x7f97dad6c790: Initialized VM with pid=10465
GCJ PLUGIN: thread 0x7f97dad6c790: plugin_start_appletviewer return
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.4.1) (6b14-1.4.1-0ubuntu11)
OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode)
Listening for transport dt_socket at address: 8787

This does however confirm that Chromium can correctly query and load the revised
NPAPI/NPRuntime IcedTea plugin. It shouldn't be too much trouble for distro's or
third parties to packages the new plug-in. I'm planning on doing that in my Ubuntu
PPA once I've ironed out the remaining issues.

https://launchpad.net/~intuitivenipple/+archive/ppa/
Comment 10 by gke...@gmail.com, Sep 26 2009
FYI, chrome on windows, and I guess linux too, only supports NPAPI for Sun Java 
Plugin.  This is why chrome requires Sun JRE SE6 U10 or higher, which is the one that 
started using NPAPI.
With IcedTea on OpenSUSE 11.2, IcedTeaPlugin.so shows up in about:plugins but there 
are no MIME types listed. If I switch back to the Sun JRE then the MIME types appear.
Labels: -Area-Plugins Area-Internals Internals-Plugins
I've got this issue for Mandriva Linux 2010.0 as well.

My issue is reported here: https://qa.mandriva.com/show_bug.cgi?id=57257
On Gentoo using dev-java/sun-jdk-1.6.0.18 and www-client/chromium-4.0.266.0-r1 java 
works. This is Sun's jdk, not icedtea6 on an amd64 machine. 
This should get fixed, but if anyone need java on chromium this^ should work.

Note that I'm using the Openjdk Java-plugin & as an example, hikinghq.net loads the
Java-menu without problem.
Comment 16 by rdw...@gmail.com, Jan 26 2010
@14: A Gentoo user, suggesting that the solution is to use precompiled binaries? For 
shame!

/me is a Gentoo user, and thus permitted to make such jokes
I have just visited www.tv4play.se to watch a clip & that works perfect.
Comment 18 by tsd...@gmail.com, Mar 1 2010
@kristoffer: For me chromium-5.0.341.0 (40245) with icedtea6-bin-1.7 does not work (no 
java plugin listed in about:plugins).

But the two sites you listed to confirm that it works do work for me, too. I guess 
they don't use java at all.  Does Sun's test applet work for you?

  http://www.java.com/en/download/help/testvm.xml
chromium-5.0.365.0

does not work at all. java test pages does not display anything. about:plugins stays
blank. please fix! this and the lack of spacebar in flash applets is what is keeping
me from using chromium regularly. 
Tested the new Java-version from Java.com & this issue is no longer existing for me.
The Oracle/Sun JRE is not free software and arguably the worse alternative to running
the FOSS OpenJDK with the Icedtea plugin for anyone on a GNU/Linux system, as it
often comes preinstalled and is ready to use, rather than having to download it from
a third party site or nonfree repos. 


Icedtea: http://icedtea.classpath.org/wiki/Main_Page
If you use the java overlay you can install icedtea:6 from source, this works perfectly 
with chromium

On a side not icedtea-bin, as the name suggests, is a precompiled version and not 
really proper Gentoo either
any solution for debian?
Find a new version of icedtea-6 with the new plugin enabled
does not get any more recent, I am afraid. 
2010-04-06-113154_1280x1024_scrot.png
281 KB View Download
Have any of you Ubuntu-users checked that java.1.6.0-openjdk-plugin is installed?
yup
Comment 28 by e...@ymail.com, Apr 9 2010
Hi mundhenke.soeren, I have the same problem, I installed openjdk and icedtea plugin 
and it's not listed on Chrome plugins list.
I suggested to be able to add directories to be scanned for plugins, but Chrome team 
doesn't like the idea and marked as WontFix, see: 
http://code.google.com/p/chromium/issues/detail?id=29442
Comment 29 by e...@ymail.com, Apr 9 2010
On Firefox Icedtea "replaced" Java sun. 
I switched back to firefox since, until this issue is fixed. free software does not
like to mix with propietary things, and java (openjdk) is crucial at times. 
Comment 31 by Deleted ...@, Apr 14 2010
On lucid (Ubuntu 10.04), the NPPlugin is used, built from IcedTea6-1.8. However the
plugin is still not recognized.

Comment 32 by a...@jwsdot.com, Apr 14 2010
openjdk requires xpcom etc. and that isnt found in chromium environment. Remember
that xpcom etc. are no real libs with ABI/API guarantees etc, hence cannot treat them
as such in ubuntu.

What chromium should do is find a GRE using the standalone glue and boot it in the
process spawn for the plugin before loading the icedtea plugin.
Comment 33 by a...@jwsdot.com, Apr 14 2010
oh ... openjdk plugin needs to export somehow the minimum version of GRE it needs, so
chromium can use the standalone xpcom glue to find the right one.
Comment 34 by tuls...@gmail.com, May 15 2010
Chromium 6.0.405.0 (47353) Ubuntu, IcedTea6-plugin 6b18-1.8-0ubuntu1, still nothing 
works. IcedTea is not even in about:plugins. Everything works in firefox.
I'm using Chromium 6.401.1 with Icedtea 1.8 on Gentoo (x86-64) and all is working 
well, it might be worth seeing if this is an Ubuntu issue
Comment 36 by Deleted ...@, May 16 2010
I've tried all sorts of ways to make Icedtea plugin work with Chrome, but I obviously
failed at that attempt in Kubuntu. Now I am stuck with Firefox, and that is not a
good feeling for a Chrome fan.
What have you actually tried?
Comment 38 by evan@chromium.org, May 19 2010
It sounds like IcedTea 1.8 works:
  http://dbhole.wordpress.com/2010/04/14/icedtea-1-8-released-with-new-np-plugin/

If anyone can confirm that, I will close this bug.
Comment 39 Deleted
Comment 40 by Deleted ...@, May 26 2010
Hi I am using Kubuntu 10.04, and I have the latest IcedTea 1.8 installed:

jacksonlim@ae016:/usr/lib/chromium-browser$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-0ubuntu1)
OpenJDK Server VM (build 14.0-b16, mixed mode)
jacksonlim@ae016:/usr/lib/chromium-browser$ 

I created a symbolic link from the icedtea folder:

sudo ln -s /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so 
/usr/lib/chromium-browser/plugins/

I check whether chrome can see the plugins by typing the following on the address 
bar:

about:plugins

It still didn't work. Kindly enlighten me if I did something wrong.
I can confirm that applets now work in Chromium for Linux using the latest 
OpenJDK/IcedTea plugin in Fedora 12/13.

Output from about:plugins:

IcedTea NPR Web Browser Plugin (using IcedTea6 1.7.1 (fedora-37.b17.fc13-i386))
Description:	The IcedTea NPR Web Browser Plugin (using IcedTea6 1.7.1 (fedora-
37.b17.fc13-i386)) executes Java applets.
Location:	/usr/lib/jvm/java-1.6.0-openjdk-
1.6.0.0/jre/lib/i386/IcedTeaNPPlugin.so
Comment 42 by gnout...@gmail.com, May 30 2010
For all fellow Ubuntu users: I'm on Ubuntu 10.04 w/ Chromium 5.0.375.55, and I've also 
had IcedTea missing from about:plugins. However, I've found that running chromium like 
this makes everything work:

LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.2.3/ chromium-browser

HTH!
Same on Fedora 12, and 13.
This is what I see:

Looking for 0xa5b86c0 0xa5b8650 0xa5adc80 (document)
java.lang.InterruptedException: sleep interrupted
	at java.lang.Thread.sleep(Native Method)
	at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:627)
	at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:295)
	at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:72)
java.lang.InterruptedException: sleep interrupted
	at java.lang.Thread.sleep(Native Method)
	at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:672)
	at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:647)
	at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:295)
	at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:72)

Crash dump id: 182ab79af069d26b
Daniel's fix in comment 42 works for me.

The best way to add to your LD_LIBRARY_PATH in ubuntu is to add a new conf file in 
/etc/ld.so.conf/

I added xulrunner.conf containing /usr/lib/xulrunner-1.9.2.3/

Then run sudo ldconfig -v to refresh the cache.

Now chromium detects the IcedTea plugin in about:plugins.
Unfortunately the plugin then crashes when I try to run a java app.
I'm on Ubuntu 10.04 with Chromium 5.0.375.38 (46659). The symlink approach from Comment 40 didn't work, but the LD_LIBRARY_PATH approach from Comment 42 also worked for me.

If you don't have root access, you can also set LD_LIBRARY_PATH in your ~/.bashrc like:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/xulrunner-1.9.2.3/


Comment 48 by karen@chromium.org, Jun 24 2010
Labels: karen624move Mstone-X
Comment 49 Deleted
Had the same problem, however with last Chromium 5.0.375.99~r51029-2 on Debian Unstable everything works just fine!

However I am using OpenJDK/Icedtea (6b20~pre1-1) that are from experimental repository 

I think it's finally time for me to make definite switch to Chrome :)


works fine using 6.0.464.0 on debian, with IcedTea6 1.8 (6b18-1.8-3)

test page works fine too

Hi this isn't an issue in chromium, actually, the whole problem is icedtea6-plugin linking against libxul and libxpcom when it doesn't need to.
Please see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=576361
@all: FYI, I'm using Ubuntu 10.04 and I believe the IcedTea plug-in suddenly started working in Chrome on 2010/10/11 when my automatic updates picked up v. 6b18-1.8.1-0ubuntu1 of icedtea6-plugin and icedtea-6-jre-cacao. I only noticed because suddenly my Java applets looked slightly different, and after a while I figured out that it was because they were using IcedTea where before they'd been using the Sun plug-in (which I also have installed, but which was lower in the pecking order).
I also confirm this for Ubuntu 10.10.
Labels: -Internals-Plugins Feature-Plugins
The Java plugin now works for me with IcedTea 1.9.5 and Chrome 10.0.648.114 beta on Ubuntu 10.10. The IcedTea issue mentioned in Comment 52 was fixed in version openjdk-6/6b18-1.8-4. Screenshots attached.
Screenshot.png
170 KB View Download
Screenshot-1.png
152 KB View Download
Comment 57 by uni...@gmail.com, Jun 5 2011
Issue is resolved with Fedora Core.

I have tested with Fedora Core 14 x86_64. openjdk java with icedtea plugin working just fine though http://www.java.com/en/download/installed.jsp?detect=jre&try=1 this site says to update to newer version it's just okay.

If you don't know how to install this plugin on fedora use this command:
$ sudo yum -y install java java-1.6.0-openjdk-plugin

Comment 58 by Deleted ...@, Aug 15 2011
It does not work for me on this site: https://www2.bancobrasil.com.br/aapf/login.jsp?aapf.IDH=sim&perfil=1

Archlinux 32 bit. I use icedtea-web 1.1.1-1 and chromium 13.0.782.107-1. Chromium lists the plugin and works for other sites

On Firefox 5 this site works just fine with the same plugin.
Comment 59 by Deleted ...@, Oct 4 2012
I have Ubuntu 12.04 and have the same problem in site above.
Project Member Comment 60 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Feature-Plugins Cr-Internals Cr-Content-Plugins
Project Member Comment 61 by bugdroid1@chromium.org, Apr 6 2013
Labels: Cr-Blink
Project Member Comment 62 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-Plugins Cr-Internals-Plugins
Status: WontFix
This issue is obsolete, as NPAPI support (used by IcedTea) has been dropped from Chrome 35. See   issue 363053 .
Sign in to add a comment